1 ikiwiki (1.36) UNRELEASED; urgency=low
3 * Fix various links on the hyperestradier pages.
4 * Use POST for poll to avoid some robots.
5 * Fix sometimes broken links to Discussion pages from blog pages.
6 * Add userdir config setting.
7 * Fix man page perms in install.
8 * Fix an issue with inlining a page with a rss feed inside another
10 * Turn $config{wiki_file_prune_regexps} into an array that is easier to
12 * Only exclude rss and atom files from processing if the inline plugin
13 is enabled and that feed type is enabled. Else it's just a copyable file
15 * Move rss and atom option handling code into the inline plugin.
16 * Applied a rather old patch from Recai to fix the "pruning is too strict"
17 issue. Now you can have wiki source directories inside dotdirs and the
19 * Patch from Emanuele Aina to fix modification time code in mercurual
21 * Add support for links of the form [../foo]], this links to the page
22 foo a level higher in the directory hierarchy than the one it would link
25 -- Joey Hess <joeyh@debian.org> Thu, 21 Dec 2006 15:10:03 -0500
27 ikiwiki (1.35) unstable; urgency=low
29 * Fix daemonisation code to only do daemon setup things after forking the
31 * The hack used to make the pagetemplate hook have access to the editpage
32 template won't work with CGI::FormBuilder 3.0401, so disable it for now.
33 * CGI::FormBuilder 3.0401 seems to work ok now with ikiwiki, although
34 there might still be bugs lurking..
36 -- Joey Hess <joeyh@debian.org> Fri, 1 Dec 2006 19:14:36 -0500
38 ikiwiki (1.34.2) unstable; urgency=low
40 * Allow /etc/ikiwiki/wikilist to list just the names of users, if so then
41 ~user/.ikiwiki/wikilist will be read.
42 * Fix url absolution code in inline plugin to support class and id fields in
43 links and imgs, and to support anchor urls.
44 * More build deps updates.
45 * /dev/null fortune failures
47 -- Joey Hess <joeyh@debian.org> Tue, 28 Nov 2006 12:58:47 -0500
49 ikiwiki (1.34.1) unstable; urgency=low
51 * Add libtime-duration-perl to build deps, as it's used by the svn module
52 which is now tested at build.
54 -- Joey Hess <joeyh@debian.org> Mon, 27 Nov 2006 12:26:12 -0500
56 ikiwiki (1.34) unstable; urgency=low
58 * Add an openid plugin to support logging in using OpenID.
59 * Web commits by OpenID users will record the full OpenID url for the user,
60 but in recentchanges, these urls will be converted to a simplified display
62 * Modified svn, git, tla backends to recognise such web commits.
63 * Move httpauth support to a plugin.
64 * Add openidsignup config option.
65 * Make the openid plugin support the callbacks from myopenid.com via its
69 * Add quick mode for archive page generation.
70 * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
71 many other plugins. It's an easy way to boost ikiwiki from its default,
72 basic wiki, to a full-featured wiki, without manually picking the right
73 set of plugins. New plugins will be added to goodstuff from time to
75 * Change how post signin actions are propigated through the signin process;
76 they're now stored in the session.
77 * Add optional "desc" parameter to shortcut definitions.
78 * Avoid locking the wiki at all when handling some basic cgi stuff
79 (searches, recentchanges).
80 * Add "last" parameter to hook function. Very basic ordering, and hopefully
81 nothing more spohisticated will be needed.
82 * Add formbuilder_setup and formbuilder hooks.
83 * Split out a passwordauth module, that holds all the traditional password
84 based authentication etc code. It's enabled by default, but can be disabled
85 if you want only openid or some other auth method.
86 * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
87 * Add some code to the build system that tries to determine if the
88 lib installation directory is in @INC. If it's not, munge ikiwiki
89 to hardcode the path to the lib directory. This should allow installing
90 ikiwiki in nonstandard locations, including home directories, by just
91 setting PREFIX at build time.
92 * Fix nested examples directory in deb.
93 * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
94 * Add a test suite for the svn backend.
95 * Add a test suite for the git backend, from Recai
96 * Daemonize before sending RPC pings, since that can take a while
98 * Daemonize before sending commit mails, as that can also take a long
99 time/hang if the mail server is unhappy.
100 * Factor out commit mail sending code into new function.
101 * Change rcs_commit, it is now passed the name of the user doing the commit
102 and their IP address, and needs to construct its own commit message
103 containing them, or do something more appropriate for the given RCS.
104 * Add softwaresite example.
105 * Mercurial backend improvements, including --get-ctime support. (Emanuele
107 * Git backend improvements, including bug fixes and better robustness,
110 -- Joey Hess <joeyh@debian.org> Sun, 26 Nov 2006 20:46:56 -0500
112 ikiwiki (1.33) unstable; urgency=low
114 * Fix issue with aggregate plugin updating expired pages.
115 * Avoid syntax errors in templates used by the template plugin crashing
117 * Enable utf8 file IO in aggregate plugin.
118 * Fix some issues with the new registration form.
119 * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
120 * Make sure to check for errors from every eval.
121 * Fix img plugin's handling of adding dependencies for images that do not
123 * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
124 FORM-SUBMIT unusable on customised formbuilder templates. For now,
125 hardcode the submit buttons in editpage.tmpl instead of using the
126 template variable, which is ok, since the buttons are static.
127 * Work with hyperestraier 1.4.9.
129 -- Joey Hess <joeyh@debian.org> Wed, 15 Nov 2006 18:32:26 -0500
131 ikiwiki (1.32) unstable; urgency=low
133 * Add a separate pass to find page links, and only render each page once,
134 instead of over and over. Typical speedup is ~4x. Max possible speedup:
136 * Add "scan" parameter to hook(), which is used to make the hook be called
137 during the scanning pass, as well as the render pass. The meta and tag
138 plugins need to use the new scan parameter, so will any others that modify
140 * Now that links are calculated in a separate pass, it can also
141 precalculate backlinks in one pass, which is O(N^2) instead of the
142 previous code that was O(N^3). A very nice speedup for wikis with lots
143 (thousands) of pages.
144 * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
146 * Add a default stylesheet entry for the pagecloud.
147 * Add examples page with some examples of things that can be done using
148 ikiwiki, like a weblog. The examples can be copied into a user's wiki
149 for a quick start, without needing to learn everything about how to put
151 * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
152 * Add perlmagick to build-depends so syntax check of img plugin works.
154 * Improve login/register process, the login dialog has only name and
155 password fields, which allows more web browsers to regognise it as a login
156 field, and is less confusing.
157 * Implemented expiry options for aggregate plugin.
158 * Use precalculated backlinks info when determining if files need an update
159 due to a page they link to being added/removed. Mostly significant if
160 there are lots of pages.
161 * Remove duplicate link info when saving index. In some cases it could
162 pile up rather badly. (Probably not the best way to deal with this
164 * Patch from James Westby to support podcasting, photoblogging, vidcasting,
165 or what have you, by creating enclosures for non-page items that are
168 -- Joey Hess <joeyh@debian.org> Fri, 3 Nov 2006 14:46:37 -0500
170 ikiwiki (1.31) unstable; urgency=low
172 * Patch from Pawel Tecza to cp -a the templates in the Makefile.
173 * Change the rss feed title from the wikiname to the page title, with
174 an exception for the wiki's toplevel index page, which will still use the
175 wikiname as the feed title.
176 Overriding the page title with meta title already overrode the rss feed
178 * Add an img plugin, based on Christian Mock's img plugin, but stripped
179 down to the bare essentials. Useful for handling large images on websites.
180 * Sanitize possibly problimatic characters out of the polygen grammar names,
181 just in case. Should not be exploitable anyway, since it only tries to run
182 polygen after finding the specified grammar file.
183 * Add missing dependency on the URI perl module.
184 * Add basic spam fighting tool for admins: An admin's prefs page now allows
185 editing a list of banned users.
187 -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 23:16:33 -0400
189 ikiwiki (1.30) unstable; urgency=low
191 * Add no_override parameter to hook().
192 * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
193 plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
194 can be configured using a page in wiki.
195 * Fix support for --pingurl at the command line.
196 * Fix a subtle bug in will_render that broke some builds, by only clearing
197 items from renderedfiles the first time per build.
198 * Wrap entire technortati ping operation in an eval to catch all possible
199 failure modes, after I observed a simple ->value crashing ikiwiki when
202 -- Joey Hess <joeyh@debian.org> Mon, 16 Oct 2006 15:17:38 -0400
204 ikiwiki (1.29) unstable; urgency=low
206 * Patch from Paul Tötterman to use CP in the Makefile.
207 * Patch from Alec Berryman adding a http_auth config item that allows
208 using HTTP Authentication instead of ikiwiki's built in authentication.
209 Useful for eg, large sites with their own previously existing user auth
210 setup. Closes: #384534
211 * Change %renderedfiles to store an array of files rendered from a given
212 source file, to allow tracking of extra rendered files like rss feeds.
213 * Note that plugins that accessed this variable will need to be updated!
214 The plugin interface has been increased to version 1.01 for this change.
215 As few plugins use %renderedfiles I haven't done anything else to ensure
216 compatability of old plugins.
217 * Add will_render function to the plugin interface, used to register that a
218 page renders a destination file, and do some security checks. Previously
219 but no longer rendered files will be cleaned up.
220 * Use will_render in the inline and linkmap plugins.
221 * You will need to rebuild your wiki on upgrade to this version.
222 * Atom feed support based on a patch by Clint Adams.
223 * Add feeds=no option to inline preprocessor directive to turn off all types
225 * $IkiWiki::version now holds the program version, and is accessible to
227 * Make the aggregate plugin emphasize error messages.
228 * Patch from Recai to limit recentchanges to displaying max 10 files for a
229 given changeset (to avoid large number of file changes excessively
232 -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
234 ikiwiki (1.28) unstable; urgency=low
236 * inline: Add ability to sort by page name, based on a patch from
238 * Fix a forkbomb in various calls to IPC::Open2, which has a highly
239 braindead interface. Closes: #389383
240 * Don't rm -rf ikiwiki on distclean, since a) there's no such file
241 and b) those poor Mac OSX users and their case insensative files!
242 * Don't fail syntax check if Text::Typography isn't installed.
245 -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
247 ikiwiki (1.27) unstable; urgency=low
249 * Work on firming up the plugin interface:
250 - Plugins should not need to load IkiWiki::Render to get commonly
251 used functions, so moved some functions from there to IkiWiki.
252 - Picked out the set of functions and variables that most plugins
253 use, documented them, and made IkiWiki export them by default,
254 like a proper perl module should.
255 - Use the other functions at your own risk.
256 - This is not quite complete, I still have to decide whether to
257 export some other things.
258 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
259 referring to stuff now exported by the IkiWiki module.
260 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
261 to declare which version of the interface your plugin needs.
262 * Anyone with a third-party ikiwiki plugin is strongly encouraged
263 to make like changes to it and avoid use of non-exported symbols from
265 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
266 * Support hyperestradier version 1.4.2, which adds a new required phraseform
268 * If an inlined page has a permalink, link the page title to that.
269 * Patch from Recai to use utf8 when reading the setup file, so that
270 utf8 wikinames from there will be used properly.
271 * Patch from Recai to kill utf-8 on the wiki name when generating the
273 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
274 * Fix a baseurl problem in hyperestradier search results.
275 * Add a stub local.css to avoid problems with 404's.
276 * Patch from Recai to fix a wide character warning from the search plugin
277 during setup if the wikiname contains utf8.
278 * Yet another fix for those poor case-insensative OS X users.
279 * pagetemplate hooks are now also called when generating cgi pages.
280 * Add a favicon plugin, which simply adds a link tag for an icon to each
282 * Patch from James Westby to deal with the case where you're editing a
283 new page, hit cancel, and need to be redirected to somewhere sane.
284 * Various documentation improvements by various wiki users.
285 * Support Text::Markdown from CPAN, which has a different interface from
286 the original markdown or the one in Debian.
287 * Version the libcgi-session-perl dependency, some features that need
288 the new version are used in some cases (sslcookie).
289 * Numerous tla fixes from Clint.
290 * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
291 a multi-resolution favicon.ico.
292 * README.Debian: typo Closes: #388110
293 * chomp trailing newline at the end of templates read in by the template
294 plugin, to allow use of the template preprocessor directive in
295 whitespace-sensative situations. Closes: #387073
296 * Patch from James Westby to make the location of the estseek.cgi script
298 * Add typography (SmartyPants) plugin by Recai.
299 * Add --render mode, which can be used to preview an edit at the command
300 line by test rendering a single page.
301 * Add a googlecalendar plugin. A bit special-purpose, but it shows
302 one way to to deal with user-supplied content that could cause XSS
303 issues w/o the htmlscrubber, and won't survive the scrubber.
305 -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
307 ikiwiki (1.26) unstable; urgency=low
309 * Add a missing -n to tla undo call.
310 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
311 writes before consuming its whole stdin. Avoid this deadlock.
312 * Fix alt tags for outline checkboxes.
314 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
316 ikiwiki (1.25) unstable; urgency=low
318 * Add proper waitpid calls for open2ed processes throughout to avoid
319 zombies; this hit htmltidy especially badly.
320 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
321 subversion repos and fixing some other issues.
322 * Add support for tla, contributed by Clint Adams. Closes: #385936
323 * Add support for mercurial, contributed by Emanuele Aina.
324 * Include <link rel> tag for RSS feeds, used by some aggregators and
325 firefox to find the feed.
326 * Add a linkmap plugin (requires graphviz).
328 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
330 ikiwiki (1.24) unstable; urgency=low
332 * Simplify the data structure returned by rcs_recentchanges to avoid
333 each rcs plugin needing to form complex strings on its own.
334 * Fix another destpage issue in the inline directive. Closes: #385512
337 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
339 ikiwiki (1.23) unstable; urgency=low
341 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
343 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
345 ikiwiki (1.22) unstable; urgency=low
347 * Change how the stylesheet url is determined in the templates: Remove
348 STYLEURL and add BASEURL to all templates (some already had it). This
349 new more general variable can be used to link to other things (eg, images)
350 from the template, as well as stylesheets.
351 * Fix a bug introduced last version to do with nested inlines.
352 * Allow preprocessor directives to span multiple lines, both to make
353 long ones with lots of values easier to write, and to allow for ones with
354 multi-line quoted values.
355 * Allow preprocessor directives to contain python-like triple-quoted
356 text blocks, for easy nesting of quotes inside.
357 * Add a template plugin.
358 * Make pagespec merge code smarter about merging duplicate pagespecs.
359 * Patch from Jordà Polo to make Setup::Standard support hashes in config
361 * Change order of linkify and preprocess; first preprocess and then linkify.
362 This allows passing a wikilink inside a parameter to a preprocessor
363 directive without it being expanded to html, and leaking out of the
364 parameter, which had required some non-obvious use of triple-quoting
365 to avoid. Note that any preprocessor plugins that output something
366 that looks like a wikilink will now have it treated as such; AFAIK
367 this doesn't change any behavior though except for the template plugin.
368 * Enable preprocessor directives when previewing an edit.
369 * Make all pages pull in a local.css style sheet, if present. This won't
370 be included in ikiwiki, but can be created to make local styling changes
371 w/o needing to merge in every new change to the distributed style.css.
372 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
373 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
374 from a different directory.
375 * Generalised preprocesser loop protection code.
376 * Patch from James Westby to allow a description to be set for rss feeds.
377 * Patch from James Westby to add a template for the search form.
378 * Added a ddate plugin.
379 * Patch from James Westby to add a --sslcookie switch, which forces
380 cookies to only be sent over ssl connections to avoid interception.
381 * Fix preferences page on anonok wikis; still need to sign in to get
382 to the preferences page.
383 * Add toc (table of contents) plugin.
384 * Change htmlize, format, and sanitize hooks to use named parameters.
385 * Patch from James Westby to add an actions option to inline; this
386 adds Edit and Discussion links at the end of blog entries.
387 * Due to some css changes, you'll want to rebuild your wiki on upgrade
388 to this version. Will be handled automatically by the deb.
389 * Add processed date to aggregate preprocessor directive status output.
391 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
393 ikiwiki (1.21) unstable; urgency=low
395 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
396 * If a page links to itself, mark up the link text in a span with
397 class="selflink" so that it can be styled. I don't have a useful style
398 defined for that though.
399 * Call filter hooks on inlined page content.
400 * Support inlining pages raw, rather than creating a blog.
401 * Clean up yes/no parameter parsing in inline plugin.
402 * Implemented better cycle detection in the inline plugin; nested inlines
404 * Add a map plugin contributed by Alessandro Dotti Contra.
405 * Add otl format plugin, which handles files as created by vimoutliner.
406 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
407 * Add first draft at a Restructured Text (rst) plugin, by Sergio
408 Talens-Oliag. Note that this has many known issues -- see the caveats on
410 * Credit everyone who wrote a plugin on the plugins' wiki pages.
411 * Fix utf-8 in blog post form.
413 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
415 ikiwiki (1.20) unstable; urgency=low
417 * Relicense the templates and basewiki under the 2-clause BSD license.
418 Since these can easily become part of other people's websites, they
419 should be under as permissive a license as possible.
420 * Add --syslog config option, to log to the syslog.
421 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
422 transient failure to fork (which I've seen happen in the wild).
423 * Fix a bug in the aggregator introduced last version that caused all
424 aggregator state to be lost during a non-aggregating build.
426 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
428 ikiwiki (1.19) unstable; urgency=low
430 * Fix several related bugs in page type determination during online editing.
431 * Add some locking to prevent 2 aggregators from running at once.
432 * Fix an infinite loop in the aggregator when finding a unique filename.
434 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
436 ikiwiki (1.18) unstable; urgency=low
438 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
440 * Man page format fixups.
441 * If the meta plugin overides the page title, set a title_overridden
442 variable in the template to true. This allows doing things with the
443 templates conditional on the title being overriden.
444 * Add a %pagecase which maps lower-case page names to the actual case
445 used in the filename. Use this in bestlinks calculation instead of
446 forcing the link to lowercase.
447 * Also use %pagecase in various other places that want to check if a page
448 with a given name exists.
449 * This means that links to pages with mixed case names will now work,
450 even if the link is in some other case mixture, and mixed case pages
451 should be fully supported throughout ikiwiki.
452 * Recommend rebuilding wikis on upgrade to this version.
454 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
456 ikiwiki (1.17) unstable; urgency=low
458 * Disable tidy generator tag.
459 * Move tidy back to sanitize hook, found out how to only show body.
460 * Turn off tidy indentation too.
461 * Turn on HTML::Template loop_context_vars; not actually used in stock
462 templates but can be useful for things like making comma-delimited lists
463 of tags or what have you.
464 * Remove <br> from end of aggregate preprocessor directive output.
465 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
466 case-sensative filesystems like OSX.
467 * Improve markdown loading. First, try to load it as a proper perl module,
468 in case it was installed as one. Then fall back to trying
470 * Document in install page how to install markdown, since it has no
471 installation procedure in the upstream tarball.
472 * Set die_on_bad_params => 0 for all templates, to allow users to modify
473 them without annoyances.
474 * Suck in the page content when generating an inline archive page, to work
475 around the meta plugin's lack of caching of title metadata across runs.
477 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
479 ikiwiki (1.16) unstable; urgency=low
481 * Try to handle relative links in aggregated feeds. However,
482 the current support is a crude hack due to limitations of XML::Feed:
483 xml:base is not supported, neither is Content-Location. And of course,
484 relative links in RSS feeds are ill-undefined..
485 * Make aggregator save permalinks and author name to pages as metadata.
486 * Add permalink and author support to meta plugin, affecting RSS feeds
488 * Various CSS and formatting changes.
489 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
490 * Add xhtml files to the default prune regexp.
491 * Also generate rel=bookmark links for permalinks.
492 * Fix the htmltidy plugin, which wasn't working due my breaking it when
494 * Don't run tidy with -xml as that fails if the input is not well-formed.
495 Run it with -asxhtml instead, so it will output well-formed xhtml no
496 matter what the input.
497 * Disable tidy warnings too.
498 * Add a new format hook, and make tidy use it, since tidy can really only
499 operate on and output complete html documents, not the body chunks
501 * Fix dates in rss feeds if running localised, so they're still rfc 822.
503 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
505 ikiwiki (1.15) unstable; urgency=low
507 * Remove CDPATH and other env vars perl taint checking doesn't like.
509 * Added created_before and created_after PageSpec limits.
511 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
513 ikiwiki (1.14) unstable; urgency=low
515 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
517 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
518 * Added many unit tests for pagespec_match.
520 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
522 ikiwiki (1.13) unstable; urgency=low
524 * ikiwiki can now download and aggregate feeds with its new aggregate
525 plugin, so it's possible to implement a Planet using ikiwiki!
526 * Add a run_hooks function for the common task of running all hooks of a
528 * Add a savestate hook.
529 * Don't put blog post forms on pages if there's no cgiurl set.
530 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
531 --wrappers to do that.
532 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
533 to update pages that haven't changed on disk.
534 * Change meta tags to use html entity-escaped text for values, so that
535 quotes and such can be represented in title tags.
536 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
538 * Make --rebuild also cause --aggregate to re-download and write aggregated
540 * Avoid outputting duplicate meta info.
541 * Include title metadata on aggregated posts for capitalised and un-munged
543 * Title metadata of inlined pages now shows up in blogs and rss feeds.
544 * Fix issue with unicode filenames and updating the hyper estradier search
545 index. (Aka Please Please Please, let that be the last one.)
546 * Patch from Roland Mas to support an rss=no parameter to inline directives.
548 * Renamed GlobLists to PageSpecs.
549 * PageSpecs can now include nested parens, "and", and "or". This remains
550 backwards compatible to the old GlobList format. It's implemented by
551 treating the GlobList as a very limited microlanguage that is transformed
552 to perl code that does the matching.
553 * The old GlobList format is deprecated, and I encourage users to switch to
554 using the new PageSpec format. Compatability with the old format will be
555 removed at some point, possibly by 2.0.
556 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
557 * Add support for creation_month and creation_year to PageSpec.
559 * Changes to index file encoding.
561 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
563 ikiwiki (1.12) unstable; urgency=low
566 * New pagestats plugin from Enrico, which can generate a table counting
567 the backlinks for each page, or a del.icio.us style cloud.
568 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
569 the wikiformat plugin works. Thanks, Emanuele Aina.
570 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
571 display, running them through pagetitle. This removes ugly underscores and
572 other gunk from the display, much nicer. You may want to rebuild your wiki
573 when upgrading to get the cleanup globally.
574 * Polygen plugin from Enrico.
575 * htmltidy plugin from Faidon.
576 * Locale patch from Faidon:
577 - Adds a locale setting to setup files.
578 - Proper local time, if the locale configuration option is used.
579 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
580 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
582 * Add getopt hook type, this allows plugins to add new command-line options.
583 * Add --tagbase option to tag plugin.
584 * Add exclude option in setup files, works same as --exclude.
585 * Put categories in rss feeds for tagged items.
586 * Allow preprocessor directives to be expanded in inlined blog pages.
587 However, to avoid inlining loops etc, don't expand inline directives in
589 * fortune plugin (trivial)
590 * Tag plugins according to type.
592 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
594 ikiwiki (1.11) unstable; urgency=low
596 * Patch from Enrico that
597 - Adds a tag plugin that allows more easily tagging pages.
598 The meta plugin can also still be used for that, but the tag plugin
599 also lists a page's tags at the bottom of the page.
600 - Allows preprocessor directives to have parameters with no specified
602 - Fixes preprocessor directive parameter parsing so that
603 foo=bar baz now means "foo=bar" and a "baz" with no value.
604 * Run pagetemplate hooks when inlining pages so that inlined pages also
606 * Make all plugins with pagetemplate hooks check that variables exist
607 on the template before setting them, for robustness.
608 * Switch pagetemplate hooks to using named parameters.
609 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
610 This will be the page that a source page will be part of, which is
611 different than the source page for inlined pages.
612 * Audited all plugins to endure they pass (page, destpage) to htmllink
613 appropriatly. This means inlining of various plugins will not work
614 properly, with correct links generated.
616 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
618 ikiwiki (1.10) unstable; urgency=low
620 * Run page through any relevant filters when generating a page preview.
621 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
622 default throughout the wiki, not only on wikitext pages. Decided to call
623 this a feature, and split the camelcase support out into a separate plugin
624 that is independant of wikitext.
625 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
627 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
629 ikiwiki (1.9) unstable; urgency=low
631 * Improve display of parentlinks and page title of toplevel index page.
632 * Patch from Faidon to use svn --limit when possible for recentchanges,
633 speeds up recentchanges a lot for wikis with more history.
634 * Patch from Recai to fix utf8 issues in git backend.
635 * Add wikitext markup plugin, which supports ".wiki" pages written in the
636 original wiki syntax, CamelCase links and all.
637 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
638 support, to edit pages etc without a web server.
639 * Display CGI processing errors if present.
640 * Fix from Faidon for a XML parser issue that breaks utf-8 for
641 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
642 area, and also way slow.
643 * Match 'web commit from' in SVN and git, these are web commits too.
645 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
646 readable and avoid future mistakes. The patch seems to work and for the
647 first time I have a UTF-8 username ;-) (Faidon)
648 * Use form->field consistently, not form->param.
649 * Patch from Recai to allow selection of page type when creating a new page.
650 Default page type is inherited from the link clicked on to create the new
653 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
655 ikiwiki (1.8) unstable; urgency=low
657 * Fix orphans plugin to not count a link to a nonexistant page as a reason
658 for a page not being an orphan.
659 * Support pinging services such as Technorati using XML-RPC to notify them
660 about changes to rss feeds.
661 * Parse svn log as xml for improved utf8 and security. Note that this makes
662 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
663 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
664 flagged string even if the locale causes it to generate utf8 output,
665 so make sure to let perl know it should be handled as utf8. Also,
666 the optimised version used for standard time formats won't work if the
667 user has changed locale, so drop it. Thanks, Faidon Liambotis.
668 * Fix re-encoding of the comments field to utf8 if a commit fails
669 due to a conflict. Thanks, Faidon Liambotis.
670 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
672 * Add insane double encode/decode to utf8 around call to markdown.
673 This works around a truely strange bug, which is apparently a bug in
674 perl, #376329. Also added a test case for it.
675 * Improve layout of edit page so formatting help link is always visible w/o
676 getting in the way of the preview.
677 * Centralised all calls to HTML::Template and force all the templates
679 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
680 * Introduce add_plugins and disable_plugins config options in setup files.
681 This allows adding or removing plugins w/o overriding the whole list of
682 default plugins, which makes it easier to upgrade when new default plugins
684 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
685 default (of course!). Based on a patch by Faidon Liambotis.
686 * Add a html plugin, which can be used to write wikis in raw html,
687 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
688 defaults to not processing .html files, since w/o this plugin they would
689 be copied unsanitised. With this plugin, it will process and html
690 sanitise them, like any other page type.
691 * Rebuilding wrappers is necessary on upgrade to this version.
692 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
693 will be automatically done on all upgrades.
694 * Don't send pings if the wiki is being rebuilt.
695 * Work around very innefficient behavior in File::Spec::abs2rel. Result
696 is a savings of 2 pointless fork/execs per link calculation, which
697 results in ~25% speedup of ikiwiki building its own doc wiki, and
698 about 35% speedup displaying RecentChanges!
699 * Make RecentChanges use a table and some CSS, should be much more readable.
700 No code changes involved.
701 * Encode & in diffurl in examples, to conform to pedantic rules.
702 * Speed up RecentChanges by another 40% or so with some memoization.
703 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
704 in time to build the doc wiki.
706 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
708 ikiwiki (1.7) unstable; urgency=low
710 * Updated logo from Recai with some kerning and alingment tuning.
711 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
715 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
717 ikiwiki (1.6) unstable; urgency=low
719 * YA utf-8 patch from Recai, this time to fix previewing a page so that
720 the text in the input box is re-encoded back to utf-8.
721 * -CSD does not affect modules, so readfile() was not using the utf-8 input
722 layer, which led to lots of problems; make it force read files as utf-8.
724 * Note that as a consequence, this version of ikiwiki will actually try to
725 parse utf8 in source files for the first time, which may expose broken
726 utf8 in wiki sources that was hidden before. Most common will be
727 perl warnings like "utf8 "\xE9" does not map to Unicode"
728 * writefile() likewise needs to use the utf8 output layer.
729 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
731 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
732 given the readfile fix.
733 * Add utf-8 testcases for readfile and htmlize.
734 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
736 * More utf-8 fixes from Recai, partly to things I broke above:
737 - The serious problem is that writefile() saves the content in undecoded
738 format in CGI, hence all (non-ascii) chars are corrupted permanently.
739 - Comment field in edit page is not decoded and all the non-ascii chars in
740 this field are corrupted as the result. We should decode it as we do it
742 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
744 * New SVG logo from Recai.
746 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
748 ikiwiki (1.5) unstable; urgency=low
750 * Add --timeformat config option to allow changing how dates are displayed.
751 Note that as a side effect, dates will now be displayed using the local
752 timezone, not as GMT.
753 * More security review.
754 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
755 for some handy stuff like:
756 - Using links as a kind of tag; creating blog pages that list all pages
757 containing a given tag/link or not containing some other tag.
758 - Subscribing to mail notifications whenever a change is made to a page
759 that is a backlink of page foo. Ie, "Please notify me of changes in all
760 pages that link to my home page in the wiki"
761 - Locking any pages that are linked to from a particular page, so that
762 lists of locks can be exposed in the wiki.
763 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
764 when a todo item is done, instead of the previous moving it to a different
766 * Allow pagetemplate plugins to override *anything* in the template.
767 * Add a meta plugin, which allows specifying various metadata about pages,
768 like license and author. It also allows for inserting html link and meta
769 tags into html, overriding the title, and adding hidden WikiLinks, which
770 can be useful when using link-based globbing for page categorisation.
771 * Remove preprocessor directives from inlined pages.
772 * Allow simple preprocessor directive values to be specified w/o quotes.
773 * Add support for using git instead of subversion as the RCS backend,
774 tremendous thanks to Recai Oktaş for this.
775 * Doc updates for git.
776 * Fix absolute url munging in rss generation to support https, ftp, etc urls
778 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
779 utf-8 for edit and other fields, and for recentchanges. There may still
780 be utf-8 issues with the preferences page though.
782 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
784 ikiwiki (1.4) unstable; urgency=low
786 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
787 very strange way of enabling proper XHTML <br /> type tags. Output html
788 should be always valid again now.
789 * The page name and parent links has switched from using a <h1> to a styled
790 <span>, so pages can use <h1> internally instead of needing to use <h2>.
791 * Updated all of ikiwiki's own wiki pages for that.
792 * Add pagetemplate hook, which can be used by plugins that want to mess
793 around with adding new stuff to the page template.
794 * Remove headercontent; the search plugin now adds the search box to the
795 header by registering a pagetemplate hook, and other plugins should do
797 * Rebuilding on upgrade to this version is recommended.
798 * Add a html validity check to the test suite, using the wdg-html-validator,
800 * Make the html valid when there is nothing in the actions list.
801 * Reordered some function call parameters for consistency.
802 * Enable full utf-8 support for page input and output.
803 * Add a workaround for markdown, which does not work well with utf-8
805 * --getctime had bitrotted (well I only ever used it the once so far..),
806 fix and make it a bit more flexible
807 * rcs_getctime is changed, now rather than needing to loop over all pages,
808 it should just use the rcs to get the ctime of the passed file.
809 * When inlining a page in another one, links from the inlined page are now
810 expanded the same as they are when rendering the inlined page as a
811 standalone page. So rather than being expanded from the POV of the
812 inlining page, they are expanded from the POV of the inlined page.
814 For example, a link from blog/foo to "bar" will now link to blog/bar
815 if it exists. Previously this needed to be a link explicitly to
816 "blog/bar"; such links will also continue to work.
818 (This was slightly complex to do as the link still has to be constructed
819 relative to the inlining page.)
820 * Make page edit textarea resize to fit browser window.
821 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
822 do not need a full rebuild, in order to update any basewiki pages.
824 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
826 ikiwiki (1.3) unstable; urgency=low
828 * Fix the preinst introduced in the last version. Closes: #367458
830 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
832 ikiwiki (1.2) unstable; urgency=low
834 * Remove dups from the brokenlinks list.
835 * Add libc6-dev to dependencies, needed to build wrappers.
836 * Install wikilist in correct location. Closes: #367371
838 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
840 ikiwiki (1.1) unstable; urgency=low
842 * Rename inlinepage to depends, so that it can be used to refer to more
843 dependency relationships than just inlining. This will require a rebuild
844 on upgrade to this version.
845 * Move the rss link, put it in the blogpost form if there is one and at the
846 top if not. This is both nicer because easier to find, and it cleans up
847 the code which had used inlinepage as a flag for adding the link later.
848 * Allow the depends GlobList to be built up from multiple sources (such as
849 plugins) during a page render.
850 * Which means that more than one blog is now supported to appear on a
851 single page. (With some limitations, like only the last one getting an
853 * Added a plugin system.
854 * Added a pagecount plugin, enabled by default.
855 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
856 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
857 backlinks when the backlinks hadn't really changed.
858 * Moved inline page support, rss generation etc into the inline plugin,
860 * Added brokenlinks plugin, not enabled by default, but rather handy.
861 * Fix several broken links in the doc wiki.
862 * Smarter behavior when creating a page and a page of the same name (but
863 different location) already exists.
864 * Add an orphans plugin for finding pages that nothing links to.
865 * Removed backlinks page, which it turns out nothing used.
866 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
867 it, this will allow for adding a unit test suite.
868 * Add unit tests for several core functions, including globlist_match,
869 dirname, basename, bestlink, linkify, pagetitle, titlepage.
870 * Smart globlist merging.
871 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
872 to pave the way for adding other RCS support. This also changes the
873 setup files, where before they had svn => 1 or svn => 0, now they have
874 rcs => "svn" or rcs => "".
875 * Add a debian/NEWS file with upgrade notes.
876 * Load whatever rcs module is specified, so new ones can be just dropped in
877 as plugins and work. (Well, in theory.)
878 * Add some basic docs about writing RCS modules.
879 * Broke search capability out into a plugin, removed the --hyperestraier
881 * Added smiley plugin, nicely controlled and documented by the smileys page.
882 * Copied in some smileys from Moin Moin.
883 * Allow links of the form [[some page|page]], with whitespace in the link
885 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
886 and --disable-plugin htmlscrubber.
887 * Allow discussion links on pages to be turned off with --no-discussion.
888 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
889 * Add some new config items to the estseek.conf template, which are needed
890 by hyperestraier 1.2.3.
892 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
894 ikiwiki (1.0) unstable; urgency=low
896 * First official release.
898 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400