1 ikiwiki (1.27) UNRELEASED; urgency=low
3 * Add a googlecalendar plugin. A bit special-purpose, but it shows
4 one way to to deal with user-supplied content that could cause XSS
5 issues w/o the htmlscrubber, and won't survive the scrubber.
6 * Work on firming up the plugin interface:
7 - Plugins should not need to load IkiWiki::Render to get commonly
8 used functions, so moved some functions from there to IkiWiki.
9 - Picked out the set of functions and variables that most plugins
10 use, documented them, and made IkiWiki export them by default,
11 like a proper perl module should.
12 - Use the other functions at your own risk.
13 - This is not quite complete, I still have to decide whether to
14 export some other things.
15 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16 referring to stuff now exported by the IkiWiki module.
17 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18 to declare which version of the interface your plugin needs.
19 * Anyone with a third-party ikiwiki plugin is strongly encouraged
20 to make like changes to it and avoid use of non-exported symboles from
22 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23 * Support hyperestradier version 1.4.2, which adds a new required phraseform
25 * If an inlined page has a permalink, link the page title to that.
26 * Patch from Recai to use utf8 when reading the setup file, so that
27 utf8 wikinames from there will be used properly.
28 * Patch from Recai to kill utf-8 on the wiki name when generating the
30 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31 * Fix a baseurl problem in hyperestradier search results.
32 * Add a stub local.css to avoid problems with 404's.
33 * Patch from Recai to fix a wide character warning from the search plugin
34 during setup if the wikiname contains utf8.
36 -- Joey Hess <joeyh@debian.org> Fri, 15 Sep 2006 13:10:06 -0400
38 ikiwiki (1.26) unstable; urgency=low
40 * Add a missing -n to tla undo call.
41 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
42 writes before consuming its whole stdin. Avoid this deadlock.
43 * Fix alt tags for outline checkboxes.
45 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
47 ikiwiki (1.25) unstable; urgency=low
49 * Add proper waitpid calls for open2ed processes throughout to avoid
50 zombies; this hit htmltidy especially badly.
51 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
52 subversion repos and fixing some other issues.
53 * Add support for tla, contributed by Clint Adams. Closes: #385936
54 * Add support for mercurial, contributed by Emanuele Aina.
55 * Include <link rel> tag for RSS feeds, used by some aggregators and
56 firefox to find the feed.
57 * Add a linkmap plugin (requires graphviz).
59 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
61 ikiwiki (1.24) unstable; urgency=low
63 * Simplify the data structure returned by rcs_recentchanges to avoid
64 each rcs plugin needing to form complex strings on its own.
65 * Fix another destpage issue in the inline directive. Closes: #385512
68 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
70 ikiwiki (1.23) unstable; urgency=low
72 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
74 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
76 ikiwiki (1.22) unstable; urgency=low
78 * Change how the stylesheet url is determined in the templates: Remove
79 STYLEURL and add BASEURL to all templates (some already had it). This
80 new more general variable can be used to link to other things (eg, images)
81 from the template, as well as stylesheets.
82 * Fix a bug introduced last version to do with nested inlines.
83 * Allow preprocessor directives to span multiple lines, both to make
84 long ones with lots of values easier to write, and to allow for ones with
85 multi-line quoted values.
86 * Allow preprocessor directives to contain python-like triple-quoted
87 text blocks, for easy nesting of quotes inside.
88 * Add a template plugin.
89 * Make pagespec merge code smarter about merging duplicate pagespecs.
90 * Patch from Jordà Polo to make Setup::Standard support hashes in config
92 * Change order of linkify and preprocess; first preprocess and then linkify.
93 This allows passing a wikilink inside a parameter to a preprocessor
94 directive without it being expanded to html, and leaking out of the
95 parameter, which had required some non-obvious use of triple-quoting
96 to avoid. Note that any preprocessor plugins that output something
97 that looks like a wikilink will now have it treated as such; AFAIK
98 this doesn't change any behavior though except for the template plugin.
99 * Enable preprocessor directives when previewing an edit.
100 * Make all pages pull in a local.css style sheet, if present. This won't
101 be included in ikiwiki, but can be created to make local styling changes
102 w/o needing to merge in every new change to the distributed style.css.
103 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
104 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
105 from a different directory.
106 * Generalised preprocesser loop protection code.
107 * Patch from James Westby to allow a description to be set for rss feeds.
108 * Patch from James Westby to add a template for the search form.
109 * Added a ddate plugin.
110 * Patch from James Westby to add a --sslcookie switch, which forces
111 cookies to only be sent over ssl connections to avoid interception.
112 * Fix preferences page on anonok wikis; still need to sign in to get
113 to the preferences page.
114 * Add toc (table of contents) plugin.
115 * Change htmlize, format, and sanitize hooks to use named parameters.
116 * Patch from James Westby to add an actions option to inline; this
117 adds Edit and Discussion links at the end of blog entries.
118 * Due to some css changes, you'll want to rebuild your wiki on upgrade
119 to this version. Will be handled automatically by the deb.
120 * Add processed date to aggregate preprocessor directive status output.
122 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
124 ikiwiki (1.21) unstable; urgency=low
126 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
127 * If a page links to itself, mark up the link text in a span with
128 class="selflink" so that it can be styled. I don't have a useful style
129 defined for that though.
130 * Call filter hooks on inlined page content.
131 * Support inlining pages raw, rather than creating a blog.
132 * Clean up yes/no parameter parsing in inline plugin.
133 * Implemented better cycle detection in the inline plugin; nested inlines
135 * Add a map plugin contributed by Alessandro Dotti Contra.
136 * Add otl format plugin, which handles files as created by vimoutliner.
137 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
138 * Add first draft at a Restructured Text (rst) plugin, by Sergio
139 Talens-Oliag. Note that this has many known issues -- see the caveats on
141 * Credit everyone who wrote a plugin on the plugins' wiki pages.
142 * Fix utf-8 in blog post form.
144 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
146 ikiwiki (1.20) unstable; urgency=low
148 * Relicense the templates and basewiki under the 2-clause BSD license.
149 Since these can easily become part of other people's websites, they
150 should be under as permissive a license as possible.
151 * Add --syslog config option, to log to the syslog.
152 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
153 transient failure to fork (which I've seen happen in the wild).
154 * Fix a bug in the aggregator introduced last version that caused all
155 aggregator state to be lost during a non-aggregating build.
157 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
159 ikiwiki (1.19) unstable; urgency=low
161 * Fix several related bugs in page type determination during online editing.
162 * Add some locking to prevent 2 aggregators from running at once.
163 * Fix an infinite loop in the aggregator when finding a unique filename.
165 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
167 ikiwiki (1.18) unstable; urgency=low
169 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
171 * Man page format fixups.
172 * If the meta plugin overides the page title, set a title_overridden
173 variable in the template to true. This allows doing things with the
174 templates conditional on the title being overriden.
175 * Add a %pagecase which maps lower-case page names to the actual case
176 used in the filename. Use this in bestlinks calculation instead of
177 forcing the link to lowercase.
178 * Also use %pagecase in various other places that want to check if a page
179 with a given name exists.
180 * This means that links to pages with mixed case names will now work,
181 even if the link is in some other case mixture, and mixed case pages
182 should be fully supported throughout ikiwiki.
183 * Recommend rebuilding wikis on upgrade to this version.
185 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
187 ikiwiki (1.17) unstable; urgency=low
189 * Disable tidy generator tag.
190 * Move tidy back to sanitize hook, found out how to only show body.
191 * Turn off tidy indentation too.
192 * Turn on HTML::Template loop_context_vars; not actually used in stock
193 templates but can be useful for things like making comma-delimited lists
194 of tags or what have you.
195 * Remove <br> from end of aggregate preprocessor directive output.
196 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
197 case-sensative filesystems like OSX.
198 * Improve markdown loading. First, try to load it as a proper perl module,
199 in case it was installed as one. Then fall back to trying
201 * Document in install page how to install markdown, since it has no
202 installation procedure in the upstream tarball.
203 * Set die_on_bad_params => 0 for all templates, to allow users to modify
204 them without annoyances.
205 * Suck in the page content when generating an inline archive page, to work
206 around the meta plugin's lack of caching of title metadata across runs.
208 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
210 ikiwiki (1.16) unstable; urgency=low
212 * Try to handle relative links in aggregated feeds. However,
213 the current support is a crude hack due to limitations of XML::Feed:
214 xml:base is not supported, neither is Content-Location. And of course,
215 relative links in RSS feeds are ill-undefined..
216 * Make aggregator save permalinks and author name to pages as metadata.
217 * Add permalink and author support to meta plugin, affecting RSS feeds
219 * Various CSS and formatting changes.
220 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
221 * Add xhtml files to the default prune regexp.
222 * Also generate rel=bookmark links for permalinks.
223 * Fix the htmltidy plugin, which wasn't working due my breaking it when
225 * Don't run tidy with -xml as that fails if the input is not well-formed.
226 Run it with -asxhtml instead, so it will output well-formed xhtml no
227 matter what the input.
228 * Disable tidy warnings too.
229 * Add a new format hook, and make tidy use it, since tidy can really only
230 operate on and output complete html documents, not the body chunks
232 * Fix dates in rss feeds if running localised, so they're still rfc 822.
234 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
236 ikiwiki (1.15) unstable; urgency=low
238 * Remove CDPATH and other env vars perl taint checking doesn't like.
240 * Added created_before and created_after PageSpec limits.
242 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
244 ikiwiki (1.14) unstable; urgency=low
246 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
248 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
249 * Added many unit tests for pagespec_match.
251 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
253 ikiwiki (1.13) unstable; urgency=low
255 * ikiwiki can now download and aggregate feeds with its new aggregate
256 plugin, so it's possible to implement a Planet using ikiwiki!
257 * Add a run_hooks function for the common task of running all hooks of a
259 * Add a savestate hook.
260 * Don't put blog post forms on pages if there's no cgiurl set.
261 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
262 --wrappers to do that.
263 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
264 to update pages that haven't changed on disk.
265 * Change meta tags to use html entity-escaped text for values, so that
266 quotes and such can be represented in title tags.
267 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
269 * Make --rebuild also cause --aggregate to re-download and write aggregated
271 * Avoid outputting duplicate meta info.
272 * Include title metadata on aggregated posts for capitalised and un-munged
274 * Title metadata of inlined pages now shows up in blogs and rss feeds.
275 * Fix issue with unicode filenames and updating the hyper estradier search
276 index. (Aka Please Please Please, let that be the last one.)
277 * Patch from Roland Mas to support an rss=no parameter to inline directives.
279 * Renamed GlobLists to PageSpecs.
280 * PageSpecs can now include nested parens, "and", and "or". This remains
281 backwards compatible to the old GlobList format. It's implemented by
282 treating the GlobList as a very limited microlanguage that is transformed
283 to perl code that does the matching.
284 * The old GlobList format is deprecated, and I encourage users to switch to
285 using the new PageSpec format. Compatability with the old format will be
286 removed at some point, possibly by 2.0.
287 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
288 * Add support for creation_month and creation_year to PageSpec.
290 * Changes to index file encoding.
292 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
294 ikiwiki (1.12) unstable; urgency=low
297 * New pagestats plugin from Enrico, which can generate a table counting
298 the backlinks for each page, or a del.icio.us style cloud.
299 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
300 the wikiformat plugin works. Thanks, Emanuele Aina.
301 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
302 display, running them through pagetitle. This removes ugly underscores and
303 other gunk from the display, much nicer. You may want to rebuild your wiki
304 when upgrading to get the cleanup globally.
305 * Polygen plugin from Enrico.
306 * htmltidy plugin from Faidon.
307 * Locale patch from Faidon:
308 - Adds a locale setting to setup files.
309 - Proper local time, if the locale configuration option is used.
310 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
311 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
313 * Add getopt hook type, this allows plugins to add new command-line options.
314 * Add --tagbase option to tag plugin.
315 * Add exclude option in setup files, works same as --exclude.
316 * Put categories in rss feeds for tagged items.
317 * Allow preprocessor directives to be expanded in inlined blog pages.
318 However, to avoid inlining loops etc, don't expand inline directives in
320 * fortune plugin (trivial)
321 * Tag plugins according to type.
323 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
325 ikiwiki (1.11) unstable; urgency=low
327 * Patch from Enrico that
328 - Adds a tag plugin that allows more easily tagging pages.
329 The meta plugin can also still be used for that, but the tag plugin
330 also lists a page's tags at the bottom of the page.
331 - Allows preprocessor directives to have parameters with no specified
333 - Fixes preprocessor directive parameter parsing so that
334 foo=bar baz now means "foo=bar" and a "baz" with no value.
335 * Run pagetemplate hooks when inlining pages so that inlined pages also
337 * Make all plugins with pagetemplate hooks check that variables exist
338 on the template before setting them, for robustness.
339 * Switch pagetemplate hooks to using named parameters.
340 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
341 This will be the page that a source page will be part of, which is
342 different than the source page for inlined pages.
343 * Audited all plugins to endure they pass (page, destpage) to htmllink
344 appropriatly. This means inlining of various plugins will not work
345 properly, with correct links generated.
347 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
349 ikiwiki (1.10) unstable; urgency=low
351 * Run page through any relevant filters when generating a page preview.
352 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
353 default throughout the wiki, not only on wikitext pages. Decided to call
354 this a feature, and split the camelcase support out into a separate plugin
355 that is independant of wikitext.
356 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
358 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
360 ikiwiki (1.9) unstable; urgency=low
362 * Improve display of parentlinks and page title of toplevel index page.
363 * Patch from Faidon to use svn --limit when possible for recentchanges,
364 speeds up recentchanges a lot for wikis with more history.
365 * Patch from Recai to fix utf8 issues in git backend.
366 * Add wikitext markup plugin, which supports ".wiki" pages written in the
367 original wiki syntax, CamelCase links and all.
368 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
369 support, to edit pages etc without a web server.
370 * Display CGI processing errors if present.
371 * Fix from Faidon for a XML parser issue that breaks utf-8 for
372 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
373 area, and also way slow.
374 * Match 'web commit from' in SVN and git, these are web commits too.
376 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
377 readable and avoid future mistakes. The patch seems to work and for the
378 first time I have a UTF-8 username ;-) (Faidon)
379 * Use form->field consistently, not form->param.
380 * Patch from Recai to allow selection of page type when creating a new page.
381 Default page type is inherited from the link clicked on to create the new
384 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
386 ikiwiki (1.8) unstable; urgency=low
388 * Fix orphans plugin to not count a link to a nonexistant page as a reason
389 for a page not being an orphan.
390 * Support pinging services such as Technorati using XML-RPC to notify them
391 about changes to rss feeds.
392 * Parse svn log as xml for improved utf8 and security. Note that this makes
393 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
394 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
395 flagged string even if the locale causes it to generate utf8 output,
396 so make sure to let perl know it should be handled as utf8. Also,
397 the optimised version used for standard time formats won't work if the
398 user has changed locale, so drop it. Thanks, Faidon Liambotis.
399 * Fix re-encoding of the comments field to utf8 if a commit fails
400 due to a conflict. Thanks, Faidon Liambotis.
401 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
403 * Add insane double encode/decode to utf8 around call to markdown.
404 This works around a truely strange bug, which is apparently a bug in
405 perl, #376329. Also added a test case for it.
406 * Improve layout of edit page so formatting help link is always visible w/o
407 getting in the way of the preview.
408 * Centralised all calls to HTML::Template and force all the templates
410 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
411 * Introduce add_plugins and disable_plugins config options in setup files.
412 This allows adding or removing plugins w/o overriding the whole list of
413 default plugins, which makes it easier to upgrade when new default plugins
415 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
416 default (of course!). Based on a patch by Faidon Liambotis.
417 * Add a html plugin, which can be used to write wikis in raw html,
418 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
419 defaults to not processing .html files, since w/o this plugin they would
420 be copied unsanitised. With this plugin, it will process and html
421 sanitise them, like any other page type.
422 * Rebuilding wrappers is necessary on upgrade to this version.
423 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
424 will be automatically done on all upgrades.
425 * Don't send pings if the wiki is being rebuilt.
426 * Work around very innefficient behavior in File::Spec::abs2rel. Result
427 is a savings of 2 pointless fork/execs per link calculation, which
428 results in ~25% speedup of ikiwiki building its own doc wiki, and
429 about 35% speedup displaying RecentChanges!
430 * Make RecentChanges use a table and some CSS, should be much more readable.
431 No code changes involved.
432 * Encode & in diffurl in examples, to conform to pedantic rules.
433 * Speed up RecentChanges by another 40% or so with some memoization.
434 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
435 in time to build the doc wiki.
437 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
439 ikiwiki (1.7) unstable; urgency=low
441 * Updated logo from Recai with some kerning and alingment tuning.
442 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
446 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
448 ikiwiki (1.6) unstable; urgency=low
450 * YA utf-8 patch from Recai, this time to fix previewing a page so that
451 the text in the input box is re-encoded back to utf-8.
452 * -CSD does not affect modules, so readfile() was not using the utf-8 input
453 layer, which led to lots of problems; make it force read files as utf-8.
455 * Note that as a consequence, this version of ikiwiki will actually try to
456 parse utf8 in source files for the first time, which may expose broken
457 utf8 in wiki sources that was hidden before. Most common will be
458 perl warnings like "utf8 "\xE9" does not map to Unicode"
459 * writefile() likewise needs to use the utf8 output layer.
460 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
462 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
463 given the readfile fix.
464 * Add utf-8 testcases for readfile and htmlize.
465 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
467 * More utf-8 fixes from Recai, partly to things I broke above:
468 - The serious problem is that writefile() saves the content in undecoded
469 format in CGI, hence all (non-ascii) chars are corrupted permanently.
470 - Comment field in edit page is not decoded and all the non-ascii chars in
471 this field are corrupted as the result. We should decode it as we do it
473 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
475 * New SVG logo from Recai.
477 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
479 ikiwiki (1.5) unstable; urgency=low
481 * Add --timeformat config option to allow changing how dates are displayed.
482 Note that as a side effect, dates will now be displayed using the local
483 timezone, not as GMT.
484 * More security review.
485 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
486 for some handy stuff like:
487 - Using links as a kind of tag; creating blog pages that list all pages
488 containing a given tag/link or not containing some other tag.
489 - Subscribing to mail notifications whenever a change is made to a page
490 that is a backlink of page foo. Ie, "Please notify me of changes in all
491 pages that link to my home page in the wiki"
492 - Locking any pages that are linked to from a particular page, so that
493 lists of locks can be exposed in the wiki.
494 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
495 when a todo item is done, instead of the previous moving it to a different
497 * Allow pagetemplate plugins to override *anything* in the template.
498 * Add a meta plugin, which allows specifying various metadata about pages,
499 like license and author. It also allows for inserting html link and meta
500 tags into html, overriding the title, and adding hidden WikiLinks, which
501 can be useful when using link-based globbing for page categorisation.
502 * Remove preprocessor directives from inlined pages.
503 * Allow simple preprocessor directive values to be specified w/o quotes.
504 * Add support for using git instead of subversion as the RCS backend,
505 tremendous thanks to Recai Oktaş for this.
506 * Doc updates for git.
507 * Fix absolute url munging in rss generation to support https, ftp, etc urls
509 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
510 utf-8 for edit and other fields, and for recentchanges. There may still
511 be utf-8 issues with the preferences page though.
513 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
515 ikiwiki (1.4) unstable; urgency=low
517 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
518 very strange way of enabling proper XHTML <br /> type tags. Output html
519 should be always valid again now.
520 * The page name and parent links has switched from using a <h1> to a styled
521 <span>, so pages can use <h1> internally instead of needing to use <h2>.
522 * Updated all of ikiwiki's own wiki pages for that.
523 * Add pagetemplate hook, which can be used by plugins that want to mess
524 around with adding new stuff to the page template.
525 * Remove headercontent; the search plugin now adds the search box to the
526 header by registering a pagetemplate hook, and other plugins should do
528 * Rebuilding on upgrade to this version is recommended.
529 * Add a html validity check to the test suite, using the wdg-html-validator,
531 * Make the html valid when there is nothing in the actions list.
532 * Reordered some function call parameters for consistency.
533 * Enable full utf-8 support for page input and output.
534 * Add a workaround for markdown, which does not work well with utf-8
536 * --getctime had bitrotted (well I only ever used it the once so far..),
537 fix and make it a bit more flexible
538 * rcs_getctime is changed, now rather than needing to loop over all pages,
539 it should just use the rcs to get the ctime of the passed file.
540 * When inlining a page in another one, links from the inlined page are now
541 expanded the same as they are when rendering the inlined page as a
542 standalone page. So rather than being expanded from the POV of the
543 inlining page, they are expanded from the POV of the inlined page.
545 For example, a link from blog/foo to "bar" will now link to blog/bar
546 if it exists. Previously this needed to be a link explicitly to
547 "blog/bar"; such links will also continue to work.
549 (This was slightly complex to do as the link still has to be constructed
550 relative to the inlining page.)
551 * Make page edit textarea resize to fit browser window.
552 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
553 do not need a full rebuild, in order to update any basewiki pages.
555 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
557 ikiwiki (1.3) unstable; urgency=low
559 * Fix the preinst introduced in the last version. Closes: #367458
561 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
563 ikiwiki (1.2) unstable; urgency=low
565 * Remove dups from the brokenlinks list.
566 * Add libc6-dev to dependencies, needed to build wrappers.
567 * Install wikilist in correct location. Closes: #367371
569 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
571 ikiwiki (1.1) unstable; urgency=low
573 * Rename inlinepage to depends, so that it can be used to refer to more
574 dependency relationships than just inlining. This will require a rebuild
575 on upgrade to this version.
576 * Move the rss link, put it in the blogpost form if there is one and at the
577 top if not. This is both nicer because easier to find, and it cleans up
578 the code which had used inlinepage as a flag for adding the link later.
579 * Allow the depends GlobList to be built up from multiple sources (such as
580 plugins) during a page render.
581 * Which means that more than one blog is now supported to appear on a
582 single page. (With some limitations, like only the last one getting an
584 * Added a plugin system.
585 * Added a pagecount plugin, enabled by default.
586 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
587 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
588 backlinks when the backlinks hadn't really changed.
589 * Moved inline page support, rss generation etc into the inline plugin,
591 * Added brokenlinks plugin, not enabled by default, but rather handy.
592 * Fix several broken links in the doc wiki.
593 * Smarter behavior when creating a page and a page of the same name (but
594 different location) already exists.
595 * Add an orphans plugin for finding pages that nothing links to.
596 * Removed backlinks page, which it turns out nothing used.
597 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
598 it, this will allow for adding a unit test suite.
599 * Add unit tests for several core functions, including globlist_match,
600 dirname, basename, bestlink, linkify, pagetitle, titlepage.
601 * Smart globlist merging.
602 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
603 to pave the way for adding other RCS support. This also changes the
604 setup files, where before they had svn => 1 or svn => 0, now they have
605 rcs => "svn" or rcs => "".
606 * Add a debian/NEWS file with upgrade notes.
607 * Load whatever rcs module is specified, so new ones can be just dropped in
608 as plugins and work. (Well, in theory.)
609 * Add some basic docs about writing RCS modules.
610 * Broke search capability out into a plugin, removed the --hyperestraier
612 * Added smiley plugin, nicely controlled and documented by the smileys page.
613 * Copied in some smileys from Moin Moin.
614 * Allow links of the form [[some page|page]], with whitespace in the link
616 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
617 and --disable-plugin htmlscrubber.
618 * Allow discussion links on pages to be turned off with --no-discussion.
619 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
620 * Add some new config items to the estseek.conf template, which are needed
621 by hyperestraier 1.2.3.
623 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
625 ikiwiki (1.0) unstable; urgency=low
627 * First official release.
629 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400