1 ikiwiki (1.32) UNRELEASED; urgency=low
3 * Add a separate pass to find page links, and only render each page once,
4 instead of over and over. Typical speedup is ~4x. Max possible speedup:
6 * Add "scan" parameter to hook(), which is used to make the hook be called
7 during the scanning pass, as well as the render pass. The meta and tag
8 plugins need to use the new scan parameter, so will any others that modify
10 * Now that links are calculated in a separate pass, it can also
11 precalculate backlinks in one pass, which is O(N^2) instead of the
12 previous code that was O(N^3). A very nice speedup for wikis with lots
15 -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 23:27:29 -0400
17 ikiwiki (1.31) unstable; urgency=low
19 * Patch from Pawel Tecza to cp -a the templates in the Makefile.
20 * Change the rss feed title from the wikiname to the page title, with
21 an exception for the wiki's toplevel index page, which will still use the
22 wikiname as the feed title.
23 Overriding the page title with meta title already overrode the rss feed
25 * Add an img plugin, based on Christian Mock's img plugin, but stripped
26 down to the bare essentials. Useful for handling large images on websites.
27 * Sanitize possibly problimatic characters out of the polygen grammar names,
28 just in case. Should not be exploitable anyway, since it only tries to run
29 polygen after finding the specified grammar file.
30 * Add missing dependency on the URI perl module.
31 * Add basic spam fighting tool for admins: An admin's prefs page now allows
32 editing a list of banned users.
34 -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 23:16:33 -0400
36 ikiwiki (1.30) unstable; urgency=low
38 * Add no_override parameter to hook().
39 * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
40 plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
41 can be configured using a page in wiki.
42 * Fix support for --pingurl at the command line.
43 * Fix a subtle bug in will_render that broke some builds, by only clearing
44 items from renderedfiles the first time per build.
45 * Wrap entire technortati ping operation in an eval to catch all possible
46 failure modes, after I observed a simple ->value crashing ikiwiki when
49 -- Joey Hess <joeyh@debian.org> Mon, 16 Oct 2006 15:17:38 -0400
51 ikiwiki (1.29) unstable; urgency=low
53 * Patch from Paul Tötterman to use CP in the Makefile.
54 * Patch from Alec Berryman adding a http_auth config item that allows
55 using HTTP Authentication instead of ikiwiki's built in authentication.
56 Useful for eg, large sites with their own previously existing user auth
57 setup. Closes: #384534
58 * Change %renderedfiles to store an array of files rendered from a given
59 source file, to allow tracking of extra rendered files like rss feeds.
60 * Note that plugins that accessed this variable will need to be updated!
61 The plugin interface has been increased to version 1.01 for this change.
62 As few plugins use %renderedfiles I haven't done anything else to ensure
63 compatability of old plugins.
64 * Add will_render function to the plugin interface, used to register that a
65 page renders a destination file, and do some security checks. Previously
66 but no longer rendered files will be cleaned up.
67 * Use will_render in the inline and linkmap plugins.
68 * You will need to rebuild your wiki on upgrade to this version.
69 * Atom feed support based on a patch by Clint Adams.
70 * Add feeds=no option to inline preprocessor directive to turn off all types
72 * $IkiWiki::version now holds the program version, and is accessible to
74 * Make the aggregate plugin emphasize error messages.
75 * Patch from Recai to limit recentchanges to displaying max 10 files for a
76 given changeset (to avoid large number of file changes excessively
79 -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
81 ikiwiki (1.28) unstable; urgency=low
83 * inline: Add ability to sort by page name, based on a patch from
85 * Fix a forkbomb in various calls to IPC::Open2, which has a highly
86 braindead interface. Closes: #389383
87 * Don't rm -rf ikiwiki on distclean, since a) there's no such file
88 and b) those poor Mac OSX users and their case insensative files!
89 * Don't fail syntax check if Text::Typography isn't installed.
92 -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
94 ikiwiki (1.27) unstable; urgency=low
96 * Work on firming up the plugin interface:
97 - Plugins should not need to load IkiWiki::Render to get commonly
98 used functions, so moved some functions from there to IkiWiki.
99 - Picked out the set of functions and variables that most plugins
100 use, documented them, and made IkiWiki export them by default,
101 like a proper perl module should.
102 - Use the other functions at your own risk.
103 - This is not quite complete, I still have to decide whether to
104 export some other things.
105 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
106 referring to stuff now exported by the IkiWiki module.
107 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
108 to declare which version of the interface your plugin needs.
109 * Anyone with a third-party ikiwiki plugin is strongly encouraged
110 to make like changes to it and avoid use of non-exported symbols from
112 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
113 * Support hyperestradier version 1.4.2, which adds a new required phraseform
115 * If an inlined page has a permalink, link the page title to that.
116 * Patch from Recai to use utf8 when reading the setup file, so that
117 utf8 wikinames from there will be used properly.
118 * Patch from Recai to kill utf-8 on the wiki name when generating the
120 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
121 * Fix a baseurl problem in hyperestradier search results.
122 * Add a stub local.css to avoid problems with 404's.
123 * Patch from Recai to fix a wide character warning from the search plugin
124 during setup if the wikiname contains utf8.
125 * Yet another fix for those poor case-insensative OS X users.
126 * pagetemplate hooks are now also called when generating cgi pages.
127 * Add a favicon plugin, which simply adds a link tag for an icon to each
129 * Patch from James Westby to deal with the case where you're editing a
130 new page, hit cancel, and need to be redirected to somewhere sane.
131 * Various documentation improvements by various wiki users.
132 * Support Text::Markdown from CPAN, which has a different interface from
133 the original markdown or the one in Debian.
134 * Version the libcgi-session-perl dependency, some features that need
135 the new version are used in some cases (sslcookie).
136 * Numerous tla fixes from Clint.
137 * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
138 a multi-resolution favicon.ico.
139 * README.Debian: typo Closes: #388110
140 * chomp trailing newline at the end of templates read in by the template
141 plugin, to allow use of the template preprocessor directive in
142 whitespace-sensative situations. Closes: #387073
143 * Patch from James Westby to make the location of the estseek.cgi script
145 * Add typography (SmartyPants) plugin by Recai.
146 * Add --render mode, which can be used to preview an edit at the command
147 line by test rendering a single page.
148 * Add a googlecalendar plugin. A bit special-purpose, but it shows
149 one way to to deal with user-supplied content that could cause XSS
150 issues w/o the htmlscrubber, and won't survive the scrubber.
152 -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
154 ikiwiki (1.26) unstable; urgency=low
156 * Add a missing -n to tla undo call.
157 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
158 writes before consuming its whole stdin. Avoid this deadlock.
159 * Fix alt tags for outline checkboxes.
161 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
163 ikiwiki (1.25) unstable; urgency=low
165 * Add proper waitpid calls for open2ed processes throughout to avoid
166 zombies; this hit htmltidy especially badly.
167 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
168 subversion repos and fixing some other issues.
169 * Add support for tla, contributed by Clint Adams. Closes: #385936
170 * Add support for mercurial, contributed by Emanuele Aina.
171 * Include <link rel> tag for RSS feeds, used by some aggregators and
172 firefox to find the feed.
173 * Add a linkmap plugin (requires graphviz).
175 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
177 ikiwiki (1.24) unstable; urgency=low
179 * Simplify the data structure returned by rcs_recentchanges to avoid
180 each rcs plugin needing to form complex strings on its own.
181 * Fix another destpage issue in the inline directive. Closes: #385512
184 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
186 ikiwiki (1.23) unstable; urgency=low
188 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
190 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
192 ikiwiki (1.22) unstable; urgency=low
194 * Change how the stylesheet url is determined in the templates: Remove
195 STYLEURL and add BASEURL to all templates (some already had it). This
196 new more general variable can be used to link to other things (eg, images)
197 from the template, as well as stylesheets.
198 * Fix a bug introduced last version to do with nested inlines.
199 * Allow preprocessor directives to span multiple lines, both to make
200 long ones with lots of values easier to write, and to allow for ones with
201 multi-line quoted values.
202 * Allow preprocessor directives to contain python-like triple-quoted
203 text blocks, for easy nesting of quotes inside.
204 * Add a template plugin.
205 * Make pagespec merge code smarter about merging duplicate pagespecs.
206 * Patch from Jordà Polo to make Setup::Standard support hashes in config
208 * Change order of linkify and preprocess; first preprocess and then linkify.
209 This allows passing a wikilink inside a parameter to a preprocessor
210 directive without it being expanded to html, and leaking out of the
211 parameter, which had required some non-obvious use of triple-quoting
212 to avoid. Note that any preprocessor plugins that output something
213 that looks like a wikilink will now have it treated as such; AFAIK
214 this doesn't change any behavior though except for the template plugin.
215 * Enable preprocessor directives when previewing an edit.
216 * Make all pages pull in a local.css style sheet, if present. This won't
217 be included in ikiwiki, but can be created to make local styling changes
218 w/o needing to merge in every new change to the distributed style.css.
219 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
220 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
221 from a different directory.
222 * Generalised preprocesser loop protection code.
223 * Patch from James Westby to allow a description to be set for rss feeds.
224 * Patch from James Westby to add a template for the search form.
225 * Added a ddate plugin.
226 * Patch from James Westby to add a --sslcookie switch, which forces
227 cookies to only be sent over ssl connections to avoid interception.
228 * Fix preferences page on anonok wikis; still need to sign in to get
229 to the preferences page.
230 * Add toc (table of contents) plugin.
231 * Change htmlize, format, and sanitize hooks to use named parameters.
232 * Patch from James Westby to add an actions option to inline; this
233 adds Edit and Discussion links at the end of blog entries.
234 * Due to some css changes, you'll want to rebuild your wiki on upgrade
235 to this version. Will be handled automatically by the deb.
236 * Add processed date to aggregate preprocessor directive status output.
238 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
240 ikiwiki (1.21) unstable; urgency=low
242 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
243 * If a page links to itself, mark up the link text in a span with
244 class="selflink" so that it can be styled. I don't have a useful style
245 defined for that though.
246 * Call filter hooks on inlined page content.
247 * Support inlining pages raw, rather than creating a blog.
248 * Clean up yes/no parameter parsing in inline plugin.
249 * Implemented better cycle detection in the inline plugin; nested inlines
251 * Add a map plugin contributed by Alessandro Dotti Contra.
252 * Add otl format plugin, which handles files as created by vimoutliner.
253 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
254 * Add first draft at a Restructured Text (rst) plugin, by Sergio
255 Talens-Oliag. Note that this has many known issues -- see the caveats on
257 * Credit everyone who wrote a plugin on the plugins' wiki pages.
258 * Fix utf-8 in blog post form.
260 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
262 ikiwiki (1.20) unstable; urgency=low
264 * Relicense the templates and basewiki under the 2-clause BSD license.
265 Since these can easily become part of other people's websites, they
266 should be under as permissive a license as possible.
267 * Add --syslog config option, to log to the syslog.
268 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
269 transient failure to fork (which I've seen happen in the wild).
270 * Fix a bug in the aggregator introduced last version that caused all
271 aggregator state to be lost during a non-aggregating build.
273 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
275 ikiwiki (1.19) unstable; urgency=low
277 * Fix several related bugs in page type determination during online editing.
278 * Add some locking to prevent 2 aggregators from running at once.
279 * Fix an infinite loop in the aggregator when finding a unique filename.
281 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
283 ikiwiki (1.18) unstable; urgency=low
285 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
287 * Man page format fixups.
288 * If the meta plugin overides the page title, set a title_overridden
289 variable in the template to true. This allows doing things with the
290 templates conditional on the title being overriden.
291 * Add a %pagecase which maps lower-case page names to the actual case
292 used in the filename. Use this in bestlinks calculation instead of
293 forcing the link to lowercase.
294 * Also use %pagecase in various other places that want to check if a page
295 with a given name exists.
296 * This means that links to pages with mixed case names will now work,
297 even if the link is in some other case mixture, and mixed case pages
298 should be fully supported throughout ikiwiki.
299 * Recommend rebuilding wikis on upgrade to this version.
301 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
303 ikiwiki (1.17) unstable; urgency=low
305 * Disable tidy generator tag.
306 * Move tidy back to sanitize hook, found out how to only show body.
307 * Turn off tidy indentation too.
308 * Turn on HTML::Template loop_context_vars; not actually used in stock
309 templates but can be useful for things like making comma-delimited lists
310 of tags or what have you.
311 * Remove <br> from end of aggregate preprocessor directive output.
312 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
313 case-sensative filesystems like OSX.
314 * Improve markdown loading. First, try to load it as a proper perl module,
315 in case it was installed as one. Then fall back to trying
317 * Document in install page how to install markdown, since it has no
318 installation procedure in the upstream tarball.
319 * Set die_on_bad_params => 0 for all templates, to allow users to modify
320 them without annoyances.
321 * Suck in the page content when generating an inline archive page, to work
322 around the meta plugin's lack of caching of title metadata across runs.
324 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
326 ikiwiki (1.16) unstable; urgency=low
328 * Try to handle relative links in aggregated feeds. However,
329 the current support is a crude hack due to limitations of XML::Feed:
330 xml:base is not supported, neither is Content-Location. And of course,
331 relative links in RSS feeds are ill-undefined..
332 * Make aggregator save permalinks and author name to pages as metadata.
333 * Add permalink and author support to meta plugin, affecting RSS feeds
335 * Various CSS and formatting changes.
336 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
337 * Add xhtml files to the default prune regexp.
338 * Also generate rel=bookmark links for permalinks.
339 * Fix the htmltidy plugin, which wasn't working due my breaking it when
341 * Don't run tidy with -xml as that fails if the input is not well-formed.
342 Run it with -asxhtml instead, so it will output well-formed xhtml no
343 matter what the input.
344 * Disable tidy warnings too.
345 * Add a new format hook, and make tidy use it, since tidy can really only
346 operate on and output complete html documents, not the body chunks
348 * Fix dates in rss feeds if running localised, so they're still rfc 822.
350 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
352 ikiwiki (1.15) unstable; urgency=low
354 * Remove CDPATH and other env vars perl taint checking doesn't like.
356 * Added created_before and created_after PageSpec limits.
358 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
360 ikiwiki (1.14) unstable; urgency=low
362 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
364 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
365 * Added many unit tests for pagespec_match.
367 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
369 ikiwiki (1.13) unstable; urgency=low
371 * ikiwiki can now download and aggregate feeds with its new aggregate
372 plugin, so it's possible to implement a Planet using ikiwiki!
373 * Add a run_hooks function for the common task of running all hooks of a
375 * Add a savestate hook.
376 * Don't put blog post forms on pages if there's no cgiurl set.
377 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
378 --wrappers to do that.
379 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
380 to update pages that haven't changed on disk.
381 * Change meta tags to use html entity-escaped text for values, so that
382 quotes and such can be represented in title tags.
383 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
385 * Make --rebuild also cause --aggregate to re-download and write aggregated
387 * Avoid outputting duplicate meta info.
388 * Include title metadata on aggregated posts for capitalised and un-munged
390 * Title metadata of inlined pages now shows up in blogs and rss feeds.
391 * Fix issue with unicode filenames and updating the hyper estradier search
392 index. (Aka Please Please Please, let that be the last one.)
393 * Patch from Roland Mas to support an rss=no parameter to inline directives.
395 * Renamed GlobLists to PageSpecs.
396 * PageSpecs can now include nested parens, "and", and "or". This remains
397 backwards compatible to the old GlobList format. It's implemented by
398 treating the GlobList as a very limited microlanguage that is transformed
399 to perl code that does the matching.
400 * The old GlobList format is deprecated, and I encourage users to switch to
401 using the new PageSpec format. Compatability with the old format will be
402 removed at some point, possibly by 2.0.
403 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
404 * Add support for creation_month and creation_year to PageSpec.
406 * Changes to index file encoding.
408 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
410 ikiwiki (1.12) unstable; urgency=low
413 * New pagestats plugin from Enrico, which can generate a table counting
414 the backlinks for each page, or a del.icio.us style cloud.
415 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
416 the wikiformat plugin works. Thanks, Emanuele Aina.
417 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
418 display, running them through pagetitle. This removes ugly underscores and
419 other gunk from the display, much nicer. You may want to rebuild your wiki
420 when upgrading to get the cleanup globally.
421 * Polygen plugin from Enrico.
422 * htmltidy plugin from Faidon.
423 * Locale patch from Faidon:
424 - Adds a locale setting to setup files.
425 - Proper local time, if the locale configuration option is used.
426 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
427 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
429 * Add getopt hook type, this allows plugins to add new command-line options.
430 * Add --tagbase option to tag plugin.
431 * Add exclude option in setup files, works same as --exclude.
432 * Put categories in rss feeds for tagged items.
433 * Allow preprocessor directives to be expanded in inlined blog pages.
434 However, to avoid inlining loops etc, don't expand inline directives in
436 * fortune plugin (trivial)
437 * Tag plugins according to type.
439 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
441 ikiwiki (1.11) unstable; urgency=low
443 * Patch from Enrico that
444 - Adds a tag plugin that allows more easily tagging pages.
445 The meta plugin can also still be used for that, but the tag plugin
446 also lists a page's tags at the bottom of the page.
447 - Allows preprocessor directives to have parameters with no specified
449 - Fixes preprocessor directive parameter parsing so that
450 foo=bar baz now means "foo=bar" and a "baz" with no value.
451 * Run pagetemplate hooks when inlining pages so that inlined pages also
453 * Make all plugins with pagetemplate hooks check that variables exist
454 on the template before setting them, for robustness.
455 * Switch pagetemplate hooks to using named parameters.
456 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
457 This will be the page that a source page will be part of, which is
458 different than the source page for inlined pages.
459 * Audited all plugins to endure they pass (page, destpage) to htmllink
460 appropriatly. This means inlining of various plugins will not work
461 properly, with correct links generated.
463 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
465 ikiwiki (1.10) unstable; urgency=low
467 * Run page through any relevant filters when generating a page preview.
468 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
469 default throughout the wiki, not only on wikitext pages. Decided to call
470 this a feature, and split the camelcase support out into a separate plugin
471 that is independant of wikitext.
472 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
474 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
476 ikiwiki (1.9) unstable; urgency=low
478 * Improve display of parentlinks and page title of toplevel index page.
479 * Patch from Faidon to use svn --limit when possible for recentchanges,
480 speeds up recentchanges a lot for wikis with more history.
481 * Patch from Recai to fix utf8 issues in git backend.
482 * Add wikitext markup plugin, which supports ".wiki" pages written in the
483 original wiki syntax, CamelCase links and all.
484 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
485 support, to edit pages etc without a web server.
486 * Display CGI processing errors if present.
487 * Fix from Faidon for a XML parser issue that breaks utf-8 for
488 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
489 area, and also way slow.
490 * Match 'web commit from' in SVN and git, these are web commits too.
492 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
493 readable and avoid future mistakes. The patch seems to work and for the
494 first time I have a UTF-8 username ;-) (Faidon)
495 * Use form->field consistently, not form->param.
496 * Patch from Recai to allow selection of page type when creating a new page.
497 Default page type is inherited from the link clicked on to create the new
500 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
502 ikiwiki (1.8) unstable; urgency=low
504 * Fix orphans plugin to not count a link to a nonexistant page as a reason
505 for a page not being an orphan.
506 * Support pinging services such as Technorati using XML-RPC to notify them
507 about changes to rss feeds.
508 * Parse svn log as xml for improved utf8 and security. Note that this makes
509 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
510 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
511 flagged string even if the locale causes it to generate utf8 output,
512 so make sure to let perl know it should be handled as utf8. Also,
513 the optimised version used for standard time formats won't work if the
514 user has changed locale, so drop it. Thanks, Faidon Liambotis.
515 * Fix re-encoding of the comments field to utf8 if a commit fails
516 due to a conflict. Thanks, Faidon Liambotis.
517 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
519 * Add insane double encode/decode to utf8 around call to markdown.
520 This works around a truely strange bug, which is apparently a bug in
521 perl, #376329. Also added a test case for it.
522 * Improve layout of edit page so formatting help link is always visible w/o
523 getting in the way of the preview.
524 * Centralised all calls to HTML::Template and force all the templates
526 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
527 * Introduce add_plugins and disable_plugins config options in setup files.
528 This allows adding or removing plugins w/o overriding the whole list of
529 default plugins, which makes it easier to upgrade when new default plugins
531 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
532 default (of course!). Based on a patch by Faidon Liambotis.
533 * Add a html plugin, which can be used to write wikis in raw html,
534 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
535 defaults to not processing .html files, since w/o this plugin they would
536 be copied unsanitised. With this plugin, it will process and html
537 sanitise them, like any other page type.
538 * Rebuilding wrappers is necessary on upgrade to this version.
539 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
540 will be automatically done on all upgrades.
541 * Don't send pings if the wiki is being rebuilt.
542 * Work around very innefficient behavior in File::Spec::abs2rel. Result
543 is a savings of 2 pointless fork/execs per link calculation, which
544 results in ~25% speedup of ikiwiki building its own doc wiki, and
545 about 35% speedup displaying RecentChanges!
546 * Make RecentChanges use a table and some CSS, should be much more readable.
547 No code changes involved.
548 * Encode & in diffurl in examples, to conform to pedantic rules.
549 * Speed up RecentChanges by another 40% or so with some memoization.
550 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
551 in time to build the doc wiki.
553 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
555 ikiwiki (1.7) unstable; urgency=low
557 * Updated logo from Recai with some kerning and alingment tuning.
558 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
562 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
564 ikiwiki (1.6) unstable; urgency=low
566 * YA utf-8 patch from Recai, this time to fix previewing a page so that
567 the text in the input box is re-encoded back to utf-8.
568 * -CSD does not affect modules, so readfile() was not using the utf-8 input
569 layer, which led to lots of problems; make it force read files as utf-8.
571 * Note that as a consequence, this version of ikiwiki will actually try to
572 parse utf8 in source files for the first time, which may expose broken
573 utf8 in wiki sources that was hidden before. Most common will be
574 perl warnings like "utf8 "\xE9" does not map to Unicode"
575 * writefile() likewise needs to use the utf8 output layer.
576 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
578 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
579 given the readfile fix.
580 * Add utf-8 testcases for readfile and htmlize.
581 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
583 * More utf-8 fixes from Recai, partly to things I broke above:
584 - The serious problem is that writefile() saves the content in undecoded
585 format in CGI, hence all (non-ascii) chars are corrupted permanently.
586 - Comment field in edit page is not decoded and all the non-ascii chars in
587 this field are corrupted as the result. We should decode it as we do it
589 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
591 * New SVG logo from Recai.
593 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
595 ikiwiki (1.5) unstable; urgency=low
597 * Add --timeformat config option to allow changing how dates are displayed.
598 Note that as a side effect, dates will now be displayed using the local
599 timezone, not as GMT.
600 * More security review.
601 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
602 for some handy stuff like:
603 - Using links as a kind of tag; creating blog pages that list all pages
604 containing a given tag/link or not containing some other tag.
605 - Subscribing to mail notifications whenever a change is made to a page
606 that is a backlink of page foo. Ie, "Please notify me of changes in all
607 pages that link to my home page in the wiki"
608 - Locking any pages that are linked to from a particular page, so that
609 lists of locks can be exposed in the wiki.
610 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
611 when a todo item is done, instead of the previous moving it to a different
613 * Allow pagetemplate plugins to override *anything* in the template.
614 * Add a meta plugin, which allows specifying various metadata about pages,
615 like license and author. It also allows for inserting html link and meta
616 tags into html, overriding the title, and adding hidden WikiLinks, which
617 can be useful when using link-based globbing for page categorisation.
618 * Remove preprocessor directives from inlined pages.
619 * Allow simple preprocessor directive values to be specified w/o quotes.
620 * Add support for using git instead of subversion as the RCS backend,
621 tremendous thanks to Recai Oktaş for this.
622 * Doc updates for git.
623 * Fix absolute url munging in rss generation to support https, ftp, etc urls
625 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
626 utf-8 for edit and other fields, and for recentchanges. There may still
627 be utf-8 issues with the preferences page though.
629 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
631 ikiwiki (1.4) unstable; urgency=low
633 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
634 very strange way of enabling proper XHTML <br /> type tags. Output html
635 should be always valid again now.
636 * The page name and parent links has switched from using a <h1> to a styled
637 <span>, so pages can use <h1> internally instead of needing to use <h2>.
638 * Updated all of ikiwiki's own wiki pages for that.
639 * Add pagetemplate hook, which can be used by plugins that want to mess
640 around with adding new stuff to the page template.
641 * Remove headercontent; the search plugin now adds the search box to the
642 header by registering a pagetemplate hook, and other plugins should do
644 * Rebuilding on upgrade to this version is recommended.
645 * Add a html validity check to the test suite, using the wdg-html-validator,
647 * Make the html valid when there is nothing in the actions list.
648 * Reordered some function call parameters for consistency.
649 * Enable full utf-8 support for page input and output.
650 * Add a workaround for markdown, which does not work well with utf-8
652 * --getctime had bitrotted (well I only ever used it the once so far..),
653 fix and make it a bit more flexible
654 * rcs_getctime is changed, now rather than needing to loop over all pages,
655 it should just use the rcs to get the ctime of the passed file.
656 * When inlining a page in another one, links from the inlined page are now
657 expanded the same as they are when rendering the inlined page as a
658 standalone page. So rather than being expanded from the POV of the
659 inlining page, they are expanded from the POV of the inlined page.
661 For example, a link from blog/foo to "bar" will now link to blog/bar
662 if it exists. Previously this needed to be a link explicitly to
663 "blog/bar"; such links will also continue to work.
665 (This was slightly complex to do as the link still has to be constructed
666 relative to the inlining page.)
667 * Make page edit textarea resize to fit browser window.
668 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
669 do not need a full rebuild, in order to update any basewiki pages.
671 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
673 ikiwiki (1.3) unstable; urgency=low
675 * Fix the preinst introduced in the last version. Closes: #367458
677 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
679 ikiwiki (1.2) unstable; urgency=low
681 * Remove dups from the brokenlinks list.
682 * Add libc6-dev to dependencies, needed to build wrappers.
683 * Install wikilist in correct location. Closes: #367371
685 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
687 ikiwiki (1.1) unstable; urgency=low
689 * Rename inlinepage to depends, so that it can be used to refer to more
690 dependency relationships than just inlining. This will require a rebuild
691 on upgrade to this version.
692 * Move the rss link, put it in the blogpost form if there is one and at the
693 top if not. This is both nicer because easier to find, and it cleans up
694 the code which had used inlinepage as a flag for adding the link later.
695 * Allow the depends GlobList to be built up from multiple sources (such as
696 plugins) during a page render.
697 * Which means that more than one blog is now supported to appear on a
698 single page. (With some limitations, like only the last one getting an
700 * Added a plugin system.
701 * Added a pagecount plugin, enabled by default.
702 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
703 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
704 backlinks when the backlinks hadn't really changed.
705 * Moved inline page support, rss generation etc into the inline plugin,
707 * Added brokenlinks plugin, not enabled by default, but rather handy.
708 * Fix several broken links in the doc wiki.
709 * Smarter behavior when creating a page and a page of the same name (but
710 different location) already exists.
711 * Add an orphans plugin for finding pages that nothing links to.
712 * Removed backlinks page, which it turns out nothing used.
713 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
714 it, this will allow for adding a unit test suite.
715 * Add unit tests for several core functions, including globlist_match,
716 dirname, basename, bestlink, linkify, pagetitle, titlepage.
717 * Smart globlist merging.
718 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
719 to pave the way for adding other RCS support. This also changes the
720 setup files, where before they had svn => 1 or svn => 0, now they have
721 rcs => "svn" or rcs => "".
722 * Add a debian/NEWS file with upgrade notes.
723 * Load whatever rcs module is specified, so new ones can be just dropped in
724 as plugins and work. (Well, in theory.)
725 * Add some basic docs about writing RCS modules.
726 * Broke search capability out into a plugin, removed the --hyperestraier
728 * Added smiley plugin, nicely controlled and documented by the smileys page.
729 * Copied in some smileys from Moin Moin.
730 * Allow links of the form [[some page|page]], with whitespace in the link
732 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
733 and --disable-plugin htmlscrubber.
734 * Allow discussion links on pages to be turned off with --no-discussion.
735 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
736 * Add some new config items to the estseek.conf template, which are needed
737 by hyperestraier 1.2.3.
739 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
741 ikiwiki (1.0) unstable; urgency=low
743 * First official release.
745 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400