1 ikiwiki (1.29) UNRELEASED; urgency=low
3 * Patch from Paul Tötterman to use CP in the Makefile.
4 * Patch from Alec Berryman adding a http_auth config item that allows
5 using HTTP Authentication instead of ikiwiki's built in authentication.
6 Useful for eg, large sites with their own previously existing user auth
8 * Change %renderedfiles to store an array of files rendered from a given
9 source file, to allow tracking of extra rendered files like rss feeds.
10 * Note that plugins that accessed this variable will need to be updated!
11 The plugin interface has been increased to version 1.01 for this change.
12 * Add will_render function to the plugin interface, used to register that a
13 page renders a destination file, and do some security checks.
14 * Use will_render in the inline and linkmap plugins.
15 * Previously but no longer rendered files will be cleaned up.
16 * You will need to rebuild your wiki on upgrade to this version.
18 -- Joey Hess <joeyh@debian.org> Sun, 8 Oct 2006 16:53:17 -0400
20 ikiwiki (1.28) unstable; urgency=low
22 * inline: Add ability to sort by page name, based on a patch from
24 * Fix a forkbomb in various calls to IPC::Open2, which has a highly
25 braindead interface. Closes: #389383
26 * Don't rm -rf ikiwiki on distclean, since a) there's no such file
27 and b) those poor Mac OSX users and their case insensative files!
28 * Don't fail syntax check if Text::Typography isn't installed.
31 -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
33 ikiwiki (1.27) unstable; urgency=low
35 * Work on firming up the plugin interface:
36 - Plugins should not need to load IkiWiki::Render to get commonly
37 used functions, so moved some functions from there to IkiWiki.
38 - Picked out the set of functions and variables that most plugins
39 use, documented them, and made IkiWiki export them by default,
40 like a proper perl module should.
41 - Use the other functions at your own risk.
42 - This is not quite complete, I still have to decide whether to
43 export some other things.
44 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
45 referring to stuff now exported by the IkiWiki module.
46 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
47 to declare which version of the interface your plugin needs.
48 * Anyone with a third-party ikiwiki plugin is strongly encouraged
49 to make like changes to it and avoid use of non-exported symbols from
51 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
52 * Support hyperestradier version 1.4.2, which adds a new required phraseform
54 * If an inlined page has a permalink, link the page title to that.
55 * Patch from Recai to use utf8 when reading the setup file, so that
56 utf8 wikinames from there will be used properly.
57 * Patch from Recai to kill utf-8 on the wiki name when generating the
59 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
60 * Fix a baseurl problem in hyperestradier search results.
61 * Add a stub local.css to avoid problems with 404's.
62 * Patch from Recai to fix a wide character warning from the search plugin
63 during setup if the wikiname contains utf8.
64 * Yet another fix for those poor case-insensative OS X users.
65 * pagetemplate hooks are now also called when generating cgi pages.
66 * Add a favicon plugin, which simply adds a link tag for an icon to each
68 * Patch from James Westby to deal with the case where you're editing a
69 new page, hit cancel, and need to be redirected to somewhere sane.
70 * Various documentation improvements by various wiki users.
71 * Support Text::Markdown from CPAN, which has a different interface from
72 the original markdown or the one in Debian.
73 * Version the libcgi-session-perl dependency, some features that need
74 the new version are used in some cases (sslcookie).
75 * Numerous tla fixes from Clint.
76 * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
77 a multi-resolution favicon.ico.
78 * README.Debian: typo Closes: #388110
79 * chomp trailing newline at the end of templates read in by the template
80 plugin, to allow use of the template preprocessor directive in
81 whitespace-sensative situations. Closes: #387073
82 * Patch from James Westby to make the location of the estseek.cgi script
84 * Add typography (SmartyPants) plugin by Recai.
85 * Add --render mode, which can be used to preview an edit at the command
86 line by test rendering a single page.
87 * Add a googlecalendar plugin. A bit special-purpose, but it shows
88 one way to to deal with user-supplied content that could cause XSS
89 issues w/o the htmlscrubber, and won't survive the scrubber.
91 -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
93 ikiwiki (1.26) unstable; urgency=low
95 * Add a missing -n to tla undo call.
96 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
97 writes before consuming its whole stdin. Avoid this deadlock.
98 * Fix alt tags for outline checkboxes.
100 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
102 ikiwiki (1.25) unstable; urgency=low
104 * Add proper waitpid calls for open2ed processes throughout to avoid
105 zombies; this hit htmltidy especially badly.
106 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
107 subversion repos and fixing some other issues.
108 * Add support for tla, contributed by Clint Adams. Closes: #385936
109 * Add support for mercurial, contributed by Emanuele Aina.
110 * Include <link rel> tag for RSS feeds, used by some aggregators and
111 firefox to find the feed.
112 * Add a linkmap plugin (requires graphviz).
114 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
116 ikiwiki (1.24) unstable; urgency=low
118 * Simplify the data structure returned by rcs_recentchanges to avoid
119 each rcs plugin needing to form complex strings on its own.
120 * Fix another destpage issue in the inline directive. Closes: #385512
123 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
125 ikiwiki (1.23) unstable; urgency=low
127 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
129 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
131 ikiwiki (1.22) unstable; urgency=low
133 * Change how the stylesheet url is determined in the templates: Remove
134 STYLEURL and add BASEURL to all templates (some already had it). This
135 new more general variable can be used to link to other things (eg, images)
136 from the template, as well as stylesheets.
137 * Fix a bug introduced last version to do with nested inlines.
138 * Allow preprocessor directives to span multiple lines, both to make
139 long ones with lots of values easier to write, and to allow for ones with
140 multi-line quoted values.
141 * Allow preprocessor directives to contain python-like triple-quoted
142 text blocks, for easy nesting of quotes inside.
143 * Add a template plugin.
144 * Make pagespec merge code smarter about merging duplicate pagespecs.
145 * Patch from Jordà Polo to make Setup::Standard support hashes in config
147 * Change order of linkify and preprocess; first preprocess and then linkify.
148 This allows passing a wikilink inside a parameter to a preprocessor
149 directive without it being expanded to html, and leaking out of the
150 parameter, which had required some non-obvious use of triple-quoting
151 to avoid. Note that any preprocessor plugins that output something
152 that looks like a wikilink will now have it treated as such; AFAIK
153 this doesn't change any behavior though except for the template plugin.
154 * Enable preprocessor directives when previewing an edit.
155 * Make all pages pull in a local.css style sheet, if present. This won't
156 be included in ikiwiki, but can be created to make local styling changes
157 w/o needing to merge in every new change to the distributed style.css.
158 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
159 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
160 from a different directory.
161 * Generalised preprocesser loop protection code.
162 * Patch from James Westby to allow a description to be set for rss feeds.
163 * Patch from James Westby to add a template for the search form.
164 * Added a ddate plugin.
165 * Patch from James Westby to add a --sslcookie switch, which forces
166 cookies to only be sent over ssl connections to avoid interception.
167 * Fix preferences page on anonok wikis; still need to sign in to get
168 to the preferences page.
169 * Add toc (table of contents) plugin.
170 * Change htmlize, format, and sanitize hooks to use named parameters.
171 * Patch from James Westby to add an actions option to inline; this
172 adds Edit and Discussion links at the end of blog entries.
173 * Due to some css changes, you'll want to rebuild your wiki on upgrade
174 to this version. Will be handled automatically by the deb.
175 * Add processed date to aggregate preprocessor directive status output.
177 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
179 ikiwiki (1.21) unstable; urgency=low
181 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
182 * If a page links to itself, mark up the link text in a span with
183 class="selflink" so that it can be styled. I don't have a useful style
184 defined for that though.
185 * Call filter hooks on inlined page content.
186 * Support inlining pages raw, rather than creating a blog.
187 * Clean up yes/no parameter parsing in inline plugin.
188 * Implemented better cycle detection in the inline plugin; nested inlines
190 * Add a map plugin contributed by Alessandro Dotti Contra.
191 * Add otl format plugin, which handles files as created by vimoutliner.
192 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
193 * Add first draft at a Restructured Text (rst) plugin, by Sergio
194 Talens-Oliag. Note that this has many known issues -- see the caveats on
196 * Credit everyone who wrote a plugin on the plugins' wiki pages.
197 * Fix utf-8 in blog post form.
199 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
201 ikiwiki (1.20) unstable; urgency=low
203 * Relicense the templates and basewiki under the 2-clause BSD license.
204 Since these can easily become part of other people's websites, they
205 should be under as permissive a license as possible.
206 * Add --syslog config option, to log to the syslog.
207 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
208 transient failure to fork (which I've seen happen in the wild).
209 * Fix a bug in the aggregator introduced last version that caused all
210 aggregator state to be lost during a non-aggregating build.
212 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
214 ikiwiki (1.19) unstable; urgency=low
216 * Fix several related bugs in page type determination during online editing.
217 * Add some locking to prevent 2 aggregators from running at once.
218 * Fix an infinite loop in the aggregator when finding a unique filename.
220 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
222 ikiwiki (1.18) unstable; urgency=low
224 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
226 * Man page format fixups.
227 * If the meta plugin overides the page title, set a title_overridden
228 variable in the template to true. This allows doing things with the
229 templates conditional on the title being overriden.
230 * Add a %pagecase which maps lower-case page names to the actual case
231 used in the filename. Use this in bestlinks calculation instead of
232 forcing the link to lowercase.
233 * Also use %pagecase in various other places that want to check if a page
234 with a given name exists.
235 * This means that links to pages with mixed case names will now work,
236 even if the link is in some other case mixture, and mixed case pages
237 should be fully supported throughout ikiwiki.
238 * Recommend rebuilding wikis on upgrade to this version.
240 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
242 ikiwiki (1.17) unstable; urgency=low
244 * Disable tidy generator tag.
245 * Move tidy back to sanitize hook, found out how to only show body.
246 * Turn off tidy indentation too.
247 * Turn on HTML::Template loop_context_vars; not actually used in stock
248 templates but can be useful for things like making comma-delimited lists
249 of tags or what have you.
250 * Remove <br> from end of aggregate preprocessor directive output.
251 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
252 case-sensative filesystems like OSX.
253 * Improve markdown loading. First, try to load it as a proper perl module,
254 in case it was installed as one. Then fall back to trying
256 * Document in install page how to install markdown, since it has no
257 installation procedure in the upstream tarball.
258 * Set die_on_bad_params => 0 for all templates, to allow users to modify
259 them without annoyances.
260 * Suck in the page content when generating an inline archive page, to work
261 around the meta plugin's lack of caching of title metadata across runs.
263 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
265 ikiwiki (1.16) unstable; urgency=low
267 * Try to handle relative links in aggregated feeds. However,
268 the current support is a crude hack due to limitations of XML::Feed:
269 xml:base is not supported, neither is Content-Location. And of course,
270 relative links in RSS feeds are ill-undefined..
271 * Make aggregator save permalinks and author name to pages as metadata.
272 * Add permalink and author support to meta plugin, affecting RSS feeds
274 * Various CSS and formatting changes.
275 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
276 * Add xhtml files to the default prune regexp.
277 * Also generate rel=bookmark links for permalinks.
278 * Fix the htmltidy plugin, which wasn't working due my breaking it when
280 * Don't run tidy with -xml as that fails if the input is not well-formed.
281 Run it with -asxhtml instead, so it will output well-formed xhtml no
282 matter what the input.
283 * Disable tidy warnings too.
284 * Add a new format hook, and make tidy use it, since tidy can really only
285 operate on and output complete html documents, not the body chunks
287 * Fix dates in rss feeds if running localised, so they're still rfc 822.
289 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
291 ikiwiki (1.15) unstable; urgency=low
293 * Remove CDPATH and other env vars perl taint checking doesn't like.
295 * Added created_before and created_after PageSpec limits.
297 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
299 ikiwiki (1.14) unstable; urgency=low
301 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
303 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
304 * Added many unit tests for pagespec_match.
306 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
308 ikiwiki (1.13) unstable; urgency=low
310 * ikiwiki can now download and aggregate feeds with its new aggregate
311 plugin, so it's possible to implement a Planet using ikiwiki!
312 * Add a run_hooks function for the common task of running all hooks of a
314 * Add a savestate hook.
315 * Don't put blog post forms on pages if there's no cgiurl set.
316 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
317 --wrappers to do that.
318 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
319 to update pages that haven't changed on disk.
320 * Change meta tags to use html entity-escaped text for values, so that
321 quotes and such can be represented in title tags.
322 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
324 * Make --rebuild also cause --aggregate to re-download and write aggregated
326 * Avoid outputting duplicate meta info.
327 * Include title metadata on aggregated posts for capitalised and un-munged
329 * Title metadata of inlined pages now shows up in blogs and rss feeds.
330 * Fix issue with unicode filenames and updating the hyper estradier search
331 index. (Aka Please Please Please, let that be the last one.)
332 * Patch from Roland Mas to support an rss=no parameter to inline directives.
334 * Renamed GlobLists to PageSpecs.
335 * PageSpecs can now include nested parens, "and", and "or". This remains
336 backwards compatible to the old GlobList format. It's implemented by
337 treating the GlobList as a very limited microlanguage that is transformed
338 to perl code that does the matching.
339 * The old GlobList format is deprecated, and I encourage users to switch to
340 using the new PageSpec format. Compatability with the old format will be
341 removed at some point, possibly by 2.0.
342 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
343 * Add support for creation_month and creation_year to PageSpec.
345 * Changes to index file encoding.
347 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
349 ikiwiki (1.12) unstable; urgency=low
352 * New pagestats plugin from Enrico, which can generate a table counting
353 the backlinks for each page, or a del.icio.us style cloud.
354 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
355 the wikiformat plugin works. Thanks, Emanuele Aina.
356 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
357 display, running them through pagetitle. This removes ugly underscores and
358 other gunk from the display, much nicer. You may want to rebuild your wiki
359 when upgrading to get the cleanup globally.
360 * Polygen plugin from Enrico.
361 * htmltidy plugin from Faidon.
362 * Locale patch from Faidon:
363 - Adds a locale setting to setup files.
364 - Proper local time, if the locale configuration option is used.
365 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
366 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
368 * Add getopt hook type, this allows plugins to add new command-line options.
369 * Add --tagbase option to tag plugin.
370 * Add exclude option in setup files, works same as --exclude.
371 * Put categories in rss feeds for tagged items.
372 * Allow preprocessor directives to be expanded in inlined blog pages.
373 However, to avoid inlining loops etc, don't expand inline directives in
375 * fortune plugin (trivial)
376 * Tag plugins according to type.
378 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
380 ikiwiki (1.11) unstable; urgency=low
382 * Patch from Enrico that
383 - Adds a tag plugin that allows more easily tagging pages.
384 The meta plugin can also still be used for that, but the tag plugin
385 also lists a page's tags at the bottom of the page.
386 - Allows preprocessor directives to have parameters with no specified
388 - Fixes preprocessor directive parameter parsing so that
389 foo=bar baz now means "foo=bar" and a "baz" with no value.
390 * Run pagetemplate hooks when inlining pages so that inlined pages also
392 * Make all plugins with pagetemplate hooks check that variables exist
393 on the template before setting them, for robustness.
394 * Switch pagetemplate hooks to using named parameters.
395 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
396 This will be the page that a source page will be part of, which is
397 different than the source page for inlined pages.
398 * Audited all plugins to endure they pass (page, destpage) to htmllink
399 appropriatly. This means inlining of various plugins will not work
400 properly, with correct links generated.
402 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
404 ikiwiki (1.10) unstable; urgency=low
406 * Run page through any relevant filters when generating a page preview.
407 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
408 default throughout the wiki, not only on wikitext pages. Decided to call
409 this a feature, and split the camelcase support out into a separate plugin
410 that is independant of wikitext.
411 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
413 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
415 ikiwiki (1.9) unstable; urgency=low
417 * Improve display of parentlinks and page title of toplevel index page.
418 * Patch from Faidon to use svn --limit when possible for recentchanges,
419 speeds up recentchanges a lot for wikis with more history.
420 * Patch from Recai to fix utf8 issues in git backend.
421 * Add wikitext markup plugin, which supports ".wiki" pages written in the
422 original wiki syntax, CamelCase links and all.
423 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
424 support, to edit pages etc without a web server.
425 * Display CGI processing errors if present.
426 * Fix from Faidon for a XML parser issue that breaks utf-8 for
427 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
428 area, and also way slow.
429 * Match 'web commit from' in SVN and git, these are web commits too.
431 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
432 readable and avoid future mistakes. The patch seems to work and for the
433 first time I have a UTF-8 username ;-) (Faidon)
434 * Use form->field consistently, not form->param.
435 * Patch from Recai to allow selection of page type when creating a new page.
436 Default page type is inherited from the link clicked on to create the new
439 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
441 ikiwiki (1.8) unstable; urgency=low
443 * Fix orphans plugin to not count a link to a nonexistant page as a reason
444 for a page not being an orphan.
445 * Support pinging services such as Technorati using XML-RPC to notify them
446 about changes to rss feeds.
447 * Parse svn log as xml for improved utf8 and security. Note that this makes
448 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
449 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
450 flagged string even if the locale causes it to generate utf8 output,
451 so make sure to let perl know it should be handled as utf8. Also,
452 the optimised version used for standard time formats won't work if the
453 user has changed locale, so drop it. Thanks, Faidon Liambotis.
454 * Fix re-encoding of the comments field to utf8 if a commit fails
455 due to a conflict. Thanks, Faidon Liambotis.
456 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
458 * Add insane double encode/decode to utf8 around call to markdown.
459 This works around a truely strange bug, which is apparently a bug in
460 perl, #376329. Also added a test case for it.
461 * Improve layout of edit page so formatting help link is always visible w/o
462 getting in the way of the preview.
463 * Centralised all calls to HTML::Template and force all the templates
465 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
466 * Introduce add_plugins and disable_plugins config options in setup files.
467 This allows adding or removing plugins w/o overriding the whole list of
468 default plugins, which makes it easier to upgrade when new default plugins
470 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
471 default (of course!). Based on a patch by Faidon Liambotis.
472 * Add a html plugin, which can be used to write wikis in raw html,
473 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
474 defaults to not processing .html files, since w/o this plugin they would
475 be copied unsanitised. With this plugin, it will process and html
476 sanitise them, like any other page type.
477 * Rebuilding wrappers is necessary on upgrade to this version.
478 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
479 will be automatically done on all upgrades.
480 * Don't send pings if the wiki is being rebuilt.
481 * Work around very innefficient behavior in File::Spec::abs2rel. Result
482 is a savings of 2 pointless fork/execs per link calculation, which
483 results in ~25% speedup of ikiwiki building its own doc wiki, and
484 about 35% speedup displaying RecentChanges!
485 * Make RecentChanges use a table and some CSS, should be much more readable.
486 No code changes involved.
487 * Encode & in diffurl in examples, to conform to pedantic rules.
488 * Speed up RecentChanges by another 40% or so with some memoization.
489 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
490 in time to build the doc wiki.
492 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
494 ikiwiki (1.7) unstable; urgency=low
496 * Updated logo from Recai with some kerning and alingment tuning.
497 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
501 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
503 ikiwiki (1.6) unstable; urgency=low
505 * YA utf-8 patch from Recai, this time to fix previewing a page so that
506 the text in the input box is re-encoded back to utf-8.
507 * -CSD does not affect modules, so readfile() was not using the utf-8 input
508 layer, which led to lots of problems; make it force read files as utf-8.
510 * Note that as a consequence, this version of ikiwiki will actually try to
511 parse utf8 in source files for the first time, which may expose broken
512 utf8 in wiki sources that was hidden before. Most common will be
513 perl warnings like "utf8 "\xE9" does not map to Unicode"
514 * writefile() likewise needs to use the utf8 output layer.
515 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
517 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
518 given the readfile fix.
519 * Add utf-8 testcases for readfile and htmlize.
520 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
522 * More utf-8 fixes from Recai, partly to things I broke above:
523 - The serious problem is that writefile() saves the content in undecoded
524 format in CGI, hence all (non-ascii) chars are corrupted permanently.
525 - Comment field in edit page is not decoded and all the non-ascii chars in
526 this field are corrupted as the result. We should decode it as we do it
528 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
530 * New SVG logo from Recai.
532 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
534 ikiwiki (1.5) unstable; urgency=low
536 * Add --timeformat config option to allow changing how dates are displayed.
537 Note that as a side effect, dates will now be displayed using the local
538 timezone, not as GMT.
539 * More security review.
540 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
541 for some handy stuff like:
542 - Using links as a kind of tag; creating blog pages that list all pages
543 containing a given tag/link or not containing some other tag.
544 - Subscribing to mail notifications whenever a change is made to a page
545 that is a backlink of page foo. Ie, "Please notify me of changes in all
546 pages that link to my home page in the wiki"
547 - Locking any pages that are linked to from a particular page, so that
548 lists of locks can be exposed in the wiki.
549 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
550 when a todo item is done, instead of the previous moving it to a different
552 * Allow pagetemplate plugins to override *anything* in the template.
553 * Add a meta plugin, which allows specifying various metadata about pages,
554 like license and author. It also allows for inserting html link and meta
555 tags into html, overriding the title, and adding hidden WikiLinks, which
556 can be useful when using link-based globbing for page categorisation.
557 * Remove preprocessor directives from inlined pages.
558 * Allow simple preprocessor directive values to be specified w/o quotes.
559 * Add support for using git instead of subversion as the RCS backend,
560 tremendous thanks to Recai Oktaş for this.
561 * Doc updates for git.
562 * Fix absolute url munging in rss generation to support https, ftp, etc urls
564 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
565 utf-8 for edit and other fields, and for recentchanges. There may still
566 be utf-8 issues with the preferences page though.
568 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
570 ikiwiki (1.4) unstable; urgency=low
572 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
573 very strange way of enabling proper XHTML <br /> type tags. Output html
574 should be always valid again now.
575 * The page name and parent links has switched from using a <h1> to a styled
576 <span>, so pages can use <h1> internally instead of needing to use <h2>.
577 * Updated all of ikiwiki's own wiki pages for that.
578 * Add pagetemplate hook, which can be used by plugins that want to mess
579 around with adding new stuff to the page template.
580 * Remove headercontent; the search plugin now adds the search box to the
581 header by registering a pagetemplate hook, and other plugins should do
583 * Rebuilding on upgrade to this version is recommended.
584 * Add a html validity check to the test suite, using the wdg-html-validator,
586 * Make the html valid when there is nothing in the actions list.
587 * Reordered some function call parameters for consistency.
588 * Enable full utf-8 support for page input and output.
589 * Add a workaround for markdown, which does not work well with utf-8
591 * --getctime had bitrotted (well I only ever used it the once so far..),
592 fix and make it a bit more flexible
593 * rcs_getctime is changed, now rather than needing to loop over all pages,
594 it should just use the rcs to get the ctime of the passed file.
595 * When inlining a page in another one, links from the inlined page are now
596 expanded the same as they are when rendering the inlined page as a
597 standalone page. So rather than being expanded from the POV of the
598 inlining page, they are expanded from the POV of the inlined page.
600 For example, a link from blog/foo to "bar" will now link to blog/bar
601 if it exists. Previously this needed to be a link explicitly to
602 "blog/bar"; such links will also continue to work.
604 (This was slightly complex to do as the link still has to be constructed
605 relative to the inlining page.)
606 * Make page edit textarea resize to fit browser window.
607 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
608 do not need a full rebuild, in order to update any basewiki pages.
610 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
612 ikiwiki (1.3) unstable; urgency=low
614 * Fix the preinst introduced in the last version. Closes: #367458
616 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
618 ikiwiki (1.2) unstable; urgency=low
620 * Remove dups from the brokenlinks list.
621 * Add libc6-dev to dependencies, needed to build wrappers.
622 * Install wikilist in correct location. Closes: #367371
624 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
626 ikiwiki (1.1) unstable; urgency=low
628 * Rename inlinepage to depends, so that it can be used to refer to more
629 dependency relationships than just inlining. This will require a rebuild
630 on upgrade to this version.
631 * Move the rss link, put it in the blogpost form if there is one and at the
632 top if not. This is both nicer because easier to find, and it cleans up
633 the code which had used inlinepage as a flag for adding the link later.
634 * Allow the depends GlobList to be built up from multiple sources (such as
635 plugins) during a page render.
636 * Which means that more than one blog is now supported to appear on a
637 single page. (With some limitations, like only the last one getting an
639 * Added a plugin system.
640 * Added a pagecount plugin, enabled by default.
641 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
642 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
643 backlinks when the backlinks hadn't really changed.
644 * Moved inline page support, rss generation etc into the inline plugin,
646 * Added brokenlinks plugin, not enabled by default, but rather handy.
647 * Fix several broken links in the doc wiki.
648 * Smarter behavior when creating a page and a page of the same name (but
649 different location) already exists.
650 * Add an orphans plugin for finding pages that nothing links to.
651 * Removed backlinks page, which it turns out nothing used.
652 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
653 it, this will allow for adding a unit test suite.
654 * Add unit tests for several core functions, including globlist_match,
655 dirname, basename, bestlink, linkify, pagetitle, titlepage.
656 * Smart globlist merging.
657 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
658 to pave the way for adding other RCS support. This also changes the
659 setup files, where before they had svn => 1 or svn => 0, now they have
660 rcs => "svn" or rcs => "".
661 * Add a debian/NEWS file with upgrade notes.
662 * Load whatever rcs module is specified, so new ones can be just dropped in
663 as plugins and work. (Well, in theory.)
664 * Add some basic docs about writing RCS modules.
665 * Broke search capability out into a plugin, removed the --hyperestraier
667 * Added smiley plugin, nicely controlled and documented by the smileys page.
668 * Copied in some smileys from Moin Moin.
669 * Allow links of the form [[some page|page]], with whitespace in the link
671 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
672 and --disable-plugin htmlscrubber.
673 * Allow discussion links on pages to be turned off with --no-discussion.
674 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
675 * Add some new config items to the estseek.conf template, which are needed
676 by hyperestraier 1.2.3.
678 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
680 ikiwiki (1.0) unstable; urgency=low
682 * First official release.
684 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400