1 ikiwiki (1.27) UNRELEASED; urgency=low
3 * Add a googlecalendar plugin. A bit special-purpose, but it shows
4 one way to to deal with user-supplied content that could cause XSS
5 issues w/o the htmlscrubber, and won't survive the scrubber.
6 * Work on firming up the plugin interface:
7 - Plugins should not need to load IkiWiki::Render to get commonly
8 used functions, so moved some functions from there to IkiWiki.
9 - Picked out the set of functions and variables that most plugins
10 use, documented them, and made IkiWiki export them by default,
11 like a proper perl module should.
12 - Use the other functions at your own risk.
13 - This is not quite complete, I still have to decide whether to
14 export some other things.
15 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16 referring to stuff now exported by the IkiWiki module.
17 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18 to declare which version of the interface your plugin needs.
19 * Anyone with a third-party ikiwiki plugin is strongly encouraged
20 to make like changes to it and avoid use of non-exported symboles from
22 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23 * Support hyperestradier version 1.4.2, which adds a new required phraseform
25 * If an inlined page has a permalink, link the page title to that.
26 * Patch from Recai to use utf8 when reading the setup file, so that
27 utf8 wikinames from there will be used properly.
28 * Patch from Recai to kill utf-8 on the wiki name when generating the
30 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31 * Fix a baseurl problem in hyperestradier search results.
32 * Add a stub local.css to avoid problems with 404's.
34 -- Joey Hess <joeyh@debian.org> Fri, 15 Sep 2006 13:02:48 -0400
36 ikiwiki (1.26) unstable; urgency=low
38 * Add a missing -n to tla undo call.
39 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
40 writes before consuming its whole stdin. Avoid this deadlock.
41 * Fix alt tags for outline checkboxes.
43 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
45 ikiwiki (1.25) unstable; urgency=low
47 * Add proper waitpid calls for open2ed processes throughout to avoid
48 zombies; this hit htmltidy especially badly.
49 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
50 subversion repos and fixing some other issues.
51 * Add support for tla, contributed by Clint Adams. Closes: #385936
52 * Add support for mercurial, contributed by Emanuele Aina.
53 * Include <link rel> tag for RSS feeds, used by some aggregators and
54 firefox to find the feed.
55 * Add a linkmap plugin (requires graphviz).
57 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
59 ikiwiki (1.24) unstable; urgency=low
61 * Simplify the data structure returned by rcs_recentchanges to avoid
62 each rcs plugin needing to form complex strings on its own.
63 * Fix another destpage issue in the inline directive. Closes: #385512
66 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
68 ikiwiki (1.23) unstable; urgency=low
70 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
72 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
74 ikiwiki (1.22) unstable; urgency=low
76 * Change how the stylesheet url is determined in the templates: Remove
77 STYLEURL and add BASEURL to all templates (some already had it). This
78 new more general variable can be used to link to other things (eg, images)
79 from the template, as well as stylesheets.
80 * Fix a bug introduced last version to do with nested inlines.
81 * Allow preprocessor directives to span multiple lines, both to make
82 long ones with lots of values easier to write, and to allow for ones with
83 multi-line quoted values.
84 * Allow preprocessor directives to contain python-like triple-quoted
85 text blocks, for easy nesting of quotes inside.
86 * Add a template plugin.
87 * Make pagespec merge code smarter about merging duplicate pagespecs.
88 * Patch from Jordà Polo to make Setup::Standard support hashes in config
90 * Change order of linkify and preprocess; first preprocess and then linkify.
91 This allows passing a wikilink inside a parameter to a preprocessor
92 directive without it being expanded to html, and leaking out of the
93 parameter, which had required some non-obvious use of triple-quoting
94 to avoid. Note that any preprocessor plugins that output something
95 that looks like a wikilink will now have it treated as such; AFAIK
96 this doesn't change any behavior though except for the template plugin.
97 * Enable preprocessor directives when previewing an edit.
98 * Make all pages pull in a local.css style sheet, if present. This won't
99 be included in ikiwiki, but can be created to make local styling changes
100 w/o needing to merge in every new change to the distributed style.css.
101 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
102 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
103 from a different directory.
104 * Generalised preprocesser loop protection code.
105 * Patch from James Westby to allow a description to be set for rss feeds.
106 * Patch from James Westby to add a template for the search form.
107 * Added a ddate plugin.
108 * Patch from James Westby to add a --sslcookie switch, which forces
109 cookies to only be sent over ssl connections to avoid interception.
110 * Fix preferences page on anonok wikis; still need to sign in to get
111 to the preferences page.
112 * Add toc (table of contents) plugin.
113 * Change htmlize, format, and sanitize hooks to use named parameters.
114 * Patch from James Westby to add an actions option to inline; this
115 adds Edit and Discussion links at the end of blog entries.
116 * Due to some css changes, you'll want to rebuild your wiki on upgrade
117 to this version. Will be handled automatically by the deb.
118 * Add processed date to aggregate preprocessor directive status output.
120 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
122 ikiwiki (1.21) unstable; urgency=low
124 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
125 * If a page links to itself, mark up the link text in a span with
126 class="selflink" so that it can be styled. I don't have a useful style
127 defined for that though.
128 * Call filter hooks on inlined page content.
129 * Support inlining pages raw, rather than creating a blog.
130 * Clean up yes/no parameter parsing in inline plugin.
131 * Implemented better cycle detection in the inline plugin; nested inlines
133 * Add a map plugin contributed by Alessandro Dotti Contra.
134 * Add otl format plugin, which handles files as created by vimoutliner.
135 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
136 * Add first draft at a Restructured Text (rst) plugin, by Sergio
137 Talens-Oliag. Note that this has many known issues -- see the caveats on
139 * Credit everyone who wrote a plugin on the plugins' wiki pages.
140 * Fix utf-8 in blog post form.
142 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
144 ikiwiki (1.20) unstable; urgency=low
146 * Relicense the templates and basewiki under the 2-clause BSD license.
147 Since these can easily become part of other people's websites, they
148 should be under as permissive a license as possible.
149 * Add --syslog config option, to log to the syslog.
150 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
151 transient failure to fork (which I've seen happen in the wild).
152 * Fix a bug in the aggregator introduced last version that caused all
153 aggregator state to be lost during a non-aggregating build.
155 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
157 ikiwiki (1.19) unstable; urgency=low
159 * Fix several related bugs in page type determination during online editing.
160 * Add some locking to prevent 2 aggregators from running at once.
161 * Fix an infinite loop in the aggregator when finding a unique filename.
163 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
165 ikiwiki (1.18) unstable; urgency=low
167 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
169 * Man page format fixups.
170 * If the meta plugin overides the page title, set a title_overridden
171 variable in the template to true. This allows doing things with the
172 templates conditional on the title being overriden.
173 * Add a %pagecase which maps lower-case page names to the actual case
174 used in the filename. Use this in bestlinks calculation instead of
175 forcing the link to lowercase.
176 * Also use %pagecase in various other places that want to check if a page
177 with a given name exists.
178 * This means that links to pages with mixed case names will now work,
179 even if the link is in some other case mixture, and mixed case pages
180 should be fully supported throughout ikiwiki.
181 * Recommend rebuilding wikis on upgrade to this version.
183 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
185 ikiwiki (1.17) unstable; urgency=low
187 * Disable tidy generator tag.
188 * Move tidy back to sanitize hook, found out how to only show body.
189 * Turn off tidy indentation too.
190 * Turn on HTML::Template loop_context_vars; not actually used in stock
191 templates but can be useful for things like making comma-delimited lists
192 of tags or what have you.
193 * Remove <br> from end of aggregate preprocessor directive output.
194 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
195 case-sensative filesystems like OSX.
196 * Improve markdown loading. First, try to load it as a proper perl module,
197 in case it was installed as one. Then fall back to trying
199 * Document in install page how to install markdown, since it has no
200 installation procedure in the upstream tarball.
201 * Set die_on_bad_params => 0 for all templates, to allow users to modify
202 them without annoyances.
203 * Suck in the page content when generating an inline archive page, to work
204 around the meta plugin's lack of caching of title metadata across runs.
206 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
208 ikiwiki (1.16) unstable; urgency=low
210 * Try to handle relative links in aggregated feeds. However,
211 the current support is a crude hack due to limitations of XML::Feed:
212 xml:base is not supported, neither is Content-Location. And of course,
213 relative links in RSS feeds are ill-undefined..
214 * Make aggregator save permalinks and author name to pages as metadata.
215 * Add permalink and author support to meta plugin, affecting RSS feeds
217 * Various CSS and formatting changes.
218 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
219 * Add xhtml files to the default prune regexp.
220 * Also generate rel=bookmark links for permalinks.
221 * Fix the htmltidy plugin, which wasn't working due my breaking it when
223 * Don't run tidy with -xml as that fails if the input is not well-formed.
224 Run it with -asxhtml instead, so it will output well-formed xhtml no
225 matter what the input.
226 * Disable tidy warnings too.
227 * Add a new format hook, and make tidy use it, since tidy can really only
228 operate on and output complete html documents, not the body chunks
230 * Fix dates in rss feeds if running localised, so they're still rfc 822.
232 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
234 ikiwiki (1.15) unstable; urgency=low
236 * Remove CDPATH and other env vars perl taint checking doesn't like.
238 * Added created_before and created_after PageSpec limits.
240 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
242 ikiwiki (1.14) unstable; urgency=low
244 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
246 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
247 * Added many unit tests for pagespec_match.
249 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
251 ikiwiki (1.13) unstable; urgency=low
253 * ikiwiki can now download and aggregate feeds with its new aggregate
254 plugin, so it's possible to implement a Planet using ikiwiki!
255 * Add a run_hooks function for the common task of running all hooks of a
257 * Add a savestate hook.
258 * Don't put blog post forms on pages if there's no cgiurl set.
259 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
260 --wrappers to do that.
261 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
262 to update pages that haven't changed on disk.
263 * Change meta tags to use html entity-escaped text for values, so that
264 quotes and such can be represented in title tags.
265 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
267 * Make --rebuild also cause --aggregate to re-download and write aggregated
269 * Avoid outputting duplicate meta info.
270 * Include title metadata on aggregated posts for capitalised and un-munged
272 * Title metadata of inlined pages now shows up in blogs and rss feeds.
273 * Fix issue with unicode filenames and updating the hyper estradier search
274 index. (Aka Please Please Please, let that be the last one.)
275 * Patch from Roland Mas to support an rss=no parameter to inline directives.
277 * Renamed GlobLists to PageSpecs.
278 * PageSpecs can now include nested parens, "and", and "or". This remains
279 backwards compatible to the old GlobList format. It's implemented by
280 treating the GlobList as a very limited microlanguage that is transformed
281 to perl code that does the matching.
282 * The old GlobList format is deprecated, and I encourage users to switch to
283 using the new PageSpec format. Compatability with the old format will be
284 removed at some point, possibly by 2.0.
285 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
286 * Add support for creation_month and creation_year to PageSpec.
288 * Changes to index file encoding.
290 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
292 ikiwiki (1.12) unstable; urgency=low
295 * New pagestats plugin from Enrico, which can generate a table counting
296 the backlinks for each page, or a del.icio.us style cloud.
297 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
298 the wikiformat plugin works. Thanks, Emanuele Aina.
299 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
300 display, running them through pagetitle. This removes ugly underscores and
301 other gunk from the display, much nicer. You may want to rebuild your wiki
302 when upgrading to get the cleanup globally.
303 * Polygen plugin from Enrico.
304 * htmltidy plugin from Faidon.
305 * Locale patch from Faidon:
306 - Adds a locale setting to setup files.
307 - Proper local time, if the locale configuration option is used.
308 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
309 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
311 * Add getopt hook type, this allows plugins to add new command-line options.
312 * Add --tagbase option to tag plugin.
313 * Add exclude option in setup files, works same as --exclude.
314 * Put categories in rss feeds for tagged items.
315 * Allow preprocessor directives to be expanded in inlined blog pages.
316 However, to avoid inlining loops etc, don't expand inline directives in
318 * fortune plugin (trivial)
319 * Tag plugins according to type.
321 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
323 ikiwiki (1.11) unstable; urgency=low
325 * Patch from Enrico that
326 - Adds a tag plugin that allows more easily tagging pages.
327 The meta plugin can also still be used for that, but the tag plugin
328 also lists a page's tags at the bottom of the page.
329 - Allows preprocessor directives to have parameters with no specified
331 - Fixes preprocessor directive parameter parsing so that
332 foo=bar baz now means "foo=bar" and a "baz" with no value.
333 * Run pagetemplate hooks when inlining pages so that inlined pages also
335 * Make all plugins with pagetemplate hooks check that variables exist
336 on the template before setting them, for robustness.
337 * Switch pagetemplate hooks to using named parameters.
338 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
339 This will be the page that a source page will be part of, which is
340 different than the source page for inlined pages.
341 * Audited all plugins to endure they pass (page, destpage) to htmllink
342 appropriatly. This means inlining of various plugins will not work
343 properly, with correct links generated.
345 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
347 ikiwiki (1.10) unstable; urgency=low
349 * Run page through any relevant filters when generating a page preview.
350 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
351 default throughout the wiki, not only on wikitext pages. Decided to call
352 this a feature, and split the camelcase support out into a separate plugin
353 that is independant of wikitext.
354 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
356 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
358 ikiwiki (1.9) unstable; urgency=low
360 * Improve display of parentlinks and page title of toplevel index page.
361 * Patch from Faidon to use svn --limit when possible for recentchanges,
362 speeds up recentchanges a lot for wikis with more history.
363 * Patch from Recai to fix utf8 issues in git backend.
364 * Add wikitext markup plugin, which supports ".wiki" pages written in the
365 original wiki syntax, CamelCase links and all.
366 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
367 support, to edit pages etc without a web server.
368 * Display CGI processing errors if present.
369 * Fix from Faidon for a XML parser issue that breaks utf-8 for
370 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
371 area, and also way slow.
372 * Match 'web commit from' in SVN and git, these are web commits too.
374 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
375 readable and avoid future mistakes. The patch seems to work and for the
376 first time I have a UTF-8 username ;-) (Faidon)
377 * Use form->field consistently, not form->param.
378 * Patch from Recai to allow selection of page type when creating a new page.
379 Default page type is inherited from the link clicked on to create the new
382 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
384 ikiwiki (1.8) unstable; urgency=low
386 * Fix orphans plugin to not count a link to a nonexistant page as a reason
387 for a page not being an orphan.
388 * Support pinging services such as Technorati using XML-RPC to notify them
389 about changes to rss feeds.
390 * Parse svn log as xml for improved utf8 and security. Note that this makes
391 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
392 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
393 flagged string even if the locale causes it to generate utf8 output,
394 so make sure to let perl know it should be handled as utf8. Also,
395 the optimised version used for standard time formats won't work if the
396 user has changed locale, so drop it. Thanks, Faidon Liambotis.
397 * Fix re-encoding of the comments field to utf8 if a commit fails
398 due to a conflict. Thanks, Faidon Liambotis.
399 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
401 * Add insane double encode/decode to utf8 around call to markdown.
402 This works around a truely strange bug, which is apparently a bug in
403 perl, #376329. Also added a test case for it.
404 * Improve layout of edit page so formatting help link is always visible w/o
405 getting in the way of the preview.
406 * Centralised all calls to HTML::Template and force all the templates
408 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
409 * Introduce add_plugins and disable_plugins config options in setup files.
410 This allows adding or removing plugins w/o overriding the whole list of
411 default plugins, which makes it easier to upgrade when new default plugins
413 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
414 default (of course!). Based on a patch by Faidon Liambotis.
415 * Add a html plugin, which can be used to write wikis in raw html,
416 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
417 defaults to not processing .html files, since w/o this plugin they would
418 be copied unsanitised. With this plugin, it will process and html
419 sanitise them, like any other page type.
420 * Rebuilding wrappers is necessary on upgrade to this version.
421 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
422 will be automatically done on all upgrades.
423 * Don't send pings if the wiki is being rebuilt.
424 * Work around very innefficient behavior in File::Spec::abs2rel. Result
425 is a savings of 2 pointless fork/execs per link calculation, which
426 results in ~25% speedup of ikiwiki building its own doc wiki, and
427 about 35% speedup displaying RecentChanges!
428 * Make RecentChanges use a table and some CSS, should be much more readable.
429 No code changes involved.
430 * Encode & in diffurl in examples, to conform to pedantic rules.
431 * Speed up RecentChanges by another 40% or so with some memoization.
432 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
433 in time to build the doc wiki.
435 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
437 ikiwiki (1.7) unstable; urgency=low
439 * Updated logo from Recai with some kerning and alingment tuning.
440 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
444 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
446 ikiwiki (1.6) unstable; urgency=low
448 * YA utf-8 patch from Recai, this time to fix previewing a page so that
449 the text in the input box is re-encoded back to utf-8.
450 * -CSD does not affect modules, so readfile() was not using the utf-8 input
451 layer, which led to lots of problems; make it force read files as utf-8.
453 * Note that as a consequence, this version of ikiwiki will actually try to
454 parse utf8 in source files for the first time, which may expose broken
455 utf8 in wiki sources that was hidden before. Most common will be
456 perl warnings like "utf8 "\xE9" does not map to Unicode"
457 * writefile() likewise needs to use the utf8 output layer.
458 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
460 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
461 given the readfile fix.
462 * Add utf-8 testcases for readfile and htmlize.
463 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
465 * More utf-8 fixes from Recai, partly to things I broke above:
466 - The serious problem is that writefile() saves the content in undecoded
467 format in CGI, hence all (non-ascii) chars are corrupted permanently.
468 - Comment field in edit page is not decoded and all the non-ascii chars in
469 this field are corrupted as the result. We should decode it as we do it
471 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
473 * New SVG logo from Recai.
475 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
477 ikiwiki (1.5) unstable; urgency=low
479 * Add --timeformat config option to allow changing how dates are displayed.
480 Note that as a side effect, dates will now be displayed using the local
481 timezone, not as GMT.
482 * More security review.
483 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
484 for some handy stuff like:
485 - Using links as a kind of tag; creating blog pages that list all pages
486 containing a given tag/link or not containing some other tag.
487 - Subscribing to mail notifications whenever a change is made to a page
488 that is a backlink of page foo. Ie, "Please notify me of changes in all
489 pages that link to my home page in the wiki"
490 - Locking any pages that are linked to from a particular page, so that
491 lists of locks can be exposed in the wiki.
492 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
493 when a todo item is done, instead of the previous moving it to a different
495 * Allow pagetemplate plugins to override *anything* in the template.
496 * Add a meta plugin, which allows specifying various metadata about pages,
497 like license and author. It also allows for inserting html link and meta
498 tags into html, overriding the title, and adding hidden WikiLinks, which
499 can be useful when using link-based globbing for page categorisation.
500 * Remove preprocessor directives from inlined pages.
501 * Allow simple preprocessor directive values to be specified w/o quotes.
502 * Add support for using git instead of subversion as the RCS backend,
503 tremendous thanks to Recai Oktaş for this.
504 * Doc updates for git.
505 * Fix absolute url munging in rss generation to support https, ftp, etc urls
507 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
508 utf-8 for edit and other fields, and for recentchanges. There may still
509 be utf-8 issues with the preferences page though.
511 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
513 ikiwiki (1.4) unstable; urgency=low
515 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
516 very strange way of enabling proper XHTML <br /> type tags. Output html
517 should be always valid again now.
518 * The page name and parent links has switched from using a <h1> to a styled
519 <span>, so pages can use <h1> internally instead of needing to use <h2>.
520 * Updated all of ikiwiki's own wiki pages for that.
521 * Add pagetemplate hook, which can be used by plugins that want to mess
522 around with adding new stuff to the page template.
523 * Remove headercontent; the search plugin now adds the search box to the
524 header by registering a pagetemplate hook, and other plugins should do
526 * Rebuilding on upgrade to this version is recommended.
527 * Add a html validity check to the test suite, using the wdg-html-validator,
529 * Make the html valid when there is nothing in the actions list.
530 * Reordered some function call parameters for consistency.
531 * Enable full utf-8 support for page input and output.
532 * Add a workaround for markdown, which does not work well with utf-8
534 * --getctime had bitrotted (well I only ever used it the once so far..),
535 fix and make it a bit more flexible
536 * rcs_getctime is changed, now rather than needing to loop over all pages,
537 it should just use the rcs to get the ctime of the passed file.
538 * When inlining a page in another one, links from the inlined page are now
539 expanded the same as they are when rendering the inlined page as a
540 standalone page. So rather than being expanded from the POV of the
541 inlining page, they are expanded from the POV of the inlined page.
543 For example, a link from blog/foo to "bar" will now link to blog/bar
544 if it exists. Previously this needed to be a link explicitly to
545 "blog/bar"; such links will also continue to work.
547 (This was slightly complex to do as the link still has to be constructed
548 relative to the inlining page.)
549 * Make page edit textarea resize to fit browser window.
550 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
551 do not need a full rebuild, in order to update any basewiki pages.
553 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
555 ikiwiki (1.3) unstable; urgency=low
557 * Fix the preinst introduced in the last version. Closes: #367458
559 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
561 ikiwiki (1.2) unstable; urgency=low
563 * Remove dups from the brokenlinks list.
564 * Add libc6-dev to dependencies, needed to build wrappers.
565 * Install wikilist in correct location. Closes: #367371
567 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
569 ikiwiki (1.1) unstable; urgency=low
571 * Rename inlinepage to depends, so that it can be used to refer to more
572 dependency relationships than just inlining. This will require a rebuild
573 on upgrade to this version.
574 * Move the rss link, put it in the blogpost form if there is one and at the
575 top if not. This is both nicer because easier to find, and it cleans up
576 the code which had used inlinepage as a flag for adding the link later.
577 * Allow the depends GlobList to be built up from multiple sources (such as
578 plugins) during a page render.
579 * Which means that more than one blog is now supported to appear on a
580 single page. (With some limitations, like only the last one getting an
582 * Added a plugin system.
583 * Added a pagecount plugin, enabled by default.
584 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
585 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
586 backlinks when the backlinks hadn't really changed.
587 * Moved inline page support, rss generation etc into the inline plugin,
589 * Added brokenlinks plugin, not enabled by default, but rather handy.
590 * Fix several broken links in the doc wiki.
591 * Smarter behavior when creating a page and a page of the same name (but
592 different location) already exists.
593 * Add an orphans plugin for finding pages that nothing links to.
594 * Removed backlinks page, which it turns out nothing used.
595 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
596 it, this will allow for adding a unit test suite.
597 * Add unit tests for several core functions, including globlist_match,
598 dirname, basename, bestlink, linkify, pagetitle, titlepage.
599 * Smart globlist merging.
600 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
601 to pave the way for adding other RCS support. This also changes the
602 setup files, where before they had svn => 1 or svn => 0, now they have
603 rcs => "svn" or rcs => "".
604 * Add a debian/NEWS file with upgrade notes.
605 * Load whatever rcs module is specified, so new ones can be just dropped in
606 as plugins and work. (Well, in theory.)
607 * Add some basic docs about writing RCS modules.
608 * Broke search capability out into a plugin, removed the --hyperestraier
610 * Added smiley plugin, nicely controlled and documented by the smileys page.
611 * Copied in some smileys from Moin Moin.
612 * Allow links of the form [[some page|page]], with whitespace in the link
614 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
615 and --disable-plugin htmlscrubber.
616 * Allow discussion links on pages to be turned off with --no-discussion.
617 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
618 * Add some new config items to the estseek.conf template, which are needed
619 by hyperestraier 1.2.3.
621 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
623 ikiwiki (1.0) unstable; urgency=low
625 * First official release.
627 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400