4 Summary: A wiki compiler
6 Group: Applications/Internet
8 URL: http://ikiwiki.info/
11 BuildRequires: perl(Text::Markdown)
12 BuildRequires: perl(Mail::Sendmail)
13 BuildRequires: perl(HTML::Scrubber)
14 BuildRequires: perl(XML::Simple)
15 BuildRequires: perl(Date::Parse)
16 BuildRequires: perl(Date::Format)
17 BuildRequires: perl(HTML::Template)
18 BuildRequires: perl(CGI::FormBuilder)
19 BuildRequires: perl(CGI::Session)
20 BuildRequires: perl(File::MimeInfo)
21 BuildRequires: gettext
24 Requires: perl(:MODULE_COMPAT_%(eval "`%{__perl} -V:version`"; echo $version))
26 Requires: perl(Text::Markdown)
27 Requires: perl(Mail::Sendmail)
28 Requires: perl(HTML::Scrubber)
29 Requires: perl(XML::Simple)
30 Requires: perl(CGI::FormBuilder)
31 Requires: perl(CGI::Session)
32 Requires: perl(Digest::SHA1)
34 Requires: python-docutils
36 %define cgi_bin %{_libexecdir}/w3m/cgi-bin
40 Ikiwiki is a wiki compiler. It converts wiki pages into HTML pages
41 suitable for publishing on a website. Ikiwiki stores pages and history
42 in a revision control system such as Subversion or Git. There are many
43 other features, including support for blogging, as well as a large
50 # Filter unwanted Provides:
51 %{__cat} << \EOF > %{name}-prov
53 %{__perl_provides} $* |\
54 %{__sed} -e '/perl(IkiWiki.*)/d'
57 %define __perl_provides %{_builddir}/%{name}/%{name}-prov
58 %{__chmod} +x %{__perl_provides}
60 # Filter Requires, all used by plugins
61 # - Monotone: see bz 450267
62 %{__cat} << \EOF > %{name}-req
64 %{__perl_requires} $* |\
65 %{__sed} -e '/perl(IkiWiki.*)/d' \
66 -e '/perl(Monotone)/d'
69 %define __perl_requires %{_builddir}/%{name}/%{name}-req
70 %{__chmod} +x %{__perl_requires}
72 # goes into the -w3m subpackage
73 %{__cat} << \EOF > README.fedora
74 See http://ikiwiki.info/w3mmode/ for more information.
79 %{__perl} Makefile.PL INSTALLDIRS=vendor PREFIX=%{_prefix}
80 # parallel builds currently don't work
85 %{__rm} -rf %{buildroot}
86 %{__make} pure_install DESTDIR=%{buildroot} W3M_CGI_BIN=%{cgi_bin}
90 %{__rm} -rf %{buildroot}
93 %files -f %{name}.lang
94 %defattr(-,root,root,-)
97 %{_mandir}/man1/ikiwiki*
98 %{_mandir}/man8/ikiwiki*
100 %dir %{_sysconfdir}/ikiwiki
101 %config(noreplace) %{_sysconfdir}/ikiwiki/*
102 # contains a packlist only
103 %exclude %{perl_vendorarch}
104 %{perl_vendorlib}/IkiWiki*
105 %exclude %{perl_vendorlib}/IkiWiki*/Plugin/skeleton.pm.example
107 %doc README debian/changelog debian/NEWS html
108 %doc IkiWiki/Plugin/skeleton.pm.example
112 Summary: Ikiwiki w3m cgi meta-wrapper
113 Group: Applications/Internet
115 Requires: %{name} = %{version}-%{release}
118 Enable usage of all of ikiwiki's web features (page editing, etc) in
119 the w3m web browser without a web server. w3m supports local CGI
120 scripts, and ikiwiki can be set up to run that way using the
121 meta-wrapper in this package.
125 %defattr(-,root,root,-)
127 %{cgi_bin}/ikiwiki-w3m.cgi