1 ikiwiki (1.30) UNRELEASED; urgency=low
3 * Add no_override parameter to hook().
4 * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
5 plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
6 can be configured using a page in wiki.
8 -- Joey Hess <joeyh@debian.org> Sun, 15 Oct 2006 14:49:28 -0400
10 ikiwiki (1.29) unstable; urgency=low
12 * Patch from Paul Tötterman to use CP in the Makefile.
13 * Patch from Alec Berryman adding a http_auth config item that allows
14 using HTTP Authentication instead of ikiwiki's built in authentication.
15 Useful for eg, large sites with their own previously existing user auth
16 setup. Closes: #384534
17 * Change %renderedfiles to store an array of files rendered from a given
18 source file, to allow tracking of extra rendered files like rss feeds.
19 * Note that plugins that accessed this variable will need to be updated!
20 The plugin interface has been increased to version 1.01 for this change.
21 As few plugins use %renderedfiles I haven't done anything else to ensure
22 compatability of old plugins.
23 * Add will_render function to the plugin interface, used to register that a
24 page renders a destination file, and do some security checks. Previously
25 but no longer rendered files will be cleaned up.
26 * Use will_render in the inline and linkmap plugins.
27 * You will need to rebuild your wiki on upgrade to this version.
28 * Atom feed support based on a patch by Clint Adams.
29 * Add feeds=no option to inline preprocessor directive to turn off all types
31 * $IkiWiki::version now holds the program version, and is accessible to
33 * Make the aggregate plugin emphasize error messages.
34 * Patch from Recai to limit recentchanges to displaying max 10 files for a
35 given changeset (to avoid large number of file changes excessively
38 -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
40 ikiwiki (1.28) unstable; urgency=low
42 * inline: Add ability to sort by page name, based on a patch from
44 * Fix a forkbomb in various calls to IPC::Open2, which has a highly
45 braindead interface. Closes: #389383
46 * Don't rm -rf ikiwiki on distclean, since a) there's no such file
47 and b) those poor Mac OSX users and their case insensative files!
48 * Don't fail syntax check if Text::Typography isn't installed.
51 -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
53 ikiwiki (1.27) unstable; urgency=low
55 * Work on firming up the plugin interface:
56 - Plugins should not need to load IkiWiki::Render to get commonly
57 used functions, so moved some functions from there to IkiWiki.
58 - Picked out the set of functions and variables that most plugins
59 use, documented them, and made IkiWiki export them by default,
60 like a proper perl module should.
61 - Use the other functions at your own risk.
62 - This is not quite complete, I still have to decide whether to
63 export some other things.
64 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
65 referring to stuff now exported by the IkiWiki module.
66 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
67 to declare which version of the interface your plugin needs.
68 * Anyone with a third-party ikiwiki plugin is strongly encouraged
69 to make like changes to it and avoid use of non-exported symbols from
71 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
72 * Support hyperestradier version 1.4.2, which adds a new required phraseform
74 * If an inlined page has a permalink, link the page title to that.
75 * Patch from Recai to use utf8 when reading the setup file, so that
76 utf8 wikinames from there will be used properly.
77 * Patch from Recai to kill utf-8 on the wiki name when generating the
79 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
80 * Fix a baseurl problem in hyperestradier search results.
81 * Add a stub local.css to avoid problems with 404's.
82 * Patch from Recai to fix a wide character warning from the search plugin
83 during setup if the wikiname contains utf8.
84 * Yet another fix for those poor case-insensative OS X users.
85 * pagetemplate hooks are now also called when generating cgi pages.
86 * Add a favicon plugin, which simply adds a link tag for an icon to each
88 * Patch from James Westby to deal with the case where you're editing a
89 new page, hit cancel, and need to be redirected to somewhere sane.
90 * Various documentation improvements by various wiki users.
91 * Support Text::Markdown from CPAN, which has a different interface from
92 the original markdown or the one in Debian.
93 * Version the libcgi-session-perl dependency, some features that need
94 the new version are used in some cases (sslcookie).
95 * Numerous tla fixes from Clint.
96 * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
97 a multi-resolution favicon.ico.
98 * README.Debian: typo Closes: #388110
99 * chomp trailing newline at the end of templates read in by the template
100 plugin, to allow use of the template preprocessor directive in
101 whitespace-sensative situations. Closes: #387073
102 * Patch from James Westby to make the location of the estseek.cgi script
104 * Add typography (SmartyPants) plugin by Recai.
105 * Add --render mode, which can be used to preview an edit at the command
106 line by test rendering a single page.
107 * Add a googlecalendar plugin. A bit special-purpose, but it shows
108 one way to to deal with user-supplied content that could cause XSS
109 issues w/o the htmlscrubber, and won't survive the scrubber.
111 -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
113 ikiwiki (1.26) unstable; urgency=low
115 * Add a missing -n to tla undo call.
116 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
117 writes before consuming its whole stdin. Avoid this deadlock.
118 * Fix alt tags for outline checkboxes.
120 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
122 ikiwiki (1.25) unstable; urgency=low
124 * Add proper waitpid calls for open2ed processes throughout to avoid
125 zombies; this hit htmltidy especially badly.
126 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
127 subversion repos and fixing some other issues.
128 * Add support for tla, contributed by Clint Adams. Closes: #385936
129 * Add support for mercurial, contributed by Emanuele Aina.
130 * Include <link rel> tag for RSS feeds, used by some aggregators and
131 firefox to find the feed.
132 * Add a linkmap plugin (requires graphviz).
134 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
136 ikiwiki (1.24) unstable; urgency=low
138 * Simplify the data structure returned by rcs_recentchanges to avoid
139 each rcs plugin needing to form complex strings on its own.
140 * Fix another destpage issue in the inline directive. Closes: #385512
143 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
145 ikiwiki (1.23) unstable; urgency=low
147 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
149 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
151 ikiwiki (1.22) unstable; urgency=low
153 * Change how the stylesheet url is determined in the templates: Remove
154 STYLEURL and add BASEURL to all templates (some already had it). This
155 new more general variable can be used to link to other things (eg, images)
156 from the template, as well as stylesheets.
157 * Fix a bug introduced last version to do with nested inlines.
158 * Allow preprocessor directives to span multiple lines, both to make
159 long ones with lots of values easier to write, and to allow for ones with
160 multi-line quoted values.
161 * Allow preprocessor directives to contain python-like triple-quoted
162 text blocks, for easy nesting of quotes inside.
163 * Add a template plugin.
164 * Make pagespec merge code smarter about merging duplicate pagespecs.
165 * Patch from Jordà Polo to make Setup::Standard support hashes in config
167 * Change order of linkify and preprocess; first preprocess and then linkify.
168 This allows passing a wikilink inside a parameter to a preprocessor
169 directive without it being expanded to html, and leaking out of the
170 parameter, which had required some non-obvious use of triple-quoting
171 to avoid. Note that any preprocessor plugins that output something
172 that looks like a wikilink will now have it treated as such; AFAIK
173 this doesn't change any behavior though except for the template plugin.
174 * Enable preprocessor directives when previewing an edit.
175 * Make all pages pull in a local.css style sheet, if present. This won't
176 be included in ikiwiki, but can be created to make local styling changes
177 w/o needing to merge in every new change to the distributed style.css.
178 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
179 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
180 from a different directory.
181 * Generalised preprocesser loop protection code.
182 * Patch from James Westby to allow a description to be set for rss feeds.
183 * Patch from James Westby to add a template for the search form.
184 * Added a ddate plugin.
185 * Patch from James Westby to add a --sslcookie switch, which forces
186 cookies to only be sent over ssl connections to avoid interception.
187 * Fix preferences page on anonok wikis; still need to sign in to get
188 to the preferences page.
189 * Add toc (table of contents) plugin.
190 * Change htmlize, format, and sanitize hooks to use named parameters.
191 * Patch from James Westby to add an actions option to inline; this
192 adds Edit and Discussion links at the end of blog entries.
193 * Due to some css changes, you'll want to rebuild your wiki on upgrade
194 to this version. Will be handled automatically by the deb.
195 * Add processed date to aggregate preprocessor directive status output.
197 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
199 ikiwiki (1.21) unstable; urgency=low
201 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
202 * If a page links to itself, mark up the link text in a span with
203 class="selflink" so that it can be styled. I don't have a useful style
204 defined for that though.
205 * Call filter hooks on inlined page content.
206 * Support inlining pages raw, rather than creating a blog.
207 * Clean up yes/no parameter parsing in inline plugin.
208 * Implemented better cycle detection in the inline plugin; nested inlines
210 * Add a map plugin contributed by Alessandro Dotti Contra.
211 * Add otl format plugin, which handles files as created by vimoutliner.
212 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
213 * Add first draft at a Restructured Text (rst) plugin, by Sergio
214 Talens-Oliag. Note that this has many known issues -- see the caveats on
216 * Credit everyone who wrote a plugin on the plugins' wiki pages.
217 * Fix utf-8 in blog post form.
219 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
221 ikiwiki (1.20) unstable; urgency=low
223 * Relicense the templates and basewiki under the 2-clause BSD license.
224 Since these can easily become part of other people's websites, they
225 should be under as permissive a license as possible.
226 * Add --syslog config option, to log to the syslog.
227 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
228 transient failure to fork (which I've seen happen in the wild).
229 * Fix a bug in the aggregator introduced last version that caused all
230 aggregator state to be lost during a non-aggregating build.
232 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
234 ikiwiki (1.19) unstable; urgency=low
236 * Fix several related bugs in page type determination during online editing.
237 * Add some locking to prevent 2 aggregators from running at once.
238 * Fix an infinite loop in the aggregator when finding a unique filename.
240 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
242 ikiwiki (1.18) unstable; urgency=low
244 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
246 * Man page format fixups.
247 * If the meta plugin overides the page title, set a title_overridden
248 variable in the template to true. This allows doing things with the
249 templates conditional on the title being overriden.
250 * Add a %pagecase which maps lower-case page names to the actual case
251 used in the filename. Use this in bestlinks calculation instead of
252 forcing the link to lowercase.
253 * Also use %pagecase in various other places that want to check if a page
254 with a given name exists.
255 * This means that links to pages with mixed case names will now work,
256 even if the link is in some other case mixture, and mixed case pages
257 should be fully supported throughout ikiwiki.
258 * Recommend rebuilding wikis on upgrade to this version.
260 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
262 ikiwiki (1.17) unstable; urgency=low
264 * Disable tidy generator tag.
265 * Move tidy back to sanitize hook, found out how to only show body.
266 * Turn off tidy indentation too.
267 * Turn on HTML::Template loop_context_vars; not actually used in stock
268 templates but can be useful for things like making comma-delimited lists
269 of tags or what have you.
270 * Remove <br> from end of aggregate preprocessor directive output.
271 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
272 case-sensative filesystems like OSX.
273 * Improve markdown loading. First, try to load it as a proper perl module,
274 in case it was installed as one. Then fall back to trying
276 * Document in install page how to install markdown, since it has no
277 installation procedure in the upstream tarball.
278 * Set die_on_bad_params => 0 for all templates, to allow users to modify
279 them without annoyances.
280 * Suck in the page content when generating an inline archive page, to work
281 around the meta plugin's lack of caching of title metadata across runs.
283 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
285 ikiwiki (1.16) unstable; urgency=low
287 * Try to handle relative links in aggregated feeds. However,
288 the current support is a crude hack due to limitations of XML::Feed:
289 xml:base is not supported, neither is Content-Location. And of course,
290 relative links in RSS feeds are ill-undefined..
291 * Make aggregator save permalinks and author name to pages as metadata.
292 * Add permalink and author support to meta plugin, affecting RSS feeds
294 * Various CSS and formatting changes.
295 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
296 * Add xhtml files to the default prune regexp.
297 * Also generate rel=bookmark links for permalinks.
298 * Fix the htmltidy plugin, which wasn't working due my breaking it when
300 * Don't run tidy with -xml as that fails if the input is not well-formed.
301 Run it with -asxhtml instead, so it will output well-formed xhtml no
302 matter what the input.
303 * Disable tidy warnings too.
304 * Add a new format hook, and make tidy use it, since tidy can really only
305 operate on and output complete html documents, not the body chunks
307 * Fix dates in rss feeds if running localised, so they're still rfc 822.
309 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
311 ikiwiki (1.15) unstable; urgency=low
313 * Remove CDPATH and other env vars perl taint checking doesn't like.
315 * Added created_before and created_after PageSpec limits.
317 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
319 ikiwiki (1.14) unstable; urgency=low
321 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
323 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
324 * Added many unit tests for pagespec_match.
326 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
328 ikiwiki (1.13) unstable; urgency=low
330 * ikiwiki can now download and aggregate feeds with its new aggregate
331 plugin, so it's possible to implement a Planet using ikiwiki!
332 * Add a run_hooks function for the common task of running all hooks of a
334 * Add a savestate hook.
335 * Don't put blog post forms on pages if there's no cgiurl set.
336 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
337 --wrappers to do that.
338 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
339 to update pages that haven't changed on disk.
340 * Change meta tags to use html entity-escaped text for values, so that
341 quotes and such can be represented in title tags.
342 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
344 * Make --rebuild also cause --aggregate to re-download and write aggregated
346 * Avoid outputting duplicate meta info.
347 * Include title metadata on aggregated posts for capitalised and un-munged
349 * Title metadata of inlined pages now shows up in blogs and rss feeds.
350 * Fix issue with unicode filenames and updating the hyper estradier search
351 index. (Aka Please Please Please, let that be the last one.)
352 * Patch from Roland Mas to support an rss=no parameter to inline directives.
354 * Renamed GlobLists to PageSpecs.
355 * PageSpecs can now include nested parens, "and", and "or". This remains
356 backwards compatible to the old GlobList format. It's implemented by
357 treating the GlobList as a very limited microlanguage that is transformed
358 to perl code that does the matching.
359 * The old GlobList format is deprecated, and I encourage users to switch to
360 using the new PageSpec format. Compatability with the old format will be
361 removed at some point, possibly by 2.0.
362 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
363 * Add support for creation_month and creation_year to PageSpec.
365 * Changes to index file encoding.
367 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
369 ikiwiki (1.12) unstable; urgency=low
372 * New pagestats plugin from Enrico, which can generate a table counting
373 the backlinks for each page, or a del.icio.us style cloud.
374 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
375 the wikiformat plugin works. Thanks, Emanuele Aina.
376 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
377 display, running them through pagetitle. This removes ugly underscores and
378 other gunk from the display, much nicer. You may want to rebuild your wiki
379 when upgrading to get the cleanup globally.
380 * Polygen plugin from Enrico.
381 * htmltidy plugin from Faidon.
382 * Locale patch from Faidon:
383 - Adds a locale setting to setup files.
384 - Proper local time, if the locale configuration option is used.
385 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
386 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
388 * Add getopt hook type, this allows plugins to add new command-line options.
389 * Add --tagbase option to tag plugin.
390 * Add exclude option in setup files, works same as --exclude.
391 * Put categories in rss feeds for tagged items.
392 * Allow preprocessor directives to be expanded in inlined blog pages.
393 However, to avoid inlining loops etc, don't expand inline directives in
395 * fortune plugin (trivial)
396 * Tag plugins according to type.
398 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
400 ikiwiki (1.11) unstable; urgency=low
402 * Patch from Enrico that
403 - Adds a tag plugin that allows more easily tagging pages.
404 The meta plugin can also still be used for that, but the tag plugin
405 also lists a page's tags at the bottom of the page.
406 - Allows preprocessor directives to have parameters with no specified
408 - Fixes preprocessor directive parameter parsing so that
409 foo=bar baz now means "foo=bar" and a "baz" with no value.
410 * Run pagetemplate hooks when inlining pages so that inlined pages also
412 * Make all plugins with pagetemplate hooks check that variables exist
413 on the template before setting them, for robustness.
414 * Switch pagetemplate hooks to using named parameters.
415 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
416 This will be the page that a source page will be part of, which is
417 different than the source page for inlined pages.
418 * Audited all plugins to endure they pass (page, destpage) to htmllink
419 appropriatly. This means inlining of various plugins will not work
420 properly, with correct links generated.
422 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
424 ikiwiki (1.10) unstable; urgency=low
426 * Run page through any relevant filters when generating a page preview.
427 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
428 default throughout the wiki, not only on wikitext pages. Decided to call
429 this a feature, and split the camelcase support out into a separate plugin
430 that is independant of wikitext.
431 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
433 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
435 ikiwiki (1.9) unstable; urgency=low
437 * Improve display of parentlinks and page title of toplevel index page.
438 * Patch from Faidon to use svn --limit when possible for recentchanges,
439 speeds up recentchanges a lot for wikis with more history.
440 * Patch from Recai to fix utf8 issues in git backend.
441 * Add wikitext markup plugin, which supports ".wiki" pages written in the
442 original wiki syntax, CamelCase links and all.
443 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
444 support, to edit pages etc without a web server.
445 * Display CGI processing errors if present.
446 * Fix from Faidon for a XML parser issue that breaks utf-8 for
447 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
448 area, and also way slow.
449 * Match 'web commit from' in SVN and git, these are web commits too.
451 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
452 readable and avoid future mistakes. The patch seems to work and for the
453 first time I have a UTF-8 username ;-) (Faidon)
454 * Use form->field consistently, not form->param.
455 * Patch from Recai to allow selection of page type when creating a new page.
456 Default page type is inherited from the link clicked on to create the new
459 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
461 ikiwiki (1.8) unstable; urgency=low
463 * Fix orphans plugin to not count a link to a nonexistant page as a reason
464 for a page not being an orphan.
465 * Support pinging services such as Technorati using XML-RPC to notify them
466 about changes to rss feeds.
467 * Parse svn log as xml for improved utf8 and security. Note that this makes
468 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
469 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
470 flagged string even if the locale causes it to generate utf8 output,
471 so make sure to let perl know it should be handled as utf8. Also,
472 the optimised version used for standard time formats won't work if the
473 user has changed locale, so drop it. Thanks, Faidon Liambotis.
474 * Fix re-encoding of the comments field to utf8 if a commit fails
475 due to a conflict. Thanks, Faidon Liambotis.
476 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
478 * Add insane double encode/decode to utf8 around call to markdown.
479 This works around a truely strange bug, which is apparently a bug in
480 perl, #376329. Also added a test case for it.
481 * Improve layout of edit page so formatting help link is always visible w/o
482 getting in the way of the preview.
483 * Centralised all calls to HTML::Template and force all the templates
485 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
486 * Introduce add_plugins and disable_plugins config options in setup files.
487 This allows adding or removing plugins w/o overriding the whole list of
488 default plugins, which makes it easier to upgrade when new default plugins
490 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
491 default (of course!). Based on a patch by Faidon Liambotis.
492 * Add a html plugin, which can be used to write wikis in raw html,
493 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
494 defaults to not processing .html files, since w/o this plugin they would
495 be copied unsanitised. With this plugin, it will process and html
496 sanitise them, like any other page type.
497 * Rebuilding wrappers is necessary on upgrade to this version.
498 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
499 will be automatically done on all upgrades.
500 * Don't send pings if the wiki is being rebuilt.
501 * Work around very innefficient behavior in File::Spec::abs2rel. Result
502 is a savings of 2 pointless fork/execs per link calculation, which
503 results in ~25% speedup of ikiwiki building its own doc wiki, and
504 about 35% speedup displaying RecentChanges!
505 * Make RecentChanges use a table and some CSS, should be much more readable.
506 No code changes involved.
507 * Encode & in diffurl in examples, to conform to pedantic rules.
508 * Speed up RecentChanges by another 40% or so with some memoization.
509 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
510 in time to build the doc wiki.
512 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
514 ikiwiki (1.7) unstable; urgency=low
516 * Updated logo from Recai with some kerning and alingment tuning.
517 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
521 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
523 ikiwiki (1.6) unstable; urgency=low
525 * YA utf-8 patch from Recai, this time to fix previewing a page so that
526 the text in the input box is re-encoded back to utf-8.
527 * -CSD does not affect modules, so readfile() was not using the utf-8 input
528 layer, which led to lots of problems; make it force read files as utf-8.
530 * Note that as a consequence, this version of ikiwiki will actually try to
531 parse utf8 in source files for the first time, which may expose broken
532 utf8 in wiki sources that was hidden before. Most common will be
533 perl warnings like "utf8 "\xE9" does not map to Unicode"
534 * writefile() likewise needs to use the utf8 output layer.
535 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
537 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
538 given the readfile fix.
539 * Add utf-8 testcases for readfile and htmlize.
540 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
542 * More utf-8 fixes from Recai, partly to things I broke above:
543 - The serious problem is that writefile() saves the content in undecoded
544 format in CGI, hence all (non-ascii) chars are corrupted permanently.
545 - Comment field in edit page is not decoded and all the non-ascii chars in
546 this field are corrupted as the result. We should decode it as we do it
548 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
550 * New SVG logo from Recai.
552 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
554 ikiwiki (1.5) unstable; urgency=low
556 * Add --timeformat config option to allow changing how dates are displayed.
557 Note that as a side effect, dates will now be displayed using the local
558 timezone, not as GMT.
559 * More security review.
560 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
561 for some handy stuff like:
562 - Using links as a kind of tag; creating blog pages that list all pages
563 containing a given tag/link or not containing some other tag.
564 - Subscribing to mail notifications whenever a change is made to a page
565 that is a backlink of page foo. Ie, "Please notify me of changes in all
566 pages that link to my home page in the wiki"
567 - Locking any pages that are linked to from a particular page, so that
568 lists of locks can be exposed in the wiki.
569 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
570 when a todo item is done, instead of the previous moving it to a different
572 * Allow pagetemplate plugins to override *anything* in the template.
573 * Add a meta plugin, which allows specifying various metadata about pages,
574 like license and author. It also allows for inserting html link and meta
575 tags into html, overriding the title, and adding hidden WikiLinks, which
576 can be useful when using link-based globbing for page categorisation.
577 * Remove preprocessor directives from inlined pages.
578 * Allow simple preprocessor directive values to be specified w/o quotes.
579 * Add support for using git instead of subversion as the RCS backend,
580 tremendous thanks to Recai Oktaş for this.
581 * Doc updates for git.
582 * Fix absolute url munging in rss generation to support https, ftp, etc urls
584 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
585 utf-8 for edit and other fields, and for recentchanges. There may still
586 be utf-8 issues with the preferences page though.
588 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
590 ikiwiki (1.4) unstable; urgency=low
592 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
593 very strange way of enabling proper XHTML <br /> type tags. Output html
594 should be always valid again now.
595 * The page name and parent links has switched from using a <h1> to a styled
596 <span>, so pages can use <h1> internally instead of needing to use <h2>.
597 * Updated all of ikiwiki's own wiki pages for that.
598 * Add pagetemplate hook, which can be used by plugins that want to mess
599 around with adding new stuff to the page template.
600 * Remove headercontent; the search plugin now adds the search box to the
601 header by registering a pagetemplate hook, and other plugins should do
603 * Rebuilding on upgrade to this version is recommended.
604 * Add a html validity check to the test suite, using the wdg-html-validator,
606 * Make the html valid when there is nothing in the actions list.
607 * Reordered some function call parameters for consistency.
608 * Enable full utf-8 support for page input and output.
609 * Add a workaround for markdown, which does not work well with utf-8
611 * --getctime had bitrotted (well I only ever used it the once so far..),
612 fix and make it a bit more flexible
613 * rcs_getctime is changed, now rather than needing to loop over all pages,
614 it should just use the rcs to get the ctime of the passed file.
615 * When inlining a page in another one, links from the inlined page are now
616 expanded the same as they are when rendering the inlined page as a
617 standalone page. So rather than being expanded from the POV of the
618 inlining page, they are expanded from the POV of the inlined page.
620 For example, a link from blog/foo to "bar" will now link to blog/bar
621 if it exists. Previously this needed to be a link explicitly to
622 "blog/bar"; such links will also continue to work.
624 (This was slightly complex to do as the link still has to be constructed
625 relative to the inlining page.)
626 * Make page edit textarea resize to fit browser window.
627 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
628 do not need a full rebuild, in order to update any basewiki pages.
630 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
632 ikiwiki (1.3) unstable; urgency=low
634 * Fix the preinst introduced in the last version. Closes: #367458
636 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
638 ikiwiki (1.2) unstable; urgency=low
640 * Remove dups from the brokenlinks list.
641 * Add libc6-dev to dependencies, needed to build wrappers.
642 * Install wikilist in correct location. Closes: #367371
644 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
646 ikiwiki (1.1) unstable; urgency=low
648 * Rename inlinepage to depends, so that it can be used to refer to more
649 dependency relationships than just inlining. This will require a rebuild
650 on upgrade to this version.
651 * Move the rss link, put it in the blogpost form if there is one and at the
652 top if not. This is both nicer because easier to find, and it cleans up
653 the code which had used inlinepage as a flag for adding the link later.
654 * Allow the depends GlobList to be built up from multiple sources (such as
655 plugins) during a page render.
656 * Which means that more than one blog is now supported to appear on a
657 single page. (With some limitations, like only the last one getting an
659 * Added a plugin system.
660 * Added a pagecount plugin, enabled by default.
661 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
662 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
663 backlinks when the backlinks hadn't really changed.
664 * Moved inline page support, rss generation etc into the inline plugin,
666 * Added brokenlinks plugin, not enabled by default, but rather handy.
667 * Fix several broken links in the doc wiki.
668 * Smarter behavior when creating a page and a page of the same name (but
669 different location) already exists.
670 * Add an orphans plugin for finding pages that nothing links to.
671 * Removed backlinks page, which it turns out nothing used.
672 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
673 it, this will allow for adding a unit test suite.
674 * Add unit tests for several core functions, including globlist_match,
675 dirname, basename, bestlink, linkify, pagetitle, titlepage.
676 * Smart globlist merging.
677 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
678 to pave the way for adding other RCS support. This also changes the
679 setup files, where before they had svn => 1 or svn => 0, now they have
680 rcs => "svn" or rcs => "".
681 * Add a debian/NEWS file with upgrade notes.
682 * Load whatever rcs module is specified, so new ones can be just dropped in
683 as plugins and work. (Well, in theory.)
684 * Add some basic docs about writing RCS modules.
685 * Broke search capability out into a plugin, removed the --hyperestraier
687 * Added smiley plugin, nicely controlled and documented by the smileys page.
688 * Copied in some smileys from Moin Moin.
689 * Allow links of the form [[some page|page]], with whitespace in the link
691 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
692 and --disable-plugin htmlscrubber.
693 * Allow discussion links on pages to be turned off with --no-discussion.
694 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
695 * Add some new config items to the estseek.conf template, which are needed
696 by hyperestraier 1.2.3.
698 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
700 ikiwiki (1.0) unstable; urgency=low
702 * First official release.
704 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400