1 ikiwiki (1.9) UNRELEASED; urgency=low
3 * Improve display of parentlinks and page title of toplevel index page.
4 * Patch from Faidon to use svn --limit when possible for recentchanges,
5 speeds up recentchanges a lot for wikis with more history.
7 -- Joey Hess <joeyh@debian.org> Wed, 5 Jul 2006 13:33:59 -0400
9 ikiwiki (1.8) unstable; urgency=low
11 * Fix orphans plugin to not count a link to a nonexistant page as a reason
12 for a page not being an orphan.
13 * Support pinging services such as Technorati using XML-RPC to notify them
14 about changes to rss feeds.
15 * Parse svn log as xml for improved utf8 and security. Note that this makes
16 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
17 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
18 flagged string even if the locale causes it to generate utf8 output,
19 so make sure to let perl know it should be handled as utf8. Also,
20 the optimised version used for standard time formats won't work if the
21 user has changed locale, so drop it. Thanks, Faidon Liambotis.
22 * Fix re-encoding of the comments field to utf8 if a commit fails
23 due to a conflict. Thanks, Faidon Liambotis.
24 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
26 * Add insane double encode/decode to utf8 around call to markdown.
27 This works around a truely strange bug, which is apparently a bug in
28 perl, #376329. Also added a test case for it.
29 * Improve layout of edit page so formatting help link is always visible w/o
30 getting in the way of the preview.
31 * Centralised all calls to HTML::Template and force all the templates
33 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
34 * Introduce add_plugins and disable_plugins config options in setup files.
35 This allows adding or removing plugins w/o overriding the whole list of
36 default plugins, which makes it easier to upgrade when new default plugins
38 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
39 default (of course!). Based on a patch by Faidon Liambotis.
40 * Add a html plugin, which can be used to write wikis in raw html,
41 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
42 defaults to not processing .html files, since w/o this plugin they would
43 be copied unsanitised. With this plugin, it will process and html
44 sanitise them, like any other page type.
45 * Rebuilding wrappers is necessary on upgrade to this version.
46 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
47 will be automatically done on all upgrades.
48 * Don't send pings if the wiki is being rebuilt.
49 * Work around very innefficient behavior in File::Spec::abs2rel. Result
50 is a savings of 2 pointless fork/execs per link calculation, which
51 results in ~25% speedup of ikiwiki building its own doc wiki, and
52 about 35% speedup displaying RecentChanges!
53 * Make RecentChanges use a table and some CSS, should be much more readable.
54 No code changes involved.
55 * Encode & in diffurl in examples, to conform to pedantic rules.
56 * Speed up RecentChanges by another 40% or so with some memoization.
57 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
58 in time to build the doc wiki.
60 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
62 ikiwiki (1.7) unstable; urgency=low
64 * Updated logo from Recai with some kerning and alingment tuning.
65 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
69 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
71 ikiwiki (1.6) unstable; urgency=low
73 * YA utf-8 patch from Recai, this time to fix previewing a page so that
74 the text in the input box is re-encoded back to utf-8.
75 * -CSD does not affect modules, so readfile() was not using the utf-8 input
76 layer, which led to lots of problems; make it force read files as utf-8.
78 * Note that as a consequence, this version of ikiwiki will actually try to
79 parse utf8 in source files for the first time, which may expose broken
80 utf8 in wiki sources that was hidden before. Most common will be
81 perl warnings like "utf8 "\xE9" does not map to Unicode"
82 * writefile() likewise needs to use the utf8 output layer.
83 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
85 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
86 given the readfile fix.
87 * Add utf-8 testcases for readfile and htmlize.
88 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
90 * More utf-8 fixes from Recai, partly to things I broke above:
91 - The serious problem is that writefile() saves the content in undecoded
92 format in CGI, hence all (non-ascii) chars are corrupted permanently.
93 - Comment field in edit page is not decoded and all the non-ascii chars in
94 this field are corrupted as the result. We should decode it as we do it
96 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
98 * New SVG logo from Recai.
100 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
102 ikiwiki (1.5) unstable; urgency=low
104 * Add --timeformat config option to allow changing how dates are displayed.
105 Note that as a side effect, dates will now be displayed using the local
106 timezone, not as GMT.
107 * More security review.
108 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
109 for some handy stuff like:
110 - Using links as a kind of tag; creating blog pages that list all pages
111 containing a given tag/link or not containing some other tag.
112 - Subscribing to mail notifications whenever a change is made to a page
113 that is a backlink of page foo. Ie, "Please notify me of changes in all
114 pages that link to my home page in the wiki"
115 - Locking any pages that are linked to from a particular page, so that
116 lists of locks can be exposed in the wiki.
117 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
118 when a todo item is done, instead of the previous moving it to a different
120 * Allow pagetemplate plugins to override *anything* in the template.
121 * Add a meta plugin, which allows specifying various metadata about pages,
122 like license and author. It also allows for inserting html link and meta
123 tags into html, overriding the title, and adding hidden WikiLinks, which
124 can be useful when using link-based globbing for page categorisation.
125 * Remove preprocessor directives from inlined pages.
126 * Allow simple preprocessor directive values to be specified w/o quotes.
127 * Add support for using git instead of subversion as the RCS backend,
128 tremendous thanks to Recai Oktaş for this.
129 * Doc updates for git.
130 * Fix absolute url munging in rss generation to support https, ftp, etc urls
132 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
133 utf-8 for edit and other fields, and for recentchanges. There may still
134 be utf-8 issues with the preferences page though.
136 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
138 ikiwiki (1.4) unstable; urgency=low
140 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
141 very strange way of enabling proper XHTML <br /> type tags. Output html
142 should be always valid again now.
143 * The page name and parent links has switched from using a <h1> to a styled
144 <span>, so pages can use <h1> internally instead of needing to use <h2>.
145 * Updated all of ikiwiki's own wiki pages for that.
146 * Add pagetemplate hook, which can be used by plugins that want to mess
147 around with adding new stuff to the page template.
148 * Remove headercontent; the search plugin now adds the search box to the
149 header by registering a pagetemplate hook, and other plugins should do
151 * Rebuilding on upgrade to this version is recommended.
152 * Add a html validity check to the test suite, using the wdg-html-validator,
154 * Make the html valid when there is nothing in the actions list.
155 * Reordered some function call parameters for consistency.
156 * Enable full utf-8 support for page input and output.
157 * Add a workaround for markdown, which does not work well with utf-8
159 * --getctime had bitrotted (well I only ever used it the once so far..),
160 fix and make it a bit more flexible
161 * rcs_getctime is changed, now rather than needing to loop over all pages,
162 it should just use the rcs to get the ctime of the passed file.
163 * When inlining a page in another one, links from the inlined page are now
164 expanded the same as they are when rendering the inlined page as a
165 standalone page. So rather than being expanded from the POV of the
166 inlining page, they are expanded from the POV of the inlined page.
168 For example, a link from blog/foo to "bar" will now link to blog/bar
169 if it exists. Previously this needed to be a link explicitly to
170 "blog/bar"; such links will also continue to work.
172 (This was slightly complex to do as the link still has to be constructed
173 relative to the inlining page.)
174 * Make page edit textarea resize to fit browser window.
175 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
176 do not need a full rebuild, in order to update any basewiki pages.
178 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
180 ikiwiki (1.3) unstable; urgency=low
182 * Fix the preinst introduced in the last version. Closes: #367458
184 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
186 ikiwiki (1.2) unstable; urgency=low
188 * Remove dups from the brokenlinks list.
189 * Add libc6-dev to dependencies, needed to build wrappers.
190 * Install wikilist in correct location. Closes: #367371
192 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
194 ikiwiki (1.1) unstable; urgency=low
196 * Rename inlinepage to depends, so that it can be used to refer to more
197 dependency relationships than just inlining. This will require a rebuild
198 on upgrade to this version.
199 * Move the rss link, put it in the blogpost form if there is one and at the
200 top if not. This is both nicer because easier to find, and it cleans up
201 the code which had used inlinepage as a flag for adding the link later.
202 * Allow the depends GlobList to be built up from multiple sources (such as
203 plugins) during a page render.
204 * Which means that more than one blog is now supported to appear on a
205 single page. (With some limitations, like only the last one getting an
207 * Added a plugin system.
208 * Added a pagecount plugin, enabled by default.
209 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
210 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
211 backlinks when the backlinks hadn't really changed.
212 * Moved inline page support, rss generation etc into the inline plugin,
214 * Added brokenlinks plugin, not enabled by default, but rather handy.
215 * Fix several broken links in the doc wiki.
216 * Smarter behavior when creating a page and a page of the same name (but
217 different location) already exists.
218 * Add an orphans plugin for finding pages that nothing links to.
219 * Removed backlinks page, which it turns out nothing used.
220 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
221 it, this will allow for adding a unit test suite.
222 * Add unit tests for several core functions, including globlist_match,
223 dirname, basename, bestlink, linkify, pagetitle, titlepage.
224 * Smart globlist merging.
225 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
226 to pave the way for adding other RCS support. This also changes the
227 setup files, where before they had svn => 1 or svn => 0, now they have
228 rcs => "svn" or rcs => "".
229 * Add a debian/NEWS file with upgrade notes.
230 * Load whatever rcs module is specified, so new ones can be just dropped in
231 as plugins and work. (Well, in theory.)
232 * Add some basic docs about writing RCS modules.
233 * Broke search capability out into a plugin, removed the --hyperestraier
235 * Added smiley plugin, nicely controlled and documented by the smileys page.
236 * Copied in some smileys from Moin Moin.
237 * Allow links of the form [[some page|page]], with whitespace in the link
239 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
240 and --disable-plugin htmlscrubber.
241 * Allow discussion links on pages to be turned off with --no-discussion.
242 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
243 * Add some new config items to the estseek.conf template, which are needed
244 by hyperestraier 1.2.3.
246 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
248 ikiwiki (1.0) unstable; urgency=low
250 * First official release.
252 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400