1 ikiwiki (1.36) UNRELEASED; urgency=low
3 * Fix various links on the hyperestradier pages.
4 * Use POST for poll to avoid some robots.
5 * Fix sometimes broken links to Discussion pages from blog pages.
6 * Add userdir config setting.
7 * Fix man page perms in install.
8 * Fix an issue with inlining a page with a rss feed inside another
11 -- Joey Hess <joeyh@debian.org> Thu, 21 Dec 2006 08:50:41 -0500
13 ikiwiki (1.35) unstable; urgency=low
15 * Fix daemonisation code to only do daemon setup things after forking the
17 * The hack used to make the pagetemplate hook have access to the editpage
18 template won't work with CGI::FormBuilder 3.0401, so disable it for now.
19 * CGI::FormBuilder 3.0401 seems to work ok now with ikiwiki, although
20 there might still be bugs lurking..
22 -- Joey Hess <joeyh@debian.org> Fri, 1 Dec 2006 19:14:36 -0500
24 ikiwiki (1.34.2) unstable; urgency=low
26 * Allow /etc/ikiwiki/wikilist to list just the names of users, if so then
27 ~user/.ikiwiki/wikilist will be read.
28 * Fix url absolution code in inline plugin to support class and id fields in
29 links and imgs, and to support anchor urls.
30 * More build deps updates.
31 * /dev/null fortune failures
33 -- Joey Hess <joeyh@debian.org> Tue, 28 Nov 2006 12:58:47 -0500
35 ikiwiki (1.34.1) unstable; urgency=low
37 * Add libtime-duration-perl to build deps, as it's used by the svn module
38 which is now tested at build.
40 -- Joey Hess <joeyh@debian.org> Mon, 27 Nov 2006 12:26:12 -0500
42 ikiwiki (1.34) unstable; urgency=low
44 * Add an openid plugin to support logging in using OpenID.
45 * Web commits by OpenID users will record the full OpenID url for the user,
46 but in recentchanges, these urls will be converted to a simplified display
48 * Modified svn, git, tla backends to recognise such web commits.
49 * Move httpauth support to a plugin.
50 * Add openidsignup config option.
51 * Make the openid plugin support the callbacks from myopenid.com via its
55 * Add quick mode for archive page generation.
56 * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
57 many other plugins. It's an easy way to boost ikiwiki from its default,
58 basic wiki, to a full-featured wiki, without manually picking the right
59 set of plugins. New plugins will be added to goodstuff from time to
61 * Change how post signin actions are propigated through the signin process;
62 they're now stored in the session.
63 * Add optional "desc" parameter to shortcut definitions.
64 * Avoid locking the wiki at all when handling some basic cgi stuff
65 (searches, recentchanges).
66 * Add "last" parameter to hook function. Very basic ordering, and hopefully
67 nothing more spohisticated will be needed.
68 * Add formbuilder_setup and formbuilder hooks.
69 * Split out a passwordauth module, that holds all the traditional password
70 based authentication etc code. It's enabled by default, but can be disabled
71 if you want only openid or some other auth method.
72 * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
73 * Add some code to the build system that tries to determine if the
74 lib installation directory is in @INC. If it's not, munge ikiwiki
75 to hardcode the path to the lib directory. This should allow installing
76 ikiwiki in nonstandard locations, including home directories, by just
77 setting PREFIX at build time.
78 * Fix nested examples directory in deb.
79 * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
80 * Add a test suite for the svn backend.
81 * Add a test suite for the git backend, from Recai
82 * Daemonize before sending RPC pings, since that can take a while
84 * Daemonize before sending commit mails, as that can also take a long
85 time/hang if the mail server is unhappy.
86 * Factor out commit mail sending code into new function.
87 * Change rcs_commit, it is now passed the name of the user doing the commit
88 and their IP address, and needs to construct its own commit message
89 containing them, or do something more appropriate for the given RCS.
90 * Add softwaresite example.
91 * Mercurial backend improvements, including --get-ctime support. (Emanuele
93 * Git backend improvements, including bug fixes and better robustness,
96 -- Joey Hess <joeyh@debian.org> Sun, 26 Nov 2006 20:46:56 -0500
98 ikiwiki (1.33) unstable; urgency=low
100 * Fix issue with aggregate plugin updating expired pages.
101 * Avoid syntax errors in templates used by the template plugin crashing
103 * Enable utf8 file IO in aggregate plugin.
104 * Fix some issues with the new registration form.
105 * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
106 * Make sure to check for errors from every eval.
107 * Fix img plugin's handling of adding dependencies for images that do not
109 * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
110 FORM-SUBMIT unusable on customised formbuilder templates. For now,
111 hardcode the submit buttons in editpage.tmpl instead of using the
112 template variable, which is ok, since the buttons are static.
113 * Work with hyperestraier 1.4.9.
115 -- Joey Hess <joeyh@debian.org> Wed, 15 Nov 2006 18:32:26 -0500
117 ikiwiki (1.32) unstable; urgency=low
119 * Add a separate pass to find page links, and only render each page once,
120 instead of over and over. Typical speedup is ~4x. Max possible speedup:
122 * Add "scan" parameter to hook(), which is used to make the hook be called
123 during the scanning pass, as well as the render pass. The meta and tag
124 plugins need to use the new scan parameter, so will any others that modify
126 * Now that links are calculated in a separate pass, it can also
127 precalculate backlinks in one pass, which is O(N^2) instead of the
128 previous code that was O(N^3). A very nice speedup for wikis with lots
129 (thousands) of pages.
130 * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
132 * Add a default stylesheet entry for the pagecloud.
133 * Add examples page with some examples of things that can be done using
134 ikiwiki, like a weblog. The examples can be copied into a user's wiki
135 for a quick start, without needing to learn everything about how to put
137 * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
138 * Add perlmagick to build-depends so syntax check of img plugin works.
140 * Improve login/register process, the login dialog has only name and
141 password fields, which allows more web browsers to regognise it as a login
142 field, and is less confusing.
143 * Implemented expiry options for aggregate plugin.
144 * Use precalculated backlinks info when determining if files need an update
145 due to a page they link to being added/removed. Mostly significant if
146 there are lots of pages.
147 * Remove duplicate link info when saving index. In some cases it could
148 pile up rather badly. (Probably not the best way to deal with this
150 * Patch from James Westby to support podcasting, photoblogging, vidcasting,
151 or what have you, by creating enclosures for non-page items that are
154 -- Joey Hess <joeyh@debian.org> Fri, 3 Nov 2006 14:46:37 -0500
156 ikiwiki (1.31) unstable; urgency=low
158 * Patch from Pawel Tecza to cp -a the templates in the Makefile.
159 * Change the rss feed title from the wikiname to the page title, with
160 an exception for the wiki's toplevel index page, which will still use the
161 wikiname as the feed title.
162 Overriding the page title with meta title already overrode the rss feed
164 * Add an img plugin, based on Christian Mock's img plugin, but stripped
165 down to the bare essentials. Useful for handling large images on websites.
166 * Sanitize possibly problimatic characters out of the polygen grammar names,
167 just in case. Should not be exploitable anyway, since it only tries to run
168 polygen after finding the specified grammar file.
169 * Add missing dependency on the URI perl module.
170 * Add basic spam fighting tool for admins: An admin's prefs page now allows
171 editing a list of banned users.
173 -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 23:16:33 -0400
175 ikiwiki (1.30) unstable; urgency=low
177 * Add no_override parameter to hook().
178 * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
179 plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
180 can be configured using a page in wiki.
181 * Fix support for --pingurl at the command line.
182 * Fix a subtle bug in will_render that broke some builds, by only clearing
183 items from renderedfiles the first time per build.
184 * Wrap entire technortati ping operation in an eval to catch all possible
185 failure modes, after I observed a simple ->value crashing ikiwiki when
188 -- Joey Hess <joeyh@debian.org> Mon, 16 Oct 2006 15:17:38 -0400
190 ikiwiki (1.29) unstable; urgency=low
192 * Patch from Paul Tötterman to use CP in the Makefile.
193 * Patch from Alec Berryman adding a http_auth config item that allows
194 using HTTP Authentication instead of ikiwiki's built in authentication.
195 Useful for eg, large sites with their own previously existing user auth
196 setup. Closes: #384534
197 * Change %renderedfiles to store an array of files rendered from a given
198 source file, to allow tracking of extra rendered files like rss feeds.
199 * Note that plugins that accessed this variable will need to be updated!
200 The plugin interface has been increased to version 1.01 for this change.
201 As few plugins use %renderedfiles I haven't done anything else to ensure
202 compatability of old plugins.
203 * Add will_render function to the plugin interface, used to register that a
204 page renders a destination file, and do some security checks. Previously
205 but no longer rendered files will be cleaned up.
206 * Use will_render in the inline and linkmap plugins.
207 * You will need to rebuild your wiki on upgrade to this version.
208 * Atom feed support based on a patch by Clint Adams.
209 * Add feeds=no option to inline preprocessor directive to turn off all types
211 * $IkiWiki::version now holds the program version, and is accessible to
213 * Make the aggregate plugin emphasize error messages.
214 * Patch from Recai to limit recentchanges to displaying max 10 files for a
215 given changeset (to avoid large number of file changes excessively
218 -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
220 ikiwiki (1.28) unstable; urgency=low
222 * inline: Add ability to sort by page name, based on a patch from
224 * Fix a forkbomb in various calls to IPC::Open2, which has a highly
225 braindead interface. Closes: #389383
226 * Don't rm -rf ikiwiki on distclean, since a) there's no such file
227 and b) those poor Mac OSX users and their case insensative files!
228 * Don't fail syntax check if Text::Typography isn't installed.
231 -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
233 ikiwiki (1.27) unstable; urgency=low
235 * Work on firming up the plugin interface:
236 - Plugins should not need to load IkiWiki::Render to get commonly
237 used functions, so moved some functions from there to IkiWiki.
238 - Picked out the set of functions and variables that most plugins
239 use, documented them, and made IkiWiki export them by default,
240 like a proper perl module should.
241 - Use the other functions at your own risk.
242 - This is not quite complete, I still have to decide whether to
243 export some other things.
244 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
245 referring to stuff now exported by the IkiWiki module.
246 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
247 to declare which version of the interface your plugin needs.
248 * Anyone with a third-party ikiwiki plugin is strongly encouraged
249 to make like changes to it and avoid use of non-exported symbols from
251 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
252 * Support hyperestradier version 1.4.2, which adds a new required phraseform
254 * If an inlined page has a permalink, link the page title to that.
255 * Patch from Recai to use utf8 when reading the setup file, so that
256 utf8 wikinames from there will be used properly.
257 * Patch from Recai to kill utf-8 on the wiki name when generating the
259 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
260 * Fix a baseurl problem in hyperestradier search results.
261 * Add a stub local.css to avoid problems with 404's.
262 * Patch from Recai to fix a wide character warning from the search plugin
263 during setup if the wikiname contains utf8.
264 * Yet another fix for those poor case-insensative OS X users.
265 * pagetemplate hooks are now also called when generating cgi pages.
266 * Add a favicon plugin, which simply adds a link tag for an icon to each
268 * Patch from James Westby to deal with the case where you're editing a
269 new page, hit cancel, and need to be redirected to somewhere sane.
270 * Various documentation improvements by various wiki users.
271 * Support Text::Markdown from CPAN, which has a different interface from
272 the original markdown or the one in Debian.
273 * Version the libcgi-session-perl dependency, some features that need
274 the new version are used in some cases (sslcookie).
275 * Numerous tla fixes from Clint.
276 * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
277 a multi-resolution favicon.ico.
278 * README.Debian: typo Closes: #388110
279 * chomp trailing newline at the end of templates read in by the template
280 plugin, to allow use of the template preprocessor directive in
281 whitespace-sensative situations. Closes: #387073
282 * Patch from James Westby to make the location of the estseek.cgi script
284 * Add typography (SmartyPants) plugin by Recai.
285 * Add --render mode, which can be used to preview an edit at the command
286 line by test rendering a single page.
287 * Add a googlecalendar plugin. A bit special-purpose, but it shows
288 one way to to deal with user-supplied content that could cause XSS
289 issues w/o the htmlscrubber, and won't survive the scrubber.
291 -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
293 ikiwiki (1.26) unstable; urgency=low
295 * Add a missing -n to tla undo call.
296 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
297 writes before consuming its whole stdin. Avoid this deadlock.
298 * Fix alt tags for outline checkboxes.
300 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
302 ikiwiki (1.25) unstable; urgency=low
304 * Add proper waitpid calls for open2ed processes throughout to avoid
305 zombies; this hit htmltidy especially badly.
306 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
307 subversion repos and fixing some other issues.
308 * Add support for tla, contributed by Clint Adams. Closes: #385936
309 * Add support for mercurial, contributed by Emanuele Aina.
310 * Include <link rel> tag for RSS feeds, used by some aggregators and
311 firefox to find the feed.
312 * Add a linkmap plugin (requires graphviz).
314 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
316 ikiwiki (1.24) unstable; urgency=low
318 * Simplify the data structure returned by rcs_recentchanges to avoid
319 each rcs plugin needing to form complex strings on its own.
320 * Fix another destpage issue in the inline directive. Closes: #385512
323 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
325 ikiwiki (1.23) unstable; urgency=low
327 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
329 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
331 ikiwiki (1.22) unstable; urgency=low
333 * Change how the stylesheet url is determined in the templates: Remove
334 STYLEURL and add BASEURL to all templates (some already had it). This
335 new more general variable can be used to link to other things (eg, images)
336 from the template, as well as stylesheets.
337 * Fix a bug introduced last version to do with nested inlines.
338 * Allow preprocessor directives to span multiple lines, both to make
339 long ones with lots of values easier to write, and to allow for ones with
340 multi-line quoted values.
341 * Allow preprocessor directives to contain python-like triple-quoted
342 text blocks, for easy nesting of quotes inside.
343 * Add a template plugin.
344 * Make pagespec merge code smarter about merging duplicate pagespecs.
345 * Patch from Jordà Polo to make Setup::Standard support hashes in config
347 * Change order of linkify and preprocess; first preprocess and then linkify.
348 This allows passing a wikilink inside a parameter to a preprocessor
349 directive without it being expanded to html, and leaking out of the
350 parameter, which had required some non-obvious use of triple-quoting
351 to avoid. Note that any preprocessor plugins that output something
352 that looks like a wikilink will now have it treated as such; AFAIK
353 this doesn't change any behavior though except for the template plugin.
354 * Enable preprocessor directives when previewing an edit.
355 * Make all pages pull in a local.css style sheet, if present. This won't
356 be included in ikiwiki, but can be created to make local styling changes
357 w/o needing to merge in every new change to the distributed style.css.
358 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
359 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
360 from a different directory.
361 * Generalised preprocesser loop protection code.
362 * Patch from James Westby to allow a description to be set for rss feeds.
363 * Patch from James Westby to add a template for the search form.
364 * Added a ddate plugin.
365 * Patch from James Westby to add a --sslcookie switch, which forces
366 cookies to only be sent over ssl connections to avoid interception.
367 * Fix preferences page on anonok wikis; still need to sign in to get
368 to the preferences page.
369 * Add toc (table of contents) plugin.
370 * Change htmlize, format, and sanitize hooks to use named parameters.
371 * Patch from James Westby to add an actions option to inline; this
372 adds Edit and Discussion links at the end of blog entries.
373 * Due to some css changes, you'll want to rebuild your wiki on upgrade
374 to this version. Will be handled automatically by the deb.
375 * Add processed date to aggregate preprocessor directive status output.
377 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
379 ikiwiki (1.21) unstable; urgency=low
381 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
382 * If a page links to itself, mark up the link text in a span with
383 class="selflink" so that it can be styled. I don't have a useful style
384 defined for that though.
385 * Call filter hooks on inlined page content.
386 * Support inlining pages raw, rather than creating a blog.
387 * Clean up yes/no parameter parsing in inline plugin.
388 * Implemented better cycle detection in the inline plugin; nested inlines
390 * Add a map plugin contributed by Alessandro Dotti Contra.
391 * Add otl format plugin, which handles files as created by vimoutliner.
392 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
393 * Add first draft at a Restructured Text (rst) plugin, by Sergio
394 Talens-Oliag. Note that this has many known issues -- see the caveats on
396 * Credit everyone who wrote a plugin on the plugins' wiki pages.
397 * Fix utf-8 in blog post form.
399 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
401 ikiwiki (1.20) unstable; urgency=low
403 * Relicense the templates and basewiki under the 2-clause BSD license.
404 Since these can easily become part of other people's websites, they
405 should be under as permissive a license as possible.
406 * Add --syslog config option, to log to the syslog.
407 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
408 transient failure to fork (which I've seen happen in the wild).
409 * Fix a bug in the aggregator introduced last version that caused all
410 aggregator state to be lost during a non-aggregating build.
412 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
414 ikiwiki (1.19) unstable; urgency=low
416 * Fix several related bugs in page type determination during online editing.
417 * Add some locking to prevent 2 aggregators from running at once.
418 * Fix an infinite loop in the aggregator when finding a unique filename.
420 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
422 ikiwiki (1.18) unstable; urgency=low
424 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
426 * Man page format fixups.
427 * If the meta plugin overides the page title, set a title_overridden
428 variable in the template to true. This allows doing things with the
429 templates conditional on the title being overriden.
430 * Add a %pagecase which maps lower-case page names to the actual case
431 used in the filename. Use this in bestlinks calculation instead of
432 forcing the link to lowercase.
433 * Also use %pagecase in various other places that want to check if a page
434 with a given name exists.
435 * This means that links to pages with mixed case names will now work,
436 even if the link is in some other case mixture, and mixed case pages
437 should be fully supported throughout ikiwiki.
438 * Recommend rebuilding wikis on upgrade to this version.
440 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
442 ikiwiki (1.17) unstable; urgency=low
444 * Disable tidy generator tag.
445 * Move tidy back to sanitize hook, found out how to only show body.
446 * Turn off tidy indentation too.
447 * Turn on HTML::Template loop_context_vars; not actually used in stock
448 templates but can be useful for things like making comma-delimited lists
449 of tags or what have you.
450 * Remove <br> from end of aggregate preprocessor directive output.
451 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
452 case-sensative filesystems like OSX.
453 * Improve markdown loading. First, try to load it as a proper perl module,
454 in case it was installed as one. Then fall back to trying
456 * Document in install page how to install markdown, since it has no
457 installation procedure in the upstream tarball.
458 * Set die_on_bad_params => 0 for all templates, to allow users to modify
459 them without annoyances.
460 * Suck in the page content when generating an inline archive page, to work
461 around the meta plugin's lack of caching of title metadata across runs.
463 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
465 ikiwiki (1.16) unstable; urgency=low
467 * Try to handle relative links in aggregated feeds. However,
468 the current support is a crude hack due to limitations of XML::Feed:
469 xml:base is not supported, neither is Content-Location. And of course,
470 relative links in RSS feeds are ill-undefined..
471 * Make aggregator save permalinks and author name to pages as metadata.
472 * Add permalink and author support to meta plugin, affecting RSS feeds
474 * Various CSS and formatting changes.
475 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
476 * Add xhtml files to the default prune regexp.
477 * Also generate rel=bookmark links for permalinks.
478 * Fix the htmltidy plugin, which wasn't working due my breaking it when
480 * Don't run tidy with -xml as that fails if the input is not well-formed.
481 Run it with -asxhtml instead, so it will output well-formed xhtml no
482 matter what the input.
483 * Disable tidy warnings too.
484 * Add a new format hook, and make tidy use it, since tidy can really only
485 operate on and output complete html documents, not the body chunks
487 * Fix dates in rss feeds if running localised, so they're still rfc 822.
489 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
491 ikiwiki (1.15) unstable; urgency=low
493 * Remove CDPATH and other env vars perl taint checking doesn't like.
495 * Added created_before and created_after PageSpec limits.
497 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
499 ikiwiki (1.14) unstable; urgency=low
501 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
503 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
504 * Added many unit tests for pagespec_match.
506 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
508 ikiwiki (1.13) unstable; urgency=low
510 * ikiwiki can now download and aggregate feeds with its new aggregate
511 plugin, so it's possible to implement a Planet using ikiwiki!
512 * Add a run_hooks function for the common task of running all hooks of a
514 * Add a savestate hook.
515 * Don't put blog post forms on pages if there's no cgiurl set.
516 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
517 --wrappers to do that.
518 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
519 to update pages that haven't changed on disk.
520 * Change meta tags to use html entity-escaped text for values, so that
521 quotes and such can be represented in title tags.
522 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
524 * Make --rebuild also cause --aggregate to re-download and write aggregated
526 * Avoid outputting duplicate meta info.
527 * Include title metadata on aggregated posts for capitalised and un-munged
529 * Title metadata of inlined pages now shows up in blogs and rss feeds.
530 * Fix issue with unicode filenames and updating the hyper estradier search
531 index. (Aka Please Please Please, let that be the last one.)
532 * Patch from Roland Mas to support an rss=no parameter to inline directives.
534 * Renamed GlobLists to PageSpecs.
535 * PageSpecs can now include nested parens, "and", and "or". This remains
536 backwards compatible to the old GlobList format. It's implemented by
537 treating the GlobList as a very limited microlanguage that is transformed
538 to perl code that does the matching.
539 * The old GlobList format is deprecated, and I encourage users to switch to
540 using the new PageSpec format. Compatability with the old format will be
541 removed at some point, possibly by 2.0.
542 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
543 * Add support for creation_month and creation_year to PageSpec.
545 * Changes to index file encoding.
547 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
549 ikiwiki (1.12) unstable; urgency=low
552 * New pagestats plugin from Enrico, which can generate a table counting
553 the backlinks for each page, or a del.icio.us style cloud.
554 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
555 the wikiformat plugin works. Thanks, Emanuele Aina.
556 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
557 display, running them through pagetitle. This removes ugly underscores and
558 other gunk from the display, much nicer. You may want to rebuild your wiki
559 when upgrading to get the cleanup globally.
560 * Polygen plugin from Enrico.
561 * htmltidy plugin from Faidon.
562 * Locale patch from Faidon:
563 - Adds a locale setting to setup files.
564 - Proper local time, if the locale configuration option is used.
565 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
566 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
568 * Add getopt hook type, this allows plugins to add new command-line options.
569 * Add --tagbase option to tag plugin.
570 * Add exclude option in setup files, works same as --exclude.
571 * Put categories in rss feeds for tagged items.
572 * Allow preprocessor directives to be expanded in inlined blog pages.
573 However, to avoid inlining loops etc, don't expand inline directives in
575 * fortune plugin (trivial)
576 * Tag plugins according to type.
578 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
580 ikiwiki (1.11) unstable; urgency=low
582 * Patch from Enrico that
583 - Adds a tag plugin that allows more easily tagging pages.
584 The meta plugin can also still be used for that, but the tag plugin
585 also lists a page's tags at the bottom of the page.
586 - Allows preprocessor directives to have parameters with no specified
588 - Fixes preprocessor directive parameter parsing so that
589 foo=bar baz now means "foo=bar" and a "baz" with no value.
590 * Run pagetemplate hooks when inlining pages so that inlined pages also
592 * Make all plugins with pagetemplate hooks check that variables exist
593 on the template before setting them, for robustness.
594 * Switch pagetemplate hooks to using named parameters.
595 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
596 This will be the page that a source page will be part of, which is
597 different than the source page for inlined pages.
598 * Audited all plugins to endure they pass (page, destpage) to htmllink
599 appropriatly. This means inlining of various plugins will not work
600 properly, with correct links generated.
602 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
604 ikiwiki (1.10) unstable; urgency=low
606 * Run page through any relevant filters when generating a page preview.
607 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
608 default throughout the wiki, not only on wikitext pages. Decided to call
609 this a feature, and split the camelcase support out into a separate plugin
610 that is independant of wikitext.
611 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
613 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
615 ikiwiki (1.9) unstable; urgency=low
617 * Improve display of parentlinks and page title of toplevel index page.
618 * Patch from Faidon to use svn --limit when possible for recentchanges,
619 speeds up recentchanges a lot for wikis with more history.
620 * Patch from Recai to fix utf8 issues in git backend.
621 * Add wikitext markup plugin, which supports ".wiki" pages written in the
622 original wiki syntax, CamelCase links and all.
623 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
624 support, to edit pages etc without a web server.
625 * Display CGI processing errors if present.
626 * Fix from Faidon for a XML parser issue that breaks utf-8 for
627 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
628 area, and also way slow.
629 * Match 'web commit from' in SVN and git, these are web commits too.
631 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
632 readable and avoid future mistakes. The patch seems to work and for the
633 first time I have a UTF-8 username ;-) (Faidon)
634 * Use form->field consistently, not form->param.
635 * Patch from Recai to allow selection of page type when creating a new page.
636 Default page type is inherited from the link clicked on to create the new
639 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
641 ikiwiki (1.8) unstable; urgency=low
643 * Fix orphans plugin to not count a link to a nonexistant page as a reason
644 for a page not being an orphan.
645 * Support pinging services such as Technorati using XML-RPC to notify them
646 about changes to rss feeds.
647 * Parse svn log as xml for improved utf8 and security. Note that this makes
648 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
649 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
650 flagged string even if the locale causes it to generate utf8 output,
651 so make sure to let perl know it should be handled as utf8. Also,
652 the optimised version used for standard time formats won't work if the
653 user has changed locale, so drop it. Thanks, Faidon Liambotis.
654 * Fix re-encoding of the comments field to utf8 if a commit fails
655 due to a conflict. Thanks, Faidon Liambotis.
656 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
658 * Add insane double encode/decode to utf8 around call to markdown.
659 This works around a truely strange bug, which is apparently a bug in
660 perl, #376329. Also added a test case for it.
661 * Improve layout of edit page so formatting help link is always visible w/o
662 getting in the way of the preview.
663 * Centralised all calls to HTML::Template and force all the templates
665 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
666 * Introduce add_plugins and disable_plugins config options in setup files.
667 This allows adding or removing plugins w/o overriding the whole list of
668 default plugins, which makes it easier to upgrade when new default plugins
670 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
671 default (of course!). Based on a patch by Faidon Liambotis.
672 * Add a html plugin, which can be used to write wikis in raw html,
673 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
674 defaults to not processing .html files, since w/o this plugin they would
675 be copied unsanitised. With this plugin, it will process and html
676 sanitise them, like any other page type.
677 * Rebuilding wrappers is necessary on upgrade to this version.
678 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
679 will be automatically done on all upgrades.
680 * Don't send pings if the wiki is being rebuilt.
681 * Work around very innefficient behavior in File::Spec::abs2rel. Result
682 is a savings of 2 pointless fork/execs per link calculation, which
683 results in ~25% speedup of ikiwiki building its own doc wiki, and
684 about 35% speedup displaying RecentChanges!
685 * Make RecentChanges use a table and some CSS, should be much more readable.
686 No code changes involved.
687 * Encode & in diffurl in examples, to conform to pedantic rules.
688 * Speed up RecentChanges by another 40% or so with some memoization.
689 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
690 in time to build the doc wiki.
692 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
694 ikiwiki (1.7) unstable; urgency=low
696 * Updated logo from Recai with some kerning and alingment tuning.
697 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
701 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
703 ikiwiki (1.6) unstable; urgency=low
705 * YA utf-8 patch from Recai, this time to fix previewing a page so that
706 the text in the input box is re-encoded back to utf-8.
707 * -CSD does not affect modules, so readfile() was not using the utf-8 input
708 layer, which led to lots of problems; make it force read files as utf-8.
710 * Note that as a consequence, this version of ikiwiki will actually try to
711 parse utf8 in source files for the first time, which may expose broken
712 utf8 in wiki sources that was hidden before. Most common will be
713 perl warnings like "utf8 "\xE9" does not map to Unicode"
714 * writefile() likewise needs to use the utf8 output layer.
715 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
717 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
718 given the readfile fix.
719 * Add utf-8 testcases for readfile and htmlize.
720 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
722 * More utf-8 fixes from Recai, partly to things I broke above:
723 - The serious problem is that writefile() saves the content in undecoded
724 format in CGI, hence all (non-ascii) chars are corrupted permanently.
725 - Comment field in edit page is not decoded and all the non-ascii chars in
726 this field are corrupted as the result. We should decode it as we do it
728 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
730 * New SVG logo from Recai.
732 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
734 ikiwiki (1.5) unstable; urgency=low
736 * Add --timeformat config option to allow changing how dates are displayed.
737 Note that as a side effect, dates will now be displayed using the local
738 timezone, not as GMT.
739 * More security review.
740 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
741 for some handy stuff like:
742 - Using links as a kind of tag; creating blog pages that list all pages
743 containing a given tag/link or not containing some other tag.
744 - Subscribing to mail notifications whenever a change is made to a page
745 that is a backlink of page foo. Ie, "Please notify me of changes in all
746 pages that link to my home page in the wiki"
747 - Locking any pages that are linked to from a particular page, so that
748 lists of locks can be exposed in the wiki.
749 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
750 when a todo item is done, instead of the previous moving it to a different
752 * Allow pagetemplate plugins to override *anything* in the template.
753 * Add a meta plugin, which allows specifying various metadata about pages,
754 like license and author. It also allows for inserting html link and meta
755 tags into html, overriding the title, and adding hidden WikiLinks, which
756 can be useful when using link-based globbing for page categorisation.
757 * Remove preprocessor directives from inlined pages.
758 * Allow simple preprocessor directive values to be specified w/o quotes.
759 * Add support for using git instead of subversion as the RCS backend,
760 tremendous thanks to Recai Oktaş for this.
761 * Doc updates for git.
762 * Fix absolute url munging in rss generation to support https, ftp, etc urls
764 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
765 utf-8 for edit and other fields, and for recentchanges. There may still
766 be utf-8 issues with the preferences page though.
768 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
770 ikiwiki (1.4) unstable; urgency=low
772 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
773 very strange way of enabling proper XHTML <br /> type tags. Output html
774 should be always valid again now.
775 * The page name and parent links has switched from using a <h1> to a styled
776 <span>, so pages can use <h1> internally instead of needing to use <h2>.
777 * Updated all of ikiwiki's own wiki pages for that.
778 * Add pagetemplate hook, which can be used by plugins that want to mess
779 around with adding new stuff to the page template.
780 * Remove headercontent; the search plugin now adds the search box to the
781 header by registering a pagetemplate hook, and other plugins should do
783 * Rebuilding on upgrade to this version is recommended.
784 * Add a html validity check to the test suite, using the wdg-html-validator,
786 * Make the html valid when there is nothing in the actions list.
787 * Reordered some function call parameters for consistency.
788 * Enable full utf-8 support for page input and output.
789 * Add a workaround for markdown, which does not work well with utf-8
791 * --getctime had bitrotted (well I only ever used it the once so far..),
792 fix and make it a bit more flexible
793 * rcs_getctime is changed, now rather than needing to loop over all pages,
794 it should just use the rcs to get the ctime of the passed file.
795 * When inlining a page in another one, links from the inlined page are now
796 expanded the same as they are when rendering the inlined page as a
797 standalone page. So rather than being expanded from the POV of the
798 inlining page, they are expanded from the POV of the inlined page.
800 For example, a link from blog/foo to "bar" will now link to blog/bar
801 if it exists. Previously this needed to be a link explicitly to
802 "blog/bar"; such links will also continue to work.
804 (This was slightly complex to do as the link still has to be constructed
805 relative to the inlining page.)
806 * Make page edit textarea resize to fit browser window.
807 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
808 do not need a full rebuild, in order to update any basewiki pages.
810 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
812 ikiwiki (1.3) unstable; urgency=low
814 * Fix the preinst introduced in the last version. Closes: #367458
816 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
818 ikiwiki (1.2) unstable; urgency=low
820 * Remove dups from the brokenlinks list.
821 * Add libc6-dev to dependencies, needed to build wrappers.
822 * Install wikilist in correct location. Closes: #367371
824 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
826 ikiwiki (1.1) unstable; urgency=low
828 * Rename inlinepage to depends, so that it can be used to refer to more
829 dependency relationships than just inlining. This will require a rebuild
830 on upgrade to this version.
831 * Move the rss link, put it in the blogpost form if there is one and at the
832 top if not. This is both nicer because easier to find, and it cleans up
833 the code which had used inlinepage as a flag for adding the link later.
834 * Allow the depends GlobList to be built up from multiple sources (such as
835 plugins) during a page render.
836 * Which means that more than one blog is now supported to appear on a
837 single page. (With some limitations, like only the last one getting an
839 * Added a plugin system.
840 * Added a pagecount plugin, enabled by default.
841 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
842 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
843 backlinks when the backlinks hadn't really changed.
844 * Moved inline page support, rss generation etc into the inline plugin,
846 * Added brokenlinks plugin, not enabled by default, but rather handy.
847 * Fix several broken links in the doc wiki.
848 * Smarter behavior when creating a page and a page of the same name (but
849 different location) already exists.
850 * Add an orphans plugin for finding pages that nothing links to.
851 * Removed backlinks page, which it turns out nothing used.
852 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
853 it, this will allow for adding a unit test suite.
854 * Add unit tests for several core functions, including globlist_match,
855 dirname, basename, bestlink, linkify, pagetitle, titlepage.
856 * Smart globlist merging.
857 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
858 to pave the way for adding other RCS support. This also changes the
859 setup files, where before they had svn => 1 or svn => 0, now they have
860 rcs => "svn" or rcs => "".
861 * Add a debian/NEWS file with upgrade notes.
862 * Load whatever rcs module is specified, so new ones can be just dropped in
863 as plugins and work. (Well, in theory.)
864 * Add some basic docs about writing RCS modules.
865 * Broke search capability out into a plugin, removed the --hyperestraier
867 * Added smiley plugin, nicely controlled and documented by the smileys page.
868 * Copied in some smileys from Moin Moin.
869 * Allow links of the form [[some page|page]], with whitespace in the link
871 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
872 and --disable-plugin htmlscrubber.
873 * Allow discussion links on pages to be turned off with --no-discussion.
874 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
875 * Add some new config items to the estseek.conf template, which are needed
876 by hyperestraier 1.2.3.
878 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
880 ikiwiki (1.0) unstable; urgency=low
882 * First official release.
884 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400