1 ikiwiki (1.8) UNRELEASED; urgency=low
3 * Fix orphans plugin to not count a link to a nonexistant page as a reason
4 for a page not being an orphan.
5 * Support pinging services such as Technorati using XML-RPC to notify them
6 about changes to rss feeds.
7 * Parse svn log as xml for improved utf8 and security. Note that this makes
8 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
9 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
10 flagged string even if the locale causes it to generate utf8 output,
11 so make sure to let perl know it should be handled as utf8. Also,
12 the optimised version used for standard time formats won't work if the
13 user has changed locale, so drop it. Thanks, Faidon Liambotis.
14 * Fix re-encoding of the comments field to utf8 if a commit fails
15 due to a conflict. Thanks, Faidon Liambotis.
16 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
18 * Add insane double encode/decode to utf8 around call to markdown.
19 This works around a truely strange bug, which is apparently a bug in
20 perl, #376329. Also added a test case for it.
21 * Improve layout of edit page so formatting help link is always visible w/o
22 getting in the way of the preview.
23 * Centralised all calls to HTML::Template and force all the templates
25 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
26 * Introduce add_plugins and disable_plugins config options in setup files.
27 This allows adding or removing plugins w/o overriding the whole list of
28 default plugins, which makes it easier to upgrade when new default plugins
30 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
31 default (of course!). Based on a patch by Faidon Liambotis.
32 * Add a html plugin, which can be used to write wikis in raw html,
33 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
34 defaults to not processing .html files, since w/o this plugin they would
35 be copied unsanitised. With this plugin, it will process, and html
36 sanitise them, like any other page type.
37 * Rebuilding wrappers is necessary on upgrade to this version.
38 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
39 will be automatically done on all upgrades.
40 * Don't sent pings if the wiki is being rebuilt.
42 -- Joey Hess <joeyh@debian.org> Mon, 3 Jul 2006 21:01:28 -0400
44 ikiwiki (1.7) unstable; urgency=low
46 * Updated logo from Recai with some kerning and alingment tuning.
47 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
51 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
53 ikiwiki (1.6) unstable; urgency=low
55 * YA utf-8 patch from Recai, this time to fix previewing a page so that
56 the text in the input box is re-encoded back to utf-8.
57 * -CSD does not affect modules, so readfile() was not using the utf-8 input
58 layer, which led to lots of problems; make it force read files as utf-8.
60 * Note that as a consequence, this version of ikiwiki will actually try to
61 parse utf8 in source files for the first time, which may expose broken
62 utf8 in wiki sources that was hidden before. Most common will be
63 perl warnings like "utf8 "\xE9" does not map to Unicode"
64 * writefile() likewise needs to use the utf8 output layer.
65 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
67 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
68 given the readfile fix.
69 * Add utf-8 testcases for readfile and htmlize.
70 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
72 * More utf-8 fixes from Recai, partly to things I broke above:
73 - The serious problem is that writefile() saves the content in undecoded
74 format in CGI, hence all (non-ascii) chars are corrupted permanently.
75 - Comment field in edit page is not decoded and all the non-ascii chars in
76 this field are corrupted as the result. We should decode it as we do it
78 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
80 * New SVG logo from Recai.
82 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
84 ikiwiki (1.5) unstable; urgency=low
86 * Add --timeformat config option to allow changing how dates are displayed.
87 Note that as a side effect, dates will now be displayed using the local
89 * More security review.
90 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
91 for some handy stuff like:
92 - Using links as a kind of tag; creating blog pages that list all pages
93 containing a given tag/link or not containing some other tag.
94 - Subscribing to mail notifications whenever a change is made to a page
95 that is a backlink of page foo. Ie, "Please notify me of changes in all
96 pages that link to my home page in the wiki"
97 - Locking any pages that are linked to from a particular page, so that
98 lists of locks can be exposed in the wiki.
99 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
100 when a todo item is done, instead of the previous moving it to a different
102 * Allow pagetemplate plugins to override *anything* in the template.
103 * Add a meta plugin, which allows specifying various metadata about pages,
104 like license and author. It also allows for inserting html link and meta
105 tags into html, overriding the title, and adding hidden WikiLinks, which
106 can be useful when using link-based globbing for page categorisation.
107 * Remove preprocessor directives from inlined pages.
108 * Allow simple preprocessor directive values to be specified w/o quotes.
109 * Add support for using git instead of subversion as the RCS backend,
110 tremendous thanks to Recai Oktaş for this.
111 * Doc updates for git.
112 * Fix absolute url munging in rss generation to support https, ftp, etc urls
114 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
115 utf-8 for edit and other fields, and for recentchanges. There may still
116 be utf-8 issues with the preferences page though.
118 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
120 ikiwiki (1.4) unstable; urgency=low
122 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
123 very strange way of enabling proper XHTML <br /> type tags. Output html
124 should be always valid again now.
125 * The page name and parent links has switched from using a <h1> to a styled
126 <span>, so pages can use <h1> internally instead of needing to use <h2>.
127 * Updated all of ikiwiki's own wiki pages for that.
128 * Add pagetemplate hook, which can be used by plugins that want to mess
129 around with adding new stuff to the page template.
130 * Remove headercontent; the search plugin now adds the search box to the
131 header by registering a pagetemplate hook, and other plugins should do
133 * Rebuilding on upgrade to this version is recommended.
134 * Add a html validity check to the test suite, using the wdg-html-validator,
136 * Make the html valid when there is nothing in the actions list.
137 * Reordered some function call parameters for consistency.
138 * Enable full utf-8 support for page input and output.
139 * Add a workaround for markdown, which does not work well with utf-8
141 * --getctime had bitrotted (well I only ever used it the once so far..),
142 fix and make it a bit more flexible
143 * rcs_getctime is changed, now rather than needing to loop over all pages,
144 it should just use the rcs to get the ctime of the passed file.
145 * When inlining a page in another one, links from the inlined page are now
146 expanded the same as they are when rendering the inlined page as a
147 standalone page. So rather than being expanded from the POV of the
148 inlining page, they are expanded from the POV of the inlined page.
150 For example, a link from blog/foo to "bar" will now link to blog/bar
151 if it exists. Previously this needed to be a link explicitly to
152 "blog/bar"; such links will also continue to work.
154 (This was slightly complex to do as the link still has to be constructed
155 relative to the inlining page.)
156 * Make page edit textarea resize to fit browser window.
157 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
158 do not need a full rebuild, in order to update any basewiki pages.
160 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
162 ikiwiki (1.3) unstable; urgency=low
164 * Fix the preinst introduced in the last version. Closes: #367458
166 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
168 ikiwiki (1.2) unstable; urgency=low
170 * Remove dups from the brokenlinks list.
171 * Add libc6-dev to dependencies, needed to build wrappers.
172 * Install wikilist in correct location. Closes: #367371
174 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
176 ikiwiki (1.1) unstable; urgency=low
178 * Rename inlinepage to depends, so that it can be used to refer to more
179 dependency relationships than just inlining. This will require a rebuild
180 on upgrade to this version.
181 * Move the rss link, put it in the blogpost form if there is one and at the
182 top if not. This is both nicer because easier to find, and it cleans up
183 the code which had used inlinepage as a flag for adding the link later.
184 * Allow the depends GlobList to be built up from multiple sources (such as
185 plugins) during a page render.
186 * Which means that more than one blog is now supported to appear on a
187 single page. (With some limitations, like only the last one getting an
189 * Added a plugin system.
190 * Added a pagecount plugin, enabled by default.
191 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
192 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
193 backlinks when the backlinks hadn't really changed.
194 * Moved inline page support, rss generation etc into the inline plugin,
196 * Added brokenlinks plugin, not enabled by default, but rather handy.
197 * Fix several broken links in the doc wiki.
198 * Smarter behavior when creating a page and a page of the same name (but
199 different location) already exists.
200 * Add an orphans plugin for finding pages that nothing links to.
201 * Removed backlinks page, which it turns out nothing used.
202 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
203 it, this will allow for adding a unit test suite.
204 * Add unit tests for several core functions, including globlist_match,
205 dirname, basename, bestlink, linkify, pagetitle, titlepage.
206 * Smart globlist merging.
207 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
208 to pave the way for adding other RCS support. This also changes the
209 setup files, where before they had svn => 1 or svn => 0, now they have
210 rcs => "svn" or rcs => "".
211 * Add a debian/NEWS file with upgrade notes.
212 * Load whatever rcs module is specified, so new ones can be just dropped in
213 as plugins and work. (Well, in theory.)
214 * Add some basic docs about writing RCS modules.
215 * Broke search capability out into a plugin, removed the --hyperestraier
217 * Added smiley plugin, nicely controlled and documented by the smileys page.
218 * Copied in some smileys from Moin Moin.
219 * Allow links of the form [[some page|page]], with whitespace in the link
221 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
222 and --disable-plugin htmlscrubber.
223 * Allow discussion links on pages to be turned off with --no-discussion.
224 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
225 * Add some new config items to the estseek.conf template, which are needed
226 by hyperestraier 1.2.3.
228 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
230 ikiwiki (1.0) unstable; urgency=low
232 * First official release.
234 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400