1 ikiwiki (1.22) UNRELEASED; urgency=low
3 * Change how the stylesheet url is determined in the templates: Remove
4 STYLEURL and add BASEURL to all templates (some already had it). This
5 new more general variable can be used to link to other things (eg, images)
6 from the template, as well as stylesheets.
7 * Fix a bug introduced last version to do with nested inlines.
8 * Allow preprocessor directives to span multiple lines, both to make
9 long ones with lots of values easier to write, and to allow for ones with
10 multi-line quoted values.
11 * Allow preprocessor directives to contain python-like triple-quoted
12 text blocks, for easy nesting of quotes inside.
13 * Add a template plugin.
14 * Use the template plugin to add infoboxes to each plugin page listing basic
15 info about the plugin.
16 * Make pagespec merge code smarter about merging duplicate pagespecs.
17 * Patch from Jordà Polo to make Setup::Standard support hashes in config
19 * Change order of linkify and preprocess; first preprocess and then linkify.
20 This allows passing a wikilink inside a parameter to a preprocessor
21 directive without it being expanded to html, and leaking out of the
22 parameter, which had required some non-obvious use of triple-quoting
23 to avoid. Note that any preprocessor plugins that output something
24 that looks like a wikilink will now have it treated as such; AFAIK
25 this doesn't change any behavior though except for the template plugin.
26 * Enable preprocessor directives when previewing an edit.
27 * Make all pages pull in a local.css style sheet, if present. This won't
28 be included in ikiwiki, but can be created to make local styling changes
29 w/o needing to merge in every new change to the distributed style.css.
30 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
31 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
32 from a different directory.
33 * Generalised preprocesser loop protection code.
35 -- Joey Hess <joeyh@debian.org> Fri, 25 Aug 2006 14:48:36 -0400
37 ikiwiki (1.21) unstable; urgency=low
39 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
40 * If a page links to itself, mark up the link text in a span with
41 class="selflink" so that it can be styled. I don't have a useful style
42 defined for that though.
43 * Call filter hooks on inlined page content.
44 * Support inlining pages raw, rather than creating a blog.
45 * Clean up yes/no parameter parsing in inline plugin.
46 * Implemented better cycle detection in the inline plugin; nested inlines
48 * Add a map plugin contributed by Alessandro Dotti Contra.
49 * Add otl format plugin, which handles files as created by vimoutliner.
50 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
51 * Add first draft at a Restructured Text (rst) plugin, by Sergio
52 Talens-Oliag. Note that this has many known issues -- see the caveats on
54 * Credit everyone who wrote a plugin on the plugins' wiki pages.
55 * Fix utf-8 in blog post form.
57 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
59 ikiwiki (1.20) unstable; urgency=low
61 * Relicense the templates and basewiki under the 2-clause BSD license.
62 Since these can easily become part of other people's websites, they
63 should be under as permissive a license as possible.
64 * Add --syslog config option, to log to the syslog.
65 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
66 transient failure to fork (which I've seen happen in the wild).
67 * Fix a bug in the aggregator introduced last version that caused all
68 aggregator state to be lost during a non-aggregating build.
70 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
72 ikiwiki (1.19) unstable; urgency=low
74 * Fix several related bugs in page type determination during online editing.
75 * Add some locking to prevent 2 aggregators from running at once.
76 * Fix an infinite loop in the aggregator when finding a unique filename.
78 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
80 ikiwiki (1.18) unstable; urgency=low
82 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
84 * Man page format fixups.
85 * If the meta plugin overides the page title, set a title_overridden
86 variable in the template to true. This allows doing things with the
87 templates conditional on the title being overriden.
88 * Add a %pagecase which maps lower-case page names to the actual case
89 used in the filename. Use this in bestlinks calculation instead of
90 forcing the link to lowercase.
91 * Also use %pagecase in various other places that want to check if a page
92 with a given name exists.
93 * This means that links to pages with mixed case names will now work,
94 even if the link is in some other case mixture, and mixed case pages
95 should be fully supported throughout ikiwiki.
96 * Recommend rebuilding wikis on upgrade to this version.
98 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
100 ikiwiki (1.17) unstable; urgency=low
102 * Disable tidy generator tag.
103 * Move tidy back to sanitize hook, found out how to only show body.
104 * Turn off tidy indentation too.
105 * Turn on HTML::Template loop_context_vars; not actually used in stock
106 templates but can be useful for things like making comma-delimited lists
107 of tags or what have you.
108 * Remove <br> from end of aggregate preprocessor directive output.
109 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
110 case-sensative filesystems like OSX.
111 * Improve markdown loading. First, try to load it as a proper perl module,
112 in case it was installed as one. Then fall back to trying
114 * Document in install page how to install markdown, since it has no
115 installation procedure in the upstream tarball.
116 * Set die_on_bad_params => 0 for all templates, to allow users to modify
117 them without annoyances.
118 * Suck in the page content when generating an inline archive page, to work
119 around the meta plugin's lack of caching of title metadata across runs.
121 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
123 ikiwiki (1.16) unstable; urgency=low
125 * Try to handle relative links in aggregated feeds. However,
126 the current support is a crude hack due to limitations of XML::Feed:
127 xml:base is not supported, neither is Content-Location. And of course,
128 relative links in RSS feeds are ill-undefined..
129 * Make aggregator save permalinks and author name to pages as metadata.
130 * Add permalink and author support to meta plugin, affecting RSS feeds
132 * Various CSS and formatting changes.
133 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
134 * Add xhtml files to the default prune regexp.
135 * Also generate rel=bookmark links for permalinks.
136 * Fix the htmltidy plugin, which wasn't working due my breaking it when
138 * Don't run tidy with -xml as that fails if the input is not well-formed.
139 Run it with -asxhtml instead, so it will output well-formed xhtml no
140 matter what the input.
141 * Disable tidy warnings too.
142 * Add a new format hook, and make tidy use it, since tidy can really only
143 operate on and output complete html documents, not the body chunks
145 * Fix dates in rss feeds if running localised, so they're still rfc 822.
147 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
149 ikiwiki (1.15) unstable; urgency=low
151 * Remove CDPATH and other env vars perl taint checking doesn't like.
153 * Added created_before and created_after PageSpec limits.
155 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
157 ikiwiki (1.14) unstable; urgency=low
159 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
161 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
162 * Added many unit tests for pagespec_match.
164 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
166 ikiwiki (1.13) unstable; urgency=low
168 * ikiwiki can now download and aggregate feeds with its new aggregate
169 plugin, so it's possible to implement a Planet using ikiwiki!
170 * Add a run_hooks function for the common task of running all hooks of a
172 * Add a savestate hook.
173 * Don't put blog post forms on pages if there's no cgiurl set.
174 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
175 --wrappers to do that.
176 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
177 to update pages that haven't changed on disk.
178 * Change meta tags to use html entity-escaped text for values, so that
179 quotes and such can be represented in title tags.
180 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
182 * Make --rebuild also cause --aggregate to re-download and write aggregated
184 * Avoid outputting duplicate meta info.
185 * Include title metadata on aggregated posts for capitalised and un-munged
187 * Title metadata of inlined pages now shows up in blogs and rss feeds.
188 * Fix issue with unicode filenames and updating the hyper estradier search
189 index. (Aka Please Please Please, let that be the last one.)
190 * Patch from Roland Mas to support an rss=no parameter to inline directives.
192 * Renamed GlobLists to PageSpecs.
193 * PageSpecs can now include nested parens, "and", and "or". This remains
194 backwards compatible to the old GlobList format. It's implemented by
195 treating the GlobList as a very limited microlanguage that is transformed
196 to perl code that does the matching.
197 * The old GlobList format is deprecated, and I encourage users to switch to
198 using the new PageSpec format. Compatability with the old format will be
199 removed at some point, possibly by 2.0.
200 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
201 * Add support for creation_month and creation_year to PageSpec.
203 * Changes to index file encoding.
205 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
207 ikiwiki (1.12) unstable; urgency=low
210 * New pagestats plugin from Enrico, which can generate a table counting
211 the backlinks for each page, or a del.icio.us style cloud.
212 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
213 the wikiformat plugin works. Thanks, Emanuele Aina.
214 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
215 display, running them through pagetitle. This removes ugly underscores and
216 other gunk from the display, much nicer. You may want to rebuild your wiki
217 when upgrading to get the cleanup globally.
218 * Polygen plugin from Enrico.
219 * htmltidy plugin from Faidon.
220 * Locale patch from Faidon:
221 - Adds a locale setting to setup files.
222 - Proper local time, if the locale configuration option is used.
223 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
224 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
226 * Add getopt hook type, this allows plugins to add new command-line options.
227 * Add --tagbase option to tag plugin.
228 * Add exclude option in setup files, works same as --exclude.
229 * Put categories in rss feeds for tagged items.
230 * Allow preprocessor directives to be expanded in inlined blog pages.
231 However, to avoid inlining loops etc, don't expand inline directives in
233 * fortune plugin (trivial)
234 * Tag plugins according to type.
236 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
238 ikiwiki (1.11) unstable; urgency=low
240 * Patch from Enrico that
241 - Adds a tag plugin that allows more easily tagging pages.
242 The meta plugin can also still be used for that, but the tag plugin
243 also lists a page's tags at the bottom of the page.
244 - Allows preprocessor directives to have parameters with no specified
246 - Fixes preprocessor directive parameter parsing so that
247 foo=bar baz now means "foo=bar" and a "baz" with no value.
248 * Run pagetemplate hooks when inlining pages so that inlined pages also
250 * Make all plugins with pagetemplate hooks check that variables exist
251 on the template before setting them, for robustness.
252 * Switch pagetemplate hooks to using named parameters.
253 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
254 This will be the page that a source page will be part of, which is
255 different than the source page for inlined pages.
256 * Audited all plugins to endure they pass (page, destpage) to htmllink
257 appropriatly. This means inlining of various plugins will not work
258 properly, with correct links generated.
260 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
262 ikiwiki (1.10) unstable; urgency=low
264 * Run page through any relevant filters when generating a page preview.
265 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
266 default throughout the wiki, not only on wikitext pages. Decided to call
267 this a feature, and split the camelcase support out into a separate plugin
268 that is independant of wikitext.
269 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
271 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
273 ikiwiki (1.9) unstable; urgency=low
275 * Improve display of parentlinks and page title of toplevel index page.
276 * Patch from Faidon to use svn --limit when possible for recentchanges,
277 speeds up recentchanges a lot for wikis with more history.
278 * Patch from Recai to fix utf8 issues in git backend.
279 * Add wikitext markup plugin, which supports ".wiki" pages written in the
280 original wiki syntax, CamelCase links and all.
281 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
282 support, to edit pages etc without a web server.
283 * Display CGI processing errors if present.
284 * Fix from Faidon for a XML parser issue that breaks utf-8 for
285 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
286 area, and also way slow.
287 * Match 'web commit from' in SVN and git, these are web commits too.
289 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
290 readable and avoid future mistakes. The patch seems to work and for the
291 first time I have a UTF-8 username ;-) (Faidon)
292 * Use form->field consistently, not form->param.
293 * Patch from Recai to allow selection of page type when creating a new page.
294 Default page type is inherited from the link clicked on to create the new
297 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
299 ikiwiki (1.8) unstable; urgency=low
301 * Fix orphans plugin to not count a link to a nonexistant page as a reason
302 for a page not being an orphan.
303 * Support pinging services such as Technorati using XML-RPC to notify them
304 about changes to rss feeds.
305 * Parse svn log as xml for improved utf8 and security. Note that this makes
306 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
307 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
308 flagged string even if the locale causes it to generate utf8 output,
309 so make sure to let perl know it should be handled as utf8. Also,
310 the optimised version used for standard time formats won't work if the
311 user has changed locale, so drop it. Thanks, Faidon Liambotis.
312 * Fix re-encoding of the comments field to utf8 if a commit fails
313 due to a conflict. Thanks, Faidon Liambotis.
314 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
316 * Add insane double encode/decode to utf8 around call to markdown.
317 This works around a truely strange bug, which is apparently a bug in
318 perl, #376329. Also added a test case for it.
319 * Improve layout of edit page so formatting help link is always visible w/o
320 getting in the way of the preview.
321 * Centralised all calls to HTML::Template and force all the templates
323 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
324 * Introduce add_plugins and disable_plugins config options in setup files.
325 This allows adding or removing plugins w/o overriding the whole list of
326 default plugins, which makes it easier to upgrade when new default plugins
328 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
329 default (of course!). Based on a patch by Faidon Liambotis.
330 * Add a html plugin, which can be used to write wikis in raw html,
331 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
332 defaults to not processing .html files, since w/o this plugin they would
333 be copied unsanitised. With this plugin, it will process and html
334 sanitise them, like any other page type.
335 * Rebuilding wrappers is necessary on upgrade to this version.
336 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
337 will be automatically done on all upgrades.
338 * Don't send pings if the wiki is being rebuilt.
339 * Work around very innefficient behavior in File::Spec::abs2rel. Result
340 is a savings of 2 pointless fork/execs per link calculation, which
341 results in ~25% speedup of ikiwiki building its own doc wiki, and
342 about 35% speedup displaying RecentChanges!
343 * Make RecentChanges use a table and some CSS, should be much more readable.
344 No code changes involved.
345 * Encode & in diffurl in examples, to conform to pedantic rules.
346 * Speed up RecentChanges by another 40% or so with some memoization.
347 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
348 in time to build the doc wiki.
350 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
352 ikiwiki (1.7) unstable; urgency=low
354 * Updated logo from Recai with some kerning and alingment tuning.
355 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
359 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
361 ikiwiki (1.6) unstable; urgency=low
363 * YA utf-8 patch from Recai, this time to fix previewing a page so that
364 the text in the input box is re-encoded back to utf-8.
365 * -CSD does not affect modules, so readfile() was not using the utf-8 input
366 layer, which led to lots of problems; make it force read files as utf-8.
368 * Note that as a consequence, this version of ikiwiki will actually try to
369 parse utf8 in source files for the first time, which may expose broken
370 utf8 in wiki sources that was hidden before. Most common will be
371 perl warnings like "utf8 "\xE9" does not map to Unicode"
372 * writefile() likewise needs to use the utf8 output layer.
373 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
375 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
376 given the readfile fix.
377 * Add utf-8 testcases for readfile and htmlize.
378 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
380 * More utf-8 fixes from Recai, partly to things I broke above:
381 - The serious problem is that writefile() saves the content in undecoded
382 format in CGI, hence all (non-ascii) chars are corrupted permanently.
383 - Comment field in edit page is not decoded and all the non-ascii chars in
384 this field are corrupted as the result. We should decode it as we do it
386 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
388 * New SVG logo from Recai.
390 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
392 ikiwiki (1.5) unstable; urgency=low
394 * Add --timeformat config option to allow changing how dates are displayed.
395 Note that as a side effect, dates will now be displayed using the local
396 timezone, not as GMT.
397 * More security review.
398 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
399 for some handy stuff like:
400 - Using links as a kind of tag; creating blog pages that list all pages
401 containing a given tag/link or not containing some other tag.
402 - Subscribing to mail notifications whenever a change is made to a page
403 that is a backlink of page foo. Ie, "Please notify me of changes in all
404 pages that link to my home page in the wiki"
405 - Locking any pages that are linked to from a particular page, so that
406 lists of locks can be exposed in the wiki.
407 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
408 when a todo item is done, instead of the previous moving it to a different
410 * Allow pagetemplate plugins to override *anything* in the template.
411 * Add a meta plugin, which allows specifying various metadata about pages,
412 like license and author. It also allows for inserting html link and meta
413 tags into html, overriding the title, and adding hidden WikiLinks, which
414 can be useful when using link-based globbing for page categorisation.
415 * Remove preprocessor directives from inlined pages.
416 * Allow simple preprocessor directive values to be specified w/o quotes.
417 * Add support for using git instead of subversion as the RCS backend,
418 tremendous thanks to Recai Oktaş for this.
419 * Doc updates for git.
420 * Fix absolute url munging in rss generation to support https, ftp, etc urls
422 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
423 utf-8 for edit and other fields, and for recentchanges. There may still
424 be utf-8 issues with the preferences page though.
426 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
428 ikiwiki (1.4) unstable; urgency=low
430 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
431 very strange way of enabling proper XHTML <br /> type tags. Output html
432 should be always valid again now.
433 * The page name and parent links has switched from using a <h1> to a styled
434 <span>, so pages can use <h1> internally instead of needing to use <h2>.
435 * Updated all of ikiwiki's own wiki pages for that.
436 * Add pagetemplate hook, which can be used by plugins that want to mess
437 around with adding new stuff to the page template.
438 * Remove headercontent; the search plugin now adds the search box to the
439 header by registering a pagetemplate hook, and other plugins should do
441 * Rebuilding on upgrade to this version is recommended.
442 * Add a html validity check to the test suite, using the wdg-html-validator,
444 * Make the html valid when there is nothing in the actions list.
445 * Reordered some function call parameters for consistency.
446 * Enable full utf-8 support for page input and output.
447 * Add a workaround for markdown, which does not work well with utf-8
449 * --getctime had bitrotted (well I only ever used it the once so far..),
450 fix and make it a bit more flexible
451 * rcs_getctime is changed, now rather than needing to loop over all pages,
452 it should just use the rcs to get the ctime of the passed file.
453 * When inlining a page in another one, links from the inlined page are now
454 expanded the same as they are when rendering the inlined page as a
455 standalone page. So rather than being expanded from the POV of the
456 inlining page, they are expanded from the POV of the inlined page.
458 For example, a link from blog/foo to "bar" will now link to blog/bar
459 if it exists. Previously this needed to be a link explicitly to
460 "blog/bar"; such links will also continue to work.
462 (This was slightly complex to do as the link still has to be constructed
463 relative to the inlining page.)
464 * Make page edit textarea resize to fit browser window.
465 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
466 do not need a full rebuild, in order to update any basewiki pages.
468 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
470 ikiwiki (1.3) unstable; urgency=low
472 * Fix the preinst introduced in the last version. Closes: #367458
474 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
476 ikiwiki (1.2) unstable; urgency=low
478 * Remove dups from the brokenlinks list.
479 * Add libc6-dev to dependencies, needed to build wrappers.
480 * Install wikilist in correct location. Closes: #367371
482 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
484 ikiwiki (1.1) unstable; urgency=low
486 * Rename inlinepage to depends, so that it can be used to refer to more
487 dependency relationships than just inlining. This will require a rebuild
488 on upgrade to this version.
489 * Move the rss link, put it in the blogpost form if there is one and at the
490 top if not. This is both nicer because easier to find, and it cleans up
491 the code which had used inlinepage as a flag for adding the link later.
492 * Allow the depends GlobList to be built up from multiple sources (such as
493 plugins) during a page render.
494 * Which means that more than one blog is now supported to appear on a
495 single page. (With some limitations, like only the last one getting an
497 * Added a plugin system.
498 * Added a pagecount plugin, enabled by default.
499 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
500 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
501 backlinks when the backlinks hadn't really changed.
502 * Moved inline page support, rss generation etc into the inline plugin,
504 * Added brokenlinks plugin, not enabled by default, but rather handy.
505 * Fix several broken links in the doc wiki.
506 * Smarter behavior when creating a page and a page of the same name (but
507 different location) already exists.
508 * Add an orphans plugin for finding pages that nothing links to.
509 * Removed backlinks page, which it turns out nothing used.
510 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
511 it, this will allow for adding a unit test suite.
512 * Add unit tests for several core functions, including globlist_match,
513 dirname, basename, bestlink, linkify, pagetitle, titlepage.
514 * Smart globlist merging.
515 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
516 to pave the way for adding other RCS support. This also changes the
517 setup files, where before they had svn => 1 or svn => 0, now they have
518 rcs => "svn" or rcs => "".
519 * Add a debian/NEWS file with upgrade notes.
520 * Load whatever rcs module is specified, so new ones can be just dropped in
521 as plugins and work. (Well, in theory.)
522 * Add some basic docs about writing RCS modules.
523 * Broke search capability out into a plugin, removed the --hyperestraier
525 * Added smiley plugin, nicely controlled and documented by the smileys page.
526 * Copied in some smileys from Moin Moin.
527 * Allow links of the form [[some page|page]], with whitespace in the link
529 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
530 and --disable-plugin htmlscrubber.
531 * Allow discussion links on pages to be turned off with --no-discussion.
532 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
533 * Add some new config items to the estseek.conf template, which are needed
534 by hyperestraier 1.2.3.
536 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
538 ikiwiki (1.0) unstable; urgency=low
540 * First official release.
542 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400