1 ikiwiki (1.17) UNRELEASED; urgency=low
3 * Disable tidy generator tag.
4 * Move tidy back to sanitize hook, found out how to only show body.
5 * Turn off tidy indentation too.
6 * Turn on HTML::Template loop_context_vars; not actually used in stock
7 templates but can be useful for things like making comma-delimited lists
8 of tags or what have you.
9 * Remove <br> from end of aggregate preprocessor directive output.
10 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
11 case-sensative filesystems like OSX.
12 * Improve markdown loading. First, try to load it as a proper perl module,
13 in case it was installed as one. Then fall back to trying
15 * Document in install page how to install markdown, since it has no
16 installation procedure in the upstream tarball.
18 -- Joey Hess <joeyh@debian.org> Wed, 9 Aug 2006 23:50:25 -0400
20 ikiwiki (1.16) unstable; urgency=low
22 * Try to handle relative links in aggregated feeds. However,
23 the current support is a crude hack due to limitations of XML::Feed:
24 xml:base is not supported, neither is Content-Location. And of course,
25 relative links in RSS feeds are ill-undefined..
26 * Make aggregator save permalinks and author name to pages as metadata.
27 * Add permalink and author support to meta plugin, affecting RSS feeds
29 * Various CSS and formatting changes.
30 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
31 * Add xhtml files to the default prune regexp.
32 * Also generate rel=bookmark links for permalinks.
33 * Fix the htmltidy plugin, which wasn't working due my breaking it when
35 * Don't run tidy with -xml as that fails if the input is not well-formed.
36 Run it with -asxhtml instead, so it will output well-formed xhtml no
37 matter what the input.
38 * Disable tidy warnings too.
39 * Add a new format hook, and make tidy use it, since tidy can really only
40 operate on and output complete html documents, not the body chunks
42 * Fix dates in rss feeds if running localised, so they're still rfc 822.
44 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
46 ikiwiki (1.15) unstable; urgency=low
48 * Remove CDPATH and other env vars perl taint checking doesn't like.
50 * Added created_before and created_after PageSpec limits.
52 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
54 ikiwiki (1.14) unstable; urgency=low
56 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
58 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
59 * Added many unit tests for pagespec_match.
61 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
63 ikiwiki (1.13) unstable; urgency=low
65 * ikiwiki can now download and aggregate feeds with its new aggregate
66 plugin, so it's possible to implement a Planet using ikiwiki!
67 * Add a run_hooks function for the common task of running all hooks of a
69 * Add a savestate hook.
70 * Don't put blog post forms on pages if there's no cgiurl set.
71 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
72 --wrappers to do that.
73 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
74 to update pages that haven't changed on disk.
75 * Change meta tags to use html entity-escaped text for values, so that
76 quotes and such can be represented in title tags.
77 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
79 * Make --rebuild also cause --aggregate to re-download and write aggregated
81 * Avoid outputting duplicate meta info.
82 * Include title metadata on aggregated posts for capitalised and un-munged
84 * Title metadata of inlined pages now shows up in blogs and rss feeds.
85 * Fix issue with unicode filenames and updating the hyper estradier search
86 index. (Aka Please Please Please, let that be the last one.)
87 * Patch from Roland Mas to support an rss=no parameter to inline directives.
89 * Renamed GlobLists to PageSpecs.
90 * PageSpecs can now include nested parens, "and", and "or". This remains
91 backwards compatible to the old GlobList format. It's implemented by
92 treating the GlobList as a very limited microlanguage that is transformed
93 to perl code that does the matching.
94 * The old GlobList format is deprecated, and I encourage users to switch to
95 using the new PageSpec format. Compatability with the old format will be
96 removed at some point, possibly by 2.0.
97 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
98 * Add support for creation_month and creation_year to PageSpec.
100 * Changes to index file encoding.
102 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
104 ikiwiki (1.12) unstable; urgency=low
107 * New pagestats plugin from Enrico, which can generate a table counting
108 the backlinks for each page, or a del.icio.us style cloud.
109 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
110 the wikiformat plugin works. Thanks, Emanuele Aina.
111 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
112 display, running them through pagetitle. This removes ugly underscores and
113 other gunk from the display, much nicer. You may want to rebuild your wiki
114 when upgrading to get the cleanup globally.
115 * Polygen plugin from Enrico.
116 * htmltidy plugin from Faidon.
117 * Locale patch from Faidon:
118 - Adds a locale setting to setup files.
119 - Proper local time, if the locale configuration option is used.
120 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
121 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
123 * Add getopt hook type, this allows plugins to add new command-line options.
124 * Add --tagbase option to tag plugin.
125 * Add exclude option in setup files, works same as --exclude.
126 * Put categories in rss feeds for tagged items.
127 * Allow preprocessor directives to be expanded in inlined blog pages.
128 However, to avoid inlining loops etc, don't expand inline directives in
130 * fortune plugin (trivial)
131 * Tag plugins according to type.
133 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
135 ikiwiki (1.11) unstable; urgency=low
137 * Patch from Enrico that
138 - Adds a tag plugin that allows more easily tagging pages.
139 The meta plugin can also still be used for that, but the tag plugin
140 also lists a page's tags at the bottom of the page.
141 - Allows preprocessor directives to have parameters with no specified
143 - Fixes preprocessor directive parameter parsing so that
144 foo=bar baz now means "foo=bar" and a "baz" with no value.
145 * Run pagetemplate hooks when inlining pages so that inlined pages also
147 * Make all plugins with pagetemplate hooks check that variables exist
148 on the template before setting them, for robustness.
149 * Switch pagetemplate hooks to using named parameters.
150 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
151 This will be the page that a source page will be part of, which is
152 different than the source page for inlined pages.
153 * Audited all plugins to endure they pass (page, destpage) to htmllink
154 appropriatly. This means inlining of various plugins will not work
155 properly, with correct links generated.
157 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
159 ikiwiki (1.10) unstable; urgency=low
161 * Run page through any relevant filters when generating a page preview.
162 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
163 default throughout the wiki, not only on wikitext pages. Decided to call
164 this a feature, and split the camelcase support out into a separate plugin
165 that is independant of wikitext.
166 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
168 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
170 ikiwiki (1.9) unstable; urgency=low
172 * Improve display of parentlinks and page title of toplevel index page.
173 * Patch from Faidon to use svn --limit when possible for recentchanges,
174 speeds up recentchanges a lot for wikis with more history.
175 * Patch from Recai to fix utf8 issues in git backend.
176 * Add wikitext markup plugin, which supports ".wiki" pages written in the
177 original wiki syntax, CamelCase links and all.
178 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
179 support, to edit pages etc without a web server.
180 * Display CGI processing errors if present.
181 * Fix from Faidon for a XML parser issue that breaks utf-8 for
182 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
183 area, and also way slow.
184 * Match 'web commit from' in SVN and git, these are web commits too.
186 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
187 readable and avoid future mistakes. The patch seems to work and for the
188 first time I have a UTF-8 username ;-) (Faidon)
189 * Use form->field consistently, not form->param.
190 * Patch from Recai to allow selection of page type when creating a new page.
191 Default page type is inherited from the link clicked on to create the new
194 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
196 ikiwiki (1.8) unstable; urgency=low
198 * Fix orphans plugin to not count a link to a nonexistant page as a reason
199 for a page not being an orphan.
200 * Support pinging services such as Technorati using XML-RPC to notify them
201 about changes to rss feeds.
202 * Parse svn log as xml for improved utf8 and security. Note that this makes
203 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
204 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
205 flagged string even if the locale causes it to generate utf8 output,
206 so make sure to let perl know it should be handled as utf8. Also,
207 the optimised version used for standard time formats won't work if the
208 user has changed locale, so drop it. Thanks, Faidon Liambotis.
209 * Fix re-encoding of the comments field to utf8 if a commit fails
210 due to a conflict. Thanks, Faidon Liambotis.
211 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
213 * Add insane double encode/decode to utf8 around call to markdown.
214 This works around a truely strange bug, which is apparently a bug in
215 perl, #376329. Also added a test case for it.
216 * Improve layout of edit page so formatting help link is always visible w/o
217 getting in the way of the preview.
218 * Centralised all calls to HTML::Template and force all the templates
220 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
221 * Introduce add_plugins and disable_plugins config options in setup files.
222 This allows adding or removing plugins w/o overriding the whole list of
223 default plugins, which makes it easier to upgrade when new default plugins
225 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
226 default (of course!). Based on a patch by Faidon Liambotis.
227 * Add a html plugin, which can be used to write wikis in raw html,
228 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
229 defaults to not processing .html files, since w/o this plugin they would
230 be copied unsanitised. With this plugin, it will process and html
231 sanitise them, like any other page type.
232 * Rebuilding wrappers is necessary on upgrade to this version.
233 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
234 will be automatically done on all upgrades.
235 * Don't send pings if the wiki is being rebuilt.
236 * Work around very innefficient behavior in File::Spec::abs2rel. Result
237 is a savings of 2 pointless fork/execs per link calculation, which
238 results in ~25% speedup of ikiwiki building its own doc wiki, and
239 about 35% speedup displaying RecentChanges!
240 * Make RecentChanges use a table and some CSS, should be much more readable.
241 No code changes involved.
242 * Encode & in diffurl in examples, to conform to pedantic rules.
243 * Speed up RecentChanges by another 40% or so with some memoization.
244 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
245 in time to build the doc wiki.
247 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
249 ikiwiki (1.7) unstable; urgency=low
251 * Updated logo from Recai with some kerning and alingment tuning.
252 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
256 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
258 ikiwiki (1.6) unstable; urgency=low
260 * YA utf-8 patch from Recai, this time to fix previewing a page so that
261 the text in the input box is re-encoded back to utf-8.
262 * -CSD does not affect modules, so readfile() was not using the utf-8 input
263 layer, which led to lots of problems; make it force read files as utf-8.
265 * Note that as a consequence, this version of ikiwiki will actually try to
266 parse utf8 in source files for the first time, which may expose broken
267 utf8 in wiki sources that was hidden before. Most common will be
268 perl warnings like "utf8 "\xE9" does not map to Unicode"
269 * writefile() likewise needs to use the utf8 output layer.
270 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
272 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
273 given the readfile fix.
274 * Add utf-8 testcases for readfile and htmlize.
275 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
277 * More utf-8 fixes from Recai, partly to things I broke above:
278 - The serious problem is that writefile() saves the content in undecoded
279 format in CGI, hence all (non-ascii) chars are corrupted permanently.
280 - Comment field in edit page is not decoded and all the non-ascii chars in
281 this field are corrupted as the result. We should decode it as we do it
283 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
285 * New SVG logo from Recai.
287 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
289 ikiwiki (1.5) unstable; urgency=low
291 * Add --timeformat config option to allow changing how dates are displayed.
292 Note that as a side effect, dates will now be displayed using the local
293 timezone, not as GMT.
294 * More security review.
295 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
296 for some handy stuff like:
297 - Using links as a kind of tag; creating blog pages that list all pages
298 containing a given tag/link or not containing some other tag.
299 - Subscribing to mail notifications whenever a change is made to a page
300 that is a backlink of page foo. Ie, "Please notify me of changes in all
301 pages that link to my home page in the wiki"
302 - Locking any pages that are linked to from a particular page, so that
303 lists of locks can be exposed in the wiki.
304 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
305 when a todo item is done, instead of the previous moving it to a different
307 * Allow pagetemplate plugins to override *anything* in the template.
308 * Add a meta plugin, which allows specifying various metadata about pages,
309 like license and author. It also allows for inserting html link and meta
310 tags into html, overriding the title, and adding hidden WikiLinks, which
311 can be useful when using link-based globbing for page categorisation.
312 * Remove preprocessor directives from inlined pages.
313 * Allow simple preprocessor directive values to be specified w/o quotes.
314 * Add support for using git instead of subversion as the RCS backend,
315 tremendous thanks to Recai Oktaş for this.
316 * Doc updates for git.
317 * Fix absolute url munging in rss generation to support https, ftp, etc urls
319 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
320 utf-8 for edit and other fields, and for recentchanges. There may still
321 be utf-8 issues with the preferences page though.
323 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
325 ikiwiki (1.4) unstable; urgency=low
327 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
328 very strange way of enabling proper XHTML <br /> type tags. Output html
329 should be always valid again now.
330 * The page name and parent links has switched from using a <h1> to a styled
331 <span>, so pages can use <h1> internally instead of needing to use <h2>.
332 * Updated all of ikiwiki's own wiki pages for that.
333 * Add pagetemplate hook, which can be used by plugins that want to mess
334 around with adding new stuff to the page template.
335 * Remove headercontent; the search plugin now adds the search box to the
336 header by registering a pagetemplate hook, and other plugins should do
338 * Rebuilding on upgrade to this version is recommended.
339 * Add a html validity check to the test suite, using the wdg-html-validator,
341 * Make the html valid when there is nothing in the actions list.
342 * Reordered some function call parameters for consistency.
343 * Enable full utf-8 support for page input and output.
344 * Add a workaround for markdown, which does not work well with utf-8
346 * --getctime had bitrotted (well I only ever used it the once so far..),
347 fix and make it a bit more flexible
348 * rcs_getctime is changed, now rather than needing to loop over all pages,
349 it should just use the rcs to get the ctime of the passed file.
350 * When inlining a page in another one, links from the inlined page are now
351 expanded the same as they are when rendering the inlined page as a
352 standalone page. So rather than being expanded from the POV of the
353 inlining page, they are expanded from the POV of the inlined page.
355 For example, a link from blog/foo to "bar" will now link to blog/bar
356 if it exists. Previously this needed to be a link explicitly to
357 "blog/bar"; such links will also continue to work.
359 (This was slightly complex to do as the link still has to be constructed
360 relative to the inlining page.)
361 * Make page edit textarea resize to fit browser window.
362 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
363 do not need a full rebuild, in order to update any basewiki pages.
365 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
367 ikiwiki (1.3) unstable; urgency=low
369 * Fix the preinst introduced in the last version. Closes: #367458
371 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
373 ikiwiki (1.2) unstable; urgency=low
375 * Remove dups from the brokenlinks list.
376 * Add libc6-dev to dependencies, needed to build wrappers.
377 * Install wikilist in correct location. Closes: #367371
379 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
381 ikiwiki (1.1) unstable; urgency=low
383 * Rename inlinepage to depends, so that it can be used to refer to more
384 dependency relationships than just inlining. This will require a rebuild
385 on upgrade to this version.
386 * Move the rss link, put it in the blogpost form if there is one and at the
387 top if not. This is both nicer because easier to find, and it cleans up
388 the code which had used inlinepage as a flag for adding the link later.
389 * Allow the depends GlobList to be built up from multiple sources (such as
390 plugins) during a page render.
391 * Which means that more than one blog is now supported to appear on a
392 single page. (With some limitations, like only the last one getting an
394 * Added a plugin system.
395 * Added a pagecount plugin, enabled by default.
396 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
397 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
398 backlinks when the backlinks hadn't really changed.
399 * Moved inline page support, rss generation etc into the inline plugin,
401 * Added brokenlinks plugin, not enabled by default, but rather handy.
402 * Fix several broken links in the doc wiki.
403 * Smarter behavior when creating a page and a page of the same name (but
404 different location) already exists.
405 * Add an orphans plugin for finding pages that nothing links to.
406 * Removed backlinks page, which it turns out nothing used.
407 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
408 it, this will allow for adding a unit test suite.
409 * Add unit tests for several core functions, including globlist_match,
410 dirname, basename, bestlink, linkify, pagetitle, titlepage.
411 * Smart globlist merging.
412 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
413 to pave the way for adding other RCS support. This also changes the
414 setup files, where before they had svn => 1 or svn => 0, now they have
415 rcs => "svn" or rcs => "".
416 * Add a debian/NEWS file with upgrade notes.
417 * Load whatever rcs module is specified, so new ones can be just dropped in
418 as plugins and work. (Well, in theory.)
419 * Add some basic docs about writing RCS modules.
420 * Broke search capability out into a plugin, removed the --hyperestraier
422 * Added smiley plugin, nicely controlled and documented by the smileys page.
423 * Copied in some smileys from Moin Moin.
424 * Allow links of the form [[some page|page]], with whitespace in the link
426 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
427 and --disable-plugin htmlscrubber.
428 * Allow discussion links on pages to be turned off with --no-discussion.
429 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
430 * Add some new config items to the estseek.conf template, which are needed
431 by hyperestraier 1.2.3.
433 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
435 ikiwiki (1.0) unstable; urgency=low
437 * First official release.
439 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400