1 ikiwiki (1.12) UNRELEASED; urgency=low
3 * Add getopt hook type, this allows plugins to add new command-line options.
4 * Add --tagbase option to tag plugin.
6 -- Joey Hess <joeyh@debian.org> Fri, 28 Jul 2006 01:17:48 -0400
8 ikiwiki (1.11) unstable; urgency=low
10 * Patch from Enrico that
11 - Adds a tag plugin that allows more easily tagging pages.
12 The meta plugin can also still be used for that, but the tag plugin
13 also lists a page's tags at the bottom of the page.
14 - Allows preprocessor directives to have parameters with no specified
16 - Fixes preprocessor directive parameter parsing so that
17 foo=bar baz now means "foo=bar" and a "baz" with no value.
18 * Run pagetemplate hooks when inlining pages so that inlined pages also
20 * Make all plugins with pagetemplate hooks check that variables exist
21 on the template before setting them, for robustness.
22 * Switch pagetemplate hooks to using named parameters.
23 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
24 This will be the page that a source page will be part of, which is
25 different than the source page for inlined pages.
26 * Audited all plugins to endure they pass (page, destpage) to htmllink
27 appropriatly. This means inlining of various plugins will not work
28 properly, with correct links generated.
30 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
32 ikiwiki (1.10) unstable; urgency=low
34 * Run page through any relevant filters when generating a page preview.
35 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
36 default throughout the wiki, not only on wikitext pages. Decided to call
37 this a feature, and split the camelcase support out into a separate plugin
38 that is independant of wikitext.
39 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
41 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
43 ikiwiki (1.9) unstable; urgency=low
45 * Improve display of parentlinks and page title of toplevel index page.
46 * Patch from Faidon to use svn --limit when possible for recentchanges,
47 speeds up recentchanges a lot for wikis with more history.
48 * Patch from Recai to fix utf8 issues in git backend.
49 * Add wikitext markup plugin, which supports ".wiki" pages written in the
50 original wiki syntax, CamelCase links and all.
51 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
52 support, to edit pages etc without a web server.
53 * Display CGI processing errors if present.
54 * Fix from Faidon for a XML parser issue that breaks utf-8 for
55 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
56 area, and also way slow.
57 * Match 'web commit from' in SVN and git, these are web commits too.
59 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
60 readable and avoid future mistakes. The patch seems to work and for the
61 first time I have a UTF-8 username ;-) (Faidon)
62 * Use form->field consistently, not form->param.
63 * Patch from Recai to allow selection of page type when creating a new page.
64 Default page type is inherited from the link clicked on to create the new
67 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
69 ikiwiki (1.8) unstable; urgency=low
71 * Fix orphans plugin to not count a link to a nonexistant page as a reason
72 for a page not being an orphan.
73 * Support pinging services such as Technorati using XML-RPC to notify them
74 about changes to rss feeds.
75 * Parse svn log as xml for improved utf8 and security. Note that this makes
76 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
77 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
78 flagged string even if the locale causes it to generate utf8 output,
79 so make sure to let perl know it should be handled as utf8. Also,
80 the optimised version used for standard time formats won't work if the
81 user has changed locale, so drop it. Thanks, Faidon Liambotis.
82 * Fix re-encoding of the comments field to utf8 if a commit fails
83 due to a conflict. Thanks, Faidon Liambotis.
84 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
86 * Add insane double encode/decode to utf8 around call to markdown.
87 This works around a truely strange bug, which is apparently a bug in
88 perl, #376329. Also added a test case for it.
89 * Improve layout of edit page so formatting help link is always visible w/o
90 getting in the way of the preview.
91 * Centralised all calls to HTML::Template and force all the templates
93 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
94 * Introduce add_plugins and disable_plugins config options in setup files.
95 This allows adding or removing plugins w/o overriding the whole list of
96 default plugins, which makes it easier to upgrade when new default plugins
98 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
99 default (of course!). Based on a patch by Faidon Liambotis.
100 * Add a html plugin, which can be used to write wikis in raw html,
101 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
102 defaults to not processing .html files, since w/o this plugin they would
103 be copied unsanitised. With this plugin, it will process and html
104 sanitise them, like any other page type.
105 * Rebuilding wrappers is necessary on upgrade to this version.
106 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
107 will be automatically done on all upgrades.
108 * Don't send pings if the wiki is being rebuilt.
109 * Work around very innefficient behavior in File::Spec::abs2rel. Result
110 is a savings of 2 pointless fork/execs per link calculation, which
111 results in ~25% speedup of ikiwiki building its own doc wiki, and
112 about 35% speedup displaying RecentChanges!
113 * Make RecentChanges use a table and some CSS, should be much more readable.
114 No code changes involved.
115 * Encode & in diffurl in examples, to conform to pedantic rules.
116 * Speed up RecentChanges by another 40% or so with some memoization.
117 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
118 in time to build the doc wiki.
120 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
122 ikiwiki (1.7) unstable; urgency=low
124 * Updated logo from Recai with some kerning and alingment tuning.
125 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
129 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
131 ikiwiki (1.6) unstable; urgency=low
133 * YA utf-8 patch from Recai, this time to fix previewing a page so that
134 the text in the input box is re-encoded back to utf-8.
135 * -CSD does not affect modules, so readfile() was not using the utf-8 input
136 layer, which led to lots of problems; make it force read files as utf-8.
138 * Note that as a consequence, this version of ikiwiki will actually try to
139 parse utf8 in source files for the first time, which may expose broken
140 utf8 in wiki sources that was hidden before. Most common will be
141 perl warnings like "utf8 "\xE9" does not map to Unicode"
142 * writefile() likewise needs to use the utf8 output layer.
143 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
145 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
146 given the readfile fix.
147 * Add utf-8 testcases for readfile and htmlize.
148 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
150 * More utf-8 fixes from Recai, partly to things I broke above:
151 - The serious problem is that writefile() saves the content in undecoded
152 format in CGI, hence all (non-ascii) chars are corrupted permanently.
153 - Comment field in edit page is not decoded and all the non-ascii chars in
154 this field are corrupted as the result. We should decode it as we do it
156 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
158 * New SVG logo from Recai.
160 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
162 ikiwiki (1.5) unstable; urgency=low
164 * Add --timeformat config option to allow changing how dates are displayed.
165 Note that as a side effect, dates will now be displayed using the local
166 timezone, not as GMT.
167 * More security review.
168 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
169 for some handy stuff like:
170 - Using links as a kind of tag; creating blog pages that list all pages
171 containing a given tag/link or not containing some other tag.
172 - Subscribing to mail notifications whenever a change is made to a page
173 that is a backlink of page foo. Ie, "Please notify me of changes in all
174 pages that link to my home page in the wiki"
175 - Locking any pages that are linked to from a particular page, so that
176 lists of locks can be exposed in the wiki.
177 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
178 when a todo item is done, instead of the previous moving it to a different
180 * Allow pagetemplate plugins to override *anything* in the template.
181 * Add a meta plugin, which allows specifying various metadata about pages,
182 like license and author. It also allows for inserting html link and meta
183 tags into html, overriding the title, and adding hidden WikiLinks, which
184 can be useful when using link-based globbing for page categorisation.
185 * Remove preprocessor directives from inlined pages.
186 * Allow simple preprocessor directive values to be specified w/o quotes.
187 * Add support for using git instead of subversion as the RCS backend,
188 tremendous thanks to Recai Oktaş for this.
189 * Doc updates for git.
190 * Fix absolute url munging in rss generation to support https, ftp, etc urls
192 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
193 utf-8 for edit and other fields, and for recentchanges. There may still
194 be utf-8 issues with the preferences page though.
196 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
198 ikiwiki (1.4) unstable; urgency=low
200 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
201 very strange way of enabling proper XHTML <br /> type tags. Output html
202 should be always valid again now.
203 * The page name and parent links has switched from using a <h1> to a styled
204 <span>, so pages can use <h1> internally instead of needing to use <h2>.
205 * Updated all of ikiwiki's own wiki pages for that.
206 * Add pagetemplate hook, which can be used by plugins that want to mess
207 around with adding new stuff to the page template.
208 * Remove headercontent; the search plugin now adds the search box to the
209 header by registering a pagetemplate hook, and other plugins should do
211 * Rebuilding on upgrade to this version is recommended.
212 * Add a html validity check to the test suite, using the wdg-html-validator,
214 * Make the html valid when there is nothing in the actions list.
215 * Reordered some function call parameters for consistency.
216 * Enable full utf-8 support for page input and output.
217 * Add a workaround for markdown, which does not work well with utf-8
219 * --getctime had bitrotted (well I only ever used it the once so far..),
220 fix and make it a bit more flexible
221 * rcs_getctime is changed, now rather than needing to loop over all pages,
222 it should just use the rcs to get the ctime of the passed file.
223 * When inlining a page in another one, links from the inlined page are now
224 expanded the same as they are when rendering the inlined page as a
225 standalone page. So rather than being expanded from the POV of the
226 inlining page, they are expanded from the POV of the inlined page.
228 For example, a link from blog/foo to "bar" will now link to blog/bar
229 if it exists. Previously this needed to be a link explicitly to
230 "blog/bar"; such links will also continue to work.
232 (This was slightly complex to do as the link still has to be constructed
233 relative to the inlining page.)
234 * Make page edit textarea resize to fit browser window.
235 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
236 do not need a full rebuild, in order to update any basewiki pages.
238 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
240 ikiwiki (1.3) unstable; urgency=low
242 * Fix the preinst introduced in the last version. Closes: #367458
244 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
246 ikiwiki (1.2) unstable; urgency=low
248 * Remove dups from the brokenlinks list.
249 * Add libc6-dev to dependencies, needed to build wrappers.
250 * Install wikilist in correct location. Closes: #367371
252 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
254 ikiwiki (1.1) unstable; urgency=low
256 * Rename inlinepage to depends, so that it can be used to refer to more
257 dependency relationships than just inlining. This will require a rebuild
258 on upgrade to this version.
259 * Move the rss link, put it in the blogpost form if there is one and at the
260 top if not. This is both nicer because easier to find, and it cleans up
261 the code which had used inlinepage as a flag for adding the link later.
262 * Allow the depends GlobList to be built up from multiple sources (such as
263 plugins) during a page render.
264 * Which means that more than one blog is now supported to appear on a
265 single page. (With some limitations, like only the last one getting an
267 * Added a plugin system.
268 * Added a pagecount plugin, enabled by default.
269 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
270 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
271 backlinks when the backlinks hadn't really changed.
272 * Moved inline page support, rss generation etc into the inline plugin,
274 * Added brokenlinks plugin, not enabled by default, but rather handy.
275 * Fix several broken links in the doc wiki.
276 * Smarter behavior when creating a page and a page of the same name (but
277 different location) already exists.
278 * Add an orphans plugin for finding pages that nothing links to.
279 * Removed backlinks page, which it turns out nothing used.
280 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
281 it, this will allow for adding a unit test suite.
282 * Add unit tests for several core functions, including globlist_match,
283 dirname, basename, bestlink, linkify, pagetitle, titlepage.
284 * Smart globlist merging.
285 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
286 to pave the way for adding other RCS support. This also changes the
287 setup files, where before they had svn => 1 or svn => 0, now they have
288 rcs => "svn" or rcs => "".
289 * Add a debian/NEWS file with upgrade notes.
290 * Load whatever rcs module is specified, so new ones can be just dropped in
291 as plugins and work. (Well, in theory.)
292 * Add some basic docs about writing RCS modules.
293 * Broke search capability out into a plugin, removed the --hyperestraier
295 * Added smiley plugin, nicely controlled and documented by the smileys page.
296 * Copied in some smileys from Moin Moin.
297 * Allow links of the form [[some page|page]], with whitespace in the link
299 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
300 and --disable-plugin htmlscrubber.
301 * Allow discussion links on pages to be turned off with --no-discussion.
302 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
303 * Add some new config items to the estseek.conf template, which are needed
304 by hyperestraier 1.2.3.
306 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
308 ikiwiki (1.0) unstable; urgency=low
310 * First official release.
312 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400