1 ikiwiki (1.27) UNRELEASED; urgency=low
3 * Add a googlecalendar plugin. A bit special-purpose, but it shows
4 one way to to deal with user-supplied content that could cause XSS
5 issues w/o the htmlscrubber, and won't survive the scrubber.
6 * Work on firming up the plugin interface:
7 - Plugins should not need to load IkiWiki::Render to get commonly
8 used functions, so moved some functions from there to IkiWiki.
9 - Picked out the set of functions and variables that most plugins
10 use, documented them, and made IkiWiki export them by default,
11 like a proper perl module should.
12 - Use the other functions at your own risk.
13 - This is not quite complete, I still have to decide whether to
14 export some other things.
15 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16 referring to stuff now exported by the IkiWiki module.
17 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18 to declare which version of the interface your plugin needs.
19 * Anyone with a third-party ikiwiki plugin is strongly encouraged
20 to make like changes to it and avoid use of non-exported symbols from
22 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23 * Support hyperestradier version 1.4.2, which adds a new required phraseform
25 * If an inlined page has a permalink, link the page title to that.
26 * Patch from Recai to use utf8 when reading the setup file, so that
27 utf8 wikinames from there will be used properly.
28 * Patch from Recai to kill utf-8 on the wiki name when generating the
30 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31 * Fix a baseurl problem in hyperestradier search results.
32 * Add a stub local.css to avoid problems with 404's.
33 * Patch from Recai to fix a wide character warning from the search plugin
34 during setup if the wikiname contains utf8.
35 * Yet another fix for those poor case-insensative OS X users.
36 * pagetemplate hooks are now also called when generating cgi pages.
37 * Add a favicon plugin, which simply adds a link tag for an icon to each
39 * Patch from James Westby to deal with the case where you're editing a
40 new page, hit cancel, and need to be redirected to somewhere sane.
41 * Various documentation improvements by various wiki users.
42 * Support Text::Markdown from CPAN, which has a different interface from
43 the original markdown or the one in Debian.
44 * Version the libcgi-session-perl dependency, some features that need
45 the new version are used in some cases (sslcookie).
46 * Numerous tla fixes from Clint.
47 * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
48 a multi-resolution favicon.ico.
49 * README.Debian: typo Closes: #388110
50 * chomp trailing newline at the end of templates read in by the template
51 plugin, to allow use of the template preprocessor directive in
52 whitespace-sensative situations. Closes: #387073
53 * Patch from James Westby to make the location of the estseek.cgi script
55 * Add typography (SmartyPants) plugin by Recai.
56 * Add --render mode, which can be used to preview an edit at the command
57 line by test rendering a single page.
59 -- Joey Hess <joeyh@debian.org> Thu, 21 Sep 2006 17:31:25 -0400
61 ikiwiki (1.26) unstable; urgency=low
63 * Add a missing -n to tla undo call.
64 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
65 writes before consuming its whole stdin. Avoid this deadlock.
66 * Fix alt tags for outline checkboxes.
68 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
70 ikiwiki (1.25) unstable; urgency=low
72 * Add proper waitpid calls for open2ed processes throughout to avoid
73 zombies; this hit htmltidy especially badly.
74 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
75 subversion repos and fixing some other issues.
76 * Add support for tla, contributed by Clint Adams. Closes: #385936
77 * Add support for mercurial, contributed by Emanuele Aina.
78 * Include <link rel> tag for RSS feeds, used by some aggregators and
79 firefox to find the feed.
80 * Add a linkmap plugin (requires graphviz).
82 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
84 ikiwiki (1.24) unstable; urgency=low
86 * Simplify the data structure returned by rcs_recentchanges to avoid
87 each rcs plugin needing to form complex strings on its own.
88 * Fix another destpage issue in the inline directive. Closes: #385512
91 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
93 ikiwiki (1.23) unstable; urgency=low
95 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
97 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
99 ikiwiki (1.22) unstable; urgency=low
101 * Change how the stylesheet url is determined in the templates: Remove
102 STYLEURL and add BASEURL to all templates (some already had it). This
103 new more general variable can be used to link to other things (eg, images)
104 from the template, as well as stylesheets.
105 * Fix a bug introduced last version to do with nested inlines.
106 * Allow preprocessor directives to span multiple lines, both to make
107 long ones with lots of values easier to write, and to allow for ones with
108 multi-line quoted values.
109 * Allow preprocessor directives to contain python-like triple-quoted
110 text blocks, for easy nesting of quotes inside.
111 * Add a template plugin.
112 * Make pagespec merge code smarter about merging duplicate pagespecs.
113 * Patch from Jordà Polo to make Setup::Standard support hashes in config
115 * Change order of linkify and preprocess; first preprocess and then linkify.
116 This allows passing a wikilink inside a parameter to a preprocessor
117 directive without it being expanded to html, and leaking out of the
118 parameter, which had required some non-obvious use of triple-quoting
119 to avoid. Note that any preprocessor plugins that output something
120 that looks like a wikilink will now have it treated as such; AFAIK
121 this doesn't change any behavior though except for the template plugin.
122 * Enable preprocessor directives when previewing an edit.
123 * Make all pages pull in a local.css style sheet, if present. This won't
124 be included in ikiwiki, but can be created to make local styling changes
125 w/o needing to merge in every new change to the distributed style.css.
126 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
127 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
128 from a different directory.
129 * Generalised preprocesser loop protection code.
130 * Patch from James Westby to allow a description to be set for rss feeds.
131 * Patch from James Westby to add a template for the search form.
132 * Added a ddate plugin.
133 * Patch from James Westby to add a --sslcookie switch, which forces
134 cookies to only be sent over ssl connections to avoid interception.
135 * Fix preferences page on anonok wikis; still need to sign in to get
136 to the preferences page.
137 * Add toc (table of contents) plugin.
138 * Change htmlize, format, and sanitize hooks to use named parameters.
139 * Patch from James Westby to add an actions option to inline; this
140 adds Edit and Discussion links at the end of blog entries.
141 * Due to some css changes, you'll want to rebuild your wiki on upgrade
142 to this version. Will be handled automatically by the deb.
143 * Add processed date to aggregate preprocessor directive status output.
145 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
147 ikiwiki (1.21) unstable; urgency=low
149 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
150 * If a page links to itself, mark up the link text in a span with
151 class="selflink" so that it can be styled. I don't have a useful style
152 defined for that though.
153 * Call filter hooks on inlined page content.
154 * Support inlining pages raw, rather than creating a blog.
155 * Clean up yes/no parameter parsing in inline plugin.
156 * Implemented better cycle detection in the inline plugin; nested inlines
158 * Add a map plugin contributed by Alessandro Dotti Contra.
159 * Add otl format plugin, which handles files as created by vimoutliner.
160 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
161 * Add first draft at a Restructured Text (rst) plugin, by Sergio
162 Talens-Oliag. Note that this has many known issues -- see the caveats on
164 * Credit everyone who wrote a plugin on the plugins' wiki pages.
165 * Fix utf-8 in blog post form.
167 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
169 ikiwiki (1.20) unstable; urgency=low
171 * Relicense the templates and basewiki under the 2-clause BSD license.
172 Since these can easily become part of other people's websites, they
173 should be under as permissive a license as possible.
174 * Add --syslog config option, to log to the syslog.
175 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
176 transient failure to fork (which I've seen happen in the wild).
177 * Fix a bug in the aggregator introduced last version that caused all
178 aggregator state to be lost during a non-aggregating build.
180 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
182 ikiwiki (1.19) unstable; urgency=low
184 * Fix several related bugs in page type determination during online editing.
185 * Add some locking to prevent 2 aggregators from running at once.
186 * Fix an infinite loop in the aggregator when finding a unique filename.
188 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
190 ikiwiki (1.18) unstable; urgency=low
192 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
194 * Man page format fixups.
195 * If the meta plugin overides the page title, set a title_overridden
196 variable in the template to true. This allows doing things with the
197 templates conditional on the title being overriden.
198 * Add a %pagecase which maps lower-case page names to the actual case
199 used in the filename. Use this in bestlinks calculation instead of
200 forcing the link to lowercase.
201 * Also use %pagecase in various other places that want to check if a page
202 with a given name exists.
203 * This means that links to pages with mixed case names will now work,
204 even if the link is in some other case mixture, and mixed case pages
205 should be fully supported throughout ikiwiki.
206 * Recommend rebuilding wikis on upgrade to this version.
208 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
210 ikiwiki (1.17) unstable; urgency=low
212 * Disable tidy generator tag.
213 * Move tidy back to sanitize hook, found out how to only show body.
214 * Turn off tidy indentation too.
215 * Turn on HTML::Template loop_context_vars; not actually used in stock
216 templates but can be useful for things like making comma-delimited lists
217 of tags or what have you.
218 * Remove <br> from end of aggregate preprocessor directive output.
219 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
220 case-sensative filesystems like OSX.
221 * Improve markdown loading. First, try to load it as a proper perl module,
222 in case it was installed as one. Then fall back to trying
224 * Document in install page how to install markdown, since it has no
225 installation procedure in the upstream tarball.
226 * Set die_on_bad_params => 0 for all templates, to allow users to modify
227 them without annoyances.
228 * Suck in the page content when generating an inline archive page, to work
229 around the meta plugin's lack of caching of title metadata across runs.
231 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
233 ikiwiki (1.16) unstable; urgency=low
235 * Try to handle relative links in aggregated feeds. However,
236 the current support is a crude hack due to limitations of XML::Feed:
237 xml:base is not supported, neither is Content-Location. And of course,
238 relative links in RSS feeds are ill-undefined..
239 * Make aggregator save permalinks and author name to pages as metadata.
240 * Add permalink and author support to meta plugin, affecting RSS feeds
242 * Various CSS and formatting changes.
243 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
244 * Add xhtml files to the default prune regexp.
245 * Also generate rel=bookmark links for permalinks.
246 * Fix the htmltidy plugin, which wasn't working due my breaking it when
248 * Don't run tidy with -xml as that fails if the input is not well-formed.
249 Run it with -asxhtml instead, so it will output well-formed xhtml no
250 matter what the input.
251 * Disable tidy warnings too.
252 * Add a new format hook, and make tidy use it, since tidy can really only
253 operate on and output complete html documents, not the body chunks
255 * Fix dates in rss feeds if running localised, so they're still rfc 822.
257 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
259 ikiwiki (1.15) unstable; urgency=low
261 * Remove CDPATH and other env vars perl taint checking doesn't like.
263 * Added created_before and created_after PageSpec limits.
265 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
267 ikiwiki (1.14) unstable; urgency=low
269 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
271 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
272 * Added many unit tests for pagespec_match.
274 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
276 ikiwiki (1.13) unstable; urgency=low
278 * ikiwiki can now download and aggregate feeds with its new aggregate
279 plugin, so it's possible to implement a Planet using ikiwiki!
280 * Add a run_hooks function for the common task of running all hooks of a
282 * Add a savestate hook.
283 * Don't put blog post forms on pages if there's no cgiurl set.
284 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
285 --wrappers to do that.
286 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
287 to update pages that haven't changed on disk.
288 * Change meta tags to use html entity-escaped text for values, so that
289 quotes and such can be represented in title tags.
290 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
292 * Make --rebuild also cause --aggregate to re-download and write aggregated
294 * Avoid outputting duplicate meta info.
295 * Include title metadata on aggregated posts for capitalised and un-munged
297 * Title metadata of inlined pages now shows up in blogs and rss feeds.
298 * Fix issue with unicode filenames and updating the hyper estradier search
299 index. (Aka Please Please Please, let that be the last one.)
300 * Patch from Roland Mas to support an rss=no parameter to inline directives.
302 * Renamed GlobLists to PageSpecs.
303 * PageSpecs can now include nested parens, "and", and "or". This remains
304 backwards compatible to the old GlobList format. It's implemented by
305 treating the GlobList as a very limited microlanguage that is transformed
306 to perl code that does the matching.
307 * The old GlobList format is deprecated, and I encourage users to switch to
308 using the new PageSpec format. Compatability with the old format will be
309 removed at some point, possibly by 2.0.
310 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
311 * Add support for creation_month and creation_year to PageSpec.
313 * Changes to index file encoding.
315 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
317 ikiwiki (1.12) unstable; urgency=low
320 * New pagestats plugin from Enrico, which can generate a table counting
321 the backlinks for each page, or a del.icio.us style cloud.
322 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
323 the wikiformat plugin works. Thanks, Emanuele Aina.
324 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
325 display, running them through pagetitle. This removes ugly underscores and
326 other gunk from the display, much nicer. You may want to rebuild your wiki
327 when upgrading to get the cleanup globally.
328 * Polygen plugin from Enrico.
329 * htmltidy plugin from Faidon.
330 * Locale patch from Faidon:
331 - Adds a locale setting to setup files.
332 - Proper local time, if the locale configuration option is used.
333 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
334 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
336 * Add getopt hook type, this allows plugins to add new command-line options.
337 * Add --tagbase option to tag plugin.
338 * Add exclude option in setup files, works same as --exclude.
339 * Put categories in rss feeds for tagged items.
340 * Allow preprocessor directives to be expanded in inlined blog pages.
341 However, to avoid inlining loops etc, don't expand inline directives in
343 * fortune plugin (trivial)
344 * Tag plugins according to type.
346 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
348 ikiwiki (1.11) unstable; urgency=low
350 * Patch from Enrico that
351 - Adds a tag plugin that allows more easily tagging pages.
352 The meta plugin can also still be used for that, but the tag plugin
353 also lists a page's tags at the bottom of the page.
354 - Allows preprocessor directives to have parameters with no specified
356 - Fixes preprocessor directive parameter parsing so that
357 foo=bar baz now means "foo=bar" and a "baz" with no value.
358 * Run pagetemplate hooks when inlining pages so that inlined pages also
360 * Make all plugins with pagetemplate hooks check that variables exist
361 on the template before setting them, for robustness.
362 * Switch pagetemplate hooks to using named parameters.
363 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
364 This will be the page that a source page will be part of, which is
365 different than the source page for inlined pages.
366 * Audited all plugins to endure they pass (page, destpage) to htmllink
367 appropriatly. This means inlining of various plugins will not work
368 properly, with correct links generated.
370 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
372 ikiwiki (1.10) unstable; urgency=low
374 * Run page through any relevant filters when generating a page preview.
375 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
376 default throughout the wiki, not only on wikitext pages. Decided to call
377 this a feature, and split the camelcase support out into a separate plugin
378 that is independant of wikitext.
379 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
381 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
383 ikiwiki (1.9) unstable; urgency=low
385 * Improve display of parentlinks and page title of toplevel index page.
386 * Patch from Faidon to use svn --limit when possible for recentchanges,
387 speeds up recentchanges a lot for wikis with more history.
388 * Patch from Recai to fix utf8 issues in git backend.
389 * Add wikitext markup plugin, which supports ".wiki" pages written in the
390 original wiki syntax, CamelCase links and all.
391 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
392 support, to edit pages etc without a web server.
393 * Display CGI processing errors if present.
394 * Fix from Faidon for a XML parser issue that breaks utf-8 for
395 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
396 area, and also way slow.
397 * Match 'web commit from' in SVN and git, these are web commits too.
399 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
400 readable and avoid future mistakes. The patch seems to work and for the
401 first time I have a UTF-8 username ;-) (Faidon)
402 * Use form->field consistently, not form->param.
403 * Patch from Recai to allow selection of page type when creating a new page.
404 Default page type is inherited from the link clicked on to create the new
407 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
409 ikiwiki (1.8) unstable; urgency=low
411 * Fix orphans plugin to not count a link to a nonexistant page as a reason
412 for a page not being an orphan.
413 * Support pinging services such as Technorati using XML-RPC to notify them
414 about changes to rss feeds.
415 * Parse svn log as xml for improved utf8 and security. Note that this makes
416 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
417 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
418 flagged string even if the locale causes it to generate utf8 output,
419 so make sure to let perl know it should be handled as utf8. Also,
420 the optimised version used for standard time formats won't work if the
421 user has changed locale, so drop it. Thanks, Faidon Liambotis.
422 * Fix re-encoding of the comments field to utf8 if a commit fails
423 due to a conflict. Thanks, Faidon Liambotis.
424 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
426 * Add insane double encode/decode to utf8 around call to markdown.
427 This works around a truely strange bug, which is apparently a bug in
428 perl, #376329. Also added a test case for it.
429 * Improve layout of edit page so formatting help link is always visible w/o
430 getting in the way of the preview.
431 * Centralised all calls to HTML::Template and force all the templates
433 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
434 * Introduce add_plugins and disable_plugins config options in setup files.
435 This allows adding or removing plugins w/o overriding the whole list of
436 default plugins, which makes it easier to upgrade when new default plugins
438 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
439 default (of course!). Based on a patch by Faidon Liambotis.
440 * Add a html plugin, which can be used to write wikis in raw html,
441 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
442 defaults to not processing .html files, since w/o this plugin they would
443 be copied unsanitised. With this plugin, it will process and html
444 sanitise them, like any other page type.
445 * Rebuilding wrappers is necessary on upgrade to this version.
446 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
447 will be automatically done on all upgrades.
448 * Don't send pings if the wiki is being rebuilt.
449 * Work around very innefficient behavior in File::Spec::abs2rel. Result
450 is a savings of 2 pointless fork/execs per link calculation, which
451 results in ~25% speedup of ikiwiki building its own doc wiki, and
452 about 35% speedup displaying RecentChanges!
453 * Make RecentChanges use a table and some CSS, should be much more readable.
454 No code changes involved.
455 * Encode & in diffurl in examples, to conform to pedantic rules.
456 * Speed up RecentChanges by another 40% or so with some memoization.
457 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
458 in time to build the doc wiki.
460 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
462 ikiwiki (1.7) unstable; urgency=low
464 * Updated logo from Recai with some kerning and alingment tuning.
465 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
469 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
471 ikiwiki (1.6) unstable; urgency=low
473 * YA utf-8 patch from Recai, this time to fix previewing a page so that
474 the text in the input box is re-encoded back to utf-8.
475 * -CSD does not affect modules, so readfile() was not using the utf-8 input
476 layer, which led to lots of problems; make it force read files as utf-8.
478 * Note that as a consequence, this version of ikiwiki will actually try to
479 parse utf8 in source files for the first time, which may expose broken
480 utf8 in wiki sources that was hidden before. Most common will be
481 perl warnings like "utf8 "\xE9" does not map to Unicode"
482 * writefile() likewise needs to use the utf8 output layer.
483 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
485 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
486 given the readfile fix.
487 * Add utf-8 testcases for readfile and htmlize.
488 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
490 * More utf-8 fixes from Recai, partly to things I broke above:
491 - The serious problem is that writefile() saves the content in undecoded
492 format in CGI, hence all (non-ascii) chars are corrupted permanently.
493 - Comment field in edit page is not decoded and all the non-ascii chars in
494 this field are corrupted as the result. We should decode it as we do it
496 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
498 * New SVG logo from Recai.
500 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
502 ikiwiki (1.5) unstable; urgency=low
504 * Add --timeformat config option to allow changing how dates are displayed.
505 Note that as a side effect, dates will now be displayed using the local
506 timezone, not as GMT.
507 * More security review.
508 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
509 for some handy stuff like:
510 - Using links as a kind of tag; creating blog pages that list all pages
511 containing a given tag/link or not containing some other tag.
512 - Subscribing to mail notifications whenever a change is made to a page
513 that is a backlink of page foo. Ie, "Please notify me of changes in all
514 pages that link to my home page in the wiki"
515 - Locking any pages that are linked to from a particular page, so that
516 lists of locks can be exposed in the wiki.
517 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
518 when a todo item is done, instead of the previous moving it to a different
520 * Allow pagetemplate plugins to override *anything* in the template.
521 * Add a meta plugin, which allows specifying various metadata about pages,
522 like license and author. It also allows for inserting html link and meta
523 tags into html, overriding the title, and adding hidden WikiLinks, which
524 can be useful when using link-based globbing for page categorisation.
525 * Remove preprocessor directives from inlined pages.
526 * Allow simple preprocessor directive values to be specified w/o quotes.
527 * Add support for using git instead of subversion as the RCS backend,
528 tremendous thanks to Recai Oktaş for this.
529 * Doc updates for git.
530 * Fix absolute url munging in rss generation to support https, ftp, etc urls
532 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
533 utf-8 for edit and other fields, and for recentchanges. There may still
534 be utf-8 issues with the preferences page though.
536 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
538 ikiwiki (1.4) unstable; urgency=low
540 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
541 very strange way of enabling proper XHTML <br /> type tags. Output html
542 should be always valid again now.
543 * The page name and parent links has switched from using a <h1> to a styled
544 <span>, so pages can use <h1> internally instead of needing to use <h2>.
545 * Updated all of ikiwiki's own wiki pages for that.
546 * Add pagetemplate hook, which can be used by plugins that want to mess
547 around with adding new stuff to the page template.
548 * Remove headercontent; the search plugin now adds the search box to the
549 header by registering a pagetemplate hook, and other plugins should do
551 * Rebuilding on upgrade to this version is recommended.
552 * Add a html validity check to the test suite, using the wdg-html-validator,
554 * Make the html valid when there is nothing in the actions list.
555 * Reordered some function call parameters for consistency.
556 * Enable full utf-8 support for page input and output.
557 * Add a workaround for markdown, which does not work well with utf-8
559 * --getctime had bitrotted (well I only ever used it the once so far..),
560 fix and make it a bit more flexible
561 * rcs_getctime is changed, now rather than needing to loop over all pages,
562 it should just use the rcs to get the ctime of the passed file.
563 * When inlining a page in another one, links from the inlined page are now
564 expanded the same as they are when rendering the inlined page as a
565 standalone page. So rather than being expanded from the POV of the
566 inlining page, they are expanded from the POV of the inlined page.
568 For example, a link from blog/foo to "bar" will now link to blog/bar
569 if it exists. Previously this needed to be a link explicitly to
570 "blog/bar"; such links will also continue to work.
572 (This was slightly complex to do as the link still has to be constructed
573 relative to the inlining page.)
574 * Make page edit textarea resize to fit browser window.
575 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
576 do not need a full rebuild, in order to update any basewiki pages.
578 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
580 ikiwiki (1.3) unstable; urgency=low
582 * Fix the preinst introduced in the last version. Closes: #367458
584 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
586 ikiwiki (1.2) unstable; urgency=low
588 * Remove dups from the brokenlinks list.
589 * Add libc6-dev to dependencies, needed to build wrappers.
590 * Install wikilist in correct location. Closes: #367371
592 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
594 ikiwiki (1.1) unstable; urgency=low
596 * Rename inlinepage to depends, so that it can be used to refer to more
597 dependency relationships than just inlining. This will require a rebuild
598 on upgrade to this version.
599 * Move the rss link, put it in the blogpost form if there is one and at the
600 top if not. This is both nicer because easier to find, and it cleans up
601 the code which had used inlinepage as a flag for adding the link later.
602 * Allow the depends GlobList to be built up from multiple sources (such as
603 plugins) during a page render.
604 * Which means that more than one blog is now supported to appear on a
605 single page. (With some limitations, like only the last one getting an
607 * Added a plugin system.
608 * Added a pagecount plugin, enabled by default.
609 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
610 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
611 backlinks when the backlinks hadn't really changed.
612 * Moved inline page support, rss generation etc into the inline plugin,
614 * Added brokenlinks plugin, not enabled by default, but rather handy.
615 * Fix several broken links in the doc wiki.
616 * Smarter behavior when creating a page and a page of the same name (but
617 different location) already exists.
618 * Add an orphans plugin for finding pages that nothing links to.
619 * Removed backlinks page, which it turns out nothing used.
620 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
621 it, this will allow for adding a unit test suite.
622 * Add unit tests for several core functions, including globlist_match,
623 dirname, basename, bestlink, linkify, pagetitle, titlepage.
624 * Smart globlist merging.
625 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
626 to pave the way for adding other RCS support. This also changes the
627 setup files, where before they had svn => 1 or svn => 0, now they have
628 rcs => "svn" or rcs => "".
629 * Add a debian/NEWS file with upgrade notes.
630 * Load whatever rcs module is specified, so new ones can be just dropped in
631 as plugins and work. (Well, in theory.)
632 * Add some basic docs about writing RCS modules.
633 * Broke search capability out into a plugin, removed the --hyperestraier
635 * Added smiley plugin, nicely controlled and documented by the smileys page.
636 * Copied in some smileys from Moin Moin.
637 * Allow links of the form [[some page|page]], with whitespace in the link
639 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
640 and --disable-plugin htmlscrubber.
641 * Allow discussion links on pages to be turned off with --no-discussion.
642 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
643 * Add some new config items to the estseek.conf template, which are needed
644 by hyperestraier 1.2.3.
646 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
648 ikiwiki (1.0) unstable; urgency=low
650 * First official release.
652 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400