1 ikiwiki (1.10) unstable; urgency=low
3 * Run page through any relevant filters when generating a page preview.
4 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
5 default throughout the wiki, not only on wikitext pages. Decided to call
6 this a feature, and split the camelcase support out into a separate plugin
7 that is independant of wikitext.
8 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
10 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
12 ikiwiki (1.9) unstable; urgency=low
14 * Improve display of parentlinks and page title of toplevel index page.
15 * Patch from Faidon to use svn --limit when possible for recentchanges,
16 speeds up recentchanges a lot for wikis with more history.
17 * Patch from Recai to fix utf8 issues in git backend.
18 * Add wikitext markup plugin, which supports ".wiki" pages written in the
19 original wiki syntax, CamelCase links and all.
20 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
21 support, to edit pages etc without a web server.
22 * Display CGI processing errors if present.
23 * Fix from Faidon for a XML parser issue that breaks utf-8 for
24 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
25 area, and also way slow.
26 * Match 'web commit from' in SVN and git, these are web commits too.
28 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
29 readable and avoid future mistakes. The patch seems to work and for the
30 first time I have a UTF-8 username ;-) (Faidon)
31 * Use form->field consistently, not form->param.
32 * Patch from Recai to allow selection of page type when creating a new page.
33 Default page type is inherited from the link clicked on to create the new
36 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
38 ikiwiki (1.8) unstable; urgency=low
40 * Fix orphans plugin to not count a link to a nonexistant page as a reason
41 for a page not being an orphan.
42 * Support pinging services such as Technorati using XML-RPC to notify them
43 about changes to rss feeds.
44 * Parse svn log as xml for improved utf8 and security. Note that this makes
45 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
46 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
47 flagged string even if the locale causes it to generate utf8 output,
48 so make sure to let perl know it should be handled as utf8. Also,
49 the optimised version used for standard time formats won't work if the
50 user has changed locale, so drop it. Thanks, Faidon Liambotis.
51 * Fix re-encoding of the comments field to utf8 if a commit fails
52 due to a conflict. Thanks, Faidon Liambotis.
53 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
55 * Add insane double encode/decode to utf8 around call to markdown.
56 This works around a truely strange bug, which is apparently a bug in
57 perl, #376329. Also added a test case for it.
58 * Improve layout of edit page so formatting help link is always visible w/o
59 getting in the way of the preview.
60 * Centralised all calls to HTML::Template and force all the templates
62 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
63 * Introduce add_plugins and disable_plugins config options in setup files.
64 This allows adding or removing plugins w/o overriding the whole list of
65 default plugins, which makes it easier to upgrade when new default plugins
67 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
68 default (of course!). Based on a patch by Faidon Liambotis.
69 * Add a html plugin, which can be used to write wikis in raw html,
70 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
71 defaults to not processing .html files, since w/o this plugin they would
72 be copied unsanitised. With this plugin, it will process and html
73 sanitise them, like any other page type.
74 * Rebuilding wrappers is necessary on upgrade to this version.
75 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
76 will be automatically done on all upgrades.
77 * Don't send pings if the wiki is being rebuilt.
78 * Work around very innefficient behavior in File::Spec::abs2rel. Result
79 is a savings of 2 pointless fork/execs per link calculation, which
80 results in ~25% speedup of ikiwiki building its own doc wiki, and
81 about 35% speedup displaying RecentChanges!
82 * Make RecentChanges use a table and some CSS, should be much more readable.
83 No code changes involved.
84 * Encode & in diffurl in examples, to conform to pedantic rules.
85 * Speed up RecentChanges by another 40% or so with some memoization.
86 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
87 in time to build the doc wiki.
89 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
91 ikiwiki (1.7) unstable; urgency=low
93 * Updated logo from Recai with some kerning and alingment tuning.
94 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
98 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
100 ikiwiki (1.6) unstable; urgency=low
102 * YA utf-8 patch from Recai, this time to fix previewing a page so that
103 the text in the input box is re-encoded back to utf-8.
104 * -CSD does not affect modules, so readfile() was not using the utf-8 input
105 layer, which led to lots of problems; make it force read files as utf-8.
107 * Note that as a consequence, this version of ikiwiki will actually try to
108 parse utf8 in source files for the first time, which may expose broken
109 utf8 in wiki sources that was hidden before. Most common will be
110 perl warnings like "utf8 "\xE9" does not map to Unicode"
111 * writefile() likewise needs to use the utf8 output layer.
112 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
114 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
115 given the readfile fix.
116 * Add utf-8 testcases for readfile and htmlize.
117 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
119 * More utf-8 fixes from Recai, partly to things I broke above:
120 - The serious problem is that writefile() saves the content in undecoded
121 format in CGI, hence all (non-ascii) chars are corrupted permanently.
122 - Comment field in edit page is not decoded and all the non-ascii chars in
123 this field are corrupted as the result. We should decode it as we do it
125 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
127 * New SVG logo from Recai.
129 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
131 ikiwiki (1.5) unstable; urgency=low
133 * Add --timeformat config option to allow changing how dates are displayed.
134 Note that as a side effect, dates will now be displayed using the local
135 timezone, not as GMT.
136 * More security review.
137 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
138 for some handy stuff like:
139 - Using links as a kind of tag; creating blog pages that list all pages
140 containing a given tag/link or not containing some other tag.
141 - Subscribing to mail notifications whenever a change is made to a page
142 that is a backlink of page foo. Ie, "Please notify me of changes in all
143 pages that link to my home page in the wiki"
144 - Locking any pages that are linked to from a particular page, so that
145 lists of locks can be exposed in the wiki.
146 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
147 when a todo item is done, instead of the previous moving it to a different
149 * Allow pagetemplate plugins to override *anything* in the template.
150 * Add a meta plugin, which allows specifying various metadata about pages,
151 like license and author. It also allows for inserting html link and meta
152 tags into html, overriding the title, and adding hidden WikiLinks, which
153 can be useful when using link-based globbing for page categorisation.
154 * Remove preprocessor directives from inlined pages.
155 * Allow simple preprocessor directive values to be specified w/o quotes.
156 * Add support for using git instead of subversion as the RCS backend,
157 tremendous thanks to Recai Oktaş for this.
158 * Doc updates for git.
159 * Fix absolute url munging in rss generation to support https, ftp, etc urls
161 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
162 utf-8 for edit and other fields, and for recentchanges. There may still
163 be utf-8 issues with the preferences page though.
165 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
167 ikiwiki (1.4) unstable; urgency=low
169 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
170 very strange way of enabling proper XHTML <br /> type tags. Output html
171 should be always valid again now.
172 * The page name and parent links has switched from using a <h1> to a styled
173 <span>, so pages can use <h1> internally instead of needing to use <h2>.
174 * Updated all of ikiwiki's own wiki pages for that.
175 * Add pagetemplate hook, which can be used by plugins that want to mess
176 around with adding new stuff to the page template.
177 * Remove headercontent; the search plugin now adds the search box to the
178 header by registering a pagetemplate hook, and other plugins should do
180 * Rebuilding on upgrade to this version is recommended.
181 * Add a html validity check to the test suite, using the wdg-html-validator,
183 * Make the html valid when there is nothing in the actions list.
184 * Reordered some function call parameters for consistency.
185 * Enable full utf-8 support for page input and output.
186 * Add a workaround for markdown, which does not work well with utf-8
188 * --getctime had bitrotted (well I only ever used it the once so far..),
189 fix and make it a bit more flexible
190 * rcs_getctime is changed, now rather than needing to loop over all pages,
191 it should just use the rcs to get the ctime of the passed file.
192 * When inlining a page in another one, links from the inlined page are now
193 expanded the same as they are when rendering the inlined page as a
194 standalone page. So rather than being expanded from the POV of the
195 inlining page, they are expanded from the POV of the inlined page.
197 For example, a link from blog/foo to "bar" will now link to blog/bar
198 if it exists. Previously this needed to be a link explicitly to
199 "blog/bar"; such links will also continue to work.
201 (This was slightly complex to do as the link still has to be constructed
202 relative to the inlining page.)
203 * Make page edit textarea resize to fit browser window.
204 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
205 do not need a full rebuild, in order to update any basewiki pages.
207 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
209 ikiwiki (1.3) unstable; urgency=low
211 * Fix the preinst introduced in the last version. Closes: #367458
213 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
215 ikiwiki (1.2) unstable; urgency=low
217 * Remove dups from the brokenlinks list.
218 * Add libc6-dev to dependencies, needed to build wrappers.
219 * Install wikilist in correct location. Closes: #367371
221 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
223 ikiwiki (1.1) unstable; urgency=low
225 * Rename inlinepage to depends, so that it can be used to refer to more
226 dependency relationships than just inlining. This will require a rebuild
227 on upgrade to this version.
228 * Move the rss link, put it in the blogpost form if there is one and at the
229 top if not. This is both nicer because easier to find, and it cleans up
230 the code which had used inlinepage as a flag for adding the link later.
231 * Allow the depends GlobList to be built up from multiple sources (such as
232 plugins) during a page render.
233 * Which means that more than one blog is now supported to appear on a
234 single page. (With some limitations, like only the last one getting an
236 * Added a plugin system.
237 * Added a pagecount plugin, enabled by default.
238 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
239 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
240 backlinks when the backlinks hadn't really changed.
241 * Moved inline page support, rss generation etc into the inline plugin,
243 * Added brokenlinks plugin, not enabled by default, but rather handy.
244 * Fix several broken links in the doc wiki.
245 * Smarter behavior when creating a page and a page of the same name (but
246 different location) already exists.
247 * Add an orphans plugin for finding pages that nothing links to.
248 * Removed backlinks page, which it turns out nothing used.
249 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
250 it, this will allow for adding a unit test suite.
251 * Add unit tests for several core functions, including globlist_match,
252 dirname, basename, bestlink, linkify, pagetitle, titlepage.
253 * Smart globlist merging.
254 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
255 to pave the way for adding other RCS support. This also changes the
256 setup files, where before they had svn => 1 or svn => 0, now they have
257 rcs => "svn" or rcs => "".
258 * Add a debian/NEWS file with upgrade notes.
259 * Load whatever rcs module is specified, so new ones can be just dropped in
260 as plugins and work. (Well, in theory.)
261 * Add some basic docs about writing RCS modules.
262 * Broke search capability out into a plugin, removed the --hyperestraier
264 * Added smiley plugin, nicely controlled and documented by the smileys page.
265 * Copied in some smileys from Moin Moin.
266 * Allow links of the form [[some page|page]], with whitespace in the link
268 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
269 and --disable-plugin htmlscrubber.
270 * Allow discussion links on pages to be turned off with --no-discussion.
271 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
272 * Add some new config items to the estseek.conf template, which are needed
273 by hyperestraier 1.2.3.
275 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
277 ikiwiki (1.0) unstable; urgency=low
279 * First official release.
281 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400