1 ikiwiki (1.17) UNRELEASED; urgency=low
3 * Disable tidy generator tag.
4 * Move tidy back to sanitize hook, found out how to only show body.
5 * Turn off tidy indentation too.
6 * Turn on HTML::Template loop_context_vars; not actually used in stock
7 templates but can be useful for things like making comma-delimited lists
8 of tags or what have you.
9 * Remove <br> from end of aggregate preprocessor directive output.
11 -- Joey Hess <joeyh@debian.org> Sat, 5 Aug 2006 17:15:12 -0400
13 ikiwiki (1.16) unstable; urgency=low
15 * Try to handle relative links in aggregated feeds. However,
16 the current support is a crude hack due to limitations of XML::Feed:
17 xml:base is not supported, neither is Content-Location. And of course,
18 relative links in RSS feeds are ill-undefined..
19 * Make aggregator save permalinks and author name to pages as metadata.
20 * Add permalink and author support to meta plugin, affecting RSS feeds
22 * Various CSS and formatting changes.
23 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
24 * Add xhtml files to the default prune regexp.
25 * Also generate rel=bookmark links for permalinks.
26 * Fix the htmltidy plugin, which wasn't working due my breaking it when
28 * Don't run tidy with -xml as that fails if the input is not well-formed.
29 Run it with -asxhtml instead, so it will output well-formed xhtml no
30 matter what the input.
31 * Disable tidy warnings too.
32 * Add a new format hook, and make tidy use it, since tidy can really only
33 operate on and output complete html documents, not the body chunks
35 * Fix dates in rss feeds if running localised, so they're still rfc 822.
37 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
39 ikiwiki (1.15) unstable; urgency=low
41 * Remove CDPATH and other env vars perl taint checking doesn't like.
43 * Added created_before and created_after PageSpec limits.
45 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
47 ikiwiki (1.14) unstable; urgency=low
49 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
51 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
52 * Added many unit tests for pagespec_match.
54 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
56 ikiwiki (1.13) unstable; urgency=low
58 * ikiwiki can now download and aggregate feeds with its new aggregate
59 plugin, so it's possible to implement a Planet using ikiwiki!
60 * Add a run_hooks function for the common task of running all hooks of a
62 * Add a savestate hook.
63 * Don't put blog post forms on pages if there's no cgiurl set.
64 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
65 --wrappers to do that.
66 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
67 to update pages that haven't changed on disk.
68 * Change meta tags to use html entity-escaped text for values, so that
69 quotes and such can be represented in title tags.
70 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
72 * Make --rebuild also cause --aggregate to re-download and write aggregated
74 * Avoid outputting duplicate meta info.
75 * Include title metadata on aggregated posts for capitalised and un-munged
77 * Title metadata of inlined pages now shows up in blogs and rss feeds.
78 * Fix issue with unicode filenames and updating the hyper estradier search
79 index. (Aka Please Please Please, let that be the last one.)
80 * Patch from Roland Mas to support an rss=no parameter to inline directives.
82 * Renamed GlobLists to PageSpecs.
83 * PageSpecs can now include nested parens, "and", and "or". This remains
84 backwards compatible to the old GlobList format. It's implemented by
85 treating the GlobList as a very limited microlanguage that is transformed
86 to perl code that does the matching.
87 * The old GlobList format is deprecated, and I encourage users to switch to
88 using the new PageSpec format. Compatability with the old format will be
89 removed at some point, possibly by 2.0.
90 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
91 * Add support for creation_month and creation_year to PageSpec.
93 * Changes to index file encoding.
95 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
97 ikiwiki (1.12) unstable; urgency=low
100 * New pagestats plugin from Enrico, which can generate a table counting
101 the backlinks for each page, or a del.icio.us style cloud.
102 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
103 the wikiformat plugin works. Thanks, Emanuele Aina.
104 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
105 display, running them through pagetitle. This removes ugly underscores and
106 other gunk from the display, much nicer. You may want to rebuild your wiki
107 when upgrading to get the cleanup globally.
108 * Polygen plugin from Enrico.
109 * htmltidy plugin from Faidon.
110 * Locale patch from Faidon:
111 - Adds a locale setting to setup files.
112 - Proper local time, if the locale configuration option is used.
113 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
114 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
116 * Add getopt hook type, this allows plugins to add new command-line options.
117 * Add --tagbase option to tag plugin.
118 * Add exclude option in setup files, works same as --exclude.
119 * Put categories in rss feeds for tagged items.
120 * Allow preprocessor directives to be expanded in inlined blog pages.
121 However, to avoid inlining loops etc, don't expand inline directives in
123 * fortune plugin (trivial)
124 * Tag plugins according to type.
126 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
128 ikiwiki (1.11) unstable; urgency=low
130 * Patch from Enrico that
131 - Adds a tag plugin that allows more easily tagging pages.
132 The meta plugin can also still be used for that, but the tag plugin
133 also lists a page's tags at the bottom of the page.
134 - Allows preprocessor directives to have parameters with no specified
136 - Fixes preprocessor directive parameter parsing so that
137 foo=bar baz now means "foo=bar" and a "baz" with no value.
138 * Run pagetemplate hooks when inlining pages so that inlined pages also
140 * Make all plugins with pagetemplate hooks check that variables exist
141 on the template before setting them, for robustness.
142 * Switch pagetemplate hooks to using named parameters.
143 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
144 This will be the page that a source page will be part of, which is
145 different than the source page for inlined pages.
146 * Audited all plugins to endure they pass (page, destpage) to htmllink
147 appropriatly. This means inlining of various plugins will not work
148 properly, with correct links generated.
150 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
152 ikiwiki (1.10) unstable; urgency=low
154 * Run page through any relevant filters when generating a page preview.
155 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
156 default throughout the wiki, not only on wikitext pages. Decided to call
157 this a feature, and split the camelcase support out into a separate plugin
158 that is independant of wikitext.
159 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
161 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
163 ikiwiki (1.9) unstable; urgency=low
165 * Improve display of parentlinks and page title of toplevel index page.
166 * Patch from Faidon to use svn --limit when possible for recentchanges,
167 speeds up recentchanges a lot for wikis with more history.
168 * Patch from Recai to fix utf8 issues in git backend.
169 * Add wikitext markup plugin, which supports ".wiki" pages written in the
170 original wiki syntax, CamelCase links and all.
171 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
172 support, to edit pages etc without a web server.
173 * Display CGI processing errors if present.
174 * Fix from Faidon for a XML parser issue that breaks utf-8 for
175 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
176 area, and also way slow.
177 * Match 'web commit from' in SVN and git, these are web commits too.
179 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
180 readable and avoid future mistakes. The patch seems to work and for the
181 first time I have a UTF-8 username ;-) (Faidon)
182 * Use form->field consistently, not form->param.
183 * Patch from Recai to allow selection of page type when creating a new page.
184 Default page type is inherited from the link clicked on to create the new
187 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
189 ikiwiki (1.8) unstable; urgency=low
191 * Fix orphans plugin to not count a link to a nonexistant page as a reason
192 for a page not being an orphan.
193 * Support pinging services such as Technorati using XML-RPC to notify them
194 about changes to rss feeds.
195 * Parse svn log as xml for improved utf8 and security. Note that this makes
196 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
197 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
198 flagged string even if the locale causes it to generate utf8 output,
199 so make sure to let perl know it should be handled as utf8. Also,
200 the optimised version used for standard time formats won't work if the
201 user has changed locale, so drop it. Thanks, Faidon Liambotis.
202 * Fix re-encoding of the comments field to utf8 if a commit fails
203 due to a conflict. Thanks, Faidon Liambotis.
204 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
206 * Add insane double encode/decode to utf8 around call to markdown.
207 This works around a truely strange bug, which is apparently a bug in
208 perl, #376329. Also added a test case for it.
209 * Improve layout of edit page so formatting help link is always visible w/o
210 getting in the way of the preview.
211 * Centralised all calls to HTML::Template and force all the templates
213 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
214 * Introduce add_plugins and disable_plugins config options in setup files.
215 This allows adding or removing plugins w/o overriding the whole list of
216 default plugins, which makes it easier to upgrade when new default plugins
218 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
219 default (of course!). Based on a patch by Faidon Liambotis.
220 * Add a html plugin, which can be used to write wikis in raw html,
221 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
222 defaults to not processing .html files, since w/o this plugin they would
223 be copied unsanitised. With this plugin, it will process and html
224 sanitise them, like any other page type.
225 * Rebuilding wrappers is necessary on upgrade to this version.
226 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
227 will be automatically done on all upgrades.
228 * Don't send pings if the wiki is being rebuilt.
229 * Work around very innefficient behavior in File::Spec::abs2rel. Result
230 is a savings of 2 pointless fork/execs per link calculation, which
231 results in ~25% speedup of ikiwiki building its own doc wiki, and
232 about 35% speedup displaying RecentChanges!
233 * Make RecentChanges use a table and some CSS, should be much more readable.
234 No code changes involved.
235 * Encode & in diffurl in examples, to conform to pedantic rules.
236 * Speed up RecentChanges by another 40% or so with some memoization.
237 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
238 in time to build the doc wiki.
240 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
242 ikiwiki (1.7) unstable; urgency=low
244 * Updated logo from Recai with some kerning and alingment tuning.
245 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
249 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
251 ikiwiki (1.6) unstable; urgency=low
253 * YA utf-8 patch from Recai, this time to fix previewing a page so that
254 the text in the input box is re-encoded back to utf-8.
255 * -CSD does not affect modules, so readfile() was not using the utf-8 input
256 layer, which led to lots of problems; make it force read files as utf-8.
258 * Note that as a consequence, this version of ikiwiki will actually try to
259 parse utf8 in source files for the first time, which may expose broken
260 utf8 in wiki sources that was hidden before. Most common will be
261 perl warnings like "utf8 "\xE9" does not map to Unicode"
262 * writefile() likewise needs to use the utf8 output layer.
263 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
265 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
266 given the readfile fix.
267 * Add utf-8 testcases for readfile and htmlize.
268 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
270 * More utf-8 fixes from Recai, partly to things I broke above:
271 - The serious problem is that writefile() saves the content in undecoded
272 format in CGI, hence all (non-ascii) chars are corrupted permanently.
273 - Comment field in edit page is not decoded and all the non-ascii chars in
274 this field are corrupted as the result. We should decode it as we do it
276 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
278 * New SVG logo from Recai.
280 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
282 ikiwiki (1.5) unstable; urgency=low
284 * Add --timeformat config option to allow changing how dates are displayed.
285 Note that as a side effect, dates will now be displayed using the local
286 timezone, not as GMT.
287 * More security review.
288 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
289 for some handy stuff like:
290 - Using links as a kind of tag; creating blog pages that list all pages
291 containing a given tag/link or not containing some other tag.
292 - Subscribing to mail notifications whenever a change is made to a page
293 that is a backlink of page foo. Ie, "Please notify me of changes in all
294 pages that link to my home page in the wiki"
295 - Locking any pages that are linked to from a particular page, so that
296 lists of locks can be exposed in the wiki.
297 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
298 when a todo item is done, instead of the previous moving it to a different
300 * Allow pagetemplate plugins to override *anything* in the template.
301 * Add a meta plugin, which allows specifying various metadata about pages,
302 like license and author. It also allows for inserting html link and meta
303 tags into html, overriding the title, and adding hidden WikiLinks, which
304 can be useful when using link-based globbing for page categorisation.
305 * Remove preprocessor directives from inlined pages.
306 * Allow simple preprocessor directive values to be specified w/o quotes.
307 * Add support for using git instead of subversion as the RCS backend,
308 tremendous thanks to Recai Oktaş for this.
309 * Doc updates for git.
310 * Fix absolute url munging in rss generation to support https, ftp, etc urls
312 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
313 utf-8 for edit and other fields, and for recentchanges. There may still
314 be utf-8 issues with the preferences page though.
316 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
318 ikiwiki (1.4) unstable; urgency=low
320 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
321 very strange way of enabling proper XHTML <br /> type tags. Output html
322 should be always valid again now.
323 * The page name and parent links has switched from using a <h1> to a styled
324 <span>, so pages can use <h1> internally instead of needing to use <h2>.
325 * Updated all of ikiwiki's own wiki pages for that.
326 * Add pagetemplate hook, which can be used by plugins that want to mess
327 around with adding new stuff to the page template.
328 * Remove headercontent; the search plugin now adds the search box to the
329 header by registering a pagetemplate hook, and other plugins should do
331 * Rebuilding on upgrade to this version is recommended.
332 * Add a html validity check to the test suite, using the wdg-html-validator,
334 * Make the html valid when there is nothing in the actions list.
335 * Reordered some function call parameters for consistency.
336 * Enable full utf-8 support for page input and output.
337 * Add a workaround for markdown, which does not work well with utf-8
339 * --getctime had bitrotted (well I only ever used it the once so far..),
340 fix and make it a bit more flexible
341 * rcs_getctime is changed, now rather than needing to loop over all pages,
342 it should just use the rcs to get the ctime of the passed file.
343 * When inlining a page in another one, links from the inlined page are now
344 expanded the same as they are when rendering the inlined page as a
345 standalone page. So rather than being expanded from the POV of the
346 inlining page, they are expanded from the POV of the inlined page.
348 For example, a link from blog/foo to "bar" will now link to blog/bar
349 if it exists. Previously this needed to be a link explicitly to
350 "blog/bar"; such links will also continue to work.
352 (This was slightly complex to do as the link still has to be constructed
353 relative to the inlining page.)
354 * Make page edit textarea resize to fit browser window.
355 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
356 do not need a full rebuild, in order to update any basewiki pages.
358 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
360 ikiwiki (1.3) unstable; urgency=low
362 * Fix the preinst introduced in the last version. Closes: #367458
364 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
366 ikiwiki (1.2) unstable; urgency=low
368 * Remove dups from the brokenlinks list.
369 * Add libc6-dev to dependencies, needed to build wrappers.
370 * Install wikilist in correct location. Closes: #367371
372 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
374 ikiwiki (1.1) unstable; urgency=low
376 * Rename inlinepage to depends, so that it can be used to refer to more
377 dependency relationships than just inlining. This will require a rebuild
378 on upgrade to this version.
379 * Move the rss link, put it in the blogpost form if there is one and at the
380 top if not. This is both nicer because easier to find, and it cleans up
381 the code which had used inlinepage as a flag for adding the link later.
382 * Allow the depends GlobList to be built up from multiple sources (such as
383 plugins) during a page render.
384 * Which means that more than one blog is now supported to appear on a
385 single page. (With some limitations, like only the last one getting an
387 * Added a plugin system.
388 * Added a pagecount plugin, enabled by default.
389 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
390 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
391 backlinks when the backlinks hadn't really changed.
392 * Moved inline page support, rss generation etc into the inline plugin,
394 * Added brokenlinks plugin, not enabled by default, but rather handy.
395 * Fix several broken links in the doc wiki.
396 * Smarter behavior when creating a page and a page of the same name (but
397 different location) already exists.
398 * Add an orphans plugin for finding pages that nothing links to.
399 * Removed backlinks page, which it turns out nothing used.
400 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
401 it, this will allow for adding a unit test suite.
402 * Add unit tests for several core functions, including globlist_match,
403 dirname, basename, bestlink, linkify, pagetitle, titlepage.
404 * Smart globlist merging.
405 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
406 to pave the way for adding other RCS support. This also changes the
407 setup files, where before they had svn => 1 or svn => 0, now they have
408 rcs => "svn" or rcs => "".
409 * Add a debian/NEWS file with upgrade notes.
410 * Load whatever rcs module is specified, so new ones can be just dropped in
411 as plugins and work. (Well, in theory.)
412 * Add some basic docs about writing RCS modules.
413 * Broke search capability out into a plugin, removed the --hyperestraier
415 * Added smiley plugin, nicely controlled and documented by the smileys page.
416 * Copied in some smileys from Moin Moin.
417 * Allow links of the form [[some page|page]], with whitespace in the link
419 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
420 and --disable-plugin htmlscrubber.
421 * Allow discussion links on pages to be turned off with --no-discussion.
422 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
423 * Add some new config items to the estseek.conf template, which are needed
424 by hyperestraier 1.2.3.
426 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
428 ikiwiki (1.0) unstable; urgency=low
430 * First official release.
432 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400