1 ikiwiki (1.13) unstable; urgency=low
3 * ikiwiki can now download and aggregate feeds with its new aggregate
4 plugin, so it's possible to implement a Planet using ikiwiki!
5 * Add a run_hooks function for the common task of running all hooks of a
7 * Add a savestate hook.
8 * Don't put blog post forms on pages if there's no cgiurl set.
9 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
10 --wrappers to do that.
11 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
12 to update pages that haven't changed on disk.
13 * Change meta tags to use html entity-escaped text for values, so that
14 quotes and such can be represented in title tags.
15 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
17 * Make --rebuild also cause --aggregate to re-download and write aggregated
19 * Avoid outputting duplicate meta info.
20 * Include title metadata on aggregated posts for capitalised and un-munged
22 * Title metadata of inlined pages now shows up in blogs and rss feeds.
23 * Fix issue with unicode filenames and updating the hyper estradier search
24 index. (Aka Please Please Please, let that be the last one.)
25 * Patch from Roland Mas to support an rss=no parameter to inline directives.
27 * Renamed GlobLists to PageSpecs.
28 * PageSpecs can now include nested parens, "and", and "or". This remains
29 backwards compatible to the old GlobList format. It's implemented by
30 treating the GlobList as a very limited microlanguage that is transformed
31 to perl code that does the matching.
32 * The old GlobList format is deprecated, and I encourage users to switch to
33 using the new PageSpec format. Compatability with the old format will be
34 removed at some point, possibly by 2.0.
35 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
36 * Add support for creation_month and creation_year to PageSpec.
38 * Changes to index file encoding.
40 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
42 ikiwiki (1.12) unstable; urgency=low
45 * New pagestats plugin from Enrico, which can generate a table counting
46 the backlinks for each page, or a del.icio.us style cloud.
47 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
48 the wikiformat plugin works. Thanks, Emanuele Aina.
49 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
50 display, running them through pagetitle. This removes ugly underscores and
51 other gunk from the display, much nicer. You may want to rebuild your wiki
52 when upgrading to get the cleanup globally.
53 * Polygen plugin from Enrico.
54 * htmltidy plugin from Faidon.
55 * Locale patch from Faidon:
56 - Adds a locale setting to setup files.
57 - Proper local time, if the locale configuration option is used.
58 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
59 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
61 * Add getopt hook type, this allows plugins to add new command-line options.
62 * Add --tagbase option to tag plugin.
63 * Add exclude option in setup files, works same as --exclude.
64 * Put categories in rss feeds for tagged items.
65 * Allow preprocessor directives to be expanded in inlined blog pages.
66 However, to avoid inlining loops etc, don't expand inline directives in
68 * fortune plugin (trivial)
69 * Tag plugins according to type.
71 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
73 ikiwiki (1.11) unstable; urgency=low
75 * Patch from Enrico that
76 - Adds a tag plugin that allows more easily tagging pages.
77 The meta plugin can also still be used for that, but the tag plugin
78 also lists a page's tags at the bottom of the page.
79 - Allows preprocessor directives to have parameters with no specified
81 - Fixes preprocessor directive parameter parsing so that
82 foo=bar baz now means "foo=bar" and a "baz" with no value.
83 * Run pagetemplate hooks when inlining pages so that inlined pages also
85 * Make all plugins with pagetemplate hooks check that variables exist
86 on the template before setting them, for robustness.
87 * Switch pagetemplate hooks to using named parameters.
88 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
89 This will be the page that a source page will be part of, which is
90 different than the source page for inlined pages.
91 * Audited all plugins to endure they pass (page, destpage) to htmllink
92 appropriatly. This means inlining of various plugins will not work
93 properly, with correct links generated.
95 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
97 ikiwiki (1.10) unstable; urgency=low
99 * Run page through any relevant filters when generating a page preview.
100 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
101 default throughout the wiki, not only on wikitext pages. Decided to call
102 this a feature, and split the camelcase support out into a separate plugin
103 that is independant of wikitext.
104 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
106 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
108 ikiwiki (1.9) unstable; urgency=low
110 * Improve display of parentlinks and page title of toplevel index page.
111 * Patch from Faidon to use svn --limit when possible for recentchanges,
112 speeds up recentchanges a lot for wikis with more history.
113 * Patch from Recai to fix utf8 issues in git backend.
114 * Add wikitext markup plugin, which supports ".wiki" pages written in the
115 original wiki syntax, CamelCase links and all.
116 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
117 support, to edit pages etc without a web server.
118 * Display CGI processing errors if present.
119 * Fix from Faidon for a XML parser issue that breaks utf-8 for
120 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
121 area, and also way slow.
122 * Match 'web commit from' in SVN and git, these are web commits too.
124 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
125 readable and avoid future mistakes. The patch seems to work and for the
126 first time I have a UTF-8 username ;-) (Faidon)
127 * Use form->field consistently, not form->param.
128 * Patch from Recai to allow selection of page type when creating a new page.
129 Default page type is inherited from the link clicked on to create the new
132 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
134 ikiwiki (1.8) unstable; urgency=low
136 * Fix orphans plugin to not count a link to a nonexistant page as a reason
137 for a page not being an orphan.
138 * Support pinging services such as Technorati using XML-RPC to notify them
139 about changes to rss feeds.
140 * Parse svn log as xml for improved utf8 and security. Note that this makes
141 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
142 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
143 flagged string even if the locale causes it to generate utf8 output,
144 so make sure to let perl know it should be handled as utf8. Also,
145 the optimised version used for standard time formats won't work if the
146 user has changed locale, so drop it. Thanks, Faidon Liambotis.
147 * Fix re-encoding of the comments field to utf8 if a commit fails
148 due to a conflict. Thanks, Faidon Liambotis.
149 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
151 * Add insane double encode/decode to utf8 around call to markdown.
152 This works around a truely strange bug, which is apparently a bug in
153 perl, #376329. Also added a test case for it.
154 * Improve layout of edit page so formatting help link is always visible w/o
155 getting in the way of the preview.
156 * Centralised all calls to HTML::Template and force all the templates
158 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
159 * Introduce add_plugins and disable_plugins config options in setup files.
160 This allows adding or removing plugins w/o overriding the whole list of
161 default plugins, which makes it easier to upgrade when new default plugins
163 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
164 default (of course!). Based on a patch by Faidon Liambotis.
165 * Add a html plugin, which can be used to write wikis in raw html,
166 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
167 defaults to not processing .html files, since w/o this plugin they would
168 be copied unsanitised. With this plugin, it will process and html
169 sanitise them, like any other page type.
170 * Rebuilding wrappers is necessary on upgrade to this version.
171 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
172 will be automatically done on all upgrades.
173 * Don't send pings if the wiki is being rebuilt.
174 * Work around very innefficient behavior in File::Spec::abs2rel. Result
175 is a savings of 2 pointless fork/execs per link calculation, which
176 results in ~25% speedup of ikiwiki building its own doc wiki, and
177 about 35% speedup displaying RecentChanges!
178 * Make RecentChanges use a table and some CSS, should be much more readable.
179 No code changes involved.
180 * Encode & in diffurl in examples, to conform to pedantic rules.
181 * Speed up RecentChanges by another 40% or so with some memoization.
182 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
183 in time to build the doc wiki.
185 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
187 ikiwiki (1.7) unstable; urgency=low
189 * Updated logo from Recai with some kerning and alingment tuning.
190 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
194 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
196 ikiwiki (1.6) unstable; urgency=low
198 * YA utf-8 patch from Recai, this time to fix previewing a page so that
199 the text in the input box is re-encoded back to utf-8.
200 * -CSD does not affect modules, so readfile() was not using the utf-8 input
201 layer, which led to lots of problems; make it force read files as utf-8.
203 * Note that as a consequence, this version of ikiwiki will actually try to
204 parse utf8 in source files for the first time, which may expose broken
205 utf8 in wiki sources that was hidden before. Most common will be
206 perl warnings like "utf8 "\xE9" does not map to Unicode"
207 * writefile() likewise needs to use the utf8 output layer.
208 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
210 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
211 given the readfile fix.
212 * Add utf-8 testcases for readfile and htmlize.
213 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
215 * More utf-8 fixes from Recai, partly to things I broke above:
216 - The serious problem is that writefile() saves the content in undecoded
217 format in CGI, hence all (non-ascii) chars are corrupted permanently.
218 - Comment field in edit page is not decoded and all the non-ascii chars in
219 this field are corrupted as the result. We should decode it as we do it
221 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
223 * New SVG logo from Recai.
225 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
227 ikiwiki (1.5) unstable; urgency=low
229 * Add --timeformat config option to allow changing how dates are displayed.
230 Note that as a side effect, dates will now be displayed using the local
231 timezone, not as GMT.
232 * More security review.
233 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
234 for some handy stuff like:
235 - Using links as a kind of tag; creating blog pages that list all pages
236 containing a given tag/link or not containing some other tag.
237 - Subscribing to mail notifications whenever a change is made to a page
238 that is a backlink of page foo. Ie, "Please notify me of changes in all
239 pages that link to my home page in the wiki"
240 - Locking any pages that are linked to from a particular page, so that
241 lists of locks can be exposed in the wiki.
242 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
243 when a todo item is done, instead of the previous moving it to a different
245 * Allow pagetemplate plugins to override *anything* in the template.
246 * Add a meta plugin, which allows specifying various metadata about pages,
247 like license and author. It also allows for inserting html link and meta
248 tags into html, overriding the title, and adding hidden WikiLinks, which
249 can be useful when using link-based globbing for page categorisation.
250 * Remove preprocessor directives from inlined pages.
251 * Allow simple preprocessor directive values to be specified w/o quotes.
252 * Add support for using git instead of subversion as the RCS backend,
253 tremendous thanks to Recai Oktaş for this.
254 * Doc updates for git.
255 * Fix absolute url munging in rss generation to support https, ftp, etc urls
257 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
258 utf-8 for edit and other fields, and for recentchanges. There may still
259 be utf-8 issues with the preferences page though.
261 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
263 ikiwiki (1.4) unstable; urgency=low
265 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
266 very strange way of enabling proper XHTML <br /> type tags. Output html
267 should be always valid again now.
268 * The page name and parent links has switched from using a <h1> to a styled
269 <span>, so pages can use <h1> internally instead of needing to use <h2>.
270 * Updated all of ikiwiki's own wiki pages for that.
271 * Add pagetemplate hook, which can be used by plugins that want to mess
272 around with adding new stuff to the page template.
273 * Remove headercontent; the search plugin now adds the search box to the
274 header by registering a pagetemplate hook, and other plugins should do
276 * Rebuilding on upgrade to this version is recommended.
277 * Add a html validity check to the test suite, using the wdg-html-validator,
279 * Make the html valid when there is nothing in the actions list.
280 * Reordered some function call parameters for consistency.
281 * Enable full utf-8 support for page input and output.
282 * Add a workaround for markdown, which does not work well with utf-8
284 * --getctime had bitrotted (well I only ever used it the once so far..),
285 fix and make it a bit more flexible
286 * rcs_getctime is changed, now rather than needing to loop over all pages,
287 it should just use the rcs to get the ctime of the passed file.
288 * When inlining a page in another one, links from the inlined page are now
289 expanded the same as they are when rendering the inlined page as a
290 standalone page. So rather than being expanded from the POV of the
291 inlining page, they are expanded from the POV of the inlined page.
293 For example, a link from blog/foo to "bar" will now link to blog/bar
294 if it exists. Previously this needed to be a link explicitly to
295 "blog/bar"; such links will also continue to work.
297 (This was slightly complex to do as the link still has to be constructed
298 relative to the inlining page.)
299 * Make page edit textarea resize to fit browser window.
300 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
301 do not need a full rebuild, in order to update any basewiki pages.
303 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
305 ikiwiki (1.3) unstable; urgency=low
307 * Fix the preinst introduced in the last version. Closes: #367458
309 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
311 ikiwiki (1.2) unstable; urgency=low
313 * Remove dups from the brokenlinks list.
314 * Add libc6-dev to dependencies, needed to build wrappers.
315 * Install wikilist in correct location. Closes: #367371
317 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
319 ikiwiki (1.1) unstable; urgency=low
321 * Rename inlinepage to depends, so that it can be used to refer to more
322 dependency relationships than just inlining. This will require a rebuild
323 on upgrade to this version.
324 * Move the rss link, put it in the blogpost form if there is one and at the
325 top if not. This is both nicer because easier to find, and it cleans up
326 the code which had used inlinepage as a flag for adding the link later.
327 * Allow the depends GlobList to be built up from multiple sources (such as
328 plugins) during a page render.
329 * Which means that more than one blog is now supported to appear on a
330 single page. (With some limitations, like only the last one getting an
332 * Added a plugin system.
333 * Added a pagecount plugin, enabled by default.
334 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
335 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
336 backlinks when the backlinks hadn't really changed.
337 * Moved inline page support, rss generation etc into the inline plugin,
339 * Added brokenlinks plugin, not enabled by default, but rather handy.
340 * Fix several broken links in the doc wiki.
341 * Smarter behavior when creating a page and a page of the same name (but
342 different location) already exists.
343 * Add an orphans plugin for finding pages that nothing links to.
344 * Removed backlinks page, which it turns out nothing used.
345 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
346 it, this will allow for adding a unit test suite.
347 * Add unit tests for several core functions, including globlist_match,
348 dirname, basename, bestlink, linkify, pagetitle, titlepage.
349 * Smart globlist merging.
350 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
351 to pave the way for adding other RCS support. This also changes the
352 setup files, where before they had svn => 1 or svn => 0, now they have
353 rcs => "svn" or rcs => "".
354 * Add a debian/NEWS file with upgrade notes.
355 * Load whatever rcs module is specified, so new ones can be just dropped in
356 as plugins and work. (Well, in theory.)
357 * Add some basic docs about writing RCS modules.
358 * Broke search capability out into a plugin, removed the --hyperestraier
360 * Added smiley plugin, nicely controlled and documented by the smileys page.
361 * Copied in some smileys from Moin Moin.
362 * Allow links of the form [[some page|page]], with whitespace in the link
364 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
365 and --disable-plugin htmlscrubber.
366 * Allow discussion links on pages to be turned off with --no-discussion.
367 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
368 * Add some new config items to the estseek.conf template, which are needed
369 by hyperestraier 1.2.3.
371 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
373 ikiwiki (1.0) unstable; urgency=low
375 * First official release.
377 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400