1 ikiwiki (1.38) UNRELEASED; urgency=low
3 * Corrected a bum regexp in openid munging.
5 -- Joey Hess <joeyh@debian.org> Tue, 2 Jan 2007 16:30:48 -0500
7 ikiwiki (1.37) unstable; urgency=low
9 * Add mirrorlist plugin.
10 * Fixed permissions of some files that were 600 in the tarball. (Did not
12 * Avoid creating edit links when the cgi url is not known.
13 * Avoid displaying discussion links at all, if there's not a discussion
14 page, when the cgi url isn't known.
15 * Before, svn was used as the RCS by default unless configured otherwise,
16 now it defaults to using no RCS unless configured to do so, to avoid some
17 suprising behavior when using a setup file and not uncommenting any RCS
19 * Fix some bugs in the commit email sending code.
20 * Improve code that ignores files in the underlaydir if the srcdir has a
21 file building the same page. Now it will work even if the extensions of
22 the source files differ.
23 * Initial work on internationalization of the program code. po/ikiwiki.pot
24 is available for translation.
25 * Export gettext() from IkiWiki module.
26 * Don't put discussion links on discussion pages.
27 * Allow disabling of plugins included in goodstuff.
28 * Add a textile format plugin contributed by mazirian.
29 * If a userdir is configured, links to pages in it can be made without
30 specifying the path. This allows for easy signing of comments by linking
31 to your page in the userdir.
32 * Escape slashes in page titles entered in the blog post form.
33 * Munge openids of the form somehost.com/user (trial, may revert).
35 -- Joey Hess <joeyh@debian.org> Sun, 31 Dec 2006 17:31:22 -0500
37 ikiwiki (1.36) unstable; urgency=low
39 * Fix various links on the hyperestraier pages.
40 * Use POST for poll to avoid some robots.
41 * Fix sometimes broken links to Discussion pages from blog pages.
42 * Add userdir config setting.
43 * Fix man page perms in install.
44 * Fix an issue with inlining a page with a rss feed inside another
45 page with an rss feed.
46 * Turn $config{wiki_file_prune_regexps} into an array that is easier to
48 * Only exclude rss and atom files from processing if the inline plugin
49 is enabled and that feed type is enabled. Else it's just a copyable file
51 * Move rss and atom option handling code into the inline plugin.
52 * Applied a rather old patch from Recai to fix the "pruning is too strict"
53 issue. Now you can have wiki source directories inside dotdirs and the
55 * Patch from Emanuele Aina to fix modification time code in mercurual
57 * Add support for links of the form [[/foo]]
58 * Fix code to make absolute urls for rss feeds, was missing some urls.
59 * Fix double-escaping of html entities in titles etc in rss feeds
60 that occured if escaped characters were present in the page filename.
62 -- Joey Hess <joeyh@debian.org> Fri, 22 Dec 2006 15:55:05 -0500
64 ikiwiki (1.35) unstable; urgency=low
66 * Fix daemonisation code to only do daemon setup things after forking the
68 * The hack used to make the pagetemplate hook have access to the editpage
69 template won't work with CGI::FormBuilder 3.0401, so disable it for now.
70 * CGI::FormBuilder 3.0401 seems to work ok now with ikiwiki, although
71 there might still be bugs lurking..
73 -- Joey Hess <joeyh@debian.org> Fri, 1 Dec 2006 19:14:36 -0500
75 ikiwiki (1.34.2) unstable; urgency=low
77 * Allow /etc/ikiwiki/wikilist to list just the names of users, if so then
78 ~user/.ikiwiki/wikilist will be read.
79 * Fix url absolution code in inline plugin to support class and id fields in
80 links and imgs, and to support anchor urls.
81 * More build deps updates.
82 * /dev/null fortune failures
84 -- Joey Hess <joeyh@debian.org> Tue, 28 Nov 2006 12:58:47 -0500
86 ikiwiki (1.34.1) unstable; urgency=low
88 * Add libtime-duration-perl to build deps, as it's used by the svn module
89 which is now tested at build.
91 -- Joey Hess <joeyh@debian.org> Mon, 27 Nov 2006 12:26:12 -0500
93 ikiwiki (1.34) unstable; urgency=low
95 * Add an openid plugin to support logging in using OpenID.
96 * Web commits by OpenID users will record the full OpenID url for the user,
97 but in recentchanges, these urls will be converted to a simplified display
99 * Modified svn, git, tla backends to recognise such web commits.
100 * Move httpauth support to a plugin.
101 * Add openidsignup config option.
102 * Make the openid plugin support the callbacks from myopenid.com via its
106 * Add quick mode for archive page generation.
107 * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
108 many other plugins. It's an easy way to boost ikiwiki from its default,
109 basic wiki, to a full-featured wiki, without manually picking the right
110 set of plugins. New plugins will be added to goodstuff from time to
112 * Change how post signin actions are propigated through the signin process;
113 they're now stored in the session.
114 * Add optional "desc" parameter to shortcut definitions.
115 * Avoid locking the wiki at all when handling some basic cgi stuff
116 (searches, recentchanges).
117 * Add "last" parameter to hook function. Very basic ordering, and hopefully
118 nothing more spohisticated will be needed.
119 * Add formbuilder_setup and formbuilder hooks.
120 * Split out a passwordauth module, that holds all the traditional password
121 based authentication etc code. It's enabled by default, but can be disabled
122 if you want only openid or some other auth method.
123 * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
124 * Add some code to the build system that tries to determine if the
125 lib installation directory is in @INC. If it's not, munge ikiwiki
126 to hardcode the path to the lib directory. This should allow installing
127 ikiwiki in nonstandard locations, including home directories, by just
128 setting PREFIX at build time.
129 * Fix nested examples directory in deb.
130 * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
131 * Add a test suite for the svn backend.
132 * Add a test suite for the git backend, from Recai
133 * Daemonize before sending RPC pings, since that can take a while
135 * Daemonize before sending commit mails, as that can also take a long
136 time/hang if the mail server is unhappy.
137 * Factor out commit mail sending code into new function.
138 * Change rcs_commit, it is now passed the name of the user doing the commit
139 and their IP address, and needs to construct its own commit message
140 containing them, or do something more appropriate for the given RCS.
141 * Add softwaresite example.
142 * Mercurial backend improvements, including --get-ctime support. (Emanuele
144 * Git backend improvements, including bug fixes and better robustness,
147 -- Joey Hess <joeyh@debian.org> Sun, 26 Nov 2006 20:46:56 -0500
149 ikiwiki (1.33) unstable; urgency=low
151 * Fix issue with aggregate plugin updating expired pages.
152 * Avoid syntax errors in templates used by the template plugin crashing
154 * Enable utf8 file IO in aggregate plugin.
155 * Fix some issues with the new registration form.
156 * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
157 * Make sure to check for errors from every eval.
158 * Fix img plugin's handling of adding dependencies for images that do not
160 * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
161 FORM-SUBMIT unusable on customised formbuilder templates. For now,
162 hardcode the submit buttons in editpage.tmpl instead of using the
163 template variable, which is ok, since the buttons are static.
164 * Work with hyperestraier 1.4.9.
166 -- Joey Hess <joeyh@debian.org> Wed, 15 Nov 2006 18:32:26 -0500
168 ikiwiki (1.32) unstable; urgency=low
170 * Add a separate pass to find page links, and only render each page once,
171 instead of over and over. Typical speedup is ~4x. Max possible speedup:
173 * Add "scan" parameter to hook(), which is used to make the hook be called
174 during the scanning pass, as well as the render pass. The meta and tag
175 plugins need to use the new scan parameter, so will any others that modify
177 * Now that links are calculated in a separate pass, it can also
178 precalculate backlinks in one pass, which is O(N^2) instead of the
179 previous code that was O(N^3). A very nice speedup for wikis with lots
180 (thousands) of pages.
181 * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
183 * Add a default stylesheet entry for the pagecloud.
184 * Add examples page with some examples of things that can be done using
185 ikiwiki, like a weblog. The examples can be copied into a user's wiki
186 for a quick start, without needing to learn everything about how to put
188 * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
189 * Add perlmagick to build-depends so syntax check of img plugin works.
191 * Improve login/register process, the login dialog has only name and
192 password fields, which allows more web browsers to regognise it as a login
193 field, and is less confusing.
194 * Implemented expiry options for aggregate plugin.
195 * Use precalculated backlinks info when determining if files need an update
196 due to a page they link to being added/removed. Mostly significant if
197 there are lots of pages.
198 * Remove duplicate link info when saving index. In some cases it could
199 pile up rather badly. (Probably not the best way to deal with this
201 * Patch from James Westby to support podcasting, photoblogging, vidcasting,
202 or what have you, by creating enclosures for non-page items that are
205 -- Joey Hess <joeyh@debian.org> Fri, 3 Nov 2006 14:46:37 -0500
207 ikiwiki (1.31) unstable; urgency=low
209 * Patch from Pawel Tecza to cp -a the templates in the Makefile.
210 * Change the rss feed title from the wikiname to the page title, with
211 an exception for the wiki's toplevel index page, which will still use the
212 wikiname as the feed title.
213 Overriding the page title with meta title already overrode the rss feed
215 * Add an img plugin, based on Christian Mock's img plugin, but stripped
216 down to the bare essentials. Useful for handling large images on websites.
217 * Sanitize possibly problimatic characters out of the polygen grammar names,
218 just in case. Should not be exploitable anyway, since it only tries to run
219 polygen after finding the specified grammar file.
220 * Add missing dependency on the URI perl module.
221 * Add basic spam fighting tool for admins: An admin's prefs page now allows
222 editing a list of banned users.
224 -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 23:16:33 -0400
226 ikiwiki (1.30) unstable; urgency=low
228 * Add no_override parameter to hook().
229 * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
230 plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
231 can be configured using a page in wiki.
232 * Fix support for --pingurl at the command line.
233 * Fix a subtle bug in will_render that broke some builds, by only clearing
234 items from renderedfiles the first time per build.
235 * Wrap entire technortati ping operation in an eval to catch all possible
236 failure modes, after I observed a simple ->value crashing ikiwiki when
239 -- Joey Hess <joeyh@debian.org> Mon, 16 Oct 2006 15:17:38 -0400
241 ikiwiki (1.29) unstable; urgency=low
243 * Patch from Paul Tötterman to use CP in the Makefile.
244 * Patch from Alec Berryman adding a http_auth config item that allows
245 using HTTP Authentication instead of ikiwiki's built in authentication.
246 Useful for eg, large sites with their own previously existing user auth
247 setup. Closes: #384534
248 * Change %renderedfiles to store an array of files rendered from a given
249 source file, to allow tracking of extra rendered files like rss feeds.
250 * Note that plugins that accessed this variable will need to be updated!
251 The plugin interface has been increased to version 1.01 for this change.
252 As few plugins use %renderedfiles I haven't done anything else to ensure
253 compatability of old plugins.
254 * Add will_render function to the plugin interface, used to register that a
255 page renders a destination file, and do some security checks. Previously
256 but no longer rendered files will be cleaned up.
257 * Use will_render in the inline and linkmap plugins.
258 * You will need to rebuild your wiki on upgrade to this version.
259 * Atom feed support based on a patch by Clint Adams.
260 * Add feeds=no option to inline preprocessor directive to turn off all types
262 * $IkiWiki::version now holds the program version, and is accessible to
264 * Make the aggregate plugin emphasize error messages.
265 * Patch from Recai to limit recentchanges to displaying max 10 files for a
266 given changeset (to avoid large number of file changes excessively
269 -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
271 ikiwiki (1.28) unstable; urgency=low
273 * inline: Add ability to sort by page name, based on a patch from
275 * Fix a forkbomb in various calls to IPC::Open2, which has a highly
276 braindead interface. Closes: #389383
277 * Don't rm -rf ikiwiki on distclean, since a) there's no such file
278 and b) those poor Mac OSX users and their case insensative files!
279 * Don't fail syntax check if Text::Typography isn't installed.
282 -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
284 ikiwiki (1.27) unstable; urgency=low
286 * Work on firming up the plugin interface:
287 - Plugins should not need to load IkiWiki::Render to get commonly
288 used functions, so moved some functions from there to IkiWiki.
289 - Picked out the set of functions and variables that most plugins
290 use, documented them, and made IkiWiki export them by default,
291 like a proper perl module should.
292 - Use the other functions at your own risk.
293 - This is not quite complete, I still have to decide whether to
294 export some other things.
295 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
296 referring to stuff now exported by the IkiWiki module.
297 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
298 to declare which version of the interface your plugin needs.
299 * Anyone with a third-party ikiwiki plugin is strongly encouraged
300 to make like changes to it and avoid use of non-exported symbols from
302 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
303 * Support hyperestradier version 1.4.2, which adds a new required phraseform
305 * If an inlined page has a permalink, link the page title to that.
306 * Patch from Recai to use utf8 when reading the setup file, so that
307 utf8 wikinames from there will be used properly.
308 * Patch from Recai to kill utf-8 on the wiki name when generating the
310 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
311 * Fix a baseurl problem in hyperestradier search results.
312 * Add a stub local.css to avoid problems with 404's.
313 * Patch from Recai to fix a wide character warning from the search plugin
314 during setup if the wikiname contains utf8.
315 * Yet another fix for those poor case-insensative OS X users.
316 * pagetemplate hooks are now also called when generating cgi pages.
317 * Add a favicon plugin, which simply adds a link tag for an icon to each
319 * Patch from James Westby to deal with the case where you're editing a
320 new page, hit cancel, and need to be redirected to somewhere sane.
321 * Various documentation improvements by various wiki users.
322 * Support Text::Markdown from CPAN, which has a different interface from
323 the original markdown or the one in Debian.
324 * Version the libcgi-session-perl dependency, some features that need
325 the new version are used in some cases (sslcookie).
326 * Numerous tla fixes from Clint.
327 * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
328 a multi-resolution favicon.ico.
329 * README.Debian: typo Closes: #388110
330 * chomp trailing newline at the end of templates read in by the template
331 plugin, to allow use of the template preprocessor directive in
332 whitespace-sensative situations. Closes: #387073
333 * Patch from James Westby to make the location of the estseek.cgi script
335 * Add typography (SmartyPants) plugin by Recai.
336 * Add --render mode, which can be used to preview an edit at the command
337 line by test rendering a single page.
338 * Add a googlecalendar plugin. A bit special-purpose, but it shows
339 one way to to deal with user-supplied content that could cause XSS
340 issues w/o the htmlscrubber, and won't survive the scrubber.
342 -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
344 ikiwiki (1.26) unstable; urgency=low
346 * Add a missing -n to tla undo call.
347 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
348 writes before consuming its whole stdin. Avoid this deadlock.
349 * Fix alt tags for outline checkboxes.
351 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
353 ikiwiki (1.25) unstable; urgency=low
355 * Add proper waitpid calls for open2ed processes throughout to avoid
356 zombies; this hit htmltidy especially badly.
357 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
358 subversion repos and fixing some other issues.
359 * Add support for tla, contributed by Clint Adams. Closes: #385936
360 * Add support for mercurial, contributed by Emanuele Aina.
361 * Include <link rel> tag for RSS feeds, used by some aggregators and
362 firefox to find the feed.
363 * Add a linkmap plugin (requires graphviz).
365 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
367 ikiwiki (1.24) unstable; urgency=low
369 * Simplify the data structure returned by rcs_recentchanges to avoid
370 each rcs plugin needing to form complex strings on its own.
371 * Fix another destpage issue in the inline directive. Closes: #385512
374 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
376 ikiwiki (1.23) unstable; urgency=low
378 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
380 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
382 ikiwiki (1.22) unstable; urgency=low
384 * Change how the stylesheet url is determined in the templates: Remove
385 STYLEURL and add BASEURL to all templates (some already had it). This
386 new more general variable can be used to link to other things (eg, images)
387 from the template, as well as stylesheets.
388 * Fix a bug introduced last version to do with nested inlines.
389 * Allow preprocessor directives to span multiple lines, both to make
390 long ones with lots of values easier to write, and to allow for ones with
391 multi-line quoted values.
392 * Allow preprocessor directives to contain python-like triple-quoted
393 text blocks, for easy nesting of quotes inside.
394 * Add a template plugin.
395 * Make pagespec merge code smarter about merging duplicate pagespecs.
396 * Patch from Jordà Polo to make Setup::Standard support hashes in config
398 * Change order of linkify and preprocess; first preprocess and then linkify.
399 This allows passing a wikilink inside a parameter to a preprocessor
400 directive without it being expanded to html, and leaking out of the
401 parameter, which had required some non-obvious use of triple-quoting
402 to avoid. Note that any preprocessor plugins that output something
403 that looks like a wikilink will now have it treated as such; AFAIK
404 this doesn't change any behavior though except for the template plugin.
405 * Enable preprocessor directives when previewing an edit.
406 * Make all pages pull in a local.css style sheet, if present. This won't
407 be included in ikiwiki, but can be created to make local styling changes
408 w/o needing to merge in every new change to the distributed style.css.
409 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
410 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
411 from a different directory.
412 * Generalised preprocesser loop protection code.
413 * Patch from James Westby to allow a description to be set for rss feeds.
414 * Patch from James Westby to add a template for the search form.
415 * Added a ddate plugin.
416 * Patch from James Westby to add a --sslcookie switch, which forces
417 cookies to only be sent over ssl connections to avoid interception.
418 * Fix preferences page on anonok wikis; still need to sign in to get
419 to the preferences page.
420 * Add toc (table of contents) plugin.
421 * Change htmlize, format, and sanitize hooks to use named parameters.
422 * Patch from James Westby to add an actions option to inline; this
423 adds Edit and Discussion links at the end of blog entries.
424 * Due to some css changes, you'll want to rebuild your wiki on upgrade
425 to this version. Will be handled automatically by the deb.
426 * Add processed date to aggregate preprocessor directive status output.
428 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
430 ikiwiki (1.21) unstable; urgency=low
432 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
433 * If a page links to itself, mark up the link text in a span with
434 class="selflink" so that it can be styled. I don't have a useful style
435 defined for that though.
436 * Call filter hooks on inlined page content.
437 * Support inlining pages raw, rather than creating a blog.
438 * Clean up yes/no parameter parsing in inline plugin.
439 * Implemented better cycle detection in the inline plugin; nested inlines
441 * Add a map plugin contributed by Alessandro Dotti Contra.
442 * Add otl format plugin, which handles files as created by vimoutliner.
443 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
444 * Add first draft at a Restructured Text (rst) plugin, by Sergio
445 Talens-Oliag. Note that this has many known issues -- see the caveats on
447 * Credit everyone who wrote a plugin on the plugins' wiki pages.
448 * Fix utf-8 in blog post form.
450 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
452 ikiwiki (1.20) unstable; urgency=low
454 * Relicense the templates and basewiki under the 2-clause BSD license.
455 Since these can easily become part of other people's websites, they
456 should be under as permissive a license as possible.
457 * Add --syslog config option, to log to the syslog.
458 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
459 transient failure to fork (which I've seen happen in the wild).
460 * Fix a bug in the aggregator introduced last version that caused all
461 aggregator state to be lost during a non-aggregating build.
463 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
465 ikiwiki (1.19) unstable; urgency=low
467 * Fix several related bugs in page type determination during online editing.
468 * Add some locking to prevent 2 aggregators from running at once.
469 * Fix an infinite loop in the aggregator when finding a unique filename.
471 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
473 ikiwiki (1.18) unstable; urgency=low
475 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
477 * Man page format fixups.
478 * If the meta plugin overides the page title, set a title_overridden
479 variable in the template to true. This allows doing things with the
480 templates conditional on the title being overriden.
481 * Add a %pagecase which maps lower-case page names to the actual case
482 used in the filename. Use this in bestlinks calculation instead of
483 forcing the link to lowercase.
484 * Also use %pagecase in various other places that want to check if a page
485 with a given name exists.
486 * This means that links to pages with mixed case names will now work,
487 even if the link is in some other case mixture, and mixed case pages
488 should be fully supported throughout ikiwiki.
489 * Recommend rebuilding wikis on upgrade to this version.
491 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
493 ikiwiki (1.17) unstable; urgency=low
495 * Disable tidy generator tag.
496 * Move tidy back to sanitize hook, found out how to only show body.
497 * Turn off tidy indentation too.
498 * Turn on HTML::Template loop_context_vars; not actually used in stock
499 templates but can be useful for things like making comma-delimited lists
500 of tags or what have you.
501 * Remove <br> from end of aggregate preprocessor directive output.
502 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
503 case-sensative filesystems like OSX.
504 * Improve markdown loading. First, try to load it as a proper perl module,
505 in case it was installed as one. Then fall back to trying
507 * Document in install page how to install markdown, since it has no
508 installation procedure in the upstream tarball.
509 * Set die_on_bad_params => 0 for all templates, to allow users to modify
510 them without annoyances.
511 * Suck in the page content when generating an inline archive page, to work
512 around the meta plugin's lack of caching of title metadata across runs.
514 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
516 ikiwiki (1.16) unstable; urgency=low
518 * Try to handle relative links in aggregated feeds. However,
519 the current support is a crude hack due to limitations of XML::Feed:
520 xml:base is not supported, neither is Content-Location. And of course,
521 relative links in RSS feeds are ill-undefined..
522 * Make aggregator save permalinks and author name to pages as metadata.
523 * Add permalink and author support to meta plugin, affecting RSS feeds
525 * Various CSS and formatting changes.
526 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
527 * Add xhtml files to the default prune regexp.
528 * Also generate rel=bookmark links for permalinks.
529 * Fix the htmltidy plugin, which wasn't working due my breaking it when
531 * Don't run tidy with -xml as that fails if the input is not well-formed.
532 Run it with -asxhtml instead, so it will output well-formed xhtml no
533 matter what the input.
534 * Disable tidy warnings too.
535 * Add a new format hook, and make tidy use it, since tidy can really only
536 operate on and output complete html documents, not the body chunks
538 * Fix dates in rss feeds if running localised, so they're still rfc 822.
540 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
542 ikiwiki (1.15) unstable; urgency=low
544 * Remove CDPATH and other env vars perl taint checking doesn't like.
546 * Added created_before and created_after PageSpec limits.
548 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
550 ikiwiki (1.14) unstable; urgency=low
552 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
554 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
555 * Added many unit tests for pagespec_match.
557 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
559 ikiwiki (1.13) unstable; urgency=low
561 * ikiwiki can now download and aggregate feeds with its new aggregate
562 plugin, so it's possible to implement a Planet using ikiwiki!
563 * Add a run_hooks function for the common task of running all hooks of a
565 * Add a savestate hook.
566 * Don't put blog post forms on pages if there's no cgiurl set.
567 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
568 --wrappers to do that.
569 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
570 to update pages that haven't changed on disk.
571 * Change meta tags to use html entity-escaped text for values, so that
572 quotes and such can be represented in title tags.
573 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
575 * Make --rebuild also cause --aggregate to re-download and write aggregated
577 * Avoid outputting duplicate meta info.
578 * Include title metadata on aggregated posts for capitalised and un-munged
580 * Title metadata of inlined pages now shows up in blogs and rss feeds.
581 * Fix issue with unicode filenames and updating the hyper estradier search
582 index. (Aka Please Please Please, let that be the last one.)
583 * Patch from Roland Mas to support an rss=no parameter to inline directives.
585 * Renamed GlobLists to PageSpecs.
586 * PageSpecs can now include nested parens, "and", and "or". This remains
587 backwards compatible to the old GlobList format. It's implemented by
588 treating the GlobList as a very limited microlanguage that is transformed
589 to perl code that does the matching.
590 * The old GlobList format is deprecated, and I encourage users to switch to
591 using the new PageSpec format. Compatability with the old format will be
592 removed at some point, possibly by 2.0.
593 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
594 * Add support for creation_month and creation_year to PageSpec.
596 * Changes to index file encoding.
598 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
600 ikiwiki (1.12) unstable; urgency=low
603 * New pagestats plugin from Enrico, which can generate a table counting
604 the backlinks for each page, or a del.icio.us style cloud.
605 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
606 the wikiformat plugin works. Thanks, Emanuele Aina.
607 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
608 display, running them through pagetitle. This removes ugly underscores and
609 other gunk from the display, much nicer. You may want to rebuild your wiki
610 when upgrading to get the cleanup globally.
611 * Polygen plugin from Enrico.
612 * htmltidy plugin from Faidon.
613 * Locale patch from Faidon:
614 - Adds a locale setting to setup files.
615 - Proper local time, if the locale configuration option is used.
616 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
617 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
619 * Add getopt hook type, this allows plugins to add new command-line options.
620 * Add --tagbase option to tag plugin.
621 * Add exclude option in setup files, works same as --exclude.
622 * Put categories in rss feeds for tagged items.
623 * Allow preprocessor directives to be expanded in inlined blog pages.
624 However, to avoid inlining loops etc, don't expand inline directives in
626 * fortune plugin (trivial)
627 * Tag plugins according to type.
629 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
631 ikiwiki (1.11) unstable; urgency=low
633 * Patch from Enrico that
634 - Adds a tag plugin that allows more easily tagging pages.
635 The meta plugin can also still be used for that, but the tag plugin
636 also lists a page's tags at the bottom of the page.
637 - Allows preprocessor directives to have parameters with no specified
639 - Fixes preprocessor directive parameter parsing so that
640 foo=bar baz now means "foo=bar" and a "baz" with no value.
641 * Run pagetemplate hooks when inlining pages so that inlined pages also
643 * Make all plugins with pagetemplate hooks check that variables exist
644 on the template before setting them, for robustness.
645 * Switch pagetemplate hooks to using named parameters.
646 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
647 This will be the page that a source page will be part of, which is
648 different than the source page for inlined pages.
649 * Audited all plugins to endure they pass (page, destpage) to htmllink
650 appropriatly. This means inlining of various plugins will not work
651 properly, with correct links generated.
653 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
655 ikiwiki (1.10) unstable; urgency=low
657 * Run page through any relevant filters when generating a page preview.
658 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
659 default throughout the wiki, not only on wikitext pages. Decided to call
660 this a feature, and split the camelcase support out into a separate plugin
661 that is independant of wikitext.
662 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
664 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
666 ikiwiki (1.9) unstable; urgency=low
668 * Improve display of parentlinks and page title of toplevel index page.
669 * Patch from Faidon to use svn --limit when possible for recentchanges,
670 speeds up recentchanges a lot for wikis with more history.
671 * Patch from Recai to fix utf8 issues in git backend.
672 * Add wikitext markup plugin, which supports ".wiki" pages written in the
673 original wiki syntax, CamelCase links and all.
674 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
675 support, to edit pages etc without a web server.
676 * Display CGI processing errors if present.
677 * Fix from Faidon for a XML parser issue that breaks utf-8 for
678 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
679 area, and also way slow.
680 * Match 'web commit from' in SVN and git, these are web commits too.
682 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
683 readable and avoid future mistakes. The patch seems to work and for the
684 first time I have a UTF-8 username ;-) (Faidon)
685 * Use form->field consistently, not form->param.
686 * Patch from Recai to allow selection of page type when creating a new page.
687 Default page type is inherited from the link clicked on to create the new
690 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
692 ikiwiki (1.8) unstable; urgency=low
694 * Fix orphans plugin to not count a link to a nonexistant page as a reason
695 for a page not being an orphan.
696 * Support pinging services such as Technorati using XML-RPC to notify them
697 about changes to rss feeds.
698 * Parse svn log as xml for improved utf8 and security. Note that this makes
699 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
700 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
701 flagged string even if the locale causes it to generate utf8 output,
702 so make sure to let perl know it should be handled as utf8. Also,
703 the optimised version used for standard time formats won't work if the
704 user has changed locale, so drop it. Thanks, Faidon Liambotis.
705 * Fix re-encoding of the comments field to utf8 if a commit fails
706 due to a conflict. Thanks, Faidon Liambotis.
707 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
709 * Add insane double encode/decode to utf8 around call to markdown.
710 This works around a truely strange bug, which is apparently a bug in
711 perl, #376329. Also added a test case for it.
712 * Improve layout of edit page so formatting help link is always visible w/o
713 getting in the way of the preview.
714 * Centralised all calls to HTML::Template and force all the templates
716 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
717 * Introduce add_plugins and disable_plugins config options in setup files.
718 This allows adding or removing plugins w/o overriding the whole list of
719 default plugins, which makes it easier to upgrade when new default plugins
721 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
722 default (of course!). Based on a patch by Faidon Liambotis.
723 * Add a html plugin, which can be used to write wikis in raw html,
724 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
725 defaults to not processing .html files, since w/o this plugin they would
726 be copied unsanitised. With this plugin, it will process and html
727 sanitise them, like any other page type.
728 * Rebuilding wrappers is necessary on upgrade to this version.
729 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
730 will be automatically done on all upgrades.
731 * Don't send pings if the wiki is being rebuilt.
732 * Work around very innefficient behavior in File::Spec::abs2rel. Result
733 is a savings of 2 pointless fork/execs per link calculation, which
734 results in ~25% speedup of ikiwiki building its own doc wiki, and
735 about 35% speedup displaying RecentChanges!
736 * Make RecentChanges use a table and some CSS, should be much more readable.
737 No code changes involved.
738 * Encode & in diffurl in examples, to conform to pedantic rules.
739 * Speed up RecentChanges by another 40% or so with some memoization.
740 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
741 in time to build the doc wiki.
743 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
745 ikiwiki (1.7) unstable; urgency=low
747 * Updated logo from Recai with some kerning and alingment tuning.
748 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
752 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
754 ikiwiki (1.6) unstable; urgency=low
756 * YA utf-8 patch from Recai, this time to fix previewing a page so that
757 the text in the input box is re-encoded back to utf-8.
758 * -CSD does not affect modules, so readfile() was not using the utf-8 input
759 layer, which led to lots of problems; make it force read files as utf-8.
761 * Note that as a consequence, this version of ikiwiki will actually try to
762 parse utf8 in source files for the first time, which may expose broken
763 utf8 in wiki sources that was hidden before. Most common will be
764 perl warnings like "utf8 "\xE9" does not map to Unicode"
765 * writefile() likewise needs to use the utf8 output layer.
766 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
768 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
769 given the readfile fix.
770 * Add utf-8 testcases for readfile and htmlize.
771 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
773 * More utf-8 fixes from Recai, partly to things I broke above:
774 - The serious problem is that writefile() saves the content in undecoded
775 format in CGI, hence all (non-ascii) chars are corrupted permanently.
776 - Comment field in edit page is not decoded and all the non-ascii chars in
777 this field are corrupted as the result. We should decode it as we do it
779 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
781 * New SVG logo from Recai.
783 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
785 ikiwiki (1.5) unstable; urgency=low
787 * Add --timeformat config option to allow changing how dates are displayed.
788 Note that as a side effect, dates will now be displayed using the local
789 timezone, not as GMT.
790 * More security review.
791 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
792 for some handy stuff like:
793 - Using links as a kind of tag; creating blog pages that list all pages
794 containing a given tag/link or not containing some other tag.
795 - Subscribing to mail notifications whenever a change is made to a page
796 that is a backlink of page foo. Ie, "Please notify me of changes in all
797 pages that link to my home page in the wiki"
798 - Locking any pages that are linked to from a particular page, so that
799 lists of locks can be exposed in the wiki.
800 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
801 when a todo item is done, instead of the previous moving it to a different
803 * Allow pagetemplate plugins to override *anything* in the template.
804 * Add a meta plugin, which allows specifying various metadata about pages,
805 like license and author. It also allows for inserting html link and meta
806 tags into html, overriding the title, and adding hidden WikiLinks, which
807 can be useful when using link-based globbing for page categorisation.
808 * Remove preprocessor directives from inlined pages.
809 * Allow simple preprocessor directive values to be specified w/o quotes.
810 * Add support for using git instead of subversion as the RCS backend,
811 tremendous thanks to Recai Oktaş for this.
812 * Doc updates for git.
813 * Fix absolute url munging in rss generation to support https, ftp, etc urls
815 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
816 utf-8 for edit and other fields, and for recentchanges. There may still
817 be utf-8 issues with the preferences page though.
819 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
821 ikiwiki (1.4) unstable; urgency=low
823 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
824 very strange way of enabling proper XHTML <br /> type tags. Output html
825 should be always valid again now.
826 * The page name and parent links has switched from using a <h1> to a styled
827 <span>, so pages can use <h1> internally instead of needing to use <h2>.
828 * Updated all of ikiwiki's own wiki pages for that.
829 * Add pagetemplate hook, which can be used by plugins that want to mess
830 around with adding new stuff to the page template.
831 * Remove headercontent; the search plugin now adds the search box to the
832 header by registering a pagetemplate hook, and other plugins should do
834 * Rebuilding on upgrade to this version is recommended.
835 * Add a html validity check to the test suite, using the wdg-html-validator,
837 * Make the html valid when there is nothing in the actions list.
838 * Reordered some function call parameters for consistency.
839 * Enable full utf-8 support for page input and output.
840 * Add a workaround for markdown, which does not work well with utf-8
842 * --getctime had bitrotted (well I only ever used it the once so far..),
843 fix and make it a bit more flexible
844 * rcs_getctime is changed, now rather than needing to loop over all pages,
845 it should just use the rcs to get the ctime of the passed file.
846 * When inlining a page in another one, links from the inlined page are now
847 expanded the same as they are when rendering the inlined page as a
848 standalone page. So rather than being expanded from the POV of the
849 inlining page, they are expanded from the POV of the inlined page.
851 For example, a link from blog/foo to "bar" will now link to blog/bar
852 if it exists. Previously this needed to be a link explicitly to
853 "blog/bar"; such links will also continue to work.
855 (This was slightly complex to do as the link still has to be constructed
856 relative to the inlining page.)
857 * Make page edit textarea resize to fit browser window.
858 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
859 do not need a full rebuild, in order to update any basewiki pages.
861 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
863 ikiwiki (1.3) unstable; urgency=low
865 * Fix the preinst introduced in the last version. Closes: #367458
867 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
869 ikiwiki (1.2) unstable; urgency=low
871 * Remove dups from the brokenlinks list.
872 * Add libc6-dev to dependencies, needed to build wrappers.
873 * Install wikilist in correct location. Closes: #367371
875 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
877 ikiwiki (1.1) unstable; urgency=low
879 * Rename inlinepage to depends, so that it can be used to refer to more
880 dependency relationships than just inlining. This will require a rebuild
881 on upgrade to this version.
882 * Move the rss link, put it in the blogpost form if there is one and at the
883 top if not. This is both nicer because easier to find, and it cleans up
884 the code which had used inlinepage as a flag for adding the link later.
885 * Allow the depends GlobList to be built up from multiple sources (such as
886 plugins) during a page render.
887 * Which means that more than one blog is now supported to appear on a
888 single page. (With some limitations, like only the last one getting an
890 * Added a plugin system.
891 * Added a pagecount plugin, enabled by default.
892 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
893 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
894 backlinks when the backlinks hadn't really changed.
895 * Moved inline page support, rss generation etc into the inline plugin,
897 * Added brokenlinks plugin, not enabled by default, but rather handy.
898 * Fix several broken links in the doc wiki.
899 * Smarter behavior when creating a page and a page of the same name (but
900 different location) already exists.
901 * Add an orphans plugin for finding pages that nothing links to.
902 * Removed backlinks page, which it turns out nothing used.
903 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
904 it, this will allow for adding a unit test suite.
905 * Add unit tests for several core functions, including globlist_match,
906 dirname, basename, bestlink, linkify, pagetitle, titlepage.
907 * Smart globlist merging.
908 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
909 to pave the way for adding other RCS support. This also changes the
910 setup files, where before they had svn => 1 or svn => 0, now they have
911 rcs => "svn" or rcs => "".
912 * Add a debian/NEWS file with upgrade notes.
913 * Load whatever rcs module is specified, so new ones can be just dropped in
914 as plugins and work. (Well, in theory.)
915 * Add some basic docs about writing RCS modules.
916 * Broke search capability out into a plugin, removed the --hyperestraier
918 * Added smiley plugin, nicely controlled and documented by the smileys page.
919 * Copied in some smileys from Moin Moin.
920 * Allow links of the form [[some page|page]], with whitespace in the link
922 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
923 and --disable-plugin htmlscrubber.
924 * Allow discussion links on pages to be turned off with --no-discussion.
925 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
926 * Add some new config items to the estseek.conf template, which are needed
927 by hyperestraier 1.2.3.
929 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
931 ikiwiki (1.0) unstable; urgency=low
933 * First official release.
935 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400