1 ikiwiki (1.11) UNRELEASED; urgency=low
3 * Patch from Enrico that
4 - Adds a tag plugin that allows more easily tagging pages.
5 The meta plugin can also still be used for that, but the tag plugin
6 also lists a page's tags at the bottom of the page.
7 - Allows preprocessor directives to have parameters with no specified
9 - Fixes preprocessor directive parameter parsing so that
10 foo=bar baz now means "foo=bar" and a "baz" with no value.
11 * Run pagetemplate hooks when inlining pages so that inlines pages also
13 * Make all plugins with pagetemplate hooks check that variables exist
14 on the template before setting them.
16 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 17:03:09 -0400
18 ikiwiki (1.10) unstable; urgency=low
20 * Run page through any relevant filters when generating a page preview.
21 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
22 default throughout the wiki, not only on wikitext pages. Decided to call
23 this a feature, and split the camelcase support out into a separate plugin
24 that is independant of wikitext.
25 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
27 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
29 ikiwiki (1.9) unstable; urgency=low
31 * Improve display of parentlinks and page title of toplevel index page.
32 * Patch from Faidon to use svn --limit when possible for recentchanges,
33 speeds up recentchanges a lot for wikis with more history.
34 * Patch from Recai to fix utf8 issues in git backend.
35 * Add wikitext markup plugin, which supports ".wiki" pages written in the
36 original wiki syntax, CamelCase links and all.
37 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
38 support, to edit pages etc without a web server.
39 * Display CGI processing errors if present.
40 * Fix from Faidon for a XML parser issue that breaks utf-8 for
41 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
42 area, and also way slow.
43 * Match 'web commit from' in SVN and git, these are web commits too.
45 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
46 readable and avoid future mistakes. The patch seems to work and for the
47 first time I have a UTF-8 username ;-) (Faidon)
48 * Use form->field consistently, not form->param.
49 * Patch from Recai to allow selection of page type when creating a new page.
50 Default page type is inherited from the link clicked on to create the new
53 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
55 ikiwiki (1.8) unstable; urgency=low
57 * Fix orphans plugin to not count a link to a nonexistant page as a reason
58 for a page not being an orphan.
59 * Support pinging services such as Technorati using XML-RPC to notify them
60 about changes to rss feeds.
61 * Parse svn log as xml for improved utf8 and security. Note that this makes
62 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
63 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
64 flagged string even if the locale causes it to generate utf8 output,
65 so make sure to let perl know it should be handled as utf8. Also,
66 the optimised version used for standard time formats won't work if the
67 user has changed locale, so drop it. Thanks, Faidon Liambotis.
68 * Fix re-encoding of the comments field to utf8 if a commit fails
69 due to a conflict. Thanks, Faidon Liambotis.
70 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
72 * Add insane double encode/decode to utf8 around call to markdown.
73 This works around a truely strange bug, which is apparently a bug in
74 perl, #376329. Also added a test case for it.
75 * Improve layout of edit page so formatting help link is always visible w/o
76 getting in the way of the preview.
77 * Centralised all calls to HTML::Template and force all the templates
79 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
80 * Introduce add_plugins and disable_plugins config options in setup files.
81 This allows adding or removing plugins w/o overriding the whole list of
82 default plugins, which makes it easier to upgrade when new default plugins
84 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
85 default (of course!). Based on a patch by Faidon Liambotis.
86 * Add a html plugin, which can be used to write wikis in raw html,
87 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
88 defaults to not processing .html files, since w/o this plugin they would
89 be copied unsanitised. With this plugin, it will process and html
90 sanitise them, like any other page type.
91 * Rebuilding wrappers is necessary on upgrade to this version.
92 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
93 will be automatically done on all upgrades.
94 * Don't send pings if the wiki is being rebuilt.
95 * Work around very innefficient behavior in File::Spec::abs2rel. Result
96 is a savings of 2 pointless fork/execs per link calculation, which
97 results in ~25% speedup of ikiwiki building its own doc wiki, and
98 about 35% speedup displaying RecentChanges!
99 * Make RecentChanges use a table and some CSS, should be much more readable.
100 No code changes involved.
101 * Encode & in diffurl in examples, to conform to pedantic rules.
102 * Speed up RecentChanges by another 40% or so with some memoization.
103 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
104 in time to build the doc wiki.
106 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
108 ikiwiki (1.7) unstable; urgency=low
110 * Updated logo from Recai with some kerning and alingment tuning.
111 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
115 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
117 ikiwiki (1.6) unstable; urgency=low
119 * YA utf-8 patch from Recai, this time to fix previewing a page so that
120 the text in the input box is re-encoded back to utf-8.
121 * -CSD does not affect modules, so readfile() was not using the utf-8 input
122 layer, which led to lots of problems; make it force read files as utf-8.
124 * Note that as a consequence, this version of ikiwiki will actually try to
125 parse utf8 in source files for the first time, which may expose broken
126 utf8 in wiki sources that was hidden before. Most common will be
127 perl warnings like "utf8 "\xE9" does not map to Unicode"
128 * writefile() likewise needs to use the utf8 output layer.
129 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
131 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
132 given the readfile fix.
133 * Add utf-8 testcases for readfile and htmlize.
134 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
136 * More utf-8 fixes from Recai, partly to things I broke above:
137 - The serious problem is that writefile() saves the content in undecoded
138 format in CGI, hence all (non-ascii) chars are corrupted permanently.
139 - Comment field in edit page is not decoded and all the non-ascii chars in
140 this field are corrupted as the result. We should decode it as we do it
142 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
144 * New SVG logo from Recai.
146 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
148 ikiwiki (1.5) unstable; urgency=low
150 * Add --timeformat config option to allow changing how dates are displayed.
151 Note that as a side effect, dates will now be displayed using the local
152 timezone, not as GMT.
153 * More security review.
154 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
155 for some handy stuff like:
156 - Using links as a kind of tag; creating blog pages that list all pages
157 containing a given tag/link or not containing some other tag.
158 - Subscribing to mail notifications whenever a change is made to a page
159 that is a backlink of page foo. Ie, "Please notify me of changes in all
160 pages that link to my home page in the wiki"
161 - Locking any pages that are linked to from a particular page, so that
162 lists of locks can be exposed in the wiki.
163 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
164 when a todo item is done, instead of the previous moving it to a different
166 * Allow pagetemplate plugins to override *anything* in the template.
167 * Add a meta plugin, which allows specifying various metadata about pages,
168 like license and author. It also allows for inserting html link and meta
169 tags into html, overriding the title, and adding hidden WikiLinks, which
170 can be useful when using link-based globbing for page categorisation.
171 * Remove preprocessor directives from inlined pages.
172 * Allow simple preprocessor directive values to be specified w/o quotes.
173 * Add support for using git instead of subversion as the RCS backend,
174 tremendous thanks to Recai Oktaş for this.
175 * Doc updates for git.
176 * Fix absolute url munging in rss generation to support https, ftp, etc urls
178 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
179 utf-8 for edit and other fields, and for recentchanges. There may still
180 be utf-8 issues with the preferences page though.
182 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
184 ikiwiki (1.4) unstable; urgency=low
186 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
187 very strange way of enabling proper XHTML <br /> type tags. Output html
188 should be always valid again now.
189 * The page name and parent links has switched from using a <h1> to a styled
190 <span>, so pages can use <h1> internally instead of needing to use <h2>.
191 * Updated all of ikiwiki's own wiki pages for that.
192 * Add pagetemplate hook, which can be used by plugins that want to mess
193 around with adding new stuff to the page template.
194 * Remove headercontent; the search plugin now adds the search box to the
195 header by registering a pagetemplate hook, and other plugins should do
197 * Rebuilding on upgrade to this version is recommended.
198 * Add a html validity check to the test suite, using the wdg-html-validator,
200 * Make the html valid when there is nothing in the actions list.
201 * Reordered some function call parameters for consistency.
202 * Enable full utf-8 support for page input and output.
203 * Add a workaround for markdown, which does not work well with utf-8
205 * --getctime had bitrotted (well I only ever used it the once so far..),
206 fix and make it a bit more flexible
207 * rcs_getctime is changed, now rather than needing to loop over all pages,
208 it should just use the rcs to get the ctime of the passed file.
209 * When inlining a page in another one, links from the inlined page are now
210 expanded the same as they are when rendering the inlined page as a
211 standalone page. So rather than being expanded from the POV of the
212 inlining page, they are expanded from the POV of the inlined page.
214 For example, a link from blog/foo to "bar" will now link to blog/bar
215 if it exists. Previously this needed to be a link explicitly to
216 "blog/bar"; such links will also continue to work.
218 (This was slightly complex to do as the link still has to be constructed
219 relative to the inlining page.)
220 * Make page edit textarea resize to fit browser window.
221 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
222 do not need a full rebuild, in order to update any basewiki pages.
224 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
226 ikiwiki (1.3) unstable; urgency=low
228 * Fix the preinst introduced in the last version. Closes: #367458
230 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
232 ikiwiki (1.2) unstable; urgency=low
234 * Remove dups from the brokenlinks list.
235 * Add libc6-dev to dependencies, needed to build wrappers.
236 * Install wikilist in correct location. Closes: #367371
238 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
240 ikiwiki (1.1) unstable; urgency=low
242 * Rename inlinepage to depends, so that it can be used to refer to more
243 dependency relationships than just inlining. This will require a rebuild
244 on upgrade to this version.
245 * Move the rss link, put it in the blogpost form if there is one and at the
246 top if not. This is both nicer because easier to find, and it cleans up
247 the code which had used inlinepage as a flag for adding the link later.
248 * Allow the depends GlobList to be built up from multiple sources (such as
249 plugins) during a page render.
250 * Which means that more than one blog is now supported to appear on a
251 single page. (With some limitations, like only the last one getting an
253 * Added a plugin system.
254 * Added a pagecount plugin, enabled by default.
255 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
256 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
257 backlinks when the backlinks hadn't really changed.
258 * Moved inline page support, rss generation etc into the inline plugin,
260 * Added brokenlinks plugin, not enabled by default, but rather handy.
261 * Fix several broken links in the doc wiki.
262 * Smarter behavior when creating a page and a page of the same name (but
263 different location) already exists.
264 * Add an orphans plugin for finding pages that nothing links to.
265 * Removed backlinks page, which it turns out nothing used.
266 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
267 it, this will allow for adding a unit test suite.
268 * Add unit tests for several core functions, including globlist_match,
269 dirname, basename, bestlink, linkify, pagetitle, titlepage.
270 * Smart globlist merging.
271 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
272 to pave the way for adding other RCS support. This also changes the
273 setup files, where before they had svn => 1 or svn => 0, now they have
274 rcs => "svn" or rcs => "".
275 * Add a debian/NEWS file with upgrade notes.
276 * Load whatever rcs module is specified, so new ones can be just dropped in
277 as plugins and work. (Well, in theory.)
278 * Add some basic docs about writing RCS modules.
279 * Broke search capability out into a plugin, removed the --hyperestraier
281 * Added smiley plugin, nicely controlled and documented by the smileys page.
282 * Copied in some smileys from Moin Moin.
283 * Allow links of the form [[some page|page]], with whitespace in the link
285 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
286 and --disable-plugin htmlscrubber.
287 * Allow discussion links on pages to be turned off with --no-discussion.
288 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
289 * Add some new config items to the estseek.conf template, which are needed
290 by hyperestraier 1.2.3.
292 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
294 ikiwiki (1.0) unstable; urgency=low
296 * First official release.
298 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400