1 ikiwiki (1.27) UNRELEASED; urgency=low
3 * Add a googlecalendar plugin. A bit special-purpose, but it shows
4 one way to to deal with user-supplied content that could cause XSS
5 issues w/o the htmlscrubber, and won't survive the scrubber.
6 * Work on firming up the plugin interface:
7 - Plugins should not need to load IkiWiki::Render to get commonly
8 used functions, so moved some functions from there to IkiWiki.
9 - Picked out the set of functions and variables that most plugins
10 use, documented them, and made IkiWiki export them by default,
11 like a proper perl module should.
12 - Use the other functions at your own risk.
13 - This is not quite complete, I still have to decide whether to
14 export some other things.
15 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16 referring to stuff now exported by the IkiWiki module.
17 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18 to declare which version of the interface your plugin needs.
19 * Anyone with a third-party ikiwiki plugin is strongly encouraged
20 to make like changes to it and avoid use of non-exported symboles from
22 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23 * Support hyperestradier version 1.4.2, which adds a new required phraseform
25 * If an inlined page has a permalink, link the page title to that.
26 * Patch from Recai to use utf8 when reading the setup file, so that
27 utf8 wikinames from there will be used properly.
28 * Patch from Recai to kill utf-8 on the wiki name when generating the
30 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31 * Fix a baseurl problem in hyperestradier search results.
32 * Add a stub local.css to avoid problems with 404's.
33 * Patch from Recai to fix a wide character warning from the search plugin
34 during setup if the wikiname contains utf8.
35 * Yet another fix for those poor case-insensative OSX users.
36 * pagetemplate hooks are now also called when generating cgi pages.
37 * Add a favicon plugin, which simply adds a link tag for an icon to each
40 -- Joey Hess <joeyh@debian.org> Fri, 15 Sep 2006 19:39:36 -0400
42 ikiwiki (1.26) unstable; urgency=low
44 * Add a missing -n to tla undo call.
45 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
46 writes before consuming its whole stdin. Avoid this deadlock.
47 * Fix alt tags for outline checkboxes.
49 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
51 ikiwiki (1.25) unstable; urgency=low
53 * Add proper waitpid calls for open2ed processes throughout to avoid
54 zombies; this hit htmltidy especially badly.
55 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
56 subversion repos and fixing some other issues.
57 * Add support for tla, contributed by Clint Adams. Closes: #385936
58 * Add support for mercurial, contributed by Emanuele Aina.
59 * Include <link rel> tag for RSS feeds, used by some aggregators and
60 firefox to find the feed.
61 * Add a linkmap plugin (requires graphviz).
63 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
65 ikiwiki (1.24) unstable; urgency=low
67 * Simplify the data structure returned by rcs_recentchanges to avoid
68 each rcs plugin needing to form complex strings on its own.
69 * Fix another destpage issue in the inline directive. Closes: #385512
72 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
74 ikiwiki (1.23) unstable; urgency=low
76 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
78 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
80 ikiwiki (1.22) unstable; urgency=low
82 * Change how the stylesheet url is determined in the templates: Remove
83 STYLEURL and add BASEURL to all templates (some already had it). This
84 new more general variable can be used to link to other things (eg, images)
85 from the template, as well as stylesheets.
86 * Fix a bug introduced last version to do with nested inlines.
87 * Allow preprocessor directives to span multiple lines, both to make
88 long ones with lots of values easier to write, and to allow for ones with
89 multi-line quoted values.
90 * Allow preprocessor directives to contain python-like triple-quoted
91 text blocks, for easy nesting of quotes inside.
92 * Add a template plugin.
93 * Make pagespec merge code smarter about merging duplicate pagespecs.
94 * Patch from Jordà Polo to make Setup::Standard support hashes in config
96 * Change order of linkify and preprocess; first preprocess and then linkify.
97 This allows passing a wikilink inside a parameter to a preprocessor
98 directive without it being expanded to html, and leaking out of the
99 parameter, which had required some non-obvious use of triple-quoting
100 to avoid. Note that any preprocessor plugins that output something
101 that looks like a wikilink will now have it treated as such; AFAIK
102 this doesn't change any behavior though except for the template plugin.
103 * Enable preprocessor directives when previewing an edit.
104 * Make all pages pull in a local.css style sheet, if present. This won't
105 be included in ikiwiki, but can be created to make local styling changes
106 w/o needing to merge in every new change to the distributed style.css.
107 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
108 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
109 from a different directory.
110 * Generalised preprocesser loop protection code.
111 * Patch from James Westby to allow a description to be set for rss feeds.
112 * Patch from James Westby to add a template for the search form.
113 * Added a ddate plugin.
114 * Patch from James Westby to add a --sslcookie switch, which forces
115 cookies to only be sent over ssl connections to avoid interception.
116 * Fix preferences page on anonok wikis; still need to sign in to get
117 to the preferences page.
118 * Add toc (table of contents) plugin.
119 * Change htmlize, format, and sanitize hooks to use named parameters.
120 * Patch from James Westby to add an actions option to inline; this
121 adds Edit and Discussion links at the end of blog entries.
122 * Due to some css changes, you'll want to rebuild your wiki on upgrade
123 to this version. Will be handled automatically by the deb.
124 * Add processed date to aggregate preprocessor directive status output.
126 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
128 ikiwiki (1.21) unstable; urgency=low
130 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
131 * If a page links to itself, mark up the link text in a span with
132 class="selflink" so that it can be styled. I don't have a useful style
133 defined for that though.
134 * Call filter hooks on inlined page content.
135 * Support inlining pages raw, rather than creating a blog.
136 * Clean up yes/no parameter parsing in inline plugin.
137 * Implemented better cycle detection in the inline plugin; nested inlines
139 * Add a map plugin contributed by Alessandro Dotti Contra.
140 * Add otl format plugin, which handles files as created by vimoutliner.
141 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
142 * Add first draft at a Restructured Text (rst) plugin, by Sergio
143 Talens-Oliag. Note that this has many known issues -- see the caveats on
145 * Credit everyone who wrote a plugin on the plugins' wiki pages.
146 * Fix utf-8 in blog post form.
148 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
150 ikiwiki (1.20) unstable; urgency=low
152 * Relicense the templates and basewiki under the 2-clause BSD license.
153 Since these can easily become part of other people's websites, they
154 should be under as permissive a license as possible.
155 * Add --syslog config option, to log to the syslog.
156 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
157 transient failure to fork (which I've seen happen in the wild).
158 * Fix a bug in the aggregator introduced last version that caused all
159 aggregator state to be lost during a non-aggregating build.
161 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
163 ikiwiki (1.19) unstable; urgency=low
165 * Fix several related bugs in page type determination during online editing.
166 * Add some locking to prevent 2 aggregators from running at once.
167 * Fix an infinite loop in the aggregator when finding a unique filename.
169 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
171 ikiwiki (1.18) unstable; urgency=low
173 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
175 * Man page format fixups.
176 * If the meta plugin overides the page title, set a title_overridden
177 variable in the template to true. This allows doing things with the
178 templates conditional on the title being overriden.
179 * Add a %pagecase which maps lower-case page names to the actual case
180 used in the filename. Use this in bestlinks calculation instead of
181 forcing the link to lowercase.
182 * Also use %pagecase in various other places that want to check if a page
183 with a given name exists.
184 * This means that links to pages with mixed case names will now work,
185 even if the link is in some other case mixture, and mixed case pages
186 should be fully supported throughout ikiwiki.
187 * Recommend rebuilding wikis on upgrade to this version.
189 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
191 ikiwiki (1.17) unstable; urgency=low
193 * Disable tidy generator tag.
194 * Move tidy back to sanitize hook, found out how to only show body.
195 * Turn off tidy indentation too.
196 * Turn on HTML::Template loop_context_vars; not actually used in stock
197 templates but can be useful for things like making comma-delimited lists
198 of tags or what have you.
199 * Remove <br> from end of aggregate preprocessor directive output.
200 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
201 case-sensative filesystems like OSX.
202 * Improve markdown loading. First, try to load it as a proper perl module,
203 in case it was installed as one. Then fall back to trying
205 * Document in install page how to install markdown, since it has no
206 installation procedure in the upstream tarball.
207 * Set die_on_bad_params => 0 for all templates, to allow users to modify
208 them without annoyances.
209 * Suck in the page content when generating an inline archive page, to work
210 around the meta plugin's lack of caching of title metadata across runs.
212 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
214 ikiwiki (1.16) unstable; urgency=low
216 * Try to handle relative links in aggregated feeds. However,
217 the current support is a crude hack due to limitations of XML::Feed:
218 xml:base is not supported, neither is Content-Location. And of course,
219 relative links in RSS feeds are ill-undefined..
220 * Make aggregator save permalinks and author name to pages as metadata.
221 * Add permalink and author support to meta plugin, affecting RSS feeds
223 * Various CSS and formatting changes.
224 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
225 * Add xhtml files to the default prune regexp.
226 * Also generate rel=bookmark links for permalinks.
227 * Fix the htmltidy plugin, which wasn't working due my breaking it when
229 * Don't run tidy with -xml as that fails if the input is not well-formed.
230 Run it with -asxhtml instead, so it will output well-formed xhtml no
231 matter what the input.
232 * Disable tidy warnings too.
233 * Add a new format hook, and make tidy use it, since tidy can really only
234 operate on and output complete html documents, not the body chunks
236 * Fix dates in rss feeds if running localised, so they're still rfc 822.
238 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
240 ikiwiki (1.15) unstable; urgency=low
242 * Remove CDPATH and other env vars perl taint checking doesn't like.
244 * Added created_before and created_after PageSpec limits.
246 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
248 ikiwiki (1.14) unstable; urgency=low
250 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
252 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
253 * Added many unit tests for pagespec_match.
255 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
257 ikiwiki (1.13) unstable; urgency=low
259 * ikiwiki can now download and aggregate feeds with its new aggregate
260 plugin, so it's possible to implement a Planet using ikiwiki!
261 * Add a run_hooks function for the common task of running all hooks of a
263 * Add a savestate hook.
264 * Don't put blog post forms on pages if there's no cgiurl set.
265 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
266 --wrappers to do that.
267 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
268 to update pages that haven't changed on disk.
269 * Change meta tags to use html entity-escaped text for values, so that
270 quotes and such can be represented in title tags.
271 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
273 * Make --rebuild also cause --aggregate to re-download and write aggregated
275 * Avoid outputting duplicate meta info.
276 * Include title metadata on aggregated posts for capitalised and un-munged
278 * Title metadata of inlined pages now shows up in blogs and rss feeds.
279 * Fix issue with unicode filenames and updating the hyper estradier search
280 index. (Aka Please Please Please, let that be the last one.)
281 * Patch from Roland Mas to support an rss=no parameter to inline directives.
283 * Renamed GlobLists to PageSpecs.
284 * PageSpecs can now include nested parens, "and", and "or". This remains
285 backwards compatible to the old GlobList format. It's implemented by
286 treating the GlobList as a very limited microlanguage that is transformed
287 to perl code that does the matching.
288 * The old GlobList format is deprecated, and I encourage users to switch to
289 using the new PageSpec format. Compatability with the old format will be
290 removed at some point, possibly by 2.0.
291 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
292 * Add support for creation_month and creation_year to PageSpec.
294 * Changes to index file encoding.
296 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
298 ikiwiki (1.12) unstable; urgency=low
301 * New pagestats plugin from Enrico, which can generate a table counting
302 the backlinks for each page, or a del.icio.us style cloud.
303 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
304 the wikiformat plugin works. Thanks, Emanuele Aina.
305 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
306 display, running them through pagetitle. This removes ugly underscores and
307 other gunk from the display, much nicer. You may want to rebuild your wiki
308 when upgrading to get the cleanup globally.
309 * Polygen plugin from Enrico.
310 * htmltidy plugin from Faidon.
311 * Locale patch from Faidon:
312 - Adds a locale setting to setup files.
313 - Proper local time, if the locale configuration option is used.
314 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
315 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
317 * Add getopt hook type, this allows plugins to add new command-line options.
318 * Add --tagbase option to tag plugin.
319 * Add exclude option in setup files, works same as --exclude.
320 * Put categories in rss feeds for tagged items.
321 * Allow preprocessor directives to be expanded in inlined blog pages.
322 However, to avoid inlining loops etc, don't expand inline directives in
324 * fortune plugin (trivial)
325 * Tag plugins according to type.
327 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
329 ikiwiki (1.11) unstable; urgency=low
331 * Patch from Enrico that
332 - Adds a tag plugin that allows more easily tagging pages.
333 The meta plugin can also still be used for that, but the tag plugin
334 also lists a page's tags at the bottom of the page.
335 - Allows preprocessor directives to have parameters with no specified
337 - Fixes preprocessor directive parameter parsing so that
338 foo=bar baz now means "foo=bar" and a "baz" with no value.
339 * Run pagetemplate hooks when inlining pages so that inlined pages also
341 * Make all plugins with pagetemplate hooks check that variables exist
342 on the template before setting them, for robustness.
343 * Switch pagetemplate hooks to using named parameters.
344 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
345 This will be the page that a source page will be part of, which is
346 different than the source page for inlined pages.
347 * Audited all plugins to endure they pass (page, destpage) to htmllink
348 appropriatly. This means inlining of various plugins will not work
349 properly, with correct links generated.
351 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
353 ikiwiki (1.10) unstable; urgency=low
355 * Run page through any relevant filters when generating a page preview.
356 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
357 default throughout the wiki, not only on wikitext pages. Decided to call
358 this a feature, and split the camelcase support out into a separate plugin
359 that is independant of wikitext.
360 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
362 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
364 ikiwiki (1.9) unstable; urgency=low
366 * Improve display of parentlinks and page title of toplevel index page.
367 * Patch from Faidon to use svn --limit when possible for recentchanges,
368 speeds up recentchanges a lot for wikis with more history.
369 * Patch from Recai to fix utf8 issues in git backend.
370 * Add wikitext markup plugin, which supports ".wiki" pages written in the
371 original wiki syntax, CamelCase links and all.
372 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
373 support, to edit pages etc without a web server.
374 * Display CGI processing errors if present.
375 * Fix from Faidon for a XML parser issue that breaks utf-8 for
376 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
377 area, and also way slow.
378 * Match 'web commit from' in SVN and git, these are web commits too.
380 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
381 readable and avoid future mistakes. The patch seems to work and for the
382 first time I have a UTF-8 username ;-) (Faidon)
383 * Use form->field consistently, not form->param.
384 * Patch from Recai to allow selection of page type when creating a new page.
385 Default page type is inherited from the link clicked on to create the new
388 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
390 ikiwiki (1.8) unstable; urgency=low
392 * Fix orphans plugin to not count a link to a nonexistant page as a reason
393 for a page not being an orphan.
394 * Support pinging services such as Technorati using XML-RPC to notify them
395 about changes to rss feeds.
396 * Parse svn log as xml for improved utf8 and security. Note that this makes
397 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
398 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
399 flagged string even if the locale causes it to generate utf8 output,
400 so make sure to let perl know it should be handled as utf8. Also,
401 the optimised version used for standard time formats won't work if the
402 user has changed locale, so drop it. Thanks, Faidon Liambotis.
403 * Fix re-encoding of the comments field to utf8 if a commit fails
404 due to a conflict. Thanks, Faidon Liambotis.
405 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
407 * Add insane double encode/decode to utf8 around call to markdown.
408 This works around a truely strange bug, which is apparently a bug in
409 perl, #376329. Also added a test case for it.
410 * Improve layout of edit page so formatting help link is always visible w/o
411 getting in the way of the preview.
412 * Centralised all calls to HTML::Template and force all the templates
414 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
415 * Introduce add_plugins and disable_plugins config options in setup files.
416 This allows adding or removing plugins w/o overriding the whole list of
417 default plugins, which makes it easier to upgrade when new default plugins
419 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
420 default (of course!). Based on a patch by Faidon Liambotis.
421 * Add a html plugin, which can be used to write wikis in raw html,
422 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
423 defaults to not processing .html files, since w/o this plugin they would
424 be copied unsanitised. With this plugin, it will process and html
425 sanitise them, like any other page type.
426 * Rebuilding wrappers is necessary on upgrade to this version.
427 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
428 will be automatically done on all upgrades.
429 * Don't send pings if the wiki is being rebuilt.
430 * Work around very innefficient behavior in File::Spec::abs2rel. Result
431 is a savings of 2 pointless fork/execs per link calculation, which
432 results in ~25% speedup of ikiwiki building its own doc wiki, and
433 about 35% speedup displaying RecentChanges!
434 * Make RecentChanges use a table and some CSS, should be much more readable.
435 No code changes involved.
436 * Encode & in diffurl in examples, to conform to pedantic rules.
437 * Speed up RecentChanges by another 40% or so with some memoization.
438 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
439 in time to build the doc wiki.
441 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
443 ikiwiki (1.7) unstable; urgency=low
445 * Updated logo from Recai with some kerning and alingment tuning.
446 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
450 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
452 ikiwiki (1.6) unstable; urgency=low
454 * YA utf-8 patch from Recai, this time to fix previewing a page so that
455 the text in the input box is re-encoded back to utf-8.
456 * -CSD does not affect modules, so readfile() was not using the utf-8 input
457 layer, which led to lots of problems; make it force read files as utf-8.
459 * Note that as a consequence, this version of ikiwiki will actually try to
460 parse utf8 in source files for the first time, which may expose broken
461 utf8 in wiki sources that was hidden before. Most common will be
462 perl warnings like "utf8 "\xE9" does not map to Unicode"
463 * writefile() likewise needs to use the utf8 output layer.
464 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
466 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
467 given the readfile fix.
468 * Add utf-8 testcases for readfile and htmlize.
469 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
471 * More utf-8 fixes from Recai, partly to things I broke above:
472 - The serious problem is that writefile() saves the content in undecoded
473 format in CGI, hence all (non-ascii) chars are corrupted permanently.
474 - Comment field in edit page is not decoded and all the non-ascii chars in
475 this field are corrupted as the result. We should decode it as we do it
477 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
479 * New SVG logo from Recai.
481 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
483 ikiwiki (1.5) unstable; urgency=low
485 * Add --timeformat config option to allow changing how dates are displayed.
486 Note that as a side effect, dates will now be displayed using the local
487 timezone, not as GMT.
488 * More security review.
489 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
490 for some handy stuff like:
491 - Using links as a kind of tag; creating blog pages that list all pages
492 containing a given tag/link or not containing some other tag.
493 - Subscribing to mail notifications whenever a change is made to a page
494 that is a backlink of page foo. Ie, "Please notify me of changes in all
495 pages that link to my home page in the wiki"
496 - Locking any pages that are linked to from a particular page, so that
497 lists of locks can be exposed in the wiki.
498 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
499 when a todo item is done, instead of the previous moving it to a different
501 * Allow pagetemplate plugins to override *anything* in the template.
502 * Add a meta plugin, which allows specifying various metadata about pages,
503 like license and author. It also allows for inserting html link and meta
504 tags into html, overriding the title, and adding hidden WikiLinks, which
505 can be useful when using link-based globbing for page categorisation.
506 * Remove preprocessor directives from inlined pages.
507 * Allow simple preprocessor directive values to be specified w/o quotes.
508 * Add support for using git instead of subversion as the RCS backend,
509 tremendous thanks to Recai Oktaş for this.
510 * Doc updates for git.
511 * Fix absolute url munging in rss generation to support https, ftp, etc urls
513 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
514 utf-8 for edit and other fields, and for recentchanges. There may still
515 be utf-8 issues with the preferences page though.
517 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
519 ikiwiki (1.4) unstable; urgency=low
521 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
522 very strange way of enabling proper XHTML <br /> type tags. Output html
523 should be always valid again now.
524 * The page name and parent links has switched from using a <h1> to a styled
525 <span>, so pages can use <h1> internally instead of needing to use <h2>.
526 * Updated all of ikiwiki's own wiki pages for that.
527 * Add pagetemplate hook, which can be used by plugins that want to mess
528 around with adding new stuff to the page template.
529 * Remove headercontent; the search plugin now adds the search box to the
530 header by registering a pagetemplate hook, and other plugins should do
532 * Rebuilding on upgrade to this version is recommended.
533 * Add a html validity check to the test suite, using the wdg-html-validator,
535 * Make the html valid when there is nothing in the actions list.
536 * Reordered some function call parameters for consistency.
537 * Enable full utf-8 support for page input and output.
538 * Add a workaround for markdown, which does not work well with utf-8
540 * --getctime had bitrotted (well I only ever used it the once so far..),
541 fix and make it a bit more flexible
542 * rcs_getctime is changed, now rather than needing to loop over all pages,
543 it should just use the rcs to get the ctime of the passed file.
544 * When inlining a page in another one, links from the inlined page are now
545 expanded the same as they are when rendering the inlined page as a
546 standalone page. So rather than being expanded from the POV of the
547 inlining page, they are expanded from the POV of the inlined page.
549 For example, a link from blog/foo to "bar" will now link to blog/bar
550 if it exists. Previously this needed to be a link explicitly to
551 "blog/bar"; such links will also continue to work.
553 (This was slightly complex to do as the link still has to be constructed
554 relative to the inlining page.)
555 * Make page edit textarea resize to fit browser window.
556 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
557 do not need a full rebuild, in order to update any basewiki pages.
559 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
561 ikiwiki (1.3) unstable; urgency=low
563 * Fix the preinst introduced in the last version. Closes: #367458
565 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
567 ikiwiki (1.2) unstable; urgency=low
569 * Remove dups from the brokenlinks list.
570 * Add libc6-dev to dependencies, needed to build wrappers.
571 * Install wikilist in correct location. Closes: #367371
573 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
575 ikiwiki (1.1) unstable; urgency=low
577 * Rename inlinepage to depends, so that it can be used to refer to more
578 dependency relationships than just inlining. This will require a rebuild
579 on upgrade to this version.
580 * Move the rss link, put it in the blogpost form if there is one and at the
581 top if not. This is both nicer because easier to find, and it cleans up
582 the code which had used inlinepage as a flag for adding the link later.
583 * Allow the depends GlobList to be built up from multiple sources (such as
584 plugins) during a page render.
585 * Which means that more than one blog is now supported to appear on a
586 single page. (With some limitations, like only the last one getting an
588 * Added a plugin system.
589 * Added a pagecount plugin, enabled by default.
590 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
591 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
592 backlinks when the backlinks hadn't really changed.
593 * Moved inline page support, rss generation etc into the inline plugin,
595 * Added brokenlinks plugin, not enabled by default, but rather handy.
596 * Fix several broken links in the doc wiki.
597 * Smarter behavior when creating a page and a page of the same name (but
598 different location) already exists.
599 * Add an orphans plugin for finding pages that nothing links to.
600 * Removed backlinks page, which it turns out nothing used.
601 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
602 it, this will allow for adding a unit test suite.
603 * Add unit tests for several core functions, including globlist_match,
604 dirname, basename, bestlink, linkify, pagetitle, titlepage.
605 * Smart globlist merging.
606 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
607 to pave the way for adding other RCS support. This also changes the
608 setup files, where before they had svn => 1 or svn => 0, now they have
609 rcs => "svn" or rcs => "".
610 * Add a debian/NEWS file with upgrade notes.
611 * Load whatever rcs module is specified, so new ones can be just dropped in
612 as plugins and work. (Well, in theory.)
613 * Add some basic docs about writing RCS modules.
614 * Broke search capability out into a plugin, removed the --hyperestraier
616 * Added smiley plugin, nicely controlled and documented by the smileys page.
617 * Copied in some smileys from Moin Moin.
618 * Allow links of the form [[some page|page]], with whitespace in the link
620 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
621 and --disable-plugin htmlscrubber.
622 * Allow discussion links on pages to be turned off with --no-discussion.
623 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
624 * Add some new config items to the estseek.conf template, which are needed
625 by hyperestraier 1.2.3.
627 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
629 ikiwiki (1.0) unstable; urgency=low
631 * First official release.
633 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400