1 ikiwiki (1.27) UNRELEASED; urgency=low
3 * Add a googlecalendar plugin. A bit special-purpose, but it shows
4 one way to to deal with user-supplied content that could cause XSS
5 issues w/o the htmlscrubber, and won't survive the scrubber.
6 * Work on firming up the plugin interface:
7 - Plugins should not need to load IkiWiki::Render to get commonly
8 used functions, so moved some functions from there to IkiWiki.
9 - Picked out the set of functions and variables that most plugins
10 use, documented them, and made IkiWiki export them by default,
11 like a proper perl module should.
12 - Use the other functions at your own risk.
13 - This is not quite complete, I still have to decide whether to
14 export some other things.
15 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16 referring to stuff now exported by the IkiWiki module.
17 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18 to declare which version of the interface your plugin needs.
19 * Anyone with a third-party ikiwiki plugin is strongly encouraged
20 to make like changes to it and avoid use of non-exported symboles from
22 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23 * Support hyperestradier version 1.4.2, which adds a new required phraseform
25 * If an inlined page has a permalink, link the page title to that.
26 * Patch from Recai to use utf8 when reading the setup file, so that
27 utf8 wikinames from there will be used properly.
28 * Patch from Recai to kill utf-8 on the wiki name when generating the
30 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
31 * Fix a baseurl problem in hyperestradier search results.
32 * Add a stub local.css to avoid problems with 404's.
33 * Patch from Recai to fix a wide character warning from the search plugin
34 during setup if the wikiname contains utf8.
35 * Yet another fix for those poor case-insensative OSX users.
36 * pagetemplate hooks are now also called when generating cgi pages.
37 * Add a favicon plugin, which simply adds a link tag for an icon to each
39 * Patch from James Westby to deal with the case where you're editing a
40 new page, hit cancel, and need to be redirected to somewhere sane.
41 * Various documentation improvements by various wiki users.
42 * Support Text::Markdown from CPAN, which has a different interface from
43 the original markdown or the one in Debian.
45 -- Joey Hess <joeyh@debian.org> Fri, 15 Sep 2006 21:49:23 -0400
47 ikiwiki (1.26) unstable; urgency=low
49 * Add a missing -n to tla undo call.
50 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
51 writes before consuming its whole stdin. Avoid this deadlock.
52 * Fix alt tags for outline checkboxes.
54 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
56 ikiwiki (1.25) unstable; urgency=low
58 * Add proper waitpid calls for open2ed processes throughout to avoid
59 zombies; this hit htmltidy especially badly.
60 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
61 subversion repos and fixing some other issues.
62 * Add support for tla, contributed by Clint Adams. Closes: #385936
63 * Add support for mercurial, contributed by Emanuele Aina.
64 * Include <link rel> tag for RSS feeds, used by some aggregators and
65 firefox to find the feed.
66 * Add a linkmap plugin (requires graphviz).
68 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
70 ikiwiki (1.24) unstable; urgency=low
72 * Simplify the data structure returned by rcs_recentchanges to avoid
73 each rcs plugin needing to form complex strings on its own.
74 * Fix another destpage issue in the inline directive. Closes: #385512
77 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
79 ikiwiki (1.23) unstable; urgency=low
81 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
83 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
85 ikiwiki (1.22) unstable; urgency=low
87 * Change how the stylesheet url is determined in the templates: Remove
88 STYLEURL and add BASEURL to all templates (some already had it). This
89 new more general variable can be used to link to other things (eg, images)
90 from the template, as well as stylesheets.
91 * Fix a bug introduced last version to do with nested inlines.
92 * Allow preprocessor directives to span multiple lines, both to make
93 long ones with lots of values easier to write, and to allow for ones with
94 multi-line quoted values.
95 * Allow preprocessor directives to contain python-like triple-quoted
96 text blocks, for easy nesting of quotes inside.
97 * Add a template plugin.
98 * Make pagespec merge code smarter about merging duplicate pagespecs.
99 * Patch from Jordà Polo to make Setup::Standard support hashes in config
101 * Change order of linkify and preprocess; first preprocess and then linkify.
102 This allows passing a wikilink inside a parameter to a preprocessor
103 directive without it being expanded to html, and leaking out of the
104 parameter, which had required some non-obvious use of triple-quoting
105 to avoid. Note that any preprocessor plugins that output something
106 that looks like a wikilink will now have it treated as such; AFAIK
107 this doesn't change any behavior though except for the template plugin.
108 * Enable preprocessor directives when previewing an edit.
109 * Make all pages pull in a local.css style sheet, if present. This won't
110 be included in ikiwiki, but can be created to make local styling changes
111 w/o needing to merge in every new change to the distributed style.css.
112 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
113 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
114 from a different directory.
115 * Generalised preprocesser loop protection code.
116 * Patch from James Westby to allow a description to be set for rss feeds.
117 * Patch from James Westby to add a template for the search form.
118 * Added a ddate plugin.
119 * Patch from James Westby to add a --sslcookie switch, which forces
120 cookies to only be sent over ssl connections to avoid interception.
121 * Fix preferences page on anonok wikis; still need to sign in to get
122 to the preferences page.
123 * Add toc (table of contents) plugin.
124 * Change htmlize, format, and sanitize hooks to use named parameters.
125 * Patch from James Westby to add an actions option to inline; this
126 adds Edit and Discussion links at the end of blog entries.
127 * Due to some css changes, you'll want to rebuild your wiki on upgrade
128 to this version. Will be handled automatically by the deb.
129 * Add processed date to aggregate preprocessor directive status output.
131 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
133 ikiwiki (1.21) unstable; urgency=low
135 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
136 * If a page links to itself, mark up the link text in a span with
137 class="selflink" so that it can be styled. I don't have a useful style
138 defined for that though.
139 * Call filter hooks on inlined page content.
140 * Support inlining pages raw, rather than creating a blog.
141 * Clean up yes/no parameter parsing in inline plugin.
142 * Implemented better cycle detection in the inline plugin; nested inlines
144 * Add a map plugin contributed by Alessandro Dotti Contra.
145 * Add otl format plugin, which handles files as created by vimoutliner.
146 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
147 * Add first draft at a Restructured Text (rst) plugin, by Sergio
148 Talens-Oliag. Note that this has many known issues -- see the caveats on
150 * Credit everyone who wrote a plugin on the plugins' wiki pages.
151 * Fix utf-8 in blog post form.
153 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
155 ikiwiki (1.20) unstable; urgency=low
157 * Relicense the templates and basewiki under the 2-clause BSD license.
158 Since these can easily become part of other people's websites, they
159 should be under as permissive a license as possible.
160 * Add --syslog config option, to log to the syslog.
161 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
162 transient failure to fork (which I've seen happen in the wild).
163 * Fix a bug in the aggregator introduced last version that caused all
164 aggregator state to be lost during a non-aggregating build.
166 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
168 ikiwiki (1.19) unstable; urgency=low
170 * Fix several related bugs in page type determination during online editing.
171 * Add some locking to prevent 2 aggregators from running at once.
172 * Fix an infinite loop in the aggregator when finding a unique filename.
174 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
176 ikiwiki (1.18) unstable; urgency=low
178 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
180 * Man page format fixups.
181 * If the meta plugin overides the page title, set a title_overridden
182 variable in the template to true. This allows doing things with the
183 templates conditional on the title being overriden.
184 * Add a %pagecase which maps lower-case page names to the actual case
185 used in the filename. Use this in bestlinks calculation instead of
186 forcing the link to lowercase.
187 * Also use %pagecase in various other places that want to check if a page
188 with a given name exists.
189 * This means that links to pages with mixed case names will now work,
190 even if the link is in some other case mixture, and mixed case pages
191 should be fully supported throughout ikiwiki.
192 * Recommend rebuilding wikis on upgrade to this version.
194 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
196 ikiwiki (1.17) unstable; urgency=low
198 * Disable tidy generator tag.
199 * Move tidy back to sanitize hook, found out how to only show body.
200 * Turn off tidy indentation too.
201 * Turn on HTML::Template loop_context_vars; not actually used in stock
202 templates but can be useful for things like making comma-delimited lists
203 of tags or what have you.
204 * Remove <br> from end of aggregate preprocessor directive output.
205 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
206 case-sensative filesystems like OSX.
207 * Improve markdown loading. First, try to load it as a proper perl module,
208 in case it was installed as one. Then fall back to trying
210 * Document in install page how to install markdown, since it has no
211 installation procedure in the upstream tarball.
212 * Set die_on_bad_params => 0 for all templates, to allow users to modify
213 them without annoyances.
214 * Suck in the page content when generating an inline archive page, to work
215 around the meta plugin's lack of caching of title metadata across runs.
217 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
219 ikiwiki (1.16) unstable; urgency=low
221 * Try to handle relative links in aggregated feeds. However,
222 the current support is a crude hack due to limitations of XML::Feed:
223 xml:base is not supported, neither is Content-Location. And of course,
224 relative links in RSS feeds are ill-undefined..
225 * Make aggregator save permalinks and author name to pages as metadata.
226 * Add permalink and author support to meta plugin, affecting RSS feeds
228 * Various CSS and formatting changes.
229 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
230 * Add xhtml files to the default prune regexp.
231 * Also generate rel=bookmark links for permalinks.
232 * Fix the htmltidy plugin, which wasn't working due my breaking it when
234 * Don't run tidy with -xml as that fails if the input is not well-formed.
235 Run it with -asxhtml instead, so it will output well-formed xhtml no
236 matter what the input.
237 * Disable tidy warnings too.
238 * Add a new format hook, and make tidy use it, since tidy can really only
239 operate on and output complete html documents, not the body chunks
241 * Fix dates in rss feeds if running localised, so they're still rfc 822.
243 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
245 ikiwiki (1.15) unstable; urgency=low
247 * Remove CDPATH and other env vars perl taint checking doesn't like.
249 * Added created_before and created_after PageSpec limits.
251 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
253 ikiwiki (1.14) unstable; urgency=low
255 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
257 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
258 * Added many unit tests for pagespec_match.
260 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
262 ikiwiki (1.13) unstable; urgency=low
264 * ikiwiki can now download and aggregate feeds with its new aggregate
265 plugin, so it's possible to implement a Planet using ikiwiki!
266 * Add a run_hooks function for the common task of running all hooks of a
268 * Add a savestate hook.
269 * Don't put blog post forms on pages if there's no cgiurl set.
270 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
271 --wrappers to do that.
272 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
273 to update pages that haven't changed on disk.
274 * Change meta tags to use html entity-escaped text for values, so that
275 quotes and such can be represented in title tags.
276 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
278 * Make --rebuild also cause --aggregate to re-download and write aggregated
280 * Avoid outputting duplicate meta info.
281 * Include title metadata on aggregated posts for capitalised and un-munged
283 * Title metadata of inlined pages now shows up in blogs and rss feeds.
284 * Fix issue with unicode filenames and updating the hyper estradier search
285 index. (Aka Please Please Please, let that be the last one.)
286 * Patch from Roland Mas to support an rss=no parameter to inline directives.
288 * Renamed GlobLists to PageSpecs.
289 * PageSpecs can now include nested parens, "and", and "or". This remains
290 backwards compatible to the old GlobList format. It's implemented by
291 treating the GlobList as a very limited microlanguage that is transformed
292 to perl code that does the matching.
293 * The old GlobList format is deprecated, and I encourage users to switch to
294 using the new PageSpec format. Compatability with the old format will be
295 removed at some point, possibly by 2.0.
296 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
297 * Add support for creation_month and creation_year to PageSpec.
299 * Changes to index file encoding.
301 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
303 ikiwiki (1.12) unstable; urgency=low
306 * New pagestats plugin from Enrico, which can generate a table counting
307 the backlinks for each page, or a del.icio.us style cloud.
308 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
309 the wikiformat plugin works. Thanks, Emanuele Aina.
310 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
311 display, running them through pagetitle. This removes ugly underscores and
312 other gunk from the display, much nicer. You may want to rebuild your wiki
313 when upgrading to get the cleanup globally.
314 * Polygen plugin from Enrico.
315 * htmltidy plugin from Faidon.
316 * Locale patch from Faidon:
317 - Adds a locale setting to setup files.
318 - Proper local time, if the locale configuration option is used.
319 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
320 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
322 * Add getopt hook type, this allows plugins to add new command-line options.
323 * Add --tagbase option to tag plugin.
324 * Add exclude option in setup files, works same as --exclude.
325 * Put categories in rss feeds for tagged items.
326 * Allow preprocessor directives to be expanded in inlined blog pages.
327 However, to avoid inlining loops etc, don't expand inline directives in
329 * fortune plugin (trivial)
330 * Tag plugins according to type.
332 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
334 ikiwiki (1.11) unstable; urgency=low
336 * Patch from Enrico that
337 - Adds a tag plugin that allows more easily tagging pages.
338 The meta plugin can also still be used for that, but the tag plugin
339 also lists a page's tags at the bottom of the page.
340 - Allows preprocessor directives to have parameters with no specified
342 - Fixes preprocessor directive parameter parsing so that
343 foo=bar baz now means "foo=bar" and a "baz" with no value.
344 * Run pagetemplate hooks when inlining pages so that inlined pages also
346 * Make all plugins with pagetemplate hooks check that variables exist
347 on the template before setting them, for robustness.
348 * Switch pagetemplate hooks to using named parameters.
349 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
350 This will be the page that a source page will be part of, which is
351 different than the source page for inlined pages.
352 * Audited all plugins to endure they pass (page, destpage) to htmllink
353 appropriatly. This means inlining of various plugins will not work
354 properly, with correct links generated.
356 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
358 ikiwiki (1.10) unstable; urgency=low
360 * Run page through any relevant filters when generating a page preview.
361 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
362 default throughout the wiki, not only on wikitext pages. Decided to call
363 this a feature, and split the camelcase support out into a separate plugin
364 that is independant of wikitext.
365 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
367 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
369 ikiwiki (1.9) unstable; urgency=low
371 * Improve display of parentlinks and page title of toplevel index page.
372 * Patch from Faidon to use svn --limit when possible for recentchanges,
373 speeds up recentchanges a lot for wikis with more history.
374 * Patch from Recai to fix utf8 issues in git backend.
375 * Add wikitext markup plugin, which supports ".wiki" pages written in the
376 original wiki syntax, CamelCase links and all.
377 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
378 support, to edit pages etc without a web server.
379 * Display CGI processing errors if present.
380 * Fix from Faidon for a XML parser issue that breaks utf-8 for
381 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
382 area, and also way slow.
383 * Match 'web commit from' in SVN and git, these are web commits too.
385 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
386 readable and avoid future mistakes. The patch seems to work and for the
387 first time I have a UTF-8 username ;-) (Faidon)
388 * Use form->field consistently, not form->param.
389 * Patch from Recai to allow selection of page type when creating a new page.
390 Default page type is inherited from the link clicked on to create the new
393 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
395 ikiwiki (1.8) unstable; urgency=low
397 * Fix orphans plugin to not count a link to a nonexistant page as a reason
398 for a page not being an orphan.
399 * Support pinging services such as Technorati using XML-RPC to notify them
400 about changes to rss feeds.
401 * Parse svn log as xml for improved utf8 and security. Note that this makes
402 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
403 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
404 flagged string even if the locale causes it to generate utf8 output,
405 so make sure to let perl know it should be handled as utf8. Also,
406 the optimised version used for standard time formats won't work if the
407 user has changed locale, so drop it. Thanks, Faidon Liambotis.
408 * Fix re-encoding of the comments field to utf8 if a commit fails
409 due to a conflict. Thanks, Faidon Liambotis.
410 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
412 * Add insane double encode/decode to utf8 around call to markdown.
413 This works around a truely strange bug, which is apparently a bug in
414 perl, #376329. Also added a test case for it.
415 * Improve layout of edit page so formatting help link is always visible w/o
416 getting in the way of the preview.
417 * Centralised all calls to HTML::Template and force all the templates
419 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
420 * Introduce add_plugins and disable_plugins config options in setup files.
421 This allows adding or removing plugins w/o overriding the whole list of
422 default plugins, which makes it easier to upgrade when new default plugins
424 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
425 default (of course!). Based on a patch by Faidon Liambotis.
426 * Add a html plugin, which can be used to write wikis in raw html,
427 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
428 defaults to not processing .html files, since w/o this plugin they would
429 be copied unsanitised. With this plugin, it will process and html
430 sanitise them, like any other page type.
431 * Rebuilding wrappers is necessary on upgrade to this version.
432 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
433 will be automatically done on all upgrades.
434 * Don't send pings if the wiki is being rebuilt.
435 * Work around very innefficient behavior in File::Spec::abs2rel. Result
436 is a savings of 2 pointless fork/execs per link calculation, which
437 results in ~25% speedup of ikiwiki building its own doc wiki, and
438 about 35% speedup displaying RecentChanges!
439 * Make RecentChanges use a table and some CSS, should be much more readable.
440 No code changes involved.
441 * Encode & in diffurl in examples, to conform to pedantic rules.
442 * Speed up RecentChanges by another 40% or so with some memoization.
443 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
444 in time to build the doc wiki.
446 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
448 ikiwiki (1.7) unstable; urgency=low
450 * Updated logo from Recai with some kerning and alingment tuning.
451 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
455 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
457 ikiwiki (1.6) unstable; urgency=low
459 * YA utf-8 patch from Recai, this time to fix previewing a page so that
460 the text in the input box is re-encoded back to utf-8.
461 * -CSD does not affect modules, so readfile() was not using the utf-8 input
462 layer, which led to lots of problems; make it force read files as utf-8.
464 * Note that as a consequence, this version of ikiwiki will actually try to
465 parse utf8 in source files for the first time, which may expose broken
466 utf8 in wiki sources that was hidden before. Most common will be
467 perl warnings like "utf8 "\xE9" does not map to Unicode"
468 * writefile() likewise needs to use the utf8 output layer.
469 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
471 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
472 given the readfile fix.
473 * Add utf-8 testcases for readfile and htmlize.
474 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
476 * More utf-8 fixes from Recai, partly to things I broke above:
477 - The serious problem is that writefile() saves the content in undecoded
478 format in CGI, hence all (non-ascii) chars are corrupted permanently.
479 - Comment field in edit page is not decoded and all the non-ascii chars in
480 this field are corrupted as the result. We should decode it as we do it
482 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
484 * New SVG logo from Recai.
486 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
488 ikiwiki (1.5) unstable; urgency=low
490 * Add --timeformat config option to allow changing how dates are displayed.
491 Note that as a side effect, dates will now be displayed using the local
492 timezone, not as GMT.
493 * More security review.
494 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
495 for some handy stuff like:
496 - Using links as a kind of tag; creating blog pages that list all pages
497 containing a given tag/link or not containing some other tag.
498 - Subscribing to mail notifications whenever a change is made to a page
499 that is a backlink of page foo. Ie, "Please notify me of changes in all
500 pages that link to my home page in the wiki"
501 - Locking any pages that are linked to from a particular page, so that
502 lists of locks can be exposed in the wiki.
503 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
504 when a todo item is done, instead of the previous moving it to a different
506 * Allow pagetemplate plugins to override *anything* in the template.
507 * Add a meta plugin, which allows specifying various metadata about pages,
508 like license and author. It also allows for inserting html link and meta
509 tags into html, overriding the title, and adding hidden WikiLinks, which
510 can be useful when using link-based globbing for page categorisation.
511 * Remove preprocessor directives from inlined pages.
512 * Allow simple preprocessor directive values to be specified w/o quotes.
513 * Add support for using git instead of subversion as the RCS backend,
514 tremendous thanks to Recai Oktaş for this.
515 * Doc updates for git.
516 * Fix absolute url munging in rss generation to support https, ftp, etc urls
518 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
519 utf-8 for edit and other fields, and for recentchanges. There may still
520 be utf-8 issues with the preferences page though.
522 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
524 ikiwiki (1.4) unstable; urgency=low
526 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
527 very strange way of enabling proper XHTML <br /> type tags. Output html
528 should be always valid again now.
529 * The page name and parent links has switched from using a <h1> to a styled
530 <span>, so pages can use <h1> internally instead of needing to use <h2>.
531 * Updated all of ikiwiki's own wiki pages for that.
532 * Add pagetemplate hook, which can be used by plugins that want to mess
533 around with adding new stuff to the page template.
534 * Remove headercontent; the search plugin now adds the search box to the
535 header by registering a pagetemplate hook, and other plugins should do
537 * Rebuilding on upgrade to this version is recommended.
538 * Add a html validity check to the test suite, using the wdg-html-validator,
540 * Make the html valid when there is nothing in the actions list.
541 * Reordered some function call parameters for consistency.
542 * Enable full utf-8 support for page input and output.
543 * Add a workaround for markdown, which does not work well with utf-8
545 * --getctime had bitrotted (well I only ever used it the once so far..),
546 fix and make it a bit more flexible
547 * rcs_getctime is changed, now rather than needing to loop over all pages,
548 it should just use the rcs to get the ctime of the passed file.
549 * When inlining a page in another one, links from the inlined page are now
550 expanded the same as they are when rendering the inlined page as a
551 standalone page. So rather than being expanded from the POV of the
552 inlining page, they are expanded from the POV of the inlined page.
554 For example, a link from blog/foo to "bar" will now link to blog/bar
555 if it exists. Previously this needed to be a link explicitly to
556 "blog/bar"; such links will also continue to work.
558 (This was slightly complex to do as the link still has to be constructed
559 relative to the inlining page.)
560 * Make page edit textarea resize to fit browser window.
561 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
562 do not need a full rebuild, in order to update any basewiki pages.
564 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
566 ikiwiki (1.3) unstable; urgency=low
568 * Fix the preinst introduced in the last version. Closes: #367458
570 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
572 ikiwiki (1.2) unstable; urgency=low
574 * Remove dups from the brokenlinks list.
575 * Add libc6-dev to dependencies, needed to build wrappers.
576 * Install wikilist in correct location. Closes: #367371
578 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
580 ikiwiki (1.1) unstable; urgency=low
582 * Rename inlinepage to depends, so that it can be used to refer to more
583 dependency relationships than just inlining. This will require a rebuild
584 on upgrade to this version.
585 * Move the rss link, put it in the blogpost form if there is one and at the
586 top if not. This is both nicer because easier to find, and it cleans up
587 the code which had used inlinepage as a flag for adding the link later.
588 * Allow the depends GlobList to be built up from multiple sources (such as
589 plugins) during a page render.
590 * Which means that more than one blog is now supported to appear on a
591 single page. (With some limitations, like only the last one getting an
593 * Added a plugin system.
594 * Added a pagecount plugin, enabled by default.
595 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
596 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
597 backlinks when the backlinks hadn't really changed.
598 * Moved inline page support, rss generation etc into the inline plugin,
600 * Added brokenlinks plugin, not enabled by default, but rather handy.
601 * Fix several broken links in the doc wiki.
602 * Smarter behavior when creating a page and a page of the same name (but
603 different location) already exists.
604 * Add an orphans plugin for finding pages that nothing links to.
605 * Removed backlinks page, which it turns out nothing used.
606 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
607 it, this will allow for adding a unit test suite.
608 * Add unit tests for several core functions, including globlist_match,
609 dirname, basename, bestlink, linkify, pagetitle, titlepage.
610 * Smart globlist merging.
611 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
612 to pave the way for adding other RCS support. This also changes the
613 setup files, where before they had svn => 1 or svn => 0, now they have
614 rcs => "svn" or rcs => "".
615 * Add a debian/NEWS file with upgrade notes.
616 * Load whatever rcs module is specified, so new ones can be just dropped in
617 as plugins and work. (Well, in theory.)
618 * Add some basic docs about writing RCS modules.
619 * Broke search capability out into a plugin, removed the --hyperestraier
621 * Added smiley plugin, nicely controlled and documented by the smileys page.
622 * Copied in some smileys from Moin Moin.
623 * Allow links of the form [[some page|page]], with whitespace in the link
625 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
626 and --disable-plugin htmlscrubber.
627 * Allow discussion links on pages to be turned off with --no-discussion.
628 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
629 * Add some new config items to the estseek.conf template, which are needed
630 by hyperestraier 1.2.3.
632 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
634 ikiwiki (1.0) unstable; urgency=low
636 * First official release.
638 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400