1 ikiwiki (1.27) UNRELEASED; urgency=low
3 * Add a googlecalendar plugin. A bit special-purpose, but it shows
4 one way to to deal with user-supplied content that could cause XSS
5 issues w/o the htmlscrubber, and won't survive the scrubber.
6 * Work on firming up the plugin interface:
7 - Plugins should not need to load IkiWiki::Render to get commonly
8 used functions, so moved some functions from there to IkiWiki.
9 - Picked out the set of functions and variables that most plugins
10 use, documented them, and made IkiWiki export them by default,
11 like a proper perl module should.
12 - Use the other functions at your own risk.
13 - This is not quite complete, I still have to decide whether to
14 export some other things.
15 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
16 referring to stuff now exported by the IkiWiki module.
17 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
18 to declare which version of the interface your plugin needs.
19 * Anyone with a third-party ikiwiki plugin is strongly encouraged
20 to make like changes to it and avoid use of non-exported symboles from
22 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
23 * Support hyperestradier version 1.4.2, which adds a new required phraseform
25 * If an inlined page has a permalink, link the page title to that.
26 * Patch from Recai to use utf8 when reading the setup file, so that
27 utf8 wikinames from there will be used properly.
28 * Patch from Recai to kill utf-8 on the wiki name when generating the
30 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
32 -- Joey Hess <joeyh@debian.org> Thu, 14 Sep 2006 18:25:27 -0400
34 ikiwiki (1.26) unstable; urgency=low
36 * Add a missing -n to tla undo call.
37 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
38 writes before consuming its whole stdin. Avoid this deadlock.
39 * Fix alt tags for outline checkboxes.
41 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
43 ikiwiki (1.25) unstable; urgency=low
45 * Add proper waitpid calls for open2ed processes throughout to avoid
46 zombies; this hit htmltidy especially badly.
47 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
48 subversion repos and fixing some other issues.
49 * Add support for tla, contributed by Clint Adams. Closes: #385936
50 * Add support for mercurial, contributed by Emanuele Aina.
51 * Include <link rel> tag for RSS feeds, used by some aggregators and
52 firefox to find the feed.
53 * Add a linkmap plugin (requires graphviz).
55 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
57 ikiwiki (1.24) unstable; urgency=low
59 * Simplify the data structure returned by rcs_recentchanges to avoid
60 each rcs plugin needing to form complex strings on its own.
61 * Fix another destpage issue in the inline directive. Closes: #385512
64 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
66 ikiwiki (1.23) unstable; urgency=low
68 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
70 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
72 ikiwiki (1.22) unstable; urgency=low
74 * Change how the stylesheet url is determined in the templates: Remove
75 STYLEURL and add BASEURL to all templates (some already had it). This
76 new more general variable can be used to link to other things (eg, images)
77 from the template, as well as stylesheets.
78 * Fix a bug introduced last version to do with nested inlines.
79 * Allow preprocessor directives to span multiple lines, both to make
80 long ones with lots of values easier to write, and to allow for ones with
81 multi-line quoted values.
82 * Allow preprocessor directives to contain python-like triple-quoted
83 text blocks, for easy nesting of quotes inside.
84 * Add a template plugin.
85 * Make pagespec merge code smarter about merging duplicate pagespecs.
86 * Patch from Jordà Polo to make Setup::Standard support hashes in config
88 * Change order of linkify and preprocess; first preprocess and then linkify.
89 This allows passing a wikilink inside a parameter to a preprocessor
90 directive without it being expanded to html, and leaking out of the
91 parameter, which had required some non-obvious use of triple-quoting
92 to avoid. Note that any preprocessor plugins that output something
93 that looks like a wikilink will now have it treated as such; AFAIK
94 this doesn't change any behavior though except for the template plugin.
95 * Enable preprocessor directives when previewing an edit.
96 * Make all pages pull in a local.css style sheet, if present. This won't
97 be included in ikiwiki, but can be created to make local styling changes
98 w/o needing to merge in every new change to the distributed style.css.
99 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
100 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
101 from a different directory.
102 * Generalised preprocesser loop protection code.
103 * Patch from James Westby to allow a description to be set for rss feeds.
104 * Patch from James Westby to add a template for the search form.
105 * Added a ddate plugin.
106 * Patch from James Westby to add a --sslcookie switch, which forces
107 cookies to only be sent over ssl connections to avoid interception.
108 * Fix preferences page on anonok wikis; still need to sign in to get
109 to the preferences page.
110 * Add toc (table of contents) plugin.
111 * Change htmlize, format, and sanitize hooks to use named parameters.
112 * Patch from James Westby to add an actions option to inline; this
113 adds Edit and Discussion links at the end of blog entries.
114 * Due to some css changes, you'll want to rebuild your wiki on upgrade
115 to this version. Will be handled automatically by the deb.
116 * Add processed date to aggregate preprocessor directive status output.
118 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
120 ikiwiki (1.21) unstable; urgency=low
122 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
123 * If a page links to itself, mark up the link text in a span with
124 class="selflink" so that it can be styled. I don't have a useful style
125 defined for that though.
126 * Call filter hooks on inlined page content.
127 * Support inlining pages raw, rather than creating a blog.
128 * Clean up yes/no parameter parsing in inline plugin.
129 * Implemented better cycle detection in the inline plugin; nested inlines
131 * Add a map plugin contributed by Alessandro Dotti Contra.
132 * Add otl format plugin, which handles files as created by vimoutliner.
133 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
134 * Add first draft at a Restructured Text (rst) plugin, by Sergio
135 Talens-Oliag. Note that this has many known issues -- see the caveats on
137 * Credit everyone who wrote a plugin on the plugins' wiki pages.
138 * Fix utf-8 in blog post form.
140 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
142 ikiwiki (1.20) unstable; urgency=low
144 * Relicense the templates and basewiki under the 2-clause BSD license.
145 Since these can easily become part of other people's websites, they
146 should be under as permissive a license as possible.
147 * Add --syslog config option, to log to the syslog.
148 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
149 transient failure to fork (which I've seen happen in the wild).
150 * Fix a bug in the aggregator introduced last version that caused all
151 aggregator state to be lost during a non-aggregating build.
153 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
155 ikiwiki (1.19) unstable; urgency=low
157 * Fix several related bugs in page type determination during online editing.
158 * Add some locking to prevent 2 aggregators from running at once.
159 * Fix an infinite loop in the aggregator when finding a unique filename.
161 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
163 ikiwiki (1.18) unstable; urgency=low
165 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
167 * Man page format fixups.
168 * If the meta plugin overides the page title, set a title_overridden
169 variable in the template to true. This allows doing things with the
170 templates conditional on the title being overriden.
171 * Add a %pagecase which maps lower-case page names to the actual case
172 used in the filename. Use this in bestlinks calculation instead of
173 forcing the link to lowercase.
174 * Also use %pagecase in various other places that want to check if a page
175 with a given name exists.
176 * This means that links to pages with mixed case names will now work,
177 even if the link is in some other case mixture, and mixed case pages
178 should be fully supported throughout ikiwiki.
179 * Recommend rebuilding wikis on upgrade to this version.
181 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
183 ikiwiki (1.17) unstable; urgency=low
185 * Disable tidy generator tag.
186 * Move tidy back to sanitize hook, found out how to only show body.
187 * Turn off tidy indentation too.
188 * Turn on HTML::Template loop_context_vars; not actually used in stock
189 templates but can be useful for things like making comma-delimited lists
190 of tags or what have you.
191 * Remove <br> from end of aggregate preprocessor directive output.
192 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
193 case-sensative filesystems like OSX.
194 * Improve markdown loading. First, try to load it as a proper perl module,
195 in case it was installed as one. Then fall back to trying
197 * Document in install page how to install markdown, since it has no
198 installation procedure in the upstream tarball.
199 * Set die_on_bad_params => 0 for all templates, to allow users to modify
200 them without annoyances.
201 * Suck in the page content when generating an inline archive page, to work
202 around the meta plugin's lack of caching of title metadata across runs.
204 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
206 ikiwiki (1.16) unstable; urgency=low
208 * Try to handle relative links in aggregated feeds. However,
209 the current support is a crude hack due to limitations of XML::Feed:
210 xml:base is not supported, neither is Content-Location. And of course,
211 relative links in RSS feeds are ill-undefined..
212 * Make aggregator save permalinks and author name to pages as metadata.
213 * Add permalink and author support to meta plugin, affecting RSS feeds
215 * Various CSS and formatting changes.
216 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
217 * Add xhtml files to the default prune regexp.
218 * Also generate rel=bookmark links for permalinks.
219 * Fix the htmltidy plugin, which wasn't working due my breaking it when
221 * Don't run tidy with -xml as that fails if the input is not well-formed.
222 Run it with -asxhtml instead, so it will output well-formed xhtml no
223 matter what the input.
224 * Disable tidy warnings too.
225 * Add a new format hook, and make tidy use it, since tidy can really only
226 operate on and output complete html documents, not the body chunks
228 * Fix dates in rss feeds if running localised, so they're still rfc 822.
230 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
232 ikiwiki (1.15) unstable; urgency=low
234 * Remove CDPATH and other env vars perl taint checking doesn't like.
236 * Added created_before and created_after PageSpec limits.
238 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
240 ikiwiki (1.14) unstable; urgency=low
242 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
244 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
245 * Added many unit tests for pagespec_match.
247 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
249 ikiwiki (1.13) unstable; urgency=low
251 * ikiwiki can now download and aggregate feeds with its new aggregate
252 plugin, so it's possible to implement a Planet using ikiwiki!
253 * Add a run_hooks function for the common task of running all hooks of a
255 * Add a savestate hook.
256 * Don't put blog post forms on pages if there's no cgiurl set.
257 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
258 --wrappers to do that.
259 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
260 to update pages that haven't changed on disk.
261 * Change meta tags to use html entity-escaped text for values, so that
262 quotes and such can be represented in title tags.
263 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
265 * Make --rebuild also cause --aggregate to re-download and write aggregated
267 * Avoid outputting duplicate meta info.
268 * Include title metadata on aggregated posts for capitalised and un-munged
270 * Title metadata of inlined pages now shows up in blogs and rss feeds.
271 * Fix issue with unicode filenames and updating the hyper estradier search
272 index. (Aka Please Please Please, let that be the last one.)
273 * Patch from Roland Mas to support an rss=no parameter to inline directives.
275 * Renamed GlobLists to PageSpecs.
276 * PageSpecs can now include nested parens, "and", and "or". This remains
277 backwards compatible to the old GlobList format. It's implemented by
278 treating the GlobList as a very limited microlanguage that is transformed
279 to perl code that does the matching.
280 * The old GlobList format is deprecated, and I encourage users to switch to
281 using the new PageSpec format. Compatability with the old format will be
282 removed at some point, possibly by 2.0.
283 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
284 * Add support for creation_month and creation_year to PageSpec.
286 * Changes to index file encoding.
288 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
290 ikiwiki (1.12) unstable; urgency=low
293 * New pagestats plugin from Enrico, which can generate a table counting
294 the backlinks for each page, or a del.icio.us style cloud.
295 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
296 the wikiformat plugin works. Thanks, Emanuele Aina.
297 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
298 display, running them through pagetitle. This removes ugly underscores and
299 other gunk from the display, much nicer. You may want to rebuild your wiki
300 when upgrading to get the cleanup globally.
301 * Polygen plugin from Enrico.
302 * htmltidy plugin from Faidon.
303 * Locale patch from Faidon:
304 - Adds a locale setting to setup files.
305 - Proper local time, if the locale configuration option is used.
306 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
307 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
309 * Add getopt hook type, this allows plugins to add new command-line options.
310 * Add --tagbase option to tag plugin.
311 * Add exclude option in setup files, works same as --exclude.
312 * Put categories in rss feeds for tagged items.
313 * Allow preprocessor directives to be expanded in inlined blog pages.
314 However, to avoid inlining loops etc, don't expand inline directives in
316 * fortune plugin (trivial)
317 * Tag plugins according to type.
319 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
321 ikiwiki (1.11) unstable; urgency=low
323 * Patch from Enrico that
324 - Adds a tag plugin that allows more easily tagging pages.
325 The meta plugin can also still be used for that, but the tag plugin
326 also lists a page's tags at the bottom of the page.
327 - Allows preprocessor directives to have parameters with no specified
329 - Fixes preprocessor directive parameter parsing so that
330 foo=bar baz now means "foo=bar" and a "baz" with no value.
331 * Run pagetemplate hooks when inlining pages so that inlined pages also
333 * Make all plugins with pagetemplate hooks check that variables exist
334 on the template before setting them, for robustness.
335 * Switch pagetemplate hooks to using named parameters.
336 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
337 This will be the page that a source page will be part of, which is
338 different than the source page for inlined pages.
339 * Audited all plugins to endure they pass (page, destpage) to htmllink
340 appropriatly. This means inlining of various plugins will not work
341 properly, with correct links generated.
343 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
345 ikiwiki (1.10) unstable; urgency=low
347 * Run page through any relevant filters when generating a page preview.
348 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
349 default throughout the wiki, not only on wikitext pages. Decided to call
350 this a feature, and split the camelcase support out into a separate plugin
351 that is independant of wikitext.
352 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
354 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
356 ikiwiki (1.9) unstable; urgency=low
358 * Improve display of parentlinks and page title of toplevel index page.
359 * Patch from Faidon to use svn --limit when possible for recentchanges,
360 speeds up recentchanges a lot for wikis with more history.
361 * Patch from Recai to fix utf8 issues in git backend.
362 * Add wikitext markup plugin, which supports ".wiki" pages written in the
363 original wiki syntax, CamelCase links and all.
364 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
365 support, to edit pages etc without a web server.
366 * Display CGI processing errors if present.
367 * Fix from Faidon for a XML parser issue that breaks utf-8 for
368 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
369 area, and also way slow.
370 * Match 'web commit from' in SVN and git, these are web commits too.
372 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
373 readable and avoid future mistakes. The patch seems to work and for the
374 first time I have a UTF-8 username ;-) (Faidon)
375 * Use form->field consistently, not form->param.
376 * Patch from Recai to allow selection of page type when creating a new page.
377 Default page type is inherited from the link clicked on to create the new
380 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
382 ikiwiki (1.8) unstable; urgency=low
384 * Fix orphans plugin to not count a link to a nonexistant page as a reason
385 for a page not being an orphan.
386 * Support pinging services such as Technorati using XML-RPC to notify them
387 about changes to rss feeds.
388 * Parse svn log as xml for improved utf8 and security. Note that this makes
389 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
390 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
391 flagged string even if the locale causes it to generate utf8 output,
392 so make sure to let perl know it should be handled as utf8. Also,
393 the optimised version used for standard time formats won't work if the
394 user has changed locale, so drop it. Thanks, Faidon Liambotis.
395 * Fix re-encoding of the comments field to utf8 if a commit fails
396 due to a conflict. Thanks, Faidon Liambotis.
397 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
399 * Add insane double encode/decode to utf8 around call to markdown.
400 This works around a truely strange bug, which is apparently a bug in
401 perl, #376329. Also added a test case for it.
402 * Improve layout of edit page so formatting help link is always visible w/o
403 getting in the way of the preview.
404 * Centralised all calls to HTML::Template and force all the templates
406 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
407 * Introduce add_plugins and disable_plugins config options in setup files.
408 This allows adding or removing plugins w/o overriding the whole list of
409 default plugins, which makes it easier to upgrade when new default plugins
411 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
412 default (of course!). Based on a patch by Faidon Liambotis.
413 * Add a html plugin, which can be used to write wikis in raw html,
414 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
415 defaults to not processing .html files, since w/o this plugin they would
416 be copied unsanitised. With this plugin, it will process and html
417 sanitise them, like any other page type.
418 * Rebuilding wrappers is necessary on upgrade to this version.
419 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
420 will be automatically done on all upgrades.
421 * Don't send pings if the wiki is being rebuilt.
422 * Work around very innefficient behavior in File::Spec::abs2rel. Result
423 is a savings of 2 pointless fork/execs per link calculation, which
424 results in ~25% speedup of ikiwiki building its own doc wiki, and
425 about 35% speedup displaying RecentChanges!
426 * Make RecentChanges use a table and some CSS, should be much more readable.
427 No code changes involved.
428 * Encode & in diffurl in examples, to conform to pedantic rules.
429 * Speed up RecentChanges by another 40% or so with some memoization.
430 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
431 in time to build the doc wiki.
433 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
435 ikiwiki (1.7) unstable; urgency=low
437 * Updated logo from Recai with some kerning and alingment tuning.
438 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
442 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
444 ikiwiki (1.6) unstable; urgency=low
446 * YA utf-8 patch from Recai, this time to fix previewing a page so that
447 the text in the input box is re-encoded back to utf-8.
448 * -CSD does not affect modules, so readfile() was not using the utf-8 input
449 layer, which led to lots of problems; make it force read files as utf-8.
451 * Note that as a consequence, this version of ikiwiki will actually try to
452 parse utf8 in source files for the first time, which may expose broken
453 utf8 in wiki sources that was hidden before. Most common will be
454 perl warnings like "utf8 "\xE9" does not map to Unicode"
455 * writefile() likewise needs to use the utf8 output layer.
456 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
458 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
459 given the readfile fix.
460 * Add utf-8 testcases for readfile and htmlize.
461 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
463 * More utf-8 fixes from Recai, partly to things I broke above:
464 - The serious problem is that writefile() saves the content in undecoded
465 format in CGI, hence all (non-ascii) chars are corrupted permanently.
466 - Comment field in edit page is not decoded and all the non-ascii chars in
467 this field are corrupted as the result. We should decode it as we do it
469 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
471 * New SVG logo from Recai.
473 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
475 ikiwiki (1.5) unstable; urgency=low
477 * Add --timeformat config option to allow changing how dates are displayed.
478 Note that as a side effect, dates will now be displayed using the local
479 timezone, not as GMT.
480 * More security review.
481 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
482 for some handy stuff like:
483 - Using links as a kind of tag; creating blog pages that list all pages
484 containing a given tag/link or not containing some other tag.
485 - Subscribing to mail notifications whenever a change is made to a page
486 that is a backlink of page foo. Ie, "Please notify me of changes in all
487 pages that link to my home page in the wiki"
488 - Locking any pages that are linked to from a particular page, so that
489 lists of locks can be exposed in the wiki.
490 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
491 when a todo item is done, instead of the previous moving it to a different
493 * Allow pagetemplate plugins to override *anything* in the template.
494 * Add a meta plugin, which allows specifying various metadata about pages,
495 like license and author. It also allows for inserting html link and meta
496 tags into html, overriding the title, and adding hidden WikiLinks, which
497 can be useful when using link-based globbing for page categorisation.
498 * Remove preprocessor directives from inlined pages.
499 * Allow simple preprocessor directive values to be specified w/o quotes.
500 * Add support for using git instead of subversion as the RCS backend,
501 tremendous thanks to Recai Oktaş for this.
502 * Doc updates for git.
503 * Fix absolute url munging in rss generation to support https, ftp, etc urls
505 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
506 utf-8 for edit and other fields, and for recentchanges. There may still
507 be utf-8 issues with the preferences page though.
509 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
511 ikiwiki (1.4) unstable; urgency=low
513 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
514 very strange way of enabling proper XHTML <br /> type tags. Output html
515 should be always valid again now.
516 * The page name and parent links has switched from using a <h1> to a styled
517 <span>, so pages can use <h1> internally instead of needing to use <h2>.
518 * Updated all of ikiwiki's own wiki pages for that.
519 * Add pagetemplate hook, which can be used by plugins that want to mess
520 around with adding new stuff to the page template.
521 * Remove headercontent; the search plugin now adds the search box to the
522 header by registering a pagetemplate hook, and other plugins should do
524 * Rebuilding on upgrade to this version is recommended.
525 * Add a html validity check to the test suite, using the wdg-html-validator,
527 * Make the html valid when there is nothing in the actions list.
528 * Reordered some function call parameters for consistency.
529 * Enable full utf-8 support for page input and output.
530 * Add a workaround for markdown, which does not work well with utf-8
532 * --getctime had bitrotted (well I only ever used it the once so far..),
533 fix and make it a bit more flexible
534 * rcs_getctime is changed, now rather than needing to loop over all pages,
535 it should just use the rcs to get the ctime of the passed file.
536 * When inlining a page in another one, links from the inlined page are now
537 expanded the same as they are when rendering the inlined page as a
538 standalone page. So rather than being expanded from the POV of the
539 inlining page, they are expanded from the POV of the inlined page.
541 For example, a link from blog/foo to "bar" will now link to blog/bar
542 if it exists. Previously this needed to be a link explicitly to
543 "blog/bar"; such links will also continue to work.
545 (This was slightly complex to do as the link still has to be constructed
546 relative to the inlining page.)
547 * Make page edit textarea resize to fit browser window.
548 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
549 do not need a full rebuild, in order to update any basewiki pages.
551 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
553 ikiwiki (1.3) unstable; urgency=low
555 * Fix the preinst introduced in the last version. Closes: #367458
557 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
559 ikiwiki (1.2) unstable; urgency=low
561 * Remove dups from the brokenlinks list.
562 * Add libc6-dev to dependencies, needed to build wrappers.
563 * Install wikilist in correct location. Closes: #367371
565 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
567 ikiwiki (1.1) unstable; urgency=low
569 * Rename inlinepage to depends, so that it can be used to refer to more
570 dependency relationships than just inlining. This will require a rebuild
571 on upgrade to this version.
572 * Move the rss link, put it in the blogpost form if there is one and at the
573 top if not. This is both nicer because easier to find, and it cleans up
574 the code which had used inlinepage as a flag for adding the link later.
575 * Allow the depends GlobList to be built up from multiple sources (such as
576 plugins) during a page render.
577 * Which means that more than one blog is now supported to appear on a
578 single page. (With some limitations, like only the last one getting an
580 * Added a plugin system.
581 * Added a pagecount plugin, enabled by default.
582 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
583 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
584 backlinks when the backlinks hadn't really changed.
585 * Moved inline page support, rss generation etc into the inline plugin,
587 * Added brokenlinks plugin, not enabled by default, but rather handy.
588 * Fix several broken links in the doc wiki.
589 * Smarter behavior when creating a page and a page of the same name (but
590 different location) already exists.
591 * Add an orphans plugin for finding pages that nothing links to.
592 * Removed backlinks page, which it turns out nothing used.
593 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
594 it, this will allow for adding a unit test suite.
595 * Add unit tests for several core functions, including globlist_match,
596 dirname, basename, bestlink, linkify, pagetitle, titlepage.
597 * Smart globlist merging.
598 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
599 to pave the way for adding other RCS support. This also changes the
600 setup files, where before they had svn => 1 or svn => 0, now they have
601 rcs => "svn" or rcs => "".
602 * Add a debian/NEWS file with upgrade notes.
603 * Load whatever rcs module is specified, so new ones can be just dropped in
604 as plugins and work. (Well, in theory.)
605 * Add some basic docs about writing RCS modules.
606 * Broke search capability out into a plugin, removed the --hyperestraier
608 * Added smiley plugin, nicely controlled and documented by the smileys page.
609 * Copied in some smileys from Moin Moin.
610 * Allow links of the form [[some page|page]], with whitespace in the link
612 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
613 and --disable-plugin htmlscrubber.
614 * Allow discussion links on pages to be turned off with --no-discussion.
615 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
616 * Add some new config items to the estseek.conf template, which are needed
617 by hyperestraier 1.2.3.
619 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
621 ikiwiki (1.0) unstable; urgency=low
623 * First official release.
625 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400