1 ikiwiki (1.29) UNRELEASED; urgency=low
3 * Patch from Paul Tötterman to use CP in the Makefile.
4 * Patch from Alec Berryman adding a http_auth config item that allows
5 using HTTP Authentication instead of ikiwiki's built in authentication.
6 Useful for eg, large sites with their own previously existing user auth
8 * Change %renderedfiles to store an array of files rendered from a given
9 source file, to allow tracking of extra rendered files like rss feeds.
10 * Note that plugins that accessed this variable will need to be updated!
11 The plugin interface has been increased to version 1.01 for this change.
12 As few plugins use %renderedfiles I haven't done anything else to ensure
13 compatability of old plugins.
14 * Add will_render function to the plugin interface, used to register that a
15 page renders a destination file, and do some security checks. Previously
16 but no longer rendered files will be cleaned up.
17 * Use will_render in the inline and linkmap plugins.
18 * You will need to rebuild your wiki on upgrade to this version.
20 -- Joey Hess <joeyh@debian.org> Sun, 8 Oct 2006 16:53:17 -0400
22 ikiwiki (1.28) unstable; urgency=low
24 * inline: Add ability to sort by page name, based on a patch from
26 * Fix a forkbomb in various calls to IPC::Open2, which has a highly
27 braindead interface. Closes: #389383
28 * Don't rm -rf ikiwiki on distclean, since a) there's no such file
29 and b) those poor Mac OSX users and their case insensative files!
30 * Don't fail syntax check if Text::Typography isn't installed.
33 -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
35 ikiwiki (1.27) unstable; urgency=low
37 * Work on firming up the plugin interface:
38 - Plugins should not need to load IkiWiki::Render to get commonly
39 used functions, so moved some functions from there to IkiWiki.
40 - Picked out the set of functions and variables that most plugins
41 use, documented them, and made IkiWiki export them by default,
42 like a proper perl module should.
43 - Use the other functions at your own risk.
44 - This is not quite complete, I still have to decide whether to
45 export some other things.
46 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
47 referring to stuff now exported by the IkiWiki module.
48 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
49 to declare which version of the interface your plugin needs.
50 * Anyone with a third-party ikiwiki plugin is strongly encouraged
51 to make like changes to it and avoid use of non-exported symbols from
53 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
54 * Support hyperestradier version 1.4.2, which adds a new required phraseform
56 * If an inlined page has a permalink, link the page title to that.
57 * Patch from Recai to use utf8 when reading the setup file, so that
58 utf8 wikinames from there will be used properly.
59 * Patch from Recai to kill utf-8 on the wiki name when generating the
61 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
62 * Fix a baseurl problem in hyperestradier search results.
63 * Add a stub local.css to avoid problems with 404's.
64 * Patch from Recai to fix a wide character warning from the search plugin
65 during setup if the wikiname contains utf8.
66 * Yet another fix for those poor case-insensative OS X users.
67 * pagetemplate hooks are now also called when generating cgi pages.
68 * Add a favicon plugin, which simply adds a link tag for an icon to each
70 * Patch from James Westby to deal with the case where you're editing a
71 new page, hit cancel, and need to be redirected to somewhere sane.
72 * Various documentation improvements by various wiki users.
73 * Support Text::Markdown from CPAN, which has a different interface from
74 the original markdown or the one in Debian.
75 * Version the libcgi-session-perl dependency, some features that need
76 the new version are used in some cases (sslcookie).
77 * Numerous tla fixes from Clint.
78 * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
79 a multi-resolution favicon.ico.
80 * README.Debian: typo Closes: #388110
81 * chomp trailing newline at the end of templates read in by the template
82 plugin, to allow use of the template preprocessor directive in
83 whitespace-sensative situations. Closes: #387073
84 * Patch from James Westby to make the location of the estseek.cgi script
86 * Add typography (SmartyPants) plugin by Recai.
87 * Add --render mode, which can be used to preview an edit at the command
88 line by test rendering a single page.
89 * Add a googlecalendar plugin. A bit special-purpose, but it shows
90 one way to to deal with user-supplied content that could cause XSS
91 issues w/o the htmlscrubber, and won't survive the scrubber.
93 -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
95 ikiwiki (1.26) unstable; urgency=low
97 * Add a missing -n to tla undo call.
98 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
99 writes before consuming its whole stdin. Avoid this deadlock.
100 * Fix alt tags for outline checkboxes.
102 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
104 ikiwiki (1.25) unstable; urgency=low
106 * Add proper waitpid calls for open2ed processes throughout to avoid
107 zombies; this hit htmltidy especially badly.
108 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
109 subversion repos and fixing some other issues.
110 * Add support for tla, contributed by Clint Adams. Closes: #385936
111 * Add support for mercurial, contributed by Emanuele Aina.
112 * Include <link rel> tag for RSS feeds, used by some aggregators and
113 firefox to find the feed.
114 * Add a linkmap plugin (requires graphviz).
116 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
118 ikiwiki (1.24) unstable; urgency=low
120 * Simplify the data structure returned by rcs_recentchanges to avoid
121 each rcs plugin needing to form complex strings on its own.
122 * Fix another destpage issue in the inline directive. Closes: #385512
125 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
127 ikiwiki (1.23) unstable; urgency=low
129 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
131 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
133 ikiwiki (1.22) unstable; urgency=low
135 * Change how the stylesheet url is determined in the templates: Remove
136 STYLEURL and add BASEURL to all templates (some already had it). This
137 new more general variable can be used to link to other things (eg, images)
138 from the template, as well as stylesheets.
139 * Fix a bug introduced last version to do with nested inlines.
140 * Allow preprocessor directives to span multiple lines, both to make
141 long ones with lots of values easier to write, and to allow for ones with
142 multi-line quoted values.
143 * Allow preprocessor directives to contain python-like triple-quoted
144 text blocks, for easy nesting of quotes inside.
145 * Add a template plugin.
146 * Make pagespec merge code smarter about merging duplicate pagespecs.
147 * Patch from Jordà Polo to make Setup::Standard support hashes in config
149 * Change order of linkify and preprocess; first preprocess and then linkify.
150 This allows passing a wikilink inside a parameter to a preprocessor
151 directive without it being expanded to html, and leaking out of the
152 parameter, which had required some non-obvious use of triple-quoting
153 to avoid. Note that any preprocessor plugins that output something
154 that looks like a wikilink will now have it treated as such; AFAIK
155 this doesn't change any behavior though except for the template plugin.
156 * Enable preprocessor directives when previewing an edit.
157 * Make all pages pull in a local.css style sheet, if present. This won't
158 be included in ikiwiki, but can be created to make local styling changes
159 w/o needing to merge in every new change to the distributed style.css.
160 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
161 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
162 from a different directory.
163 * Generalised preprocesser loop protection code.
164 * Patch from James Westby to allow a description to be set for rss feeds.
165 * Patch from James Westby to add a template for the search form.
166 * Added a ddate plugin.
167 * Patch from James Westby to add a --sslcookie switch, which forces
168 cookies to only be sent over ssl connections to avoid interception.
169 * Fix preferences page on anonok wikis; still need to sign in to get
170 to the preferences page.
171 * Add toc (table of contents) plugin.
172 * Change htmlize, format, and sanitize hooks to use named parameters.
173 * Patch from James Westby to add an actions option to inline; this
174 adds Edit and Discussion links at the end of blog entries.
175 * Due to some css changes, you'll want to rebuild your wiki on upgrade
176 to this version. Will be handled automatically by the deb.
177 * Add processed date to aggregate preprocessor directive status output.
179 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
181 ikiwiki (1.21) unstable; urgency=low
183 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
184 * If a page links to itself, mark up the link text in a span with
185 class="selflink" so that it can be styled. I don't have a useful style
186 defined for that though.
187 * Call filter hooks on inlined page content.
188 * Support inlining pages raw, rather than creating a blog.
189 * Clean up yes/no parameter parsing in inline plugin.
190 * Implemented better cycle detection in the inline plugin; nested inlines
192 * Add a map plugin contributed by Alessandro Dotti Contra.
193 * Add otl format plugin, which handles files as created by vimoutliner.
194 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
195 * Add first draft at a Restructured Text (rst) plugin, by Sergio
196 Talens-Oliag. Note that this has many known issues -- see the caveats on
198 * Credit everyone who wrote a plugin on the plugins' wiki pages.
199 * Fix utf-8 in blog post form.
201 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
203 ikiwiki (1.20) unstable; urgency=low
205 * Relicense the templates and basewiki under the 2-clause BSD license.
206 Since these can easily become part of other people's websites, they
207 should be under as permissive a license as possible.
208 * Add --syslog config option, to log to the syslog.
209 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
210 transient failure to fork (which I've seen happen in the wild).
211 * Fix a bug in the aggregator introduced last version that caused all
212 aggregator state to be lost during a non-aggregating build.
214 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
216 ikiwiki (1.19) unstable; urgency=low
218 * Fix several related bugs in page type determination during online editing.
219 * Add some locking to prevent 2 aggregators from running at once.
220 * Fix an infinite loop in the aggregator when finding a unique filename.
222 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
224 ikiwiki (1.18) unstable; urgency=low
226 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
228 * Man page format fixups.
229 * If the meta plugin overides the page title, set a title_overridden
230 variable in the template to true. This allows doing things with the
231 templates conditional on the title being overriden.
232 * Add a %pagecase which maps lower-case page names to the actual case
233 used in the filename. Use this in bestlinks calculation instead of
234 forcing the link to lowercase.
235 * Also use %pagecase in various other places that want to check if a page
236 with a given name exists.
237 * This means that links to pages with mixed case names will now work,
238 even if the link is in some other case mixture, and mixed case pages
239 should be fully supported throughout ikiwiki.
240 * Recommend rebuilding wikis on upgrade to this version.
242 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
244 ikiwiki (1.17) unstable; urgency=low
246 * Disable tidy generator tag.
247 * Move tidy back to sanitize hook, found out how to only show body.
248 * Turn off tidy indentation too.
249 * Turn on HTML::Template loop_context_vars; not actually used in stock
250 templates but can be useful for things like making comma-delimited lists
251 of tags or what have you.
252 * Remove <br> from end of aggregate preprocessor directive output.
253 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
254 case-sensative filesystems like OSX.
255 * Improve markdown loading. First, try to load it as a proper perl module,
256 in case it was installed as one. Then fall back to trying
258 * Document in install page how to install markdown, since it has no
259 installation procedure in the upstream tarball.
260 * Set die_on_bad_params => 0 for all templates, to allow users to modify
261 them without annoyances.
262 * Suck in the page content when generating an inline archive page, to work
263 around the meta plugin's lack of caching of title metadata across runs.
265 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
267 ikiwiki (1.16) unstable; urgency=low
269 * Try to handle relative links in aggregated feeds. However,
270 the current support is a crude hack due to limitations of XML::Feed:
271 xml:base is not supported, neither is Content-Location. And of course,
272 relative links in RSS feeds are ill-undefined..
273 * Make aggregator save permalinks and author name to pages as metadata.
274 * Add permalink and author support to meta plugin, affecting RSS feeds
276 * Various CSS and formatting changes.
277 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
278 * Add xhtml files to the default prune regexp.
279 * Also generate rel=bookmark links for permalinks.
280 * Fix the htmltidy plugin, which wasn't working due my breaking it when
282 * Don't run tidy with -xml as that fails if the input is not well-formed.
283 Run it with -asxhtml instead, so it will output well-formed xhtml no
284 matter what the input.
285 * Disable tidy warnings too.
286 * Add a new format hook, and make tidy use it, since tidy can really only
287 operate on and output complete html documents, not the body chunks
289 * Fix dates in rss feeds if running localised, so they're still rfc 822.
291 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
293 ikiwiki (1.15) unstable; urgency=low
295 * Remove CDPATH and other env vars perl taint checking doesn't like.
297 * Added created_before and created_after PageSpec limits.
299 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
301 ikiwiki (1.14) unstable; urgency=low
303 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
305 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
306 * Added many unit tests for pagespec_match.
308 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
310 ikiwiki (1.13) unstable; urgency=low
312 * ikiwiki can now download and aggregate feeds with its new aggregate
313 plugin, so it's possible to implement a Planet using ikiwiki!
314 * Add a run_hooks function for the common task of running all hooks of a
316 * Add a savestate hook.
317 * Don't put blog post forms on pages if there's no cgiurl set.
318 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
319 --wrappers to do that.
320 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
321 to update pages that haven't changed on disk.
322 * Change meta tags to use html entity-escaped text for values, so that
323 quotes and such can be represented in title tags.
324 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
326 * Make --rebuild also cause --aggregate to re-download and write aggregated
328 * Avoid outputting duplicate meta info.
329 * Include title metadata on aggregated posts for capitalised and un-munged
331 * Title metadata of inlined pages now shows up in blogs and rss feeds.
332 * Fix issue with unicode filenames and updating the hyper estradier search
333 index. (Aka Please Please Please, let that be the last one.)
334 * Patch from Roland Mas to support an rss=no parameter to inline directives.
336 * Renamed GlobLists to PageSpecs.
337 * PageSpecs can now include nested parens, "and", and "or". This remains
338 backwards compatible to the old GlobList format. It's implemented by
339 treating the GlobList as a very limited microlanguage that is transformed
340 to perl code that does the matching.
341 * The old GlobList format is deprecated, and I encourage users to switch to
342 using the new PageSpec format. Compatability with the old format will be
343 removed at some point, possibly by 2.0.
344 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
345 * Add support for creation_month and creation_year to PageSpec.
347 * Changes to index file encoding.
349 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
351 ikiwiki (1.12) unstable; urgency=low
354 * New pagestats plugin from Enrico, which can generate a table counting
355 the backlinks for each page, or a del.icio.us style cloud.
356 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
357 the wikiformat plugin works. Thanks, Emanuele Aina.
358 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
359 display, running them through pagetitle. This removes ugly underscores and
360 other gunk from the display, much nicer. You may want to rebuild your wiki
361 when upgrading to get the cleanup globally.
362 * Polygen plugin from Enrico.
363 * htmltidy plugin from Faidon.
364 * Locale patch from Faidon:
365 - Adds a locale setting to setup files.
366 - Proper local time, if the locale configuration option is used.
367 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
368 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
370 * Add getopt hook type, this allows plugins to add new command-line options.
371 * Add --tagbase option to tag plugin.
372 * Add exclude option in setup files, works same as --exclude.
373 * Put categories in rss feeds for tagged items.
374 * Allow preprocessor directives to be expanded in inlined blog pages.
375 However, to avoid inlining loops etc, don't expand inline directives in
377 * fortune plugin (trivial)
378 * Tag plugins according to type.
380 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
382 ikiwiki (1.11) unstable; urgency=low
384 * Patch from Enrico that
385 - Adds a tag plugin that allows more easily tagging pages.
386 The meta plugin can also still be used for that, but the tag plugin
387 also lists a page's tags at the bottom of the page.
388 - Allows preprocessor directives to have parameters with no specified
390 - Fixes preprocessor directive parameter parsing so that
391 foo=bar baz now means "foo=bar" and a "baz" with no value.
392 * Run pagetemplate hooks when inlining pages so that inlined pages also
394 * Make all plugins with pagetemplate hooks check that variables exist
395 on the template before setting them, for robustness.
396 * Switch pagetemplate hooks to using named parameters.
397 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
398 This will be the page that a source page will be part of, which is
399 different than the source page for inlined pages.
400 * Audited all plugins to endure they pass (page, destpage) to htmllink
401 appropriatly. This means inlining of various plugins will not work
402 properly, with correct links generated.
404 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
406 ikiwiki (1.10) unstable; urgency=low
408 * Run page through any relevant filters when generating a page preview.
409 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
410 default throughout the wiki, not only on wikitext pages. Decided to call
411 this a feature, and split the camelcase support out into a separate plugin
412 that is independant of wikitext.
413 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
415 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
417 ikiwiki (1.9) unstable; urgency=low
419 * Improve display of parentlinks and page title of toplevel index page.
420 * Patch from Faidon to use svn --limit when possible for recentchanges,
421 speeds up recentchanges a lot for wikis with more history.
422 * Patch from Recai to fix utf8 issues in git backend.
423 * Add wikitext markup plugin, which supports ".wiki" pages written in the
424 original wiki syntax, CamelCase links and all.
425 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
426 support, to edit pages etc without a web server.
427 * Display CGI processing errors if present.
428 * Fix from Faidon for a XML parser issue that breaks utf-8 for
429 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
430 area, and also way slow.
431 * Match 'web commit from' in SVN and git, these are web commits too.
433 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
434 readable and avoid future mistakes. The patch seems to work and for the
435 first time I have a UTF-8 username ;-) (Faidon)
436 * Use form->field consistently, not form->param.
437 * Patch from Recai to allow selection of page type when creating a new page.
438 Default page type is inherited from the link clicked on to create the new
441 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
443 ikiwiki (1.8) unstable; urgency=low
445 * Fix orphans plugin to not count a link to a nonexistant page as a reason
446 for a page not being an orphan.
447 * Support pinging services such as Technorati using XML-RPC to notify them
448 about changes to rss feeds.
449 * Parse svn log as xml for improved utf8 and security. Note that this makes
450 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
451 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
452 flagged string even if the locale causes it to generate utf8 output,
453 so make sure to let perl know it should be handled as utf8. Also,
454 the optimised version used for standard time formats won't work if the
455 user has changed locale, so drop it. Thanks, Faidon Liambotis.
456 * Fix re-encoding of the comments field to utf8 if a commit fails
457 due to a conflict. Thanks, Faidon Liambotis.
458 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
460 * Add insane double encode/decode to utf8 around call to markdown.
461 This works around a truely strange bug, which is apparently a bug in
462 perl, #376329. Also added a test case for it.
463 * Improve layout of edit page so formatting help link is always visible w/o
464 getting in the way of the preview.
465 * Centralised all calls to HTML::Template and force all the templates
467 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
468 * Introduce add_plugins and disable_plugins config options in setup files.
469 This allows adding or removing plugins w/o overriding the whole list of
470 default plugins, which makes it easier to upgrade when new default plugins
472 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
473 default (of course!). Based on a patch by Faidon Liambotis.
474 * Add a html plugin, which can be used to write wikis in raw html,
475 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
476 defaults to not processing .html files, since w/o this plugin they would
477 be copied unsanitised. With this plugin, it will process and html
478 sanitise them, like any other page type.
479 * Rebuilding wrappers is necessary on upgrade to this version.
480 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
481 will be automatically done on all upgrades.
482 * Don't send pings if the wiki is being rebuilt.
483 * Work around very innefficient behavior in File::Spec::abs2rel. Result
484 is a savings of 2 pointless fork/execs per link calculation, which
485 results in ~25% speedup of ikiwiki building its own doc wiki, and
486 about 35% speedup displaying RecentChanges!
487 * Make RecentChanges use a table and some CSS, should be much more readable.
488 No code changes involved.
489 * Encode & in diffurl in examples, to conform to pedantic rules.
490 * Speed up RecentChanges by another 40% or so with some memoization.
491 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
492 in time to build the doc wiki.
494 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
496 ikiwiki (1.7) unstable; urgency=low
498 * Updated logo from Recai with some kerning and alingment tuning.
499 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
503 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
505 ikiwiki (1.6) unstable; urgency=low
507 * YA utf-8 patch from Recai, this time to fix previewing a page so that
508 the text in the input box is re-encoded back to utf-8.
509 * -CSD does not affect modules, so readfile() was not using the utf-8 input
510 layer, which led to lots of problems; make it force read files as utf-8.
512 * Note that as a consequence, this version of ikiwiki will actually try to
513 parse utf8 in source files for the first time, which may expose broken
514 utf8 in wiki sources that was hidden before. Most common will be
515 perl warnings like "utf8 "\xE9" does not map to Unicode"
516 * writefile() likewise needs to use the utf8 output layer.
517 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
519 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
520 given the readfile fix.
521 * Add utf-8 testcases for readfile and htmlize.
522 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
524 * More utf-8 fixes from Recai, partly to things I broke above:
525 - The serious problem is that writefile() saves the content in undecoded
526 format in CGI, hence all (non-ascii) chars are corrupted permanently.
527 - Comment field in edit page is not decoded and all the non-ascii chars in
528 this field are corrupted as the result. We should decode it as we do it
530 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
532 * New SVG logo from Recai.
534 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
536 ikiwiki (1.5) unstable; urgency=low
538 * Add --timeformat config option to allow changing how dates are displayed.
539 Note that as a side effect, dates will now be displayed using the local
540 timezone, not as GMT.
541 * More security review.
542 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
543 for some handy stuff like:
544 - Using links as a kind of tag; creating blog pages that list all pages
545 containing a given tag/link or not containing some other tag.
546 - Subscribing to mail notifications whenever a change is made to a page
547 that is a backlink of page foo. Ie, "Please notify me of changes in all
548 pages that link to my home page in the wiki"
549 - Locking any pages that are linked to from a particular page, so that
550 lists of locks can be exposed in the wiki.
551 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
552 when a todo item is done, instead of the previous moving it to a different
554 * Allow pagetemplate plugins to override *anything* in the template.
555 * Add a meta plugin, which allows specifying various metadata about pages,
556 like license and author. It also allows for inserting html link and meta
557 tags into html, overriding the title, and adding hidden WikiLinks, which
558 can be useful when using link-based globbing for page categorisation.
559 * Remove preprocessor directives from inlined pages.
560 * Allow simple preprocessor directive values to be specified w/o quotes.
561 * Add support for using git instead of subversion as the RCS backend,
562 tremendous thanks to Recai Oktaş for this.
563 * Doc updates for git.
564 * Fix absolute url munging in rss generation to support https, ftp, etc urls
566 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
567 utf-8 for edit and other fields, and for recentchanges. There may still
568 be utf-8 issues with the preferences page though.
570 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
572 ikiwiki (1.4) unstable; urgency=low
574 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
575 very strange way of enabling proper XHTML <br /> type tags. Output html
576 should be always valid again now.
577 * The page name and parent links has switched from using a <h1> to a styled
578 <span>, so pages can use <h1> internally instead of needing to use <h2>.
579 * Updated all of ikiwiki's own wiki pages for that.
580 * Add pagetemplate hook, which can be used by plugins that want to mess
581 around with adding new stuff to the page template.
582 * Remove headercontent; the search plugin now adds the search box to the
583 header by registering a pagetemplate hook, and other plugins should do
585 * Rebuilding on upgrade to this version is recommended.
586 * Add a html validity check to the test suite, using the wdg-html-validator,
588 * Make the html valid when there is nothing in the actions list.
589 * Reordered some function call parameters for consistency.
590 * Enable full utf-8 support for page input and output.
591 * Add a workaround for markdown, which does not work well with utf-8
593 * --getctime had bitrotted (well I only ever used it the once so far..),
594 fix and make it a bit more flexible
595 * rcs_getctime is changed, now rather than needing to loop over all pages,
596 it should just use the rcs to get the ctime of the passed file.
597 * When inlining a page in another one, links from the inlined page are now
598 expanded the same as they are when rendering the inlined page as a
599 standalone page. So rather than being expanded from the POV of the
600 inlining page, they are expanded from the POV of the inlined page.
602 For example, a link from blog/foo to "bar" will now link to blog/bar
603 if it exists. Previously this needed to be a link explicitly to
604 "blog/bar"; such links will also continue to work.
606 (This was slightly complex to do as the link still has to be constructed
607 relative to the inlining page.)
608 * Make page edit textarea resize to fit browser window.
609 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
610 do not need a full rebuild, in order to update any basewiki pages.
612 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
614 ikiwiki (1.3) unstable; urgency=low
616 * Fix the preinst introduced in the last version. Closes: #367458
618 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
620 ikiwiki (1.2) unstable; urgency=low
622 * Remove dups from the brokenlinks list.
623 * Add libc6-dev to dependencies, needed to build wrappers.
624 * Install wikilist in correct location. Closes: #367371
626 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
628 ikiwiki (1.1) unstable; urgency=low
630 * Rename inlinepage to depends, so that it can be used to refer to more
631 dependency relationships than just inlining. This will require a rebuild
632 on upgrade to this version.
633 * Move the rss link, put it in the blogpost form if there is one and at the
634 top if not. This is both nicer because easier to find, and it cleans up
635 the code which had used inlinepage as a flag for adding the link later.
636 * Allow the depends GlobList to be built up from multiple sources (such as
637 plugins) during a page render.
638 * Which means that more than one blog is now supported to appear on a
639 single page. (With some limitations, like only the last one getting an
641 * Added a plugin system.
642 * Added a pagecount plugin, enabled by default.
643 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
644 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
645 backlinks when the backlinks hadn't really changed.
646 * Moved inline page support, rss generation etc into the inline plugin,
648 * Added brokenlinks plugin, not enabled by default, but rather handy.
649 * Fix several broken links in the doc wiki.
650 * Smarter behavior when creating a page and a page of the same name (but
651 different location) already exists.
652 * Add an orphans plugin for finding pages that nothing links to.
653 * Removed backlinks page, which it turns out nothing used.
654 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
655 it, this will allow for adding a unit test suite.
656 * Add unit tests for several core functions, including globlist_match,
657 dirname, basename, bestlink, linkify, pagetitle, titlepage.
658 * Smart globlist merging.
659 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
660 to pave the way for adding other RCS support. This also changes the
661 setup files, where before they had svn => 1 or svn => 0, now they have
662 rcs => "svn" or rcs => "".
663 * Add a debian/NEWS file with upgrade notes.
664 * Load whatever rcs module is specified, so new ones can be just dropped in
665 as plugins and work. (Well, in theory.)
666 * Add some basic docs about writing RCS modules.
667 * Broke search capability out into a plugin, removed the --hyperestraier
669 * Added smiley plugin, nicely controlled and documented by the smileys page.
670 * Copied in some smileys from Moin Moin.
671 * Allow links of the form [[some page|page]], with whitespace in the link
673 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
674 and --disable-plugin htmlscrubber.
675 * Allow discussion links on pages to be turned off with --no-discussion.
676 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
677 * Add some new config items to the estseek.conf template, which are needed
678 by hyperestraier 1.2.3.
680 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
682 ikiwiki (1.0) unstable; urgency=low
684 * First official release.
686 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400