1 ikiwiki (1.36) UNRELEASED; urgency=low
3 * Fix various links on the hyperestradier pages.
5 -- Joey Hess <joeyh@debian.org> Mon, 4 Dec 2006 11:50:27 +0100
7 ikiwiki (1.35) unstable; urgency=low
9 * Fix daemonisation code to only do daemon setup things after forking the
11 * The hack used to make the pagetemplate hook have access to the editpage
12 template won't work with CGI::FormBuilder 3.0401, so disable it for now.
13 * CGI::FormBuilder 3.0401 seems to work ok now with ikiwiki, although
14 there might still be bugs lurking..
16 -- Joey Hess <joeyh@debian.org> Fri, 1 Dec 2006 19:14:36 -0500
18 ikiwiki (1.34.2) unstable; urgency=low
20 * Allow /etc/ikiwiki/wikilist to list just the names of users, if so then
21 ~user/.ikiwiki/wikilist will be read.
22 * Fix url absolution code in inline plugin to support class and id fields in
23 links and imgs, and to support anchor urls.
24 * More build deps updates.
25 * /dev/null fortune failures
27 -- Joey Hess <joeyh@debian.org> Tue, 28 Nov 2006 12:58:47 -0500
29 ikiwiki (1.34.1) unstable; urgency=low
31 * Add libtime-duration-perl to build deps, as it's used by the svn module
32 which is now tested at build.
34 -- Joey Hess <joeyh@debian.org> Mon, 27 Nov 2006 12:26:12 -0500
36 ikiwiki (1.34) unstable; urgency=low
38 * Add an openid plugin to support logging in using OpenID.
39 * Web commits by OpenID users will record the full OpenID url for the user,
40 but in recentchanges, these urls will be converted to a simplified display
42 * Modified svn, git, tla backends to recognise such web commits.
43 * Move httpauth support to a plugin.
44 * Add openidsignup config option.
45 * Make the openid plugin support the callbacks from myopenid.com via its
49 * Add quick mode for archive page generation.
50 * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
51 many other plugins. It's an easy way to boost ikiwiki from its default,
52 basic wiki, to a full-featured wiki, without manually picking the right
53 set of plugins. New plugins will be added to goodstuff from time to
55 * Change how post signin actions are propigated through the signin process;
56 they're now stored in the session.
57 * Add optional "desc" parameter to shortcut definitions.
58 * Avoid locking the wiki at all when handling some basic cgi stuff
59 (searches, recentchanges).
60 * Add "last" parameter to hook function. Very basic ordering, and hopefully
61 nothing more spohisticated will be needed.
62 * Add formbuilder_setup and formbuilder hooks.
63 * Split out a passwordauth module, that holds all the traditional password
64 based authentication etc code. It's enabled by default, but can be disabled
65 if you want only openid or some other auth method.
66 * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
67 * Add some code to the build system that tries to determine if the
68 lib installation directory is in @INC. If it's not, munge ikiwiki
69 to hardcode the path to the lib directory. This should allow installing
70 ikiwiki in nonstandard locations, including home directories, by just
71 setting PREFIX at build time.
72 * Fix nested examples directory in deb.
73 * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
74 * Add a test suite for the svn backend.
75 * Add a test suite for the git backend, from Recai
76 * Daemonize before sending RPC pings, since that can take a while
78 * Daemonize before sending commit mails, as that can also take a long
79 time/hang if the mail server is unhappy.
80 * Factor out commit mail sending code into new function.
81 * Change rcs_commit, it is now passed the name of the user doing the commit
82 and their IP address, and needs to construct its own commit message
83 containing them, or do something more appropriate for the given RCS.
84 * Add softwaresite example.
85 * Mercurial backend improvements, including --get-ctime support. (Emanuele
87 * Git backend improvements, including bug fixes and better robustness,
90 -- Joey Hess <joeyh@debian.org> Sun, 26 Nov 2006 20:46:56 -0500
92 ikiwiki (1.33) unstable; urgency=low
94 * Fix issue with aggregate plugin updating expired pages.
95 * Avoid syntax errors in templates used by the template plugin crashing
97 * Enable utf8 file IO in aggregate plugin.
98 * Fix some issues with the new registration form.
99 * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
100 * Make sure to check for errors from every eval.
101 * Fix img plugin's handling of adding dependencies for images that do not
103 * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
104 FORM-SUBMIT unusable on customised formbuilder templates. For now,
105 hardcode the submit buttons in editpage.tmpl instead of using the
106 template variable, which is ok, since the buttons are static.
107 * Work with hyperestraier 1.4.9.
109 -- Joey Hess <joeyh@debian.org> Wed, 15 Nov 2006 18:32:26 -0500
111 ikiwiki (1.32) unstable; urgency=low
113 * Add a separate pass to find page links, and only render each page once,
114 instead of over and over. Typical speedup is ~4x. Max possible speedup:
116 * Add "scan" parameter to hook(), which is used to make the hook be called
117 during the scanning pass, as well as the render pass. The meta and tag
118 plugins need to use the new scan parameter, so will any others that modify
120 * Now that links are calculated in a separate pass, it can also
121 precalculate backlinks in one pass, which is O(N^2) instead of the
122 previous code that was O(N^3). A very nice speedup for wikis with lots
123 (thousands) of pages.
124 * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
126 * Add a default stylesheet entry for the pagecloud.
127 * Add examples page with some examples of things that can be done using
128 ikiwiki, like a weblog. The examples can be copied into a user's wiki
129 for a quick start, without needing to learn everything about how to put
131 * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
132 * Add perlmagick to build-depends so syntax check of img plugin works.
134 * Improve login/register process, the login dialog has only name and
135 password fields, which allows more web browsers to regognise it as a login
136 field, and is less confusing.
137 * Implemented expiry options for aggregate plugin.
138 * Use precalculated backlinks info when determining if files need an update
139 due to a page they link to being added/removed. Mostly significant if
140 there are lots of pages.
141 * Remove duplicate link info when saving index. In some cases it could
142 pile up rather badly. (Probably not the best way to deal with this
144 * Patch from James Westby to support podcasting, photoblogging, vidcasting,
145 or what have you, by creating enclosures for non-page items that are
148 -- Joey Hess <joeyh@debian.org> Fri, 3 Nov 2006 14:46:37 -0500
150 ikiwiki (1.31) unstable; urgency=low
152 * Patch from Pawel Tecza to cp -a the templates in the Makefile.
153 * Change the rss feed title from the wikiname to the page title, with
154 an exception for the wiki's toplevel index page, which will still use the
155 wikiname as the feed title.
156 Overriding the page title with meta title already overrode the rss feed
158 * Add an img plugin, based on Christian Mock's img plugin, but stripped
159 down to the bare essentials. Useful for handling large images on websites.
160 * Sanitize possibly problimatic characters out of the polygen grammar names,
161 just in case. Should not be exploitable anyway, since it only tries to run
162 polygen after finding the specified grammar file.
163 * Add missing dependency on the URI perl module.
164 * Add basic spam fighting tool for admins: An admin's prefs page now allows
165 editing a list of banned users.
167 -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 23:16:33 -0400
169 ikiwiki (1.30) unstable; urgency=low
171 * Add no_override parameter to hook().
172 * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
173 plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
174 can be configured using a page in wiki.
175 * Fix support for --pingurl at the command line.
176 * Fix a subtle bug in will_render that broke some builds, by only clearing
177 items from renderedfiles the first time per build.
178 * Wrap entire technortati ping operation in an eval to catch all possible
179 failure modes, after I observed a simple ->value crashing ikiwiki when
182 -- Joey Hess <joeyh@debian.org> Mon, 16 Oct 2006 15:17:38 -0400
184 ikiwiki (1.29) unstable; urgency=low
186 * Patch from Paul Tötterman to use CP in the Makefile.
187 * Patch from Alec Berryman adding a http_auth config item that allows
188 using HTTP Authentication instead of ikiwiki's built in authentication.
189 Useful for eg, large sites with their own previously existing user auth
190 setup. Closes: #384534
191 * Change %renderedfiles to store an array of files rendered from a given
192 source file, to allow tracking of extra rendered files like rss feeds.
193 * Note that plugins that accessed this variable will need to be updated!
194 The plugin interface has been increased to version 1.01 for this change.
195 As few plugins use %renderedfiles I haven't done anything else to ensure
196 compatability of old plugins.
197 * Add will_render function to the plugin interface, used to register that a
198 page renders a destination file, and do some security checks. Previously
199 but no longer rendered files will be cleaned up.
200 * Use will_render in the inline and linkmap plugins.
201 * You will need to rebuild your wiki on upgrade to this version.
202 * Atom feed support based on a patch by Clint Adams.
203 * Add feeds=no option to inline preprocessor directive to turn off all types
205 * $IkiWiki::version now holds the program version, and is accessible to
207 * Make the aggregate plugin emphasize error messages.
208 * Patch from Recai to limit recentchanges to displaying max 10 files for a
209 given changeset (to avoid large number of file changes excessively
212 -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
214 ikiwiki (1.28) unstable; urgency=low
216 * inline: Add ability to sort by page name, based on a patch from
218 * Fix a forkbomb in various calls to IPC::Open2, which has a highly
219 braindead interface. Closes: #389383
220 * Don't rm -rf ikiwiki on distclean, since a) there's no such file
221 and b) those poor Mac OSX users and their case insensative files!
222 * Don't fail syntax check if Text::Typography isn't installed.
225 -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
227 ikiwiki (1.27) unstable; urgency=low
229 * Work on firming up the plugin interface:
230 - Plugins should not need to load IkiWiki::Render to get commonly
231 used functions, so moved some functions from there to IkiWiki.
232 - Picked out the set of functions and variables that most plugins
233 use, documented them, and made IkiWiki export them by default,
234 like a proper perl module should.
235 - Use the other functions at your own risk.
236 - This is not quite complete, I still have to decide whether to
237 export some other things.
238 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
239 referring to stuff now exported by the IkiWiki module.
240 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
241 to declare which version of the interface your plugin needs.
242 * Anyone with a third-party ikiwiki plugin is strongly encouraged
243 to make like changes to it and avoid use of non-exported symbols from
245 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
246 * Support hyperestradier version 1.4.2, which adds a new required phraseform
248 * If an inlined page has a permalink, link the page title to that.
249 * Patch from Recai to use utf8 when reading the setup file, so that
250 utf8 wikinames from there will be used properly.
251 * Patch from Recai to kill utf-8 on the wiki name when generating the
253 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
254 * Fix a baseurl problem in hyperestradier search results.
255 * Add a stub local.css to avoid problems with 404's.
256 * Patch from Recai to fix a wide character warning from the search plugin
257 during setup if the wikiname contains utf8.
258 * Yet another fix for those poor case-insensative OS X users.
259 * pagetemplate hooks are now also called when generating cgi pages.
260 * Add a favicon plugin, which simply adds a link tag for an icon to each
262 * Patch from James Westby to deal with the case where you're editing a
263 new page, hit cancel, and need to be redirected to somewhere sane.
264 * Various documentation improvements by various wiki users.
265 * Support Text::Markdown from CPAN, which has a different interface from
266 the original markdown or the one in Debian.
267 * Version the libcgi-session-perl dependency, some features that need
268 the new version are used in some cases (sslcookie).
269 * Numerous tla fixes from Clint.
270 * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
271 a multi-resolution favicon.ico.
272 * README.Debian: typo Closes: #388110
273 * chomp trailing newline at the end of templates read in by the template
274 plugin, to allow use of the template preprocessor directive in
275 whitespace-sensative situations. Closes: #387073
276 * Patch from James Westby to make the location of the estseek.cgi script
278 * Add typography (SmartyPants) plugin by Recai.
279 * Add --render mode, which can be used to preview an edit at the command
280 line by test rendering a single page.
281 * Add a googlecalendar plugin. A bit special-purpose, but it shows
282 one way to to deal with user-supplied content that could cause XSS
283 issues w/o the htmlscrubber, and won't survive the scrubber.
285 -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
287 ikiwiki (1.26) unstable; urgency=low
289 * Add a missing -n to tla undo call.
290 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
291 writes before consuming its whole stdin. Avoid this deadlock.
292 * Fix alt tags for outline checkboxes.
294 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
296 ikiwiki (1.25) unstable; urgency=low
298 * Add proper waitpid calls for open2ed processes throughout to avoid
299 zombies; this hit htmltidy especially badly.
300 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
301 subversion repos and fixing some other issues.
302 * Add support for tla, contributed by Clint Adams. Closes: #385936
303 * Add support for mercurial, contributed by Emanuele Aina.
304 * Include <link rel> tag for RSS feeds, used by some aggregators and
305 firefox to find the feed.
306 * Add a linkmap plugin (requires graphviz).
308 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
310 ikiwiki (1.24) unstable; urgency=low
312 * Simplify the data structure returned by rcs_recentchanges to avoid
313 each rcs plugin needing to form complex strings on its own.
314 * Fix another destpage issue in the inline directive. Closes: #385512
317 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
319 ikiwiki (1.23) unstable; urgency=low
321 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
323 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
325 ikiwiki (1.22) unstable; urgency=low
327 * Change how the stylesheet url is determined in the templates: Remove
328 STYLEURL and add BASEURL to all templates (some already had it). This
329 new more general variable can be used to link to other things (eg, images)
330 from the template, as well as stylesheets.
331 * Fix a bug introduced last version to do with nested inlines.
332 * Allow preprocessor directives to span multiple lines, both to make
333 long ones with lots of values easier to write, and to allow for ones with
334 multi-line quoted values.
335 * Allow preprocessor directives to contain python-like triple-quoted
336 text blocks, for easy nesting of quotes inside.
337 * Add a template plugin.
338 * Make pagespec merge code smarter about merging duplicate pagespecs.
339 * Patch from Jordà Polo to make Setup::Standard support hashes in config
341 * Change order of linkify and preprocess; first preprocess and then linkify.
342 This allows passing a wikilink inside a parameter to a preprocessor
343 directive without it being expanded to html, and leaking out of the
344 parameter, which had required some non-obvious use of triple-quoting
345 to avoid. Note that any preprocessor plugins that output something
346 that looks like a wikilink will now have it treated as such; AFAIK
347 this doesn't change any behavior though except for the template plugin.
348 * Enable preprocessor directives when previewing an edit.
349 * Make all pages pull in a local.css style sheet, if present. This won't
350 be included in ikiwiki, but can be created to make local styling changes
351 w/o needing to merge in every new change to the distributed style.css.
352 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
353 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
354 from a different directory.
355 * Generalised preprocesser loop protection code.
356 * Patch from James Westby to allow a description to be set for rss feeds.
357 * Patch from James Westby to add a template for the search form.
358 * Added a ddate plugin.
359 * Patch from James Westby to add a --sslcookie switch, which forces
360 cookies to only be sent over ssl connections to avoid interception.
361 * Fix preferences page on anonok wikis; still need to sign in to get
362 to the preferences page.
363 * Add toc (table of contents) plugin.
364 * Change htmlize, format, and sanitize hooks to use named parameters.
365 * Patch from James Westby to add an actions option to inline; this
366 adds Edit and Discussion links at the end of blog entries.
367 * Due to some css changes, you'll want to rebuild your wiki on upgrade
368 to this version. Will be handled automatically by the deb.
369 * Add processed date to aggregate preprocessor directive status output.
371 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
373 ikiwiki (1.21) unstable; urgency=low
375 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
376 * If a page links to itself, mark up the link text in a span with
377 class="selflink" so that it can be styled. I don't have a useful style
378 defined for that though.
379 * Call filter hooks on inlined page content.
380 * Support inlining pages raw, rather than creating a blog.
381 * Clean up yes/no parameter parsing in inline plugin.
382 * Implemented better cycle detection in the inline plugin; nested inlines
384 * Add a map plugin contributed by Alessandro Dotti Contra.
385 * Add otl format plugin, which handles files as created by vimoutliner.
386 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
387 * Add first draft at a Restructured Text (rst) plugin, by Sergio
388 Talens-Oliag. Note that this has many known issues -- see the caveats on
390 * Credit everyone who wrote a plugin on the plugins' wiki pages.
391 * Fix utf-8 in blog post form.
393 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
395 ikiwiki (1.20) unstable; urgency=low
397 * Relicense the templates and basewiki under the 2-clause BSD license.
398 Since these can easily become part of other people's websites, they
399 should be under as permissive a license as possible.
400 * Add --syslog config option, to log to the syslog.
401 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
402 transient failure to fork (which I've seen happen in the wild).
403 * Fix a bug in the aggregator introduced last version that caused all
404 aggregator state to be lost during a non-aggregating build.
406 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
408 ikiwiki (1.19) unstable; urgency=low
410 * Fix several related bugs in page type determination during online editing.
411 * Add some locking to prevent 2 aggregators from running at once.
412 * Fix an infinite loop in the aggregator when finding a unique filename.
414 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
416 ikiwiki (1.18) unstable; urgency=low
418 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
420 * Man page format fixups.
421 * If the meta plugin overides the page title, set a title_overridden
422 variable in the template to true. This allows doing things with the
423 templates conditional on the title being overriden.
424 * Add a %pagecase which maps lower-case page names to the actual case
425 used in the filename. Use this in bestlinks calculation instead of
426 forcing the link to lowercase.
427 * Also use %pagecase in various other places that want to check if a page
428 with a given name exists.
429 * This means that links to pages with mixed case names will now work,
430 even if the link is in some other case mixture, and mixed case pages
431 should be fully supported throughout ikiwiki.
432 * Recommend rebuilding wikis on upgrade to this version.
434 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
436 ikiwiki (1.17) unstable; urgency=low
438 * Disable tidy generator tag.
439 * Move tidy back to sanitize hook, found out how to only show body.
440 * Turn off tidy indentation too.
441 * Turn on HTML::Template loop_context_vars; not actually used in stock
442 templates but can be useful for things like making comma-delimited lists
443 of tags or what have you.
444 * Remove <br> from end of aggregate preprocessor directive output.
445 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
446 case-sensative filesystems like OSX.
447 * Improve markdown loading. First, try to load it as a proper perl module,
448 in case it was installed as one. Then fall back to trying
450 * Document in install page how to install markdown, since it has no
451 installation procedure in the upstream tarball.
452 * Set die_on_bad_params => 0 for all templates, to allow users to modify
453 them without annoyances.
454 * Suck in the page content when generating an inline archive page, to work
455 around the meta plugin's lack of caching of title metadata across runs.
457 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
459 ikiwiki (1.16) unstable; urgency=low
461 * Try to handle relative links in aggregated feeds. However,
462 the current support is a crude hack due to limitations of XML::Feed:
463 xml:base is not supported, neither is Content-Location. And of course,
464 relative links in RSS feeds are ill-undefined..
465 * Make aggregator save permalinks and author name to pages as metadata.
466 * Add permalink and author support to meta plugin, affecting RSS feeds
468 * Various CSS and formatting changes.
469 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
470 * Add xhtml files to the default prune regexp.
471 * Also generate rel=bookmark links for permalinks.
472 * Fix the htmltidy plugin, which wasn't working due my breaking it when
474 * Don't run tidy with -xml as that fails if the input is not well-formed.
475 Run it with -asxhtml instead, so it will output well-formed xhtml no
476 matter what the input.
477 * Disable tidy warnings too.
478 * Add a new format hook, and make tidy use it, since tidy can really only
479 operate on and output complete html documents, not the body chunks
481 * Fix dates in rss feeds if running localised, so they're still rfc 822.
483 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
485 ikiwiki (1.15) unstable; urgency=low
487 * Remove CDPATH and other env vars perl taint checking doesn't like.
489 * Added created_before and created_after PageSpec limits.
491 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
493 ikiwiki (1.14) unstable; urgency=low
495 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
497 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
498 * Added many unit tests for pagespec_match.
500 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
502 ikiwiki (1.13) unstable; urgency=low
504 * ikiwiki can now download and aggregate feeds with its new aggregate
505 plugin, so it's possible to implement a Planet using ikiwiki!
506 * Add a run_hooks function for the common task of running all hooks of a
508 * Add a savestate hook.
509 * Don't put blog post forms on pages if there's no cgiurl set.
510 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
511 --wrappers to do that.
512 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
513 to update pages that haven't changed on disk.
514 * Change meta tags to use html entity-escaped text for values, so that
515 quotes and such can be represented in title tags.
516 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
518 * Make --rebuild also cause --aggregate to re-download and write aggregated
520 * Avoid outputting duplicate meta info.
521 * Include title metadata on aggregated posts for capitalised and un-munged
523 * Title metadata of inlined pages now shows up in blogs and rss feeds.
524 * Fix issue with unicode filenames and updating the hyper estradier search
525 index. (Aka Please Please Please, let that be the last one.)
526 * Patch from Roland Mas to support an rss=no parameter to inline directives.
528 * Renamed GlobLists to PageSpecs.
529 * PageSpecs can now include nested parens, "and", and "or". This remains
530 backwards compatible to the old GlobList format. It's implemented by
531 treating the GlobList as a very limited microlanguage that is transformed
532 to perl code that does the matching.
533 * The old GlobList format is deprecated, and I encourage users to switch to
534 using the new PageSpec format. Compatability with the old format will be
535 removed at some point, possibly by 2.0.
536 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
537 * Add support for creation_month and creation_year to PageSpec.
539 * Changes to index file encoding.
541 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
543 ikiwiki (1.12) unstable; urgency=low
546 * New pagestats plugin from Enrico, which can generate a table counting
547 the backlinks for each page, or a del.icio.us style cloud.
548 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
549 the wikiformat plugin works. Thanks, Emanuele Aina.
550 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
551 display, running them through pagetitle. This removes ugly underscores and
552 other gunk from the display, much nicer. You may want to rebuild your wiki
553 when upgrading to get the cleanup globally.
554 * Polygen plugin from Enrico.
555 * htmltidy plugin from Faidon.
556 * Locale patch from Faidon:
557 - Adds a locale setting to setup files.
558 - Proper local time, if the locale configuration option is used.
559 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
560 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
562 * Add getopt hook type, this allows plugins to add new command-line options.
563 * Add --tagbase option to tag plugin.
564 * Add exclude option in setup files, works same as --exclude.
565 * Put categories in rss feeds for tagged items.
566 * Allow preprocessor directives to be expanded in inlined blog pages.
567 However, to avoid inlining loops etc, don't expand inline directives in
569 * fortune plugin (trivial)
570 * Tag plugins according to type.
572 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
574 ikiwiki (1.11) unstable; urgency=low
576 * Patch from Enrico that
577 - Adds a tag plugin that allows more easily tagging pages.
578 The meta plugin can also still be used for that, but the tag plugin
579 also lists a page's tags at the bottom of the page.
580 - Allows preprocessor directives to have parameters with no specified
582 - Fixes preprocessor directive parameter parsing so that
583 foo=bar baz now means "foo=bar" and a "baz" with no value.
584 * Run pagetemplate hooks when inlining pages so that inlined pages also
586 * Make all plugins with pagetemplate hooks check that variables exist
587 on the template before setting them, for robustness.
588 * Switch pagetemplate hooks to using named parameters.
589 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
590 This will be the page that a source page will be part of, which is
591 different than the source page for inlined pages.
592 * Audited all plugins to endure they pass (page, destpage) to htmllink
593 appropriatly. This means inlining of various plugins will not work
594 properly, with correct links generated.
596 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
598 ikiwiki (1.10) unstable; urgency=low
600 * Run page through any relevant filters when generating a page preview.
601 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
602 default throughout the wiki, not only on wikitext pages. Decided to call
603 this a feature, and split the camelcase support out into a separate plugin
604 that is independant of wikitext.
605 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
607 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
609 ikiwiki (1.9) unstable; urgency=low
611 * Improve display of parentlinks and page title of toplevel index page.
612 * Patch from Faidon to use svn --limit when possible for recentchanges,
613 speeds up recentchanges a lot for wikis with more history.
614 * Patch from Recai to fix utf8 issues in git backend.
615 * Add wikitext markup plugin, which supports ".wiki" pages written in the
616 original wiki syntax, CamelCase links and all.
617 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
618 support, to edit pages etc without a web server.
619 * Display CGI processing errors if present.
620 * Fix from Faidon for a XML parser issue that breaks utf-8 for
621 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
622 area, and also way slow.
623 * Match 'web commit from' in SVN and git, these are web commits too.
625 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
626 readable and avoid future mistakes. The patch seems to work and for the
627 first time I have a UTF-8 username ;-) (Faidon)
628 * Use form->field consistently, not form->param.
629 * Patch from Recai to allow selection of page type when creating a new page.
630 Default page type is inherited from the link clicked on to create the new
633 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
635 ikiwiki (1.8) unstable; urgency=low
637 * Fix orphans plugin to not count a link to a nonexistant page as a reason
638 for a page not being an orphan.
639 * Support pinging services such as Technorati using XML-RPC to notify them
640 about changes to rss feeds.
641 * Parse svn log as xml for improved utf8 and security. Note that this makes
642 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
643 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
644 flagged string even if the locale causes it to generate utf8 output,
645 so make sure to let perl know it should be handled as utf8. Also,
646 the optimised version used for standard time formats won't work if the
647 user has changed locale, so drop it. Thanks, Faidon Liambotis.
648 * Fix re-encoding of the comments field to utf8 if a commit fails
649 due to a conflict. Thanks, Faidon Liambotis.
650 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
652 * Add insane double encode/decode to utf8 around call to markdown.
653 This works around a truely strange bug, which is apparently a bug in
654 perl, #376329. Also added a test case for it.
655 * Improve layout of edit page so formatting help link is always visible w/o
656 getting in the way of the preview.
657 * Centralised all calls to HTML::Template and force all the templates
659 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
660 * Introduce add_plugins and disable_plugins config options in setup files.
661 This allows adding or removing plugins w/o overriding the whole list of
662 default plugins, which makes it easier to upgrade when new default plugins
664 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
665 default (of course!). Based on a patch by Faidon Liambotis.
666 * Add a html plugin, which can be used to write wikis in raw html,
667 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
668 defaults to not processing .html files, since w/o this plugin they would
669 be copied unsanitised. With this plugin, it will process and html
670 sanitise them, like any other page type.
671 * Rebuilding wrappers is necessary on upgrade to this version.
672 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
673 will be automatically done on all upgrades.
674 * Don't send pings if the wiki is being rebuilt.
675 * Work around very innefficient behavior in File::Spec::abs2rel. Result
676 is a savings of 2 pointless fork/execs per link calculation, which
677 results in ~25% speedup of ikiwiki building its own doc wiki, and
678 about 35% speedup displaying RecentChanges!
679 * Make RecentChanges use a table and some CSS, should be much more readable.
680 No code changes involved.
681 * Encode & in diffurl in examples, to conform to pedantic rules.
682 * Speed up RecentChanges by another 40% or so with some memoization.
683 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
684 in time to build the doc wiki.
686 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
688 ikiwiki (1.7) unstable; urgency=low
690 * Updated logo from Recai with some kerning and alingment tuning.
691 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
695 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
697 ikiwiki (1.6) unstable; urgency=low
699 * YA utf-8 patch from Recai, this time to fix previewing a page so that
700 the text in the input box is re-encoded back to utf-8.
701 * -CSD does not affect modules, so readfile() was not using the utf-8 input
702 layer, which led to lots of problems; make it force read files as utf-8.
704 * Note that as a consequence, this version of ikiwiki will actually try to
705 parse utf8 in source files for the first time, which may expose broken
706 utf8 in wiki sources that was hidden before. Most common will be
707 perl warnings like "utf8 "\xE9" does not map to Unicode"
708 * writefile() likewise needs to use the utf8 output layer.
709 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
711 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
712 given the readfile fix.
713 * Add utf-8 testcases for readfile and htmlize.
714 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
716 * More utf-8 fixes from Recai, partly to things I broke above:
717 - The serious problem is that writefile() saves the content in undecoded
718 format in CGI, hence all (non-ascii) chars are corrupted permanently.
719 - Comment field in edit page is not decoded and all the non-ascii chars in
720 this field are corrupted as the result. We should decode it as we do it
722 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
724 * New SVG logo from Recai.
726 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
728 ikiwiki (1.5) unstable; urgency=low
730 * Add --timeformat config option to allow changing how dates are displayed.
731 Note that as a side effect, dates will now be displayed using the local
732 timezone, not as GMT.
733 * More security review.
734 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
735 for some handy stuff like:
736 - Using links as a kind of tag; creating blog pages that list all pages
737 containing a given tag/link or not containing some other tag.
738 - Subscribing to mail notifications whenever a change is made to a page
739 that is a backlink of page foo. Ie, "Please notify me of changes in all
740 pages that link to my home page in the wiki"
741 - Locking any pages that are linked to from a particular page, so that
742 lists of locks can be exposed in the wiki.
743 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
744 when a todo item is done, instead of the previous moving it to a different
746 * Allow pagetemplate plugins to override *anything* in the template.
747 * Add a meta plugin, which allows specifying various metadata about pages,
748 like license and author. It also allows for inserting html link and meta
749 tags into html, overriding the title, and adding hidden WikiLinks, which
750 can be useful when using link-based globbing for page categorisation.
751 * Remove preprocessor directives from inlined pages.
752 * Allow simple preprocessor directive values to be specified w/o quotes.
753 * Add support for using git instead of subversion as the RCS backend,
754 tremendous thanks to Recai Oktaş for this.
755 * Doc updates for git.
756 * Fix absolute url munging in rss generation to support https, ftp, etc urls
758 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
759 utf-8 for edit and other fields, and for recentchanges. There may still
760 be utf-8 issues with the preferences page though.
762 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
764 ikiwiki (1.4) unstable; urgency=low
766 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
767 very strange way of enabling proper XHTML <br /> type tags. Output html
768 should be always valid again now.
769 * The page name and parent links has switched from using a <h1> to a styled
770 <span>, so pages can use <h1> internally instead of needing to use <h2>.
771 * Updated all of ikiwiki's own wiki pages for that.
772 * Add pagetemplate hook, which can be used by plugins that want to mess
773 around with adding new stuff to the page template.
774 * Remove headercontent; the search plugin now adds the search box to the
775 header by registering a pagetemplate hook, and other plugins should do
777 * Rebuilding on upgrade to this version is recommended.
778 * Add a html validity check to the test suite, using the wdg-html-validator,
780 * Make the html valid when there is nothing in the actions list.
781 * Reordered some function call parameters for consistency.
782 * Enable full utf-8 support for page input and output.
783 * Add a workaround for markdown, which does not work well with utf-8
785 * --getctime had bitrotted (well I only ever used it the once so far..),
786 fix and make it a bit more flexible
787 * rcs_getctime is changed, now rather than needing to loop over all pages,
788 it should just use the rcs to get the ctime of the passed file.
789 * When inlining a page in another one, links from the inlined page are now
790 expanded the same as they are when rendering the inlined page as a
791 standalone page. So rather than being expanded from the POV of the
792 inlining page, they are expanded from the POV of the inlined page.
794 For example, a link from blog/foo to "bar" will now link to blog/bar
795 if it exists. Previously this needed to be a link explicitly to
796 "blog/bar"; such links will also continue to work.
798 (This was slightly complex to do as the link still has to be constructed
799 relative to the inlining page.)
800 * Make page edit textarea resize to fit browser window.
801 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
802 do not need a full rebuild, in order to update any basewiki pages.
804 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
806 ikiwiki (1.3) unstable; urgency=low
808 * Fix the preinst introduced in the last version. Closes: #367458
810 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
812 ikiwiki (1.2) unstable; urgency=low
814 * Remove dups from the brokenlinks list.
815 * Add libc6-dev to dependencies, needed to build wrappers.
816 * Install wikilist in correct location. Closes: #367371
818 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
820 ikiwiki (1.1) unstable; urgency=low
822 * Rename inlinepage to depends, so that it can be used to refer to more
823 dependency relationships than just inlining. This will require a rebuild
824 on upgrade to this version.
825 * Move the rss link, put it in the blogpost form if there is one and at the
826 top if not. This is both nicer because easier to find, and it cleans up
827 the code which had used inlinepage as a flag for adding the link later.
828 * Allow the depends GlobList to be built up from multiple sources (such as
829 plugins) during a page render.
830 * Which means that more than one blog is now supported to appear on a
831 single page. (With some limitations, like only the last one getting an
833 * Added a plugin system.
834 * Added a pagecount plugin, enabled by default.
835 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
836 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
837 backlinks when the backlinks hadn't really changed.
838 * Moved inline page support, rss generation etc into the inline plugin,
840 * Added brokenlinks plugin, not enabled by default, but rather handy.
841 * Fix several broken links in the doc wiki.
842 * Smarter behavior when creating a page and a page of the same name (but
843 different location) already exists.
844 * Add an orphans plugin for finding pages that nothing links to.
845 * Removed backlinks page, which it turns out nothing used.
846 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
847 it, this will allow for adding a unit test suite.
848 * Add unit tests for several core functions, including globlist_match,
849 dirname, basename, bestlink, linkify, pagetitle, titlepage.
850 * Smart globlist merging.
851 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
852 to pave the way for adding other RCS support. This also changes the
853 setup files, where before they had svn => 1 or svn => 0, now they have
854 rcs => "svn" or rcs => "".
855 * Add a debian/NEWS file with upgrade notes.
856 * Load whatever rcs module is specified, so new ones can be just dropped in
857 as plugins and work. (Well, in theory.)
858 * Add some basic docs about writing RCS modules.
859 * Broke search capability out into a plugin, removed the --hyperestraier
861 * Added smiley plugin, nicely controlled and documented by the smileys page.
862 * Copied in some smileys from Moin Moin.
863 * Allow links of the form [[some page|page]], with whitespace in the link
865 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
866 and --disable-plugin htmlscrubber.
867 * Allow discussion links on pages to be turned off with --no-discussion.
868 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
869 * Add some new config items to the estseek.conf template, which are needed
870 by hyperestraier 1.2.3.
872 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
874 ikiwiki (1.0) unstable; urgency=low
876 * First official release.
878 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400