1 ikiwiki (1.31) UNRELEASED; urgency=low
3 * Patch from Pawel Tecza to cp -a the templates in the Makefile.
4 * Change the rss feed title from the wikiname to the page title, with
5 an exception for the wiki's toplevel index page, which will still use the
6 wikiname as the feed title.
7 Overriding the page title with meta title already overrode the rss feed
9 * Add an img plugin, based on Christian Mock's img plugin, but stripped
10 down to the bare essentials. Useful for handling large images on websites.
11 * Sanitize possibly problimatic characters out of the polygen grammar names,
12 just in case. Should not be exploitable anyway, since it only tries to run
13 polygen after finding the specified grammar file.
15 -- Joey Hess <joeyh@debian.org> Sun, 22 Oct 2006 15:47:08 -0400
17 ikiwiki (1.30) unstable; urgency=low
19 * Add no_override parameter to hook().
20 * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
21 plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
22 can be configured using a page in wiki.
23 * Fix support for --pingurl at the command line.
24 * Fix a subtle bug in will_render that broke some builds, by only clearing
25 items from renderedfiles the first time per build.
26 * Wrap entire technortati ping operation in an eval to catch all possible
27 failure modes, after I observed a simple ->value crashing ikiwiki when
30 -- Joey Hess <joeyh@debian.org> Mon, 16 Oct 2006 15:17:38 -0400
32 ikiwiki (1.29) unstable; urgency=low
34 * Patch from Paul Tötterman to use CP in the Makefile.
35 * Patch from Alec Berryman adding a http_auth config item that allows
36 using HTTP Authentication instead of ikiwiki's built in authentication.
37 Useful for eg, large sites with their own previously existing user auth
38 setup. Closes: #384534
39 * Change %renderedfiles to store an array of files rendered from a given
40 source file, to allow tracking of extra rendered files like rss feeds.
41 * Note that plugins that accessed this variable will need to be updated!
42 The plugin interface has been increased to version 1.01 for this change.
43 As few plugins use %renderedfiles I haven't done anything else to ensure
44 compatability of old plugins.
45 * Add will_render function to the plugin interface, used to register that a
46 page renders a destination file, and do some security checks. Previously
47 but no longer rendered files will be cleaned up.
48 * Use will_render in the inline and linkmap plugins.
49 * You will need to rebuild your wiki on upgrade to this version.
50 * Atom feed support based on a patch by Clint Adams.
51 * Add feeds=no option to inline preprocessor directive to turn off all types
53 * $IkiWiki::version now holds the program version, and is accessible to
55 * Make the aggregate plugin emphasize error messages.
56 * Patch from Recai to limit recentchanges to displaying max 10 files for a
57 given changeset (to avoid large number of file changes excessively
60 -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
62 ikiwiki (1.28) unstable; urgency=low
64 * inline: Add ability to sort by page name, based on a patch from
66 * Fix a forkbomb in various calls to IPC::Open2, which has a highly
67 braindead interface. Closes: #389383
68 * Don't rm -rf ikiwiki on distclean, since a) there's no such file
69 and b) those poor Mac OSX users and their case insensative files!
70 * Don't fail syntax check if Text::Typography isn't installed.
73 -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
75 ikiwiki (1.27) unstable; urgency=low
77 * Work on firming up the plugin interface:
78 - Plugins should not need to load IkiWiki::Render to get commonly
79 used functions, so moved some functions from there to IkiWiki.
80 - Picked out the set of functions and variables that most plugins
81 use, documented them, and made IkiWiki export them by default,
82 like a proper perl module should.
83 - Use the other functions at your own risk.
84 - This is not quite complete, I still have to decide whether to
85 export some other things.
86 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
87 referring to stuff now exported by the IkiWiki module.
88 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
89 to declare which version of the interface your plugin needs.
90 * Anyone with a third-party ikiwiki plugin is strongly encouraged
91 to make like changes to it and avoid use of non-exported symbols from
93 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
94 * Support hyperestradier version 1.4.2, which adds a new required phraseform
96 * If an inlined page has a permalink, link the page title to that.
97 * Patch from Recai to use utf8 when reading the setup file, so that
98 utf8 wikinames from there will be used properly.
99 * Patch from Recai to kill utf-8 on the wiki name when generating the
101 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
102 * Fix a baseurl problem in hyperestradier search results.
103 * Add a stub local.css to avoid problems with 404's.
104 * Patch from Recai to fix a wide character warning from the search plugin
105 during setup if the wikiname contains utf8.
106 * Yet another fix for those poor case-insensative OS X users.
107 * pagetemplate hooks are now also called when generating cgi pages.
108 * Add a favicon plugin, which simply adds a link tag for an icon to each
110 * Patch from James Westby to deal with the case where you're editing a
111 new page, hit cancel, and need to be redirected to somewhere sane.
112 * Various documentation improvements by various wiki users.
113 * Support Text::Markdown from CPAN, which has a different interface from
114 the original markdown or the one in Debian.
115 * Version the libcgi-session-perl dependency, some features that need
116 the new version are used in some cases (sslcookie).
117 * Numerous tla fixes from Clint.
118 * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
119 a multi-resolution favicon.ico.
120 * README.Debian: typo Closes: #388110
121 * chomp trailing newline at the end of templates read in by the template
122 plugin, to allow use of the template preprocessor directive in
123 whitespace-sensative situations. Closes: #387073
124 * Patch from James Westby to make the location of the estseek.cgi script
126 * Add typography (SmartyPants) plugin by Recai.
127 * Add --render mode, which can be used to preview an edit at the command
128 line by test rendering a single page.
129 * Add a googlecalendar plugin. A bit special-purpose, but it shows
130 one way to to deal with user-supplied content that could cause XSS
131 issues w/o the htmlscrubber, and won't survive the scrubber.
133 -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
135 ikiwiki (1.26) unstable; urgency=low
137 * Add a missing -n to tla undo call.
138 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
139 writes before consuming its whole stdin. Avoid this deadlock.
140 * Fix alt tags for outline checkboxes.
142 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
144 ikiwiki (1.25) unstable; urgency=low
146 * Add proper waitpid calls for open2ed processes throughout to avoid
147 zombies; this hit htmltidy especially badly.
148 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
149 subversion repos and fixing some other issues.
150 * Add support for tla, contributed by Clint Adams. Closes: #385936
151 * Add support for mercurial, contributed by Emanuele Aina.
152 * Include <link rel> tag for RSS feeds, used by some aggregators and
153 firefox to find the feed.
154 * Add a linkmap plugin (requires graphviz).
156 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
158 ikiwiki (1.24) unstable; urgency=low
160 * Simplify the data structure returned by rcs_recentchanges to avoid
161 each rcs plugin needing to form complex strings on its own.
162 * Fix another destpage issue in the inline directive. Closes: #385512
165 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
167 ikiwiki (1.23) unstable; urgency=low
169 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
171 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
173 ikiwiki (1.22) unstable; urgency=low
175 * Change how the stylesheet url is determined in the templates: Remove
176 STYLEURL and add BASEURL to all templates (some already had it). This
177 new more general variable can be used to link to other things (eg, images)
178 from the template, as well as stylesheets.
179 * Fix a bug introduced last version to do with nested inlines.
180 * Allow preprocessor directives to span multiple lines, both to make
181 long ones with lots of values easier to write, and to allow for ones with
182 multi-line quoted values.
183 * Allow preprocessor directives to contain python-like triple-quoted
184 text blocks, for easy nesting of quotes inside.
185 * Add a template plugin.
186 * Make pagespec merge code smarter about merging duplicate pagespecs.
187 * Patch from Jordà Polo to make Setup::Standard support hashes in config
189 * Change order of linkify and preprocess; first preprocess and then linkify.
190 This allows passing a wikilink inside a parameter to a preprocessor
191 directive without it being expanded to html, and leaking out of the
192 parameter, which had required some non-obvious use of triple-quoting
193 to avoid. Note that any preprocessor plugins that output something
194 that looks like a wikilink will now have it treated as such; AFAIK
195 this doesn't change any behavior though except for the template plugin.
196 * Enable preprocessor directives when previewing an edit.
197 * Make all pages pull in a local.css style sheet, if present. This won't
198 be included in ikiwiki, but can be created to make local styling changes
199 w/o needing to merge in every new change to the distributed style.css.
200 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
201 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
202 from a different directory.
203 * Generalised preprocesser loop protection code.
204 * Patch from James Westby to allow a description to be set for rss feeds.
205 * Patch from James Westby to add a template for the search form.
206 * Added a ddate plugin.
207 * Patch from James Westby to add a --sslcookie switch, which forces
208 cookies to only be sent over ssl connections to avoid interception.
209 * Fix preferences page on anonok wikis; still need to sign in to get
210 to the preferences page.
211 * Add toc (table of contents) plugin.
212 * Change htmlize, format, and sanitize hooks to use named parameters.
213 * Patch from James Westby to add an actions option to inline; this
214 adds Edit and Discussion links at the end of blog entries.
215 * Due to some css changes, you'll want to rebuild your wiki on upgrade
216 to this version. Will be handled automatically by the deb.
217 * Add processed date to aggregate preprocessor directive status output.
219 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
221 ikiwiki (1.21) unstable; urgency=low
223 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
224 * If a page links to itself, mark up the link text in a span with
225 class="selflink" so that it can be styled. I don't have a useful style
226 defined for that though.
227 * Call filter hooks on inlined page content.
228 * Support inlining pages raw, rather than creating a blog.
229 * Clean up yes/no parameter parsing in inline plugin.
230 * Implemented better cycle detection in the inline plugin; nested inlines
232 * Add a map plugin contributed by Alessandro Dotti Contra.
233 * Add otl format plugin, which handles files as created by vimoutliner.
234 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
235 * Add first draft at a Restructured Text (rst) plugin, by Sergio
236 Talens-Oliag. Note that this has many known issues -- see the caveats on
238 * Credit everyone who wrote a plugin on the plugins' wiki pages.
239 * Fix utf-8 in blog post form.
241 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
243 ikiwiki (1.20) unstable; urgency=low
245 * Relicense the templates and basewiki under the 2-clause BSD license.
246 Since these can easily become part of other people's websites, they
247 should be under as permissive a license as possible.
248 * Add --syslog config option, to log to the syslog.
249 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
250 transient failure to fork (which I've seen happen in the wild).
251 * Fix a bug in the aggregator introduced last version that caused all
252 aggregator state to be lost during a non-aggregating build.
254 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
256 ikiwiki (1.19) unstable; urgency=low
258 * Fix several related bugs in page type determination during online editing.
259 * Add some locking to prevent 2 aggregators from running at once.
260 * Fix an infinite loop in the aggregator when finding a unique filename.
262 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
264 ikiwiki (1.18) unstable; urgency=low
266 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
268 * Man page format fixups.
269 * If the meta plugin overides the page title, set a title_overridden
270 variable in the template to true. This allows doing things with the
271 templates conditional on the title being overriden.
272 * Add a %pagecase which maps lower-case page names to the actual case
273 used in the filename. Use this in bestlinks calculation instead of
274 forcing the link to lowercase.
275 * Also use %pagecase in various other places that want to check if a page
276 with a given name exists.
277 * This means that links to pages with mixed case names will now work,
278 even if the link is in some other case mixture, and mixed case pages
279 should be fully supported throughout ikiwiki.
280 * Recommend rebuilding wikis on upgrade to this version.
282 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
284 ikiwiki (1.17) unstable; urgency=low
286 * Disable tidy generator tag.
287 * Move tidy back to sanitize hook, found out how to only show body.
288 * Turn off tidy indentation too.
289 * Turn on HTML::Template loop_context_vars; not actually used in stock
290 templates but can be useful for things like making comma-delimited lists
291 of tags or what have you.
292 * Remove <br> from end of aggregate preprocessor directive output.
293 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
294 case-sensative filesystems like OSX.
295 * Improve markdown loading. First, try to load it as a proper perl module,
296 in case it was installed as one. Then fall back to trying
298 * Document in install page how to install markdown, since it has no
299 installation procedure in the upstream tarball.
300 * Set die_on_bad_params => 0 for all templates, to allow users to modify
301 them without annoyances.
302 * Suck in the page content when generating an inline archive page, to work
303 around the meta plugin's lack of caching of title metadata across runs.
305 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
307 ikiwiki (1.16) unstable; urgency=low
309 * Try to handle relative links in aggregated feeds. However,
310 the current support is a crude hack due to limitations of XML::Feed:
311 xml:base is not supported, neither is Content-Location. And of course,
312 relative links in RSS feeds are ill-undefined..
313 * Make aggregator save permalinks and author name to pages as metadata.
314 * Add permalink and author support to meta plugin, affecting RSS feeds
316 * Various CSS and formatting changes.
317 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
318 * Add xhtml files to the default prune regexp.
319 * Also generate rel=bookmark links for permalinks.
320 * Fix the htmltidy plugin, which wasn't working due my breaking it when
322 * Don't run tidy with -xml as that fails if the input is not well-formed.
323 Run it with -asxhtml instead, so it will output well-formed xhtml no
324 matter what the input.
325 * Disable tidy warnings too.
326 * Add a new format hook, and make tidy use it, since tidy can really only
327 operate on and output complete html documents, not the body chunks
329 * Fix dates in rss feeds if running localised, so they're still rfc 822.
331 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
333 ikiwiki (1.15) unstable; urgency=low
335 * Remove CDPATH and other env vars perl taint checking doesn't like.
337 * Added created_before and created_after PageSpec limits.
339 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
341 ikiwiki (1.14) unstable; urgency=low
343 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
345 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
346 * Added many unit tests for pagespec_match.
348 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
350 ikiwiki (1.13) unstable; urgency=low
352 * ikiwiki can now download and aggregate feeds with its new aggregate
353 plugin, so it's possible to implement a Planet using ikiwiki!
354 * Add a run_hooks function for the common task of running all hooks of a
356 * Add a savestate hook.
357 * Don't put blog post forms on pages if there's no cgiurl set.
358 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
359 --wrappers to do that.
360 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
361 to update pages that haven't changed on disk.
362 * Change meta tags to use html entity-escaped text for values, so that
363 quotes and such can be represented in title tags.
364 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
366 * Make --rebuild also cause --aggregate to re-download and write aggregated
368 * Avoid outputting duplicate meta info.
369 * Include title metadata on aggregated posts for capitalised and un-munged
371 * Title metadata of inlined pages now shows up in blogs and rss feeds.
372 * Fix issue with unicode filenames and updating the hyper estradier search
373 index. (Aka Please Please Please, let that be the last one.)
374 * Patch from Roland Mas to support an rss=no parameter to inline directives.
376 * Renamed GlobLists to PageSpecs.
377 * PageSpecs can now include nested parens, "and", and "or". This remains
378 backwards compatible to the old GlobList format. It's implemented by
379 treating the GlobList as a very limited microlanguage that is transformed
380 to perl code that does the matching.
381 * The old GlobList format is deprecated, and I encourage users to switch to
382 using the new PageSpec format. Compatability with the old format will be
383 removed at some point, possibly by 2.0.
384 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
385 * Add support for creation_month and creation_year to PageSpec.
387 * Changes to index file encoding.
389 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
391 ikiwiki (1.12) unstable; urgency=low
394 * New pagestats plugin from Enrico, which can generate a table counting
395 the backlinks for each page, or a del.icio.us style cloud.
396 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
397 the wikiformat plugin works. Thanks, Emanuele Aina.
398 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
399 display, running them through pagetitle. This removes ugly underscores and
400 other gunk from the display, much nicer. You may want to rebuild your wiki
401 when upgrading to get the cleanup globally.
402 * Polygen plugin from Enrico.
403 * htmltidy plugin from Faidon.
404 * Locale patch from Faidon:
405 - Adds a locale setting to setup files.
406 - Proper local time, if the locale configuration option is used.
407 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
408 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
410 * Add getopt hook type, this allows plugins to add new command-line options.
411 * Add --tagbase option to tag plugin.
412 * Add exclude option in setup files, works same as --exclude.
413 * Put categories in rss feeds for tagged items.
414 * Allow preprocessor directives to be expanded in inlined blog pages.
415 However, to avoid inlining loops etc, don't expand inline directives in
417 * fortune plugin (trivial)
418 * Tag plugins according to type.
420 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
422 ikiwiki (1.11) unstable; urgency=low
424 * Patch from Enrico that
425 - Adds a tag plugin that allows more easily tagging pages.
426 The meta plugin can also still be used for that, but the tag plugin
427 also lists a page's tags at the bottom of the page.
428 - Allows preprocessor directives to have parameters with no specified
430 - Fixes preprocessor directive parameter parsing so that
431 foo=bar baz now means "foo=bar" and a "baz" with no value.
432 * Run pagetemplate hooks when inlining pages so that inlined pages also
434 * Make all plugins with pagetemplate hooks check that variables exist
435 on the template before setting them, for robustness.
436 * Switch pagetemplate hooks to using named parameters.
437 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
438 This will be the page that a source page will be part of, which is
439 different than the source page for inlined pages.
440 * Audited all plugins to endure they pass (page, destpage) to htmllink
441 appropriatly. This means inlining of various plugins will not work
442 properly, with correct links generated.
444 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
446 ikiwiki (1.10) unstable; urgency=low
448 * Run page through any relevant filters when generating a page preview.
449 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
450 default throughout the wiki, not only on wikitext pages. Decided to call
451 this a feature, and split the camelcase support out into a separate plugin
452 that is independant of wikitext.
453 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
455 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
457 ikiwiki (1.9) unstable; urgency=low
459 * Improve display of parentlinks and page title of toplevel index page.
460 * Patch from Faidon to use svn --limit when possible for recentchanges,
461 speeds up recentchanges a lot for wikis with more history.
462 * Patch from Recai to fix utf8 issues in git backend.
463 * Add wikitext markup plugin, which supports ".wiki" pages written in the
464 original wiki syntax, CamelCase links and all.
465 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
466 support, to edit pages etc without a web server.
467 * Display CGI processing errors if present.
468 * Fix from Faidon for a XML parser issue that breaks utf-8 for
469 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
470 area, and also way slow.
471 * Match 'web commit from' in SVN and git, these are web commits too.
473 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
474 readable and avoid future mistakes. The patch seems to work and for the
475 first time I have a UTF-8 username ;-) (Faidon)
476 * Use form->field consistently, not form->param.
477 * Patch from Recai to allow selection of page type when creating a new page.
478 Default page type is inherited from the link clicked on to create the new
481 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
483 ikiwiki (1.8) unstable; urgency=low
485 * Fix orphans plugin to not count a link to a nonexistant page as a reason
486 for a page not being an orphan.
487 * Support pinging services such as Technorati using XML-RPC to notify them
488 about changes to rss feeds.
489 * Parse svn log as xml for improved utf8 and security. Note that this makes
490 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
491 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
492 flagged string even if the locale causes it to generate utf8 output,
493 so make sure to let perl know it should be handled as utf8. Also,
494 the optimised version used for standard time formats won't work if the
495 user has changed locale, so drop it. Thanks, Faidon Liambotis.
496 * Fix re-encoding of the comments field to utf8 if a commit fails
497 due to a conflict. Thanks, Faidon Liambotis.
498 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
500 * Add insane double encode/decode to utf8 around call to markdown.
501 This works around a truely strange bug, which is apparently a bug in
502 perl, #376329. Also added a test case for it.
503 * Improve layout of edit page so formatting help link is always visible w/o
504 getting in the way of the preview.
505 * Centralised all calls to HTML::Template and force all the templates
507 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
508 * Introduce add_plugins and disable_plugins config options in setup files.
509 This allows adding or removing plugins w/o overriding the whole list of
510 default plugins, which makes it easier to upgrade when new default plugins
512 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
513 default (of course!). Based on a patch by Faidon Liambotis.
514 * Add a html plugin, which can be used to write wikis in raw html,
515 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
516 defaults to not processing .html files, since w/o this plugin they would
517 be copied unsanitised. With this plugin, it will process and html
518 sanitise them, like any other page type.
519 * Rebuilding wrappers is necessary on upgrade to this version.
520 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
521 will be automatically done on all upgrades.
522 * Don't send pings if the wiki is being rebuilt.
523 * Work around very innefficient behavior in File::Spec::abs2rel. Result
524 is a savings of 2 pointless fork/execs per link calculation, which
525 results in ~25% speedup of ikiwiki building its own doc wiki, and
526 about 35% speedup displaying RecentChanges!
527 * Make RecentChanges use a table and some CSS, should be much more readable.
528 No code changes involved.
529 * Encode & in diffurl in examples, to conform to pedantic rules.
530 * Speed up RecentChanges by another 40% or so with some memoization.
531 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
532 in time to build the doc wiki.
534 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
536 ikiwiki (1.7) unstable; urgency=low
538 * Updated logo from Recai with some kerning and alingment tuning.
539 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
543 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
545 ikiwiki (1.6) unstable; urgency=low
547 * YA utf-8 patch from Recai, this time to fix previewing a page so that
548 the text in the input box is re-encoded back to utf-8.
549 * -CSD does not affect modules, so readfile() was not using the utf-8 input
550 layer, which led to lots of problems; make it force read files as utf-8.
552 * Note that as a consequence, this version of ikiwiki will actually try to
553 parse utf8 in source files for the first time, which may expose broken
554 utf8 in wiki sources that was hidden before. Most common will be
555 perl warnings like "utf8 "\xE9" does not map to Unicode"
556 * writefile() likewise needs to use the utf8 output layer.
557 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
559 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
560 given the readfile fix.
561 * Add utf-8 testcases for readfile and htmlize.
562 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
564 * More utf-8 fixes from Recai, partly to things I broke above:
565 - The serious problem is that writefile() saves the content in undecoded
566 format in CGI, hence all (non-ascii) chars are corrupted permanently.
567 - Comment field in edit page is not decoded and all the non-ascii chars in
568 this field are corrupted as the result. We should decode it as we do it
570 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
572 * New SVG logo from Recai.
574 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
576 ikiwiki (1.5) unstable; urgency=low
578 * Add --timeformat config option to allow changing how dates are displayed.
579 Note that as a side effect, dates will now be displayed using the local
580 timezone, not as GMT.
581 * More security review.
582 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
583 for some handy stuff like:
584 - Using links as a kind of tag; creating blog pages that list all pages
585 containing a given tag/link or not containing some other tag.
586 - Subscribing to mail notifications whenever a change is made to a page
587 that is a backlink of page foo. Ie, "Please notify me of changes in all
588 pages that link to my home page in the wiki"
589 - Locking any pages that are linked to from a particular page, so that
590 lists of locks can be exposed in the wiki.
591 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
592 when a todo item is done, instead of the previous moving it to a different
594 * Allow pagetemplate plugins to override *anything* in the template.
595 * Add a meta plugin, which allows specifying various metadata about pages,
596 like license and author. It also allows for inserting html link and meta
597 tags into html, overriding the title, and adding hidden WikiLinks, which
598 can be useful when using link-based globbing for page categorisation.
599 * Remove preprocessor directives from inlined pages.
600 * Allow simple preprocessor directive values to be specified w/o quotes.
601 * Add support for using git instead of subversion as the RCS backend,
602 tremendous thanks to Recai Oktaş for this.
603 * Doc updates for git.
604 * Fix absolute url munging in rss generation to support https, ftp, etc urls
606 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
607 utf-8 for edit and other fields, and for recentchanges. There may still
608 be utf-8 issues with the preferences page though.
610 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
612 ikiwiki (1.4) unstable; urgency=low
614 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
615 very strange way of enabling proper XHTML <br /> type tags. Output html
616 should be always valid again now.
617 * The page name and parent links has switched from using a <h1> to a styled
618 <span>, so pages can use <h1> internally instead of needing to use <h2>.
619 * Updated all of ikiwiki's own wiki pages for that.
620 * Add pagetemplate hook, which can be used by plugins that want to mess
621 around with adding new stuff to the page template.
622 * Remove headercontent; the search plugin now adds the search box to the
623 header by registering a pagetemplate hook, and other plugins should do
625 * Rebuilding on upgrade to this version is recommended.
626 * Add a html validity check to the test suite, using the wdg-html-validator,
628 * Make the html valid when there is nothing in the actions list.
629 * Reordered some function call parameters for consistency.
630 * Enable full utf-8 support for page input and output.
631 * Add a workaround for markdown, which does not work well with utf-8
633 * --getctime had bitrotted (well I only ever used it the once so far..),
634 fix and make it a bit more flexible
635 * rcs_getctime is changed, now rather than needing to loop over all pages,
636 it should just use the rcs to get the ctime of the passed file.
637 * When inlining a page in another one, links from the inlined page are now
638 expanded the same as they are when rendering the inlined page as a
639 standalone page. So rather than being expanded from the POV of the
640 inlining page, they are expanded from the POV of the inlined page.
642 For example, a link from blog/foo to "bar" will now link to blog/bar
643 if it exists. Previously this needed to be a link explicitly to
644 "blog/bar"; such links will also continue to work.
646 (This was slightly complex to do as the link still has to be constructed
647 relative to the inlining page.)
648 * Make page edit textarea resize to fit browser window.
649 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
650 do not need a full rebuild, in order to update any basewiki pages.
652 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
654 ikiwiki (1.3) unstable; urgency=low
656 * Fix the preinst introduced in the last version. Closes: #367458
658 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
660 ikiwiki (1.2) unstable; urgency=low
662 * Remove dups from the brokenlinks list.
663 * Add libc6-dev to dependencies, needed to build wrappers.
664 * Install wikilist in correct location. Closes: #367371
666 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
668 ikiwiki (1.1) unstable; urgency=low
670 * Rename inlinepage to depends, so that it can be used to refer to more
671 dependency relationships than just inlining. This will require a rebuild
672 on upgrade to this version.
673 * Move the rss link, put it in the blogpost form if there is one and at the
674 top if not. This is both nicer because easier to find, and it cleans up
675 the code which had used inlinepage as a flag for adding the link later.
676 * Allow the depends GlobList to be built up from multiple sources (such as
677 plugins) during a page render.
678 * Which means that more than one blog is now supported to appear on a
679 single page. (With some limitations, like only the last one getting an
681 * Added a plugin system.
682 * Added a pagecount plugin, enabled by default.
683 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
684 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
685 backlinks when the backlinks hadn't really changed.
686 * Moved inline page support, rss generation etc into the inline plugin,
688 * Added brokenlinks plugin, not enabled by default, but rather handy.
689 * Fix several broken links in the doc wiki.
690 * Smarter behavior when creating a page and a page of the same name (but
691 different location) already exists.
692 * Add an orphans plugin for finding pages that nothing links to.
693 * Removed backlinks page, which it turns out nothing used.
694 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
695 it, this will allow for adding a unit test suite.
696 * Add unit tests for several core functions, including globlist_match,
697 dirname, basename, bestlink, linkify, pagetitle, titlepage.
698 * Smart globlist merging.
699 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
700 to pave the way for adding other RCS support. This also changes the
701 setup files, where before they had svn => 1 or svn => 0, now they have
702 rcs => "svn" or rcs => "".
703 * Add a debian/NEWS file with upgrade notes.
704 * Load whatever rcs module is specified, so new ones can be just dropped in
705 as plugins and work. (Well, in theory.)
706 * Add some basic docs about writing RCS modules.
707 * Broke search capability out into a plugin, removed the --hyperestraier
709 * Added smiley plugin, nicely controlled and documented by the smileys page.
710 * Copied in some smileys from Moin Moin.
711 * Allow links of the form [[some page|page]], with whitespace in the link
713 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
714 and --disable-plugin htmlscrubber.
715 * Allow discussion links on pages to be turned off with --no-discussion.
716 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
717 * Add some new config items to the estseek.conf template, which are needed
718 by hyperestraier 1.2.3.
720 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
722 ikiwiki (1.0) unstable; urgency=low
724 * First official release.
726 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400