1 ikiwiki (1.36) UNRELEASED; urgency=low
3 * Fix various links on the hyperestradier pages.
4 * Use POST for poll to avoid some robots.
5 * Fix sometimes broken links to Discussion pages from blog pages.
6 * Add userdir config setting.
7 * Fix man page perms in install.
9 -- Joey Hess <joeyh@debian.org> Tue, 19 Dec 2006 12:08:40 -0500
11 ikiwiki (1.35) unstable; urgency=low
13 * Fix daemonisation code to only do daemon setup things after forking the
15 * The hack used to make the pagetemplate hook have access to the editpage
16 template won't work with CGI::FormBuilder 3.0401, so disable it for now.
17 * CGI::FormBuilder 3.0401 seems to work ok now with ikiwiki, although
18 there might still be bugs lurking..
20 -- Joey Hess <joeyh@debian.org> Fri, 1 Dec 2006 19:14:36 -0500
22 ikiwiki (1.34.2) unstable; urgency=low
24 * Allow /etc/ikiwiki/wikilist to list just the names of users, if so then
25 ~user/.ikiwiki/wikilist will be read.
26 * Fix url absolution code in inline plugin to support class and id fields in
27 links and imgs, and to support anchor urls.
28 * More build deps updates.
29 * /dev/null fortune failures
31 -- Joey Hess <joeyh@debian.org> Tue, 28 Nov 2006 12:58:47 -0500
33 ikiwiki (1.34.1) unstable; urgency=low
35 * Add libtime-duration-perl to build deps, as it's used by the svn module
36 which is now tested at build.
38 -- Joey Hess <joeyh@debian.org> Mon, 27 Nov 2006 12:26:12 -0500
40 ikiwiki (1.34) unstable; urgency=low
42 * Add an openid plugin to support logging in using OpenID.
43 * Web commits by OpenID users will record the full OpenID url for the user,
44 but in recentchanges, these urls will be converted to a simplified display
46 * Modified svn, git, tla backends to recognise such web commits.
47 * Move httpauth support to a plugin.
48 * Add openidsignup config option.
49 * Make the openid plugin support the callbacks from myopenid.com via its
53 * Add quick mode for archive page generation.
54 * Introduce the goodstuff bundle. This is a kind of plugin, that just enables
55 many other plugins. It's an easy way to boost ikiwiki from its default,
56 basic wiki, to a full-featured wiki, without manually picking the right
57 set of plugins. New plugins will be added to goodstuff from time to
59 * Change how post signin actions are propigated through the signin process;
60 they're now stored in the session.
61 * Add optional "desc" parameter to shortcut definitions.
62 * Avoid locking the wiki at all when handling some basic cgi stuff
63 (searches, recentchanges).
64 * Add "last" parameter to hook function. Very basic ordering, and hopefully
65 nothing more spohisticated will be needed.
66 * Add formbuilder_setup and formbuilder hooks.
67 * Split out a passwordauth module, that holds all the traditional password
68 based authentication etc code. It's enabled by default, but can be disabled
69 if you want only openid or some other auth method.
70 * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
71 * Add some code to the build system that tries to determine if the
72 lib installation directory is in @INC. If it's not, munge ikiwiki
73 to hardcode the path to the lib directory. This should allow installing
74 ikiwiki in nonstandard locations, including home directories, by just
75 setting PREFIX at build time.
76 * Fix nested examples directory in deb.
77 * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
78 * Add a test suite for the svn backend.
79 * Add a test suite for the git backend, from Recai
80 * Daemonize before sending RPC pings, since that can take a while
82 * Daemonize before sending commit mails, as that can also take a long
83 time/hang if the mail server is unhappy.
84 * Factor out commit mail sending code into new function.
85 * Change rcs_commit, it is now passed the name of the user doing the commit
86 and their IP address, and needs to construct its own commit message
87 containing them, or do something more appropriate for the given RCS.
88 * Add softwaresite example.
89 * Mercurial backend improvements, including --get-ctime support. (Emanuele
91 * Git backend improvements, including bug fixes and better robustness,
94 -- Joey Hess <joeyh@debian.org> Sun, 26 Nov 2006 20:46:56 -0500
96 ikiwiki (1.33) unstable; urgency=low
98 * Fix issue with aggregate plugin updating expired pages.
99 * Avoid syntax errors in templates used by the template plugin crashing
101 * Enable utf8 file IO in aggregate plugin.
102 * Fix some issues with the new registration form.
103 * Patch from Ethan Glasser Camp to add a skip option to the inline plugin.
104 * Make sure to check for errors from every eval.
105 * Fix img plugin's handling of adding dependencies for images that do not
107 * Work around a strange bug in CGI::FormBuilder 3.0401 that makes
108 FORM-SUBMIT unusable on customised formbuilder templates. For now,
109 hardcode the submit buttons in editpage.tmpl instead of using the
110 template variable, which is ok, since the buttons are static.
111 * Work with hyperestraier 1.4.9.
113 -- Joey Hess <joeyh@debian.org> Wed, 15 Nov 2006 18:32:26 -0500
115 ikiwiki (1.32) unstable; urgency=low
117 * Add a separate pass to find page links, and only render each page once,
118 instead of over and over. Typical speedup is ~4x. Max possible speedup:
120 * Add "scan" parameter to hook(), which is used to make the hook be called
121 during the scanning pass, as well as the render pass. The meta and tag
122 plugins need to use the new scan parameter, so will any others that modify
124 * Now that links are calculated in a separate pass, it can also
125 precalculate backlinks in one pass, which is O(N^2) instead of the
126 previous code that was O(N^3). A very nice speedup for wikis with lots
127 (thousands) of pages.
128 * Stylish update to the ikiwiki logo, thanks to Recai Oktaş and Selçuk
130 * Add a default stylesheet entry for the pagecloud.
131 * Add examples page with some examples of things that can be done using
132 ikiwiki, like a weblog. The examples can be copied into a user's wiki
133 for a quick start, without needing to learn everything about how to put
135 * Install the source of the examples into /usr/share/doc/ikiwiki/examples.
136 * Add perlmagick to build-depends so syntax check of img plugin works.
138 * Improve login/register process, the login dialog has only name and
139 password fields, which allows more web browsers to regognise it as a login
140 field, and is less confusing.
141 * Implemented expiry options for aggregate plugin.
142 * Use precalculated backlinks info when determining if files need an update
143 due to a page they link to being added/removed. Mostly significant if
144 there are lots of pages.
145 * Remove duplicate link info when saving index. In some cases it could
146 pile up rather badly. (Probably not the best way to deal with this
148 * Patch from James Westby to support podcasting, photoblogging, vidcasting,
149 or what have you, by creating enclosures for non-page items that are
152 -- Joey Hess <joeyh@debian.org> Fri, 3 Nov 2006 14:46:37 -0500
154 ikiwiki (1.31) unstable; urgency=low
156 * Patch from Pawel Tecza to cp -a the templates in the Makefile.
157 * Change the rss feed title from the wikiname to the page title, with
158 an exception for the wiki's toplevel index page, which will still use the
159 wikiname as the feed title.
160 Overriding the page title with meta title already overrode the rss feed
162 * Add an img plugin, based on Christian Mock's img plugin, but stripped
163 down to the bare essentials. Useful for handling large images on websites.
164 * Sanitize possibly problimatic characters out of the polygen grammar names,
165 just in case. Should not be exploitable anyway, since it only tries to run
166 polygen after finding the specified grammar file.
167 * Add missing dependency on the URI perl module.
168 * Add basic spam fighting tool for admins: An admin's prefs page now allows
169 editing a list of banned users.
171 -- Joey Hess <joeyh@debian.org> Fri, 27 Oct 2006 23:16:33 -0400
173 ikiwiki (1.30) unstable; urgency=low
175 * Add no_override parameter to hook().
176 * Add a shortcut plugin, inspired by Victor Moral's contributed shortcuts
177 plugin, but featuring a more ikiwiki-ish syntax and with shortcuts that
178 can be configured using a page in wiki.
179 * Fix support for --pingurl at the command line.
180 * Fix a subtle bug in will_render that broke some builds, by only clearing
181 items from renderedfiles the first time per build.
182 * Wrap entire technortati ping operation in an eval to catch all possible
183 failure modes, after I observed a simple ->value crashing ikiwiki when
186 -- Joey Hess <joeyh@debian.org> Mon, 16 Oct 2006 15:17:38 -0400
188 ikiwiki (1.29) unstable; urgency=low
190 * Patch from Paul Tötterman to use CP in the Makefile.
191 * Patch from Alec Berryman adding a http_auth config item that allows
192 using HTTP Authentication instead of ikiwiki's built in authentication.
193 Useful for eg, large sites with their own previously existing user auth
194 setup. Closes: #384534
195 * Change %renderedfiles to store an array of files rendered from a given
196 source file, to allow tracking of extra rendered files like rss feeds.
197 * Note that plugins that accessed this variable will need to be updated!
198 The plugin interface has been increased to version 1.01 for this change.
199 As few plugins use %renderedfiles I haven't done anything else to ensure
200 compatability of old plugins.
201 * Add will_render function to the plugin interface, used to register that a
202 page renders a destination file, and do some security checks. Previously
203 but no longer rendered files will be cleaned up.
204 * Use will_render in the inline and linkmap plugins.
205 * You will need to rebuild your wiki on upgrade to this version.
206 * Atom feed support based on a patch by Clint Adams.
207 * Add feeds=no option to inline preprocessor directive to turn off all types
209 * $IkiWiki::version now holds the program version, and is accessible to
211 * Make the aggregate plugin emphasize error messages.
212 * Patch from Recai to limit recentchanges to displaying max 10 files for a
213 given changeset (to avoid large number of file changes excessively
216 -- Joey Hess <joeyh@debian.org> Fri, 13 Oct 2006 23:14:28 -0400
218 ikiwiki (1.28) unstable; urgency=low
220 * inline: Add ability to sort by page name, based on a patch from
222 * Fix a forkbomb in various calls to IPC::Open2, which has a highly
223 braindead interface. Closes: #389383
224 * Don't rm -rf ikiwiki on distclean, since a) there's no such file
225 and b) those poor Mac OSX users and their case insensative files!
226 * Don't fail syntax check if Text::Typography isn't installed.
229 -- Joey Hess <joeyh@debian.org> Tue, 26 Sep 2006 02:08:17 -0400
231 ikiwiki (1.27) unstable; urgency=low
233 * Work on firming up the plugin interface:
234 - Plugins should not need to load IkiWiki::Render to get commonly
235 used functions, so moved some functions from there to IkiWiki.
236 - Picked out the set of functions and variables that most plugins
237 use, documented them, and made IkiWiki export them by default,
238 like a proper perl module should.
239 - Use the other functions at your own risk.
240 - This is not quite complete, I still have to decide whether to
241 export some other things.
242 * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
243 referring to stuff now exported by the IkiWiki module.
244 * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
245 to declare which version of the interface your plugin needs.
246 * Anyone with a third-party ikiwiki plugin is strongly encouraged
247 to make like changes to it and avoid use of non-exported symbols from
249 * Link debian/changelog and debian/news to NEWS and CHANGELOG.
250 * Support hyperestradier version 1.4.2, which adds a new required phraseform
252 * If an inlined page has a permalink, link the page title to that.
253 * Patch from Recai to use utf8 when reading the setup file, so that
254 utf8 wikinames from there will be used properly.
255 * Patch from Recai to kill utf-8 on the wiki name when generating the
257 * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
258 * Fix a baseurl problem in hyperestradier search results.
259 * Add a stub local.css to avoid problems with 404's.
260 * Patch from Recai to fix a wide character warning from the search plugin
261 during setup if the wikiname contains utf8.
262 * Yet another fix for those poor case-insensative OS X users.
263 * pagetemplate hooks are now also called when generating cgi pages.
264 * Add a favicon plugin, which simply adds a link tag for an icon to each
266 * Patch from James Westby to deal with the case where you're editing a
267 new page, hit cancel, and need to be redirected to somewhere sane.
268 * Various documentation improvements by various wiki users.
269 * Support Text::Markdown from CPAN, which has a different interface from
270 the original markdown or the one in Debian.
271 * Version the libcgi-session-perl dependency, some features that need
272 the new version are used in some cases (sslcookie).
273 * Numerous tla fixes from Clint.
274 * Updated ikiwiki.svgz from Recai, includes an icon and is used to generate
275 a multi-resolution favicon.ico.
276 * README.Debian: typo Closes: #388110
277 * chomp trailing newline at the end of templates read in by the template
278 plugin, to allow use of the template preprocessor directive in
279 whitespace-sensative situations. Closes: #387073
280 * Patch from James Westby to make the location of the estseek.cgi script
282 * Add typography (SmartyPants) plugin by Recai.
283 * Add --render mode, which can be used to preview an edit at the command
284 line by test rendering a single page.
285 * Add a googlecalendar plugin. A bit special-purpose, but it shows
286 one way to to deal with user-supplied content that could cause XSS
287 issues w/o the htmlscrubber, and won't survive the scrubber.
289 -- Joey Hess <joeyh@debian.org> Sun, 24 Sep 2006 00:02:21 -0400
291 ikiwiki (1.26) unstable; urgency=low
293 * Add a missing -n to tla undo call.
294 * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
295 writes before consuming its whole stdin. Avoid this deadlock.
296 * Fix alt tags for outline checkboxes.
298 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
300 ikiwiki (1.25) unstable; urgency=low
302 * Add proper waitpid calls for open2ed processes throughout to avoid
303 zombies; this hit htmltidy especially badly.
304 * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
305 subversion repos and fixing some other issues.
306 * Add support for tla, contributed by Clint Adams. Closes: #385936
307 * Add support for mercurial, contributed by Emanuele Aina.
308 * Include <link rel> tag for RSS feeds, used by some aggregators and
309 firefox to find the feed.
310 * Add a linkmap plugin (requires graphviz).
312 -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
314 ikiwiki (1.24) unstable; urgency=low
316 * Simplify the data structure returned by rcs_recentchanges to avoid
317 each rcs plugin needing to form complex strings on its own.
318 * Fix another destpage issue in the inline directive. Closes: #385512
321 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
323 ikiwiki (1.23) unstable; urgency=low
325 * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
327 -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
329 ikiwiki (1.22) unstable; urgency=low
331 * Change how the stylesheet url is determined in the templates: Remove
332 STYLEURL and add BASEURL to all templates (some already had it). This
333 new more general variable can be used to link to other things (eg, images)
334 from the template, as well as stylesheets.
335 * Fix a bug introduced last version to do with nested inlines.
336 * Allow preprocessor directives to span multiple lines, both to make
337 long ones with lots of values easier to write, and to allow for ones with
338 multi-line quoted values.
339 * Allow preprocessor directives to contain python-like triple-quoted
340 text blocks, for easy nesting of quotes inside.
341 * Add a template plugin.
342 * Make pagespec merge code smarter about merging duplicate pagespecs.
343 * Patch from Jordà Polo to make Setup::Standard support hashes in config
345 * Change order of linkify and preprocess; first preprocess and then linkify.
346 This allows passing a wikilink inside a parameter to a preprocessor
347 directive without it being expanded to html, and leaking out of the
348 parameter, which had required some non-obvious use of triple-quoting
349 to avoid. Note that any preprocessor plugins that output something
350 that looks like a wikilink will now have it treated as such; AFAIK
351 this doesn't change any behavior though except for the template plugin.
352 * Enable preprocessor directives when previewing an edit.
353 * Make all pages pull in a local.css style sheet, if present. This won't
354 be included in ikiwiki, but can be created to make local styling changes
355 w/o needing to merge in every new change to the distributed style.css.
356 * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
357 * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
358 from a different directory.
359 * Generalised preprocesser loop protection code.
360 * Patch from James Westby to allow a description to be set for rss feeds.
361 * Patch from James Westby to add a template for the search form.
362 * Added a ddate plugin.
363 * Patch from James Westby to add a --sslcookie switch, which forces
364 cookies to only be sent over ssl connections to avoid interception.
365 * Fix preferences page on anonok wikis; still need to sign in to get
366 to the preferences page.
367 * Add toc (table of contents) plugin.
368 * Change htmlize, format, and sanitize hooks to use named parameters.
369 * Patch from James Westby to add an actions option to inline; this
370 adds Edit and Discussion links at the end of blog entries.
371 * Due to some css changes, you'll want to rebuild your wiki on upgrade
372 to this version. Will be handled automatically by the deb.
373 * Add processed date to aggregate preprocessor directive status output.
375 -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
377 ikiwiki (1.21) unstable; urgency=low
379 * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
380 * If a page links to itself, mark up the link text in a span with
381 class="selflink" so that it can be styled. I don't have a useful style
382 defined for that though.
383 * Call filter hooks on inlined page content.
384 * Support inlining pages raw, rather than creating a blog.
385 * Clean up yes/no parameter parsing in inline plugin.
386 * Implemented better cycle detection in the inline plugin; nested inlines
388 * Add a map plugin contributed by Alessandro Dotti Contra.
389 * Add otl format plugin, which handles files as created by vimoutliner.
390 * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
391 * Add first draft at a Restructured Text (rst) plugin, by Sergio
392 Talens-Oliag. Note that this has many known issues -- see the caveats on
394 * Credit everyone who wrote a plugin on the plugins' wiki pages.
395 * Fix utf-8 in blog post form.
397 -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
399 ikiwiki (1.20) unstable; urgency=low
401 * Relicense the templates and basewiki under the 2-clause BSD license.
402 Since these can easily become part of other people's websites, they
403 should be under as permissive a license as possible.
404 * Add --syslog config option, to log to the syslog.
405 * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
406 transient failure to fork (which I've seen happen in the wild).
407 * Fix a bug in the aggregator introduced last version that caused all
408 aggregator state to be lost during a non-aggregating build.
410 -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
412 ikiwiki (1.19) unstable; urgency=low
414 * Fix several related bugs in page type determination during online editing.
415 * Add some locking to prevent 2 aggregators from running at once.
416 * Fix an infinite loop in the aggregator when finding a unique filename.
418 -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
420 ikiwiki (1.18) unstable; urgency=low
422 * The last release accidentially installed ikiwiki as ikiwiki.pl, now fixed.
424 * Man page format fixups.
425 * If the meta plugin overides the page title, set a title_overridden
426 variable in the template to true. This allows doing things with the
427 templates conditional on the title being overriden.
428 * Add a %pagecase which maps lower-case page names to the actual case
429 used in the filename. Use this in bestlinks calculation instead of
430 forcing the link to lowercase.
431 * Also use %pagecase in various other places that want to check if a page
432 with a given name exists.
433 * This means that links to pages with mixed case names will now work,
434 even if the link is in some other case mixture, and mixed case pages
435 should be fully supported throughout ikiwiki.
436 * Recommend rebuilding wikis on upgrade to this version.
438 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 22:10:48 -0400
440 ikiwiki (1.17) unstable; urgency=low
442 * Disable tidy generator tag.
443 * Move tidy back to sanitize hook, found out how to only show body.
444 * Turn off tidy indentation too.
445 * Turn on HTML::Template loop_context_vars; not actually used in stock
446 templates but can be useful for things like making comma-delimited lists
447 of tags or what have you.
448 * Remove <br> from end of aggregate preprocessor directive output.
449 * Ship ikiwiki executable as ikiwiki.pl in source to avoid issues on
450 case-sensative filesystems like OSX.
451 * Improve markdown loading. First, try to load it as a proper perl module,
452 in case it was installed as one. Then fall back to trying
454 * Document in install page how to install markdown, since it has no
455 installation procedure in the upstream tarball.
456 * Set die_on_bad_params => 0 for all templates, to allow users to modify
457 them without annoyances.
458 * Suck in the page content when generating an inline archive page, to work
459 around the meta plugin's lack of caching of title metadata across runs.
461 -- Joey Hess <joeyh@debian.org> Sat, 12 Aug 2006 12:52:13 -0400
463 ikiwiki (1.16) unstable; urgency=low
465 * Try to handle relative links in aggregated feeds. However,
466 the current support is a crude hack due to limitations of XML::Feed:
467 xml:base is not supported, neither is Content-Location. And of course,
468 relative links in RSS feeds are ill-undefined..
469 * Make aggregator save permalinks and author name to pages as metadata.
470 * Add permalink and author support to meta plugin, affecting RSS feeds
472 * Various CSS and formatting changes.
473 * Encode link and guid urls in rss feeds to avoid illegal utf8 slipping in.
474 * Add xhtml files to the default prune regexp.
475 * Also generate rel=bookmark links for permalinks.
476 * Fix the htmltidy plugin, which wasn't working due my breaking it when
478 * Don't run tidy with -xml as that fails if the input is not well-formed.
479 Run it with -asxhtml instead, so it will output well-formed xhtml no
480 matter what the input.
481 * Disable tidy warnings too.
482 * Add a new format hook, and make tidy use it, since tidy can really only
483 operate on and output complete html documents, not the body chunks
485 * Fix dates in rss feeds if running localised, so they're still rfc 822.
487 -- Joey Hess <joeyh@debian.org> Fri, 4 Aug 2006 20:48:36 -0400
489 ikiwiki (1.15) unstable; urgency=low
491 * Remove CDPATH and other env vars perl taint checking doesn't like.
493 * Added created_before and created_after PageSpec limits.
495 -- Joey Hess <joeyh@debian.org> Thu, 3 Aug 2006 13:00:57 -0400
497 ikiwiki (1.14) unstable; urgency=low
499 * Memoize pagespec translation, this speeds up a build of the ikiwiki tree
501 * Fix stupid bug in date matching, patch from Roland Mas. Closes: #381132
502 * Added many unit tests for pagespec_match.
504 -- Joey Hess <joeyh@debian.org> Wed, 2 Aug 2006 11:34:06 -0400
506 ikiwiki (1.13) unstable; urgency=low
508 * ikiwiki can now download and aggregate feeds with its new aggregate
509 plugin, so it's possible to implement a Planet using ikiwiki!
510 * Add a run_hooks function for the common task of running all hooks of a
512 * Add a savestate hook.
513 * Don't put blog post forms on pages if there's no cgiurl set.
514 * --setup --refresh no longer rebuilds wrappers. Use --setup --refresh
515 --wrappers to do that.
516 * Add %IkiWiki::forcerebuild to provide a way for plugins like aggregate
517 to update pages that haven't changed on disk.
518 * Change meta tags to use html entity-escaped text for values, so that
519 quotes and such can be represented in title tags.
520 * Depend and build-depend on HTML::Parser for HTML::Entities which is used
522 * Make --rebuild also cause --aggregate to re-download and write aggregated
524 * Avoid outputting duplicate meta info.
525 * Include title metadata on aggregated posts for capitalised and un-munged
527 * Title metadata of inlined pages now shows up in blogs and rss feeds.
528 * Fix issue with unicode filenames and updating the hyper estradier search
529 index. (Aka Please Please Please, let that be the last one.)
530 * Patch from Roland Mas to support an rss=no parameter to inline directives.
532 * Renamed GlobLists to PageSpecs.
533 * PageSpecs can now include nested parens, "and", and "or". This remains
534 backwards compatible to the old GlobList format. It's implemented by
535 treating the GlobList as a very limited microlanguage that is transformed
536 to perl code that does the matching.
537 * The old GlobList format is deprecated, and I encourage users to switch to
538 using the new PageSpec format. Compatability with the old format will be
539 removed at some point, possibly by 2.0.
540 * Wiki rebuild needed on upgrade to this version due to PageSpec change.
541 * Add support for creation_month and creation_year to PageSpec.
543 * Changes to index file encoding.
545 -- Joey Hess <joeyh@debian.org> Tue, 1 Aug 2006 21:21:19 -0400
547 ikiwiki (1.12) unstable; urgency=low
550 * New pagestats plugin from Enrico, which can generate a table counting
551 the backlinks for each page, or a del.icio.us style cloud.
552 * Build-depend on libtext-wikiformat-perl, so that the syntax check of
553 the wikiformat plugin works. Thanks, Emanuele Aina.
554 * Patch from Alessandro Dotti Contra to clean up backlinks and navbar
555 display, running them through pagetitle. This removes ugly underscores and
556 other gunk from the display, much nicer. You may want to rebuild your wiki
557 when upgrading to get the cleanup globally.
558 * Polygen plugin from Enrico.
559 * htmltidy plugin from Faidon.
560 * Locale patch from Faidon:
561 - Adds a locale setting to setup files.
562 - Proper local time, if the locale configuration option is used.
563 - Support for UTF-8 (or ISO-8859-X) filenames in SVN. Before this patch,
564 commiting (or even rcs_updating) on repositories with UTF-8 filenames was
566 * Add getopt hook type, this allows plugins to add new command-line options.
567 * Add --tagbase option to tag plugin.
568 * Add exclude option in setup files, works same as --exclude.
569 * Put categories in rss feeds for tagged items.
570 * Allow preprocessor directives to be expanded in inlined blog pages.
571 However, to avoid inlining loops etc, don't expand inline directives in
573 * fortune plugin (trivial)
574 * Tag plugins according to type.
576 -- Joey Hess <joeyh@debian.org> Sat, 29 Jul 2006 17:12:56 -0400
578 ikiwiki (1.11) unstable; urgency=low
580 * Patch from Enrico that
581 - Adds a tag plugin that allows more easily tagging pages.
582 The meta plugin can also still be used for that, but the tag plugin
583 also lists a page's tags at the bottom of the page.
584 - Allows preprocessor directives to have parameters with no specified
586 - Fixes preprocessor directive parameter parsing so that
587 foo=bar baz now means "foo=bar" and a "baz" with no value.
588 * Run pagetemplate hooks when inlining pages so that inlined pages also
590 * Make all plugins with pagetemplate hooks check that variables exist
591 on the template before setting them, for robustness.
592 * Switch pagetemplate hooks to using named parameters.
593 * Pass a destpage parameter to preprocessor and pagetemplate hooks.
594 This will be the page that a source page will be part of, which is
595 different than the source page for inlined pages.
596 * Audited all plugins to endure they pass (page, destpage) to htmllink
597 appropriatly. This means inlining of various plugins will not work
598 properly, with correct links generated.
600 -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400
602 ikiwiki (1.10) unstable; urgency=low
604 * Run page through any relevant filters when generating a page preview.
605 * Noticed a bug in the wikitext markup plugin -- it made CamelCase links the
606 default throughout the wiki, not only on wikitext pages. Decided to call
607 this a feature, and split the camelcase support out into a separate plugin
608 that is independant of wikitext.
609 * Fix CamelCase regexp to not break [[FooBar|BazBar]] WikiLinks.
611 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 18:06:35 -0400
613 ikiwiki (1.9) unstable; urgency=low
615 * Improve display of parentlinks and page title of toplevel index page.
616 * Patch from Faidon to use svn --limit when possible for recentchanges,
617 speeds up recentchanges a lot for wikis with more history.
618 * Patch from Recai to fix utf8 issues in git backend.
619 * Add wikitext markup plugin, which supports ".wiki" pages written in the
620 original wiki syntax, CamelCase links and all.
621 * Support a w3mmode, which lets w3m run ikiwiki using its local CGI
622 support, to edit pages etc without a web server.
623 * Display CGI processing errors if present.
624 * Fix from Faidon for a XML parser issue that breaks utf-8 for
625 RecentChanges. Avoid using XML::SAX::PurePerl, which is buggy in this
626 area, and also way slow.
627 * Match 'web commit from' in SVN and git, these are web commits too.
629 * Consolidated all decode_utf8 in FormBuilder's fields to make the code more
630 readable and avoid future mistakes. The patch seems to work and for the
631 first time I have a UTF-8 username ;-) (Faidon)
632 * Use form->field consistently, not form->param.
633 * Patch from Recai to allow selection of page type when creating a new page.
634 Default page type is inherited from the link clicked on to create the new
637 -- Joey Hess <joeyh@debian.org> Wed, 26 Jul 2006 17:25:30 -0400
639 ikiwiki (1.8) unstable; urgency=low
641 * Fix orphans plugin to not count a link to a nonexistant page as a reason
642 for a page not being an orphan.
643 * Support pinging services such as Technorati using XML-RPC to notify them
644 about changes to rss feeds.
645 * Parse svn log as xml for improved utf8 and security. Note that this makes
646 ikiwiki depend on XML::Simple. Patch by Faidon Liambotis.
647 * POSIX::strftime doesn't know about encodings and doesn't return a utf8
648 flagged string even if the locale causes it to generate utf8 output,
649 so make sure to let perl know it should be handled as utf8. Also,
650 the optimised version used for standard time formats won't work if the
651 user has changed locale, so drop it. Thanks, Faidon Liambotis.
652 * Fix re-encoding of the comments field to utf8 if a commit fails
653 due to a conflict. Thanks, Faidon Liambotis.
654 * Let svn know that commits have utf8 commit messages. Thanks, Faidon
656 * Add insane double encode/decode to utf8 around call to markdown.
657 This works around a truely strange bug, which is apparently a bug in
658 perl, #376329. Also added a test case for it.
659 * Improve layout of edit page so formatting help link is always visible w/o
660 getting in the way of the preview.
661 * Centralised all calls to HTML::Template and force all the templates
663 * Support pages with utf8 filenames. Patch by Faidon Liambotis.
664 * Introduce add_plugins and disable_plugins config options in setup files.
665 This allows adding or removing plugins w/o overriding the whole list of
666 default plugins, which makes it easier to upgrade when new default plugins
668 * Support htmlize plugins and make mdwn one such plugin, which is enabled by
669 default (of course!). Based on a patch by Faidon Liambotis.
670 * Add a html plugin, which can be used to write wikis in raw html,
671 if you'd ever want to do such a thing. Slightly tricky, since ikiwiki
672 defaults to not processing .html files, since w/o this plugin they would
673 be copied unsanitised. With this plugin, it will process and html
674 sanitise them, like any other page type.
675 * Rebuilding wrappers is necessary on upgrade to this version.
676 * Make ikiwiki --setup --refresh rebuild wrappers, so wrapper rebuild
677 will be automatically done on all upgrades.
678 * Don't send pings if the wiki is being rebuilt.
679 * Work around very innefficient behavior in File::Spec::abs2rel. Result
680 is a savings of 2 pointless fork/execs per link calculation, which
681 results in ~25% speedup of ikiwiki building its own doc wiki, and
682 about 35% speedup displaying RecentChanges!
683 * Make RecentChanges use a table and some CSS, should be much more readable.
684 No code changes involved.
685 * Encode & in diffurl in examples, to conform to pedantic rules.
686 * Speed up RecentChanges by another 40% or so with some memoization.
687 * Memoize abs2rel, which is still kinda slow, for another 30% speedup
688 in time to build the doc wiki.
690 -- Joey Hess <joeyh@debian.org> Tue, 4 Jul 2006 12:46:29 -0400
692 ikiwiki (1.7) unstable; urgency=low
694 * Updated logo from Recai with some kerning and alingment tuning.
695 * Patch from Recai to fix git recentchanges code to work with git 1.4 which
699 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 23:33:35 -0400
701 ikiwiki (1.6) unstable; urgency=low
703 * YA utf-8 patch from Recai, this time to fix previewing a page so that
704 the text in the input box is re-encoded back to utf-8.
705 * -CSD does not affect modules, so readfile() was not using the utf-8 input
706 layer, which led to lots of problems; make it force read files as utf-8.
708 * Note that as a consequence, this version of ikiwiki will actually try to
709 parse utf8 in source files for the first time, which may expose broken
710 utf8 in wiki sources that was hidden before. Most common will be
711 perl warnings like "utf8 "\xE9" does not map to Unicode"
712 * writefile() likewise needs to use the utf8 output layer.
713 * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
715 * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
716 given the readfile fix.
717 * Add utf-8 testcases for readfile and htmlize.
718 * Put back the encode_utf8 in the input to markdown; it's really not utf-8
720 * More utf-8 fixes from Recai, partly to things I broke above:
721 - The serious problem is that writefile() saves the content in undecoded
722 format in CGI, hence all (non-ascii) chars are corrupted permanently.
723 - Comment field in edit page is not decoded and all the non-ascii chars in
724 this field are corrupted as the result. We should decode it as we do it
726 - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
728 * New SVG logo from Recai.
730 -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
732 ikiwiki (1.5) unstable; urgency=low
734 * Add --timeformat config option to allow changing how dates are displayed.
735 Note that as a side effect, dates will now be displayed using the local
736 timezone, not as GMT.
737 * More security review.
738 * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
739 for some handy stuff like:
740 - Using links as a kind of tag; creating blog pages that list all pages
741 containing a given tag/link or not containing some other tag.
742 - Subscribing to mail notifications whenever a change is made to a page
743 that is a backlink of page foo. Ie, "Please notify me of changes in all
744 pages that link to my home page in the wiki"
745 - Locking any pages that are linked to from a particular page, so that
746 lists of locks can be exposed in the wiki.
747 * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
748 when a todo item is done, instead of the previous moving it to a different
750 * Allow pagetemplate plugins to override *anything* in the template.
751 * Add a meta plugin, which allows specifying various metadata about pages,
752 like license and author. It also allows for inserting html link and meta
753 tags into html, overriding the title, and adding hidden WikiLinks, which
754 can be useful when using link-based globbing for page categorisation.
755 * Remove preprocessor directives from inlined pages.
756 * Allow simple preprocessor directive values to be specified w/o quotes.
757 * Add support for using git instead of subversion as the RCS backend,
758 tremendous thanks to Recai Oktaş for this.
759 * Doc updates for git.
760 * Fix absolute url munging in rss generation to support https, ftp, etc urls
762 * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
763 utf-8 for edit and other fields, and for recentchanges. There may still
764 be utf-8 issues with the preferences page though.
766 -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
768 ikiwiki (1.4) unstable; urgency=low
770 * Tell HTML::Scrubber to treat "/" as a valid attribute which is its
771 very strange way of enabling proper XHTML <br /> type tags. Output html
772 should be always valid again now.
773 * The page name and parent links has switched from using a <h1> to a styled
774 <span>, so pages can use <h1> internally instead of needing to use <h2>.
775 * Updated all of ikiwiki's own wiki pages for that.
776 * Add pagetemplate hook, which can be used by plugins that want to mess
777 around with adding new stuff to the page template.
778 * Remove headercontent; the search plugin now adds the search box to the
779 header by registering a pagetemplate hook, and other plugins should do
781 * Rebuilding on upgrade to this version is recommended.
782 * Add a html validity check to the test suite, using the wdg-html-validator,
784 * Make the html valid when there is nothing in the actions list.
785 * Reordered some function call parameters for consistency.
786 * Enable full utf-8 support for page input and output.
787 * Add a workaround for markdown, which does not work well with utf-8
789 * --getctime had bitrotted (well I only ever used it the once so far..),
790 fix and make it a bit more flexible
791 * rcs_getctime is changed, now rather than needing to loop over all pages,
792 it should just use the rcs to get the ctime of the passed file.
793 * When inlining a page in another one, links from the inlined page are now
794 expanded the same as they are when rendering the inlined page as a
795 standalone page. So rather than being expanded from the POV of the
796 inlining page, they are expanded from the POV of the inlined page.
798 For example, a link from blog/foo to "bar" will now link to blog/bar
799 if it exists. Previously this needed to be a link explicitly to
800 "blog/bar"; such links will also continue to work.
802 (This was slightly complex to do as the link still has to be constructed
803 relative to the inlining page.)
804 * Make page edit textarea resize to fit browser window.
805 * Add -refresh option to ikiwiki-mass-rebuild and use that on upgrades that
806 do not need a full rebuild, in order to update any basewiki pages.
808 -- Joey Hess <joeyh@debian.org> Sat, 27 May 2006 15:08:49 -0400
810 ikiwiki (1.3) unstable; urgency=low
812 * Fix the preinst introduced in the last version. Closes: #367458
814 -- Joey Hess <joeyh@debian.org> Tue, 16 May 2006 02:43:02 -0500
816 ikiwiki (1.2) unstable; urgency=low
818 * Remove dups from the brokenlinks list.
819 * Add libc6-dev to dependencies, needed to build wrappers.
820 * Install wikilist in correct location. Closes: #367371
822 -- Joey Hess <joeyh@debian.org> Mon, 15 May 2006 10:53:49 -0500
824 ikiwiki (1.1) unstable; urgency=low
826 * Rename inlinepage to depends, so that it can be used to refer to more
827 dependency relationships than just inlining. This will require a rebuild
828 on upgrade to this version.
829 * Move the rss link, put it in the blogpost form if there is one and at the
830 top if not. This is both nicer because easier to find, and it cleans up
831 the code which had used inlinepage as a flag for adding the link later.
832 * Allow the depends GlobList to be built up from multiple sources (such as
833 plugins) during a page render.
834 * Which means that more than one blog is now supported to appear on a
835 single page. (With some limitations, like only the last one getting an
837 * Added a plugin system.
838 * Added a pagecount plugin, enabled by default.
839 * Support PreProcessorDirectives with no parameters, ie "[[pagecount ]]".
840 * Fixed/optimised backlinks code, to avoid rebuilding pages to update
841 backlinks when the backlinks hadn't really changed.
842 * Moved inline page support, rss generation etc into the inline plugin,
844 * Added brokenlinks plugin, not enabled by default, but rather handy.
845 * Fix several broken links in the doc wiki.
846 * Smarter behavior when creating a page and a page of the same name (but
847 different location) already exists.
848 * Add an orphans plugin for finding pages that nothing links to.
849 * Removed backlinks page, which it turns out nothing used.
850 * Split off an IkiWiki.pm out of ikiwiki and have all the other modules use
851 it, this will allow for adding a unit test suite.
852 * Add unit tests for several core functions, including globlist_match,
853 dirname, basename, bestlink, linkify, pagetitle, titlepage.
854 * Smart globlist merging.
855 * Patch from Thomas Schwinge to switch from --svn to --rcs=svn, etc,
856 to pave the way for adding other RCS support. This also changes the
857 setup files, where before they had svn => 1 or svn => 0, now they have
858 rcs => "svn" or rcs => "".
859 * Add a debian/NEWS file with upgrade notes.
860 * Load whatever rcs module is specified, so new ones can be just dropped in
861 as plugins and work. (Well, in theory.)
862 * Add some basic docs about writing RCS modules.
863 * Broke search capability out into a plugin, removed the --hyperestraier
865 * Added smiley plugin, nicely controlled and documented by the smileys page.
866 * Copied in some smileys from Moin Moin.
867 * Allow links of the form [[some page|page]], with whitespace in the link
869 * Removed --sanitize and --no-sanitize, replaced with --plugin htmlscrubber
870 and --disable-plugin htmlscrubber.
871 * Allow discussion links on pages to be turned off with --no-discussion.
872 * Add ikiwiki-mass-rebuild script, ripped out of the postinst.
873 * Add some new config items to the estseek.conf template, which are needed
874 by hyperestraier 1.2.3.
876 -- Joey Hess <joeyh@debian.org> Fri, 5 May 2006 17:00:41 -0400
878 ikiwiki (1.0) unstable; urgency=low
880 * First official release.
882 -- Joey Hess <joeyh@debian.org> Tue, 25 Apr 2006 02:08:17 -0400