X-Git-Url: http://git.vanrenterghem.biz/git.ikiwiki.info.git/blobdiff_plain/f0d7a5ee1a9fe6ea28b63544904e5126faad12ec..e0d6ef53d81456eb9edb2899e1838654d2c95191:/debian/rules

diff --git a/debian/rules b/debian/rules
index b1ae6dd1f..cf3087d1d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,40 +1,15 @@
 #!/usr/bin/make -f
+%:
+	LC_ALL=C.UTF-8 TZ=UTC dh $@
 
-build: build-stamp
-build-stamp:
-	dh_testdir
-	perl Makefile.PL
-	$(MAKE)
-	touch build-stamp
+override_dh_auto_configure:
+	# keeps it out of /usr/local
+	dh_auto_configure -- PREFIX=/usr
 
-clean:
-	dh_testdir
-	dh_testroot
-	rm -f build-stamp
-	perl Makefile.PL
-	-$(MAKE) realclean
-	dh_clean
+override_dh_compress:
+	# avoid compressing files in the doc wiki
+	dh_compress -Xhtml
 
-binary-arch: build
-
-binary-indep: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k
-	$(MAKE) pure_install INSTALLDIRS=vendor \
-		PREFIX=$(shell pwd)/debian/ikiwiki/$(shell perl -MConfig -e 'print $$Config{prefix}')
-	dh_installdocs html
-	dh_link usr/share/ikiwiki/basewiki \
-		usr/share/doc/ikiwiki/examples/basewiki
-	dh_installman ikiwiki.man
-	dh_installchangelogs
-	dh_compress
-	dh_fixperms
-	dh_perl
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+override_dh_auto_clean:
+	# distclean moans about MANIFEST, this is quieter
+	if [ -e Makefile ]; then $(MAKE) realclean; fi