X-Git-Url: http://git.vanrenterghem.biz/git.ikiwiki.info.git/blobdiff_plain/e6992480e2e0cf965650f84aa97e01fe0fa71544..44b0cea85f1641f33ccb305f9da6f96e812b84e9:/debian/rules

diff --git a/debian/rules b/debian/rules
index 2434d92c8..0a7ce7a26 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,45 +1,19 @@
 #!/usr/bin/make -f
+%:
+	dh $@
 
-build: build-stamp
-build-stamp:
-	dh_testdir
-	perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor
-	$(MAKE) -C po
-	$(MAKE)
-	$(MAKE) test
-	touch build-stamp
+override_dh_auto_configure:
+	# keeps it out of /usr/local
+	dh_auto_configure -- PREFIX=/usr
 
-clean:
-	dh_testdir
-	dh_testroot
-	rm -f build-stamp
-	perl Makefile.PL
-	if [ -e Makefile ]; then $(MAKE) realclean; fi
-	dh_clean
-
-binary-arch: build
+override_dh_compress:
+	# avoid compressing files in the doc wiki
+	dh_compress -Xhtml
 
-binary-indep: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k
-	$(MAKE) pure_install DESTDIR=$(shell pwd)/debian/ikiwiki
-	dh_installdocs html
-	dh_link usr/share/ikiwiki/examples usr/share/doc/ikiwiki/examples
-	dh_link usr/share/common-licenses/GPL-2 usr/share/doc/ikiwiki/html/GPL
-	dh_installexamples
-	dh_installchangelogs
-	dh_compress -X html
-	dh_fixperms
-	dh_perl
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
+override_dh_auto_clean:
+	# distclean moans about MANIFEST, this is quieter
+	if [ -e Makefile ]; then $(MAKE) realclean; fi
 
 # Not intended for use by anyone except the author.
 announcedir:
 	@echo ${HOME}/src/ikiwiki/doc/news
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary