X-Git-Url: http://git.vanrenterghem.biz/git.ikiwiki.info.git/blobdiff_plain/b37070d888919ae30219ce13e4d3cce359fd75e1..6bc787e14c114cd93d5c35ffeb5ba57529f66eef:/debian/rules

diff --git a/debian/rules b/debian/rules
index fcbf2959d..0a7ce7a26 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,44 +1,19 @@
 #!/usr/bin/make -f
+%:
+	dh $@
 
-build: build-stamp
-build-stamp:
-	dh_testdir
-	perl Makefile.PL PREFIX=/usr
-	$(MAKE)
-	$(MAKE) test
-	touch build-stamp
+override_dh_auto_configure:
+	# keeps it out of /usr/local
+	dh_auto_configure -- PREFIX=/usr
 
-clean:
-	dh_testdir
-	dh_testroot
-	rm -f build-stamp
-	perl Makefile.PL
-	-$(MAKE) realclean
-	dh_clean
+override_dh_compress:
+	# avoid compressing files in the doc wiki
+	dh_compress -Xhtml
 
-binary-arch: build
-
-binary-indep: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k
-	$(MAKE) pure_install INSTALLDIRS=vendor \
-		DESTDIR=$(shell pwd)/debian/ikiwiki
-	dh_install wikilist etc/ikiwiki
-	dh_installdocs html
-	dh_link usr/share/common-licenses/GPL usr/share/doc/ikiwiki/html/GPL
-	dh_installchangelogs
-	dh_compress -X html
-	dh_fixperms
-	dh_perl
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
+override_dh_auto_clean:
+	# distclean moans about MANIFEST, this is quieter
+	if [ -e Makefile ]; then $(MAKE) realclean; fi
 
 # Not intended for use by anyone except the author.
 announcedir:
 	@echo ${HOME}/src/ikiwiki/doc/news
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary