X-Git-Url: http://git.vanrenterghem.biz/git.ikiwiki.info.git/blobdiff_plain/862caff2a9d66ec7b79f03cf769a53ba0fdc3539..59ea3f3d451e5640d4c9bd9a78a847d17f1831a0:/debian/rules

diff --git a/debian/rules b/debian/rules
index 115b3f0c2..cf3087d1d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,7 +1,15 @@
 #!/usr/bin/make -f
 %:
-	dh $@
+	LC_ALL=C.UTF-8 TZ=UTC dh $@
 
-# Not intended for use by anyone except the author.
-announcedir:
-	@echo ${HOME}/src/ikiwiki/doc/news
+override_dh_auto_configure:
+	# keeps it out of /usr/local
+	dh_auto_configure -- PREFIX=/usr
+
+override_dh_compress:
+	# avoid compressing files in the doc wiki
+	dh_compress -Xhtml
+
+override_dh_auto_clean:
+	# distclean moans about MANIFEST, this is quieter
+	if [ -e Makefile ]; then $(MAKE) realclean; fi