X-Git-Url: http://git.vanrenterghem.biz/git.ikiwiki.info.git/blobdiff_plain/55ebfd5de723acb59b5a2f8cb060b7e568284612..03b956ab4cb2fee8f7b93e725869060bb45fa4ea:/debian/rules

diff --git a/debian/rules b/debian/rules
index 6ca612c9e..0a7ce7a26 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,41 +1,19 @@
 #!/usr/bin/make -f
+%:
+	dh $@
 
-build: build-stamp
-build-stamp:
-	dh_testdir
-	perl Makefile.PL
-	$(MAKE)
-	touch build-stamp
+override_dh_auto_configure:
+	# keeps it out of /usr/local
+	dh_auto_configure -- PREFIX=/usr
 
-clean:
-	dh_testdir
-	dh_testroot
-	rm -f build-stamp
-	perl Makefile.PL
-	-$(MAKE) realclean
-	dh_clean
+override_dh_compress:
+	# avoid compressing files in the doc wiki
+	dh_compress -Xhtml
 
-binary-arch: build
+override_dh_auto_clean:
+	# distclean moans about MANIFEST, this is quieter
+	if [ -e Makefile ]; then $(MAKE) realclean; fi
 
-binary-indep: build
-	dh_testdir
-	dh_testroot
-	dh_clean -k
-	$(MAKE) pure_install INSTALLDIRS=vendor \
-		PREFIX=$(shell pwd)/debian/ikiwiki/$(shell perl -MConfig -e 'print $$Config{prefix}')
-	dh_installdocs html
-	dh_link usr/share/common-licenses/GPL usr/share/doc/ikiwiki/html/GPL
-	dh_link usr/share/ikiwiki/basewiki \
-		usr/share/doc/ikiwiki/examples/basewiki
-	dh_installman ikiwiki.man
-	dh_installchangelogs
-	dh_compress -X html
-	dh_fixperms
-	dh_perl
-	dh_installdeb
-	dh_gencontrol
-	dh_md5sums
-	dh_builddeb
-
-binary: binary-indep binary-arch
-.PHONY: build clean binary-indep binary-arch binary
+# Not intended for use by anyone except the author.
+announcedir:
+	@echo ${HOME}/src/ikiwiki/doc/news