X-Git-Url: http://git.vanrenterghem.biz/git.ikiwiki.info.git/blobdiff_plain/44a74ec022d1ab0fe3fe12fb26b3f2a432dbb2eb..6a8c921ee1bbfd4c980ffaf2c43e5b45e452f4de:/debian/rules

diff --git a/debian/rules b/debian/rules
index 74206370b..8c06011bc 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,8 +3,9 @@
 build: build-stamp
 build-stamp:
 	dh_testdir
-	perl Makefile.PL
+	perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor
 	$(MAKE)
+	$(MAKE) test
 	touch build-stamp
 
 clean:
@@ -12,7 +13,7 @@ clean:
 	dh_testroot
 	rm -f build-stamp
 	perl Makefile.PL
-	-$(MAKE) realclean
+	if [ -e Makefile ]; then $(MAKE) realclean; fi
 	dh_clean
 
 binary-arch: build
@@ -21,13 +22,11 @@ binary-indep: build
 	dh_testdir
 	dh_testroot
 	dh_clean -k
-	$(MAKE) pure_install INSTALLDIRS=vendor \
-		PREFIX=$(shell pwd)/debian/ikiwiki/$(shell perl -MConfig -e 'print $$Config{prefix}')
-	dh_install debian/wikilist etc/ikiwiki
+	$(MAKE) pure_install DESTDIR=$(shell pwd)/debian/ikiwiki
+	dh_install wikilist etc/ikiwiki
 	dh_installdocs html
+	dh_installexamples doc/examples/*
 	dh_link usr/share/common-licenses/GPL usr/share/doc/ikiwiki/html/GPL
-	dh_link usr/share/ikiwiki/basewiki \
-		usr/share/doc/ikiwiki/examples/basewiki
 	dh_installchangelogs
 	dh_compress -X html
 	dh_fixperms
@@ -39,7 +38,7 @@ binary-indep: build
 
 # Not intended for use by anyone except the author.
 announcedir:
-	@echo ${HOME}/src/ikiwiki/news
+	@echo ${HOME}/src/ikiwiki/doc/news
 
 binary: binary-indep binary-arch
 .PHONY: build clean binary-indep binary-arch binary