X-Git-Url: http://git.vanrenterghem.biz/git.ikiwiki.info.git/blobdiff_plain/25b1f60aeb26f8d14d7619b304f8aca0735c850f..c467e1f7cf8e8960a77d248af8bc127e48fd0abe:/debian/rules?ds=sidebyside

diff --git a/debian/rules b/debian/rules
index 0a6571521..cf3087d1d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,19 +1,15 @@
 #!/usr/bin/make -f
 %:
-	dh $@
+	LC_ALL=C.UTF-8 TZ=UTC dh $@
 
-# keeps it out if /usr/local
 override_dh_auto_configure:
+	# keeps it out of /usr/local
 	dh_auto_configure -- PREFIX=/usr
 
-# avoid compressing files in the doc wiki
 override_dh_compress:
+	# avoid compressing files in the doc wiki
 	dh_compress -Xhtml
 
-# distclean moans about MANIFEST, this is quieter
 override_dh_auto_clean:
-	$(MAKE) realclean
-
-# Not intended for use by anyone except the author.
-announcedir:
-	@echo ${HOME}/src/ikiwiki/doc/news
+	# distclean moans about MANIFEST, this is quieter
+	if [ -e Makefile ]; then $(MAKE) realclean; fi