X-Git-Url: http://git.vanrenterghem.biz/git.ikiwiki.info.git/blobdiff_plain/14e081b2c6cf5eed4903d61bee0a23ac49fc120f..09e7c1ad99367eb00d56cfc1e6c64e9b0e361dc4:/debian/rules

diff --git a/debian/rules b/debian/rules
index da8249920..0a7ce7a26 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,13 +1,18 @@
 #!/usr/bin/make -f
+%:
+	dh $@
+
+override_dh_auto_configure:
+	# keeps it out of /usr/local
+	dh_auto_configure -- PREFIX=/usr
 
-binary: binary-indep
-binary-indep:
-	dh $@ --before dh_compress
+override_dh_compress:
+	# avoid compressing files in the doc wiki
 	dh_compress -Xhtml
-	dh $@ --after dh_compress
 
-%:
-	dh $@
+override_dh_auto_clean:
+	# distclean moans about MANIFEST, this is quieter
+	if [ -e Makefile ]; then $(MAKE) realclean; fi
 
 # Not intended for use by anyone except the author.
 announcedir: