-ikiwiki (2.54) UNRELEASED; urgency=low
+ikiwiki (2.60) UNRELEASED; urgency=low
+
+ * Starting with this version, "ikiwiki -setup /etc/ikiwiki/auto.setup"
+ can be used create a new wiki in seconds.
+ * Add getsetup hook, all plugins that add fields to %config should use it.
+ * ikiwiki --dumpsetup can generate a nice setup file snapshotting ikiwiki's
+ current configuration.
+ * Large amounts of internal config data reorg.
+ * The way wrappers are defined in the setup file has changed. Old setup
+ files will continue to work, for now.
+ * Version control backends promoted to first-class plugins.
+ * ikiwiki-update-wikilist: Add -r switch to remove. Default behavior is now
+ always to add.
+ * Start moving admin preferences from the web interface to the setup file.
+ * websetup: New plugin providing a setup form on the web.
+ * ikiwiki-makerepo: Bail if both srcdir and repository are not specified.
+ Closes: #493628
+
+ -- Joey Hess <joeyh@debian.org> Mon, 21 Jul 2008 11:35:46 -0400
+
+ikiwiki (2.56) unstable; urgency=low
+
+ * autoindex: New plugin that generates missing index pages.
+ (Sponsored by The TOVA Company.)
+ * Escape HTML is rss and atom feeds instead of respectively using CDATA and
+ treating it as XHTML. This avoids problems with escaping the end of the
+ CDATA when the htmlscrubber is not used, and it avoids problems with atom
+ XHTML using named entity references that are not in the atom DTD. (Simon McVittie)
+ * Add test for old versions of git that don't support --cleanup=verbatim,
+ and munge empty commit messages.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 31 Jul 2008 19:25:24 -0400
+
+ikiwiki (2.55) unstable; urgency=low
+
+ * remove: New plugin that adds the ability to remove pages via the web.
+ (Sponsored by The TOVA Company.)
+ * rename: New plugin that adds the ability to rename pages via the web.
+ (Sponsored by The TOVA Company.) (This one's for you, Kyle.)
+ * All rcs backends need to implement rcs_remove, rcs_commitstaged,
+ and rcs_rename. (Done for svn, git).
+ * This version adds renamepage hooks, which can be used to modify page content,
+ including links, during renames.
+ * prefix_directives enabled in doc wiki, all preprocessor directives
+ converted. (Simon McVittie)
+ * editpage: Don't show attachments link when attachments are disabled.
+ * tag: Allow tagbase to be overridden by starting a tag with "./" or "/".
+ (Simon McVittie)
+ * Really fix bug with links to pages with names containing colons.
+ Previous fix mised a few cases.
+ * Avoid troublesome abs_path calls in wrapper setup.
+ * Add allow_symlinks_before_srcdir config setting that can be used to avoid
+ a security check that is a good safe default, but problimatic overkill in
+ some situations.
+ * Don't allow uploading an attachment with the same name as an existing
+ page, to avoid confusion.
+ * Split out error messages from editpage.tmpl into several separate
+ templates.
+ * attachment: Do not escape _ when determining attachment filenames.
+ * Rebuild pages that change their type. (Gabriel McManus)
+ * monotone: Add support for rename, delete, and also diff. (William Uther)
+ * toggle: Fix incompatability between javascript and webkit.
+ * bzr: Add support for rename and delete. (Jelmer Vernooij)
+ * attachment: Use relative paths when inserting links.
+ * toggle: Fix for when html got tidied. Closes: #492529 (Enrico Zini)
+ * cutpaste: New plugin by Enrico Zini
+
+ -- Joey Hess <joeyh@debian.org> Sun, 27 Jul 2008 11:23:13 -0400
+ikiwiki (2.54) unstable; urgency=low
+
+ [ Joey Hess ]
* Make it possible to load setup files w/o running them. Code
needing to do so can call IkiWiki::Setup::load, which will return
a hash of values.
- -- Joey Hess <joeyh@debian.org> Wed, 09 Jul 2008 22:27:19 -0400
+ [ Josh Triplett ]
+ * ikiwiki-transition: Fix command-line processing so the prefix_directives
+ transition works again.
+
+ [ Joey Hess ]
+ * template: Add support for a BASENAME variable.
+ * Fixes creation of pages when clicking on WikiLinks starting with "/".
+ * Change deb dependencies to list Text::Markdown before markdown, since
+ the former, while slower, has a much better html parser that avoids
+ numerous bugs.
+ * Move yesno function out of inline and into IkiWiki core, not exported.
+ * Error handling improvement for preprocess hooks. It's now safe to call
+ error() from such hooks; it will cause a nicely formatted error message
+ to be inserted into the page.
+ * Cut the size of the binary package in half by excluding pages for bugs
+ and todo items from the html shipped in it.
+ * parentlinks: New plugin, split out of ikiwiki core and enabled by default,
+ and several new fields added to allow for advanced styling. (intrigeri)
+ * smileys: Some fixes for escaped smileys.
+ * smileys: Note that smileys need to be double-escaped for the escaping to
+ work. Markdown removes one level of escaping.
+ * Add a postscan hook.
+ * search: Use postscan hook, avoid updating index when previewing.
+ * git: Put web committer name/openid/address in the git author field.
+ The committer's email address is not used (because leaking email addresses
+ is not liked by many users). Closes: #451023
+ * git: Fix parsing of git logs with no commit messages at all.
+ * search: Fixes for title stemming, and use better term for tags.
+ (Gabriel McManus)
+ (Rebuilding the wiki on upgrade to this version is recommended if you
+ use the search plugin.)
+
+ [ Simon McVittie ]
+ * meta, inline: Support guid options, to allow forcing a particular url or
+ uuid in feeds.
+ * meta: fix title() PageSpec
+ * Some footer style changes.
+ * aggregate: Add an `aggregateinternal` option, which allows storing
+ aggregated data to internal-use files, rather than wiki pages. This
+ can save disk space, and be faster.
+ * ikiwiki-transition: Add a `aggregateinternal` transition to rename
+ the aggregated files.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 21 Jul 2008 10:10:52 -0400
ikiwiki (2.53) unstable; urgency=low
pounding on the cgi following edit links.
* passwordauth: If Authen::Passphrase is installed, use it to store
password hashes, crypted with Eksblowfish.
- * `ikiwiki-transiition hashpassword /path/to/srcdir` can be used to
+ * `ikiwiki-transition hashpassword /path/to/srcdir` can be used to
hash existing plaintext passwords.
* Passwords will no longer be mailed, but instead a password reset link.
* The password_cost config setting is provided as a "more security" knob.