+ [ Simon McVittie ]
+ * git: use an explicit function parameter for the directory to work
+ in. Previously, we used global state that was not restored correctly
+ on catching exceptions, causing an unintended log message
+ "cannot chdir to .../ikiwiki-temp-working: No such file or directory"
+ with versions >= 3.20161229 when an attempt to revert a change fails
+ or is disallowed
+ * git: don't run "git rev-list ... -- -- ..." which would select the
+ wrong commits if a file named literally "--" is present in the
+ repository
+ * check_canchange: log "bad file name whatever", not literal string
+ "bad file name %s"
+ * t/git-cgi.t: fix a race condition that made the test fail
+ intermittently
+ * t/git-cgi.t: be more careful to provide a syntactically valid
+ author/committer name and email, hopefully fixing this test on
+ ci.debian.net
+ * templates, comments, passwordauth: use rel=nofollow microformat
+ for dynamic URLs
+ * templates: use rel=nofollow microformat for comment authors
+ * news: use Debian security tracker instead of MITRE for security
+ references. Thanks, anarcat
+ * Set package format to 3.0 (native)
+ * d/copyright: re-order to put more specific stanzas later, to get the
+ intended interpretation
+ * d/source/lintian-overrides: override obsolete-url-in-packaging for
+ OpenID Selector, which does not seem to have any more current URL
+ (and in any case our version is a fork)
+ * docwiki.setup: exclude TourBusStop from offline documentation.
+ It does not make much sense there.
+ * d/ikiwiki.lintian-overrides: override script-not-executable warnings
+ * d/ikiwiki.lintian-overrides: silence false positive spelling warning
+ for Moin Moin
+ * d/ikiwiki.doc-base: register the documentation with doc-base
+ * d/control: set libmagickcore-6.q16-3-extra as preferred
+ build-dependency, with virtual package libmagickcore-extra as an
+ alternative, to help autopkgtest to do the right thing
+
+ -- Simon McVittie <smcv@debian.org> Tue, 10 Jan 2017 13:22:01 +0000
+
+ikiwiki (3.20161229.1) unstable; urgency=medium
+
+ * git: Attribute reverts to the user doing the revert, not the wiki
+ itself.
+ * git: Do not disable the commit hook while preparing a revert.
+
+ -- Simon McVittie <smcv@debian.org> Thu, 29 Dec 2016 20:46:24 +0000
+
+ikiwiki (3.20161229) unstable; urgency=medium
+
+ * Security: force CGI::FormBuilder->field to scalar context where
+ necessary, avoiding unintended function argument injection
+ analogous to CVE-2014-1572. In ikiwiki this could be used to
+ forge commit metadata, but thankfully nothing more serious.
+ (CVE-2016-9646)
+ * Security: try revert operations in a temporary working tree before
+ approving them. Previously, automatic rename detection could result in
+ a revert writing outside the wiki srcdir or altering a file that the
+ reverting user should not be able to alter, an authorization bypass.
+ (CVE-2016-10026 represents the original vulnerability.)
+ The incomplete fix released in 3.20161219 was not effective for git
+ versions prior to 2.8.0rc0.
+ (CVE-2016-9645 represents that incomplete solution.)
+ * Add CVE references for CVE-2016-10026
+ * Add automated test for using the CGI with git, including
+ CVE-2016-10026
+ - Build-depend on libipc-run-perl for better build-time test coverage
+ * Add missing ikiwiki.setup for the manual test for CVE-2016-10026
+ * git: don't issue a warning if the rcsinfo CGI parameter is undefined
+ * git: do not fail to commit changes with a recent git version
+ and an anonymous committer
+
+ -- Simon McVittie <smcv@debian.org> Thu, 29 Dec 2016 17:36:15 +0000
+
+ikiwiki (3.20161219) unstable; urgency=medium
+
+ [ Joey Hess ]
+ * inline: Prevent creating a file named ".mdwn" when the
+ postform is submitted with an empty title.
+
+ [ Simon McVittie ]
+ * Security: tell `git revert` not to follow renames. If it does, then
+ renaming a file can result in a revert writing outside the wiki srcdir
+ or altering a file that the reverting user should not be able to alter,
+ an authorization bypass. Thanks, intrigeri. (CVE-2016-10026)
+ * cgitemplate: remove some dead code. Thanks, blipvert
+ * Restrict CSS matches against header class to not break
+ Pandoc tables with header rows. Thanks, karsk
+ * Make pagestats output more deterministic. Thanks, intrigeri
+
+ -- Simon McVittie <smcv@debian.org> Mon, 19 Dec 2016 20:34:23 +0000
+
+ikiwiki (3.20160905) unstable; urgency=medium
+
+ [ Joey Hess ]