+ * Avoid locking the wiki at all when handling some basic cgi stuff
+ (searches, recentchanges).
+ * Add "last" parameter to hook function. Very basic ordering, and hopefully
+ nothing more spohisticated will be needed.
+ * Add formbuilder_setup and formbuilder hooks.
+ * Split out a passwordauth module, that holds all the traditional password
+ based authentication etc code. It's enabled by default, but can be disabled
+ if you want only openid or some other auth method.
+ * Rename ikiwiki.pl so MakeMaker doesn't see it, and install it.
+ * Add some code to the build system that tries to determine if the
+ lib installation directory is in @INC. If it's not, munge ikiwiki
+ to hardcode the path to the lib directory. This should allow installing
+ ikiwiki in nonstandard locations, including home directories, by just
+ setting PREFIX at build time.
+ * Fix nested examples directory in deb.
+ * Add a test suite for the mercurial backend, contributed by Emanuele Aina.
+ * Add a test suite for the svn backend.
+ * Add a test suite for the git backend, from Recai
+ * Daemonize before sending RPC pings, since that can take a while
+ and/or hang.
+ * Daemonize before sending commit mails, as that can also take a long
+ time/hang if the mail server is unhappy.
+ * Factor out commit mail sending code into new function.
+ * Change rcs_commit, it is now passed the name of the user doing the commit
+ and their IP address, and needs to construct its own commit message
+ containing them, or do something more appropriate for the given RCS.
+ * Add softwaresite example.
+ * Mercurial backend improvements, including --get-ctime support. (Emanuele
+ Aina)
+ * Git backend improvements, including bug fixes and better robustness,
+ from Recai.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 26 Nov 2006 20:46:56 -0500