* Fix a bug that could lead to duplicate links being recorded
for tags.
* Added support framework for multiple types of dependencies.
- * Allow declaring that a dependency does not encompass the content of a
- page. (By passing content => 0 to add_depends.)
- * pagecount: Use a contentless dependency, which makes this
- directive much less expensive to use, since page edits will
- no longer trigger an unnecessary update of the page count.
- * map: Use a contentless dependency unless show= is specified.
- This makes simple maps efficient enough that they can be used on sidebars!
- * inline: Use a contentless dependency in quick mode.
+ * Allow declaring that a dependency is only affected by page presence
+ or changes to its links.
+ * pagecount, calendar, postsparkline, progress: Use a presence dependency,
+ which makes these directives much less expensive to use, since page
+ edits will no longer trigger an unnecessary update.
+ * map: Use a presence dependency unless show= is specified.
+ This makes maps efficient enough that they can be used on sidebars!
+ * inline: Use a presence dependency in quick mode.
+ * brokenlinks: Use a link dependency.
+ This makes it much more efficient, only updating when really necessary.
+ * orphans, pagestats: Use a combination of presence and link dependencies.
+ This makes them more efficient. It also fixes a longstanding bug,
+ where if only a small set of pages were considered by orphans/pagestats,
+ changes to links on other pages failed to cause an update.
+ * linkmap: Use a combination of presence and link dependencies.
+ This makes the map be regenerated much less frequently in many cases,
+ so larger maps are more practical to use now.
+ * Transitive dependencies are now correctly supported.
+ * Rebuild wikis on upgrade to this version to get improved dependency
+ info.
+ * Plugins providing PageSpec `match_*` functions should pass additional
+ influence information when creating result objects.
+ * API change: `pagespec_match_list` has completly changed its interface.
+ The old interface will be removed soon, and a warning will be printed
+ if any plugins try to use it.
+ * Optimize away most expensive file prune checks, when refreshing,
+ by only checking new files.
-- Joey Hess <joeyh@debian.org> Sun, 27 Sep 2009 17:40:03 -0400