-ikiwiki (3.20100415) UNRELEASED; urgency=low
+ikiwiki (3.20100609) unstable; urgency=low
+
+ * creation_day() etc use local time, not gmtime. To match calendars, which
+ use local time.
+ * img: Fill in missing height or width when scaling image.
+ * Remove example blog tag pages; allow autotag creation to create them
+ when used.
+ * Fix support for globbing in tagged() pagespecs.
+ * Fix display of sidebar when previewing page edit. (Thanks, privat)
+ * relativedate: Fix problem with localised dates not working.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 31 May 2010 20:44:17 -0400
+
+ikiwiki (3.20100518.2) unstable; urgency=low
+
+ * Fix a typo in the last release.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 18 May 2010 14:17:01 -0400
+
+ikiwiki (3.20100518) unstable; urgency=low
+
+ * page.tmpl: Accidentially broke po plugin's otherlanguages list styling
+ when modifying for html5; now fixed.
+ * Fix a bug that prevented matching deleted comments, and so did not update
+ pages that had contained them.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 18 May 2010 13:37:39 -0400
+
+ikiwiki (3.20100515) unstable; urgency=low
+
+ * Removed misc.tmpl. Now to theme ikiwiki, you only need to customise
+ a single template, page.tmpl.
+ * If you have a locally customised page.tmpl, it needs to be updated
+ to set <base> when BASEURL or FORCEBASEURL is set.
+ * comments: Comments pending moderation are now stored in the srcdir
+ alongside accepted comments, but with a `._comment_pending` extension.
+ This allows easier byhand moderation, as the "_pending" need
+ only be stripped off and the comment be committed to version control.
+ * The `comment_pending()` pagespec can be used to match such unmoderated
+ comments, which makes it easy to add a feed of them, or a counter
+ indicating how many there are.
+ * Belatedly added a `comment()` pagespec.
+ * Gave comment and page editing forms some CSS and accessability love.
+ * Renamed postscan hook to indexhtml, to reflect its changed position,
+ and typical use.
+ * inline: Call indexhtml when inlining internal pages, so their
+ text can be indexed for searching.
+ * Delete hooks are passed deleted internal pages.
+ * openid: Incorporated a fancy openid-selector signin form.
+ (Based on http://code.google.com/p/openid-selector/)
+ * openid: Use "openid_identifier" as the form field, as required
+ by OpenID Authentication v2.0 spec.
+ * Removed the openidsignup option. Instead, my recommendation is to
+ leave passwordauth enabled and let people who don't have an openid use it.
+ The openid selector form avoids the UI annoyance of having both openid
+ and passwordauth on one form.
+ * calendar: Allow negative month to be specified. -1 is last month, etc.
+ (And also negative years.)
+ * calendar: Display year in title of month calendar.
+ * Use xhtml friendly pubdate setting.
+ * remove, rename: Add guards against XSRF attacks.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 15 May 2010 21:00:45 -0400
+
+ikiwiki (3.20100504) unstable; urgency=low
+
+ * Add parameter to displaytime to specify that it is a pubdate,
+ and in html5 mode, use time tag.
+ * Add placeholder text in search form (in html5 mode only).
+ * In html5 mode, use all the nice new semantic tags. Care was taken
+ to not change the id/class named used in the CSS, so only CSS
+ that refers to tag types needed to be changed.
+ * Add ACTIONS variable to page.tmpl, which allows plugins to add arbitrary
+ links to the action bar without modifying the template further.
+ (COMMENTSLINK and DISCUSSIONLINK could be folded into this, but
+ are kept separate for now to avoid breaking modified templates.)
+ * websetup: Only display Setup button on admins' preferences page.
+ * graphviz: Fix display of preexisting images in preview mode.
+ * Fixes a bug in skipping of illegal source files introduced in
+ 3.20100427.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 04 May 2010 20:26:20 -0400
+
+ikiwiki (3.20100501) unstable; urgency=low
+
+ * TMPL_INCLUDE re-enabled for templates read from the templatedir.
+ (But not in-wiki templates.)
+ * Version dependency on liburi-perl to >= 1.36; previous versions
+ did not support building urls from utf-8 strings. Closes: #579713
+ * Ikiwiki can be configured to generate html5 instead of the default xhtml
+ 1.0. The html5 output mode is experimental, not yet fully standards
+ compliant, and will be subject to rapid change.
+ * htmlscrubber: Allow html5 semantic tags: section, nav, article, aside
+ hgroup, header, footer, figure, figcaption, time, mark
+ * htmlscrubber: Also allow some other html5 tags: canvas, progress, meter,
+ ruby, rt, rp, details, summary, datalist.
+ * htmlscrubber: Round out html5 video support with the preload
+ attribute and the source tag.
+ * htmlscrubber: Allow the html5 form attributes: placeholder, autofocus,
+ min, max, step, required, autocomplete, novalidate, pattern, list,
+ and form. (Also the form* override attributes for input and buttons.)
+ * htmlscrubber: Allow additional misc html5 attributes: reversed,
+ spellcheck, and hidden.
+ * template: Fix typo.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 01 May 2010 20:49:28 -0400
+
+ikiwiki (3.20100427) unstable; urgency=low
[ Joey Hess ]
+ * tag: Automatic creation of tag pages can now be enabled using
+ the tag_autocreate setting. (David Riebenbauer)
+ * Customised templates can now be included in the source of wikis
+ (and also in underlays), and dependencies on them are tracked.
+ * TMPL_INCLUDE is no longer supported in any template.
+ * underlay: Removed the add_templates option.
+ * Add template_depends function to plugin API.
* bzr: Fix bzr log parsing to work with bzr 2.0. (liw)
* comments: Fix missing entity encoding in title.
* txt: Add a special case for robots.txt.
$pagestate{index}.
* bzr: Support rcs_getmtime, and fix rcs_getctime implementation
(Jelmer Vernooij)
-
- -- Joey Hess <joeyh@debian.org> Sun, 04 Apr 2010 12:17:11 -0400
+ * Quite a lot of new optimisations, and one major fix to a recent
+ performance regression.
+ * Moved javascript files under the ikiwiki/ directory, to avoid cluttering
+ the top of the web root. This is another things that requires a wiki
+ rebuild on upgrade to this version.
+ * Fix removal of rendered files in rebuild mode.
+ * Add page() PageSpec, which is like glob() but matches only pages,
+ not other files.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 27 Apr 2010 00:00:00 -0400
ikiwiki (3.20100403) unstable; urgency=low