+ * comment: Make comment directives no longer use the internal "_comment"
+ form, and document the comment directive syntax.
+ * Avoid relying on translators preserving the case when translating
+ "discussion", which caused Discussion pages to get unwanted Discussion
+ links.
+ * Tighten up matching of bare words inside directives; do not
+ allow an unterminated """ string to be treated as a series
+ of bare words. Fixes runaway regexp recursion/backtracking
+ in strange situations.
+ * Setup automator: Check that each plugin added to the generated
+ setup file can be loaded and that its config is ok. If a plugin
+ fails for any reason, disable it in the generated file.
+ Closes: 532001
+ * pagecount: Fix broken optimisation for * pagespec.
+ * goto: Support being passed a page title that is not a valid page
+ name, to support several cases including mercurial's long user
+ names on the RecentChanges page, and urls with spaces being handled
+ by the 404 plugin.
+ * Optimise use of gettext, and avoid ugly warnings if Locale::gettext
+ is not available. Closes: #532285
+
+ -- Joey Hess <joeyh@debian.org> Tue, 02 Jun 2009 17:03:41 -0400
+
+ikiwiki (3.14) unstable; urgency=low
+
+ * highlight: New plugin supporting syntax highlighting of pretty much
+ anything.
+ * debian/control: Add suggests for libhighlight-perl, although
+ that package is not yet created by Debian's highlight source package.
+ (See #529869)
+ * format: Provide a htmlizefallback hook that other plugins
+ can use to handle formats that are not suitable for general-purpose
+ htmlize hooks. Used by highlight.
+ * Fix test suite to not rely on an installed copy of ikiwiki after
+ underlaydir change. Closes: #530502
+ * Danish translation update. Closes: #530877
+
+ -- Joey Hess <joeyh@debian.org> Mon, 01 Jun 2009 13:05:34 -0400
+
+ikiwiki (3.13) unstable; urgency=low
+
+ * ikiwiki-transition: If passed a nonexistant srcdir, or one not
+ containing .ikiwiki, abort with an error rather than creating it.
+ * Allow underlaydir to be overridden without messing up inclusion
+ of other underlays via add_underlay.
+ * More friendly display of markdown, textile in edit form selector
+ (jmtd)
+ * Allow curly braces to be used in pagespecs, and avoid a whole class
+ of potential security problems, by avoiding performing any string
+ interpolation on user-supplied data when translating pagespecs.
+ * ikiwiki-transition: Allow setup files to be passed to all subcommands
+ that need a srcdir.
+ * ikiwiki-transition: deduplinks was broken and threw away all
+ metadata stored by plugins in the index. Fix this bug.
+ * listdirectives: Avoid listing _comment directives and generally
+ assume any directive starting with _ is likewise internal.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 22 May 2009 14:10:56 -0400
+
+ikiwiki (3.12) unstable; urgency=low
+
+ * Re-enable python-support and add python:Depends to control file.
+ * ikiwiki-makerepo: Avoid using abs_path, as it apparently
+ fails on nonexistant directories with some broken perl
+ versions.
+ * inline: Minor optimisation.
+ * add_link: New function, which plugins should use rather than
+ modifying %links directly, to avoid it accumulating duplicates.
+ * ikiwiki-transition: Add a deduplinks action, that can be used
+ to remove duplicate links and optimise a wiki w/o rebuilding it.
+ * external: Fix pagespec_match and pagespec_match_list.
+ Closes: #527281
+
+ -- Joey Hess <joeyh@debian.org> Wed, 06 May 2009 00:31:16 -0400
+
+ikiwiki (3.11) unstable; urgency=low
+
+ * Avoid using python-support. Closes: #525086
+ * websetup: Display stderr in browser if ikiwiki setup fails.
+ * blogspam: Load RPC::XML library in checkconfig, so that an
+ error can be printed at that point if it's not available,
+ allowing the admin to see it during wiki setup.
+ Closes: #520015
+ * websetup: If setup fails, restore old setup file.
+ * relativedate: Deal with clock skew.
+ * Add IkiWiki::ErrorReason objects, and modify pagespecs to return
+ them in cases where they fail to match due to a configuration or syntax
+ error.
+ * pagespec_match_list: New API function, matches pages in a list
+ and throws an error if the pagespec is bad.
+ * inline, brokenlinks, calendar, linkmap, map, orphans, pagecount,
+ pagestate, postsparkline: Display a handy error message if the pagespec
+ is erronious.
+ * comments: Add link to comment post form to allow user to sign in
+ if they wish to, if the configuration makes signin optional
+ for commenting.
+ * Updated Danish translation from Jonas Smedegaard. Closes: #525751
+ * translation.mdwn: Typo fixes. Closes: #525753
+
+ -- Joey Hess <joeyh@debian.org> Mon, 04 May 2009 15:45:10 -0400
+
+ikiwiki (3.10) unstable; urgency=low
+
+ * darcs: Finally added support for this VCS, thanks to many
+ contributors:
+ - Thomas Schwinge wrote the original file, implementing only rcs_commit.
+ - Benjamin A'Lee contributed an alternative implementation.
+ - Tuomo Valkonen contributed rcs_getctime and stub rcs_recentchanges.
+ - Simon Michael contributed multiple changes.
+ - Petr Ročkai fixed rcs_recentchanges.
+ - Sven M. Hallberg merged the above and added missing features.
+ * Add missing newline to Confirm Password prompt.
+ * Add missing permalink support to archivepage and titlepage templates.
+ * debian/control: Wrap fields.
+ * inline: Add author info to archive display.
+ * Add a microblog template that is useful for inlining microblogging posts.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 18 Apr 2009 19:40:25 -0400
+
+ikiwiki (3.09) unstable; urgency=low
+
+ * inline: Add title_natural sort order, using Sort::Naturally
+ (chrysn)
+ * inline: Fix urls to feed when feedfile is used on an index page.
+ * git, mercurial: Fix --getctime to return file creation time,
+ not last commit time.
+ * Updated French translation (Jean-Luc Coulon). Closes: #521072
+ * css: Add clear: both to inlinefooter.
+ * comments: Fix too loose test for comments pages that matched
+ normal pages with "comment_" in their name. Closes: #521322
+ * comments: Fix anchor ids to be legal xhtml. Closes: #521339
+ * Fix documentation of anonok_pagespec. Closes: #521793
+ * Add missing suggests on libtext-textile-perl. Closes: #522039
+ * recentchanges: change to using do=goto links for user links.
+ * Fix git test suite to use a bare repo.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 04 Apr 2009 14:33:49 -0400
+
+ikiwiki (3.08) unstable; urgency=low
+
+ * git: Fix utf-8 encoding of author names.
+ * git: Manually decode git output from utf-8, avoids
+ warning messages on invalidly encoded output.
+ * Fix bug that caused weird things to appear as page types.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 15 Mar 2009 17:54:47 -0400
+
+ikiwiki (3.07) unstable; urgency=low
+
+ * Updated German translation (Kai Wasserbäch). Closes: #518377
+ * Updated French translation (Jean-Luc Coulon). Closes: #518510
+ * wmd: New plugin contributed by William Uther to support the WMD
+ Wysiwym markdown editor.
+ * smiley: Avoid infinite loop in smiley expansion triggered
+ by the template scan mode change in version 3.05. Closes: #518805
+ * template: When loading a template in scan mode, let preprocess
+ know it only needs to scan.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 08 Mar 2009 19:00:46 -0400
+
+ikiwiki (3.06) unstable; urgency=low
+
+ * Setup automator: Fix bug in password comparison. Closes: #517654
+
+ -- Joey Hess <joeyh@debian.org> Sun, 01 Mar 2009 15:02:30 -0500
+
+ikiwiki (3.05) unstable; urgency=low
+
+ * debhelper v7(.0.50); rules file minimisation.