]> git.vanrenterghem.biz Git - git.ikiwiki.info.git/blobdiff - debian/rules
Update upstream source from tag 'upstream/3.20180228'
[git.ikiwiki.info.git] / debian / rules
index 0a7ce7a267e43c0999d6e468f7e6844abbc8d660..3f80a273f9abca0082273fae8991a44a0a0365dc 100755 (executable)
@@ -1,11 +1,16 @@
 #!/usr/bin/make -f
 %:
-       dh $@
+       LC_ALL=C.UTF-8 TZ=UTC dh $@
 
 override_dh_auto_configure:
        # keeps it out of /usr/local
        dh_auto_configure -- PREFIX=/usr
 
+override_dh_auto_install:
+       dh_auto_install
+       sed -i -e '1s,^#!.*[ /]python$$,#!/usr/bin/python3,' \
+               debian/ikiwiki/usr/lib/ikiwiki/plugins/*
+
 override_dh_compress:
        # avoid compressing files in the doc wiki
        dh_compress -Xhtml
@@ -13,7 +18,3 @@ override_dh_compress:
 override_dh_auto_clean:
        # distclean moans about MANIFEST, this is quieter
        if [ -e Makefile ]; then $(MAKE) realclean; fi
-
-# Not intended for use by anyone except the author.
-announcedir:
-       @echo ${HOME}/src/ikiwiki/doc/news