]> git.vanrenterghem.biz Git - git.ikiwiki.info.git/blobdiff - debian/rules
add news item for ikiwiki 3.11
[git.ikiwiki.info.git] / debian / rules
index 115b3f0c20fae4ecd26c9747d8f9790988a7d71b..3541d348df82f5056688f50b092126e58c1ab46d 100755 (executable)
@@ -1,6 +1,18 @@
 #!/usr/bin/make -f
 %:
-       dh $@
+       dh --without=python-support $@
+
+override_dh_auto_configure:
+       # keeps it out of /usr/local
+       dh_auto_configure -- PREFIX=/usr
+
+override_dh_compress:
+       # avoid compressing files in the doc wiki
+       dh_compress -Xhtml
+
+override_dh_auto_clean:
+       # distclean moans about MANIFEST, this is quieter
+       if [ -e Makefile ]; then $(MAKE) realclean; fi
 
 # Not intended for use by anyone except the author.
 announcedir: