]> git.vanrenterghem.biz Git - git.ikiwiki.info.git/blobdiff - debian/rules
allow emailuser to be called when there is no %config set
[git.ikiwiki.info.git] / debian / rules
index 115b3f0c20fae4ecd26c9747d8f9790988a7d71b..9cb2a8adc3af0549830b0bbe57dd61a5a3740c43 100755 (executable)
@@ -2,6 +2,14 @@
 %:
        dh $@
 
-# Not intended for use by anyone except the author.
-announcedir:
-       @echo ${HOME}/src/ikiwiki/doc/news
+override_dh_auto_configure:
+       # keeps it out of /usr/local
+       dh_auto_configure -- PREFIX=/usr
+
+override_dh_compress:
+       # avoid compressing files in the doc wiki
+       dh_compress -Xhtml
+
+override_dh_auto_clean:
+       # distclean moans about MANIFEST, this is quieter
+       if [ -e Makefile ]; then $(MAKE) realclean; fi