]> git.vanrenterghem.biz Git - git.ikiwiki.info.git/blobdiff - debian/rules
3.20160728
[git.ikiwiki.info.git] / debian / rules
index 115b3f0c20fae4ecd26c9747d8f9790988a7d71b..cf3087d1db711dc46539c908742b1983f2b70967 100755 (executable)
@@ -1,7 +1,15 @@
 #!/usr/bin/make -f
 %:
-       dh $@
+       LC_ALL=C.UTF-8 TZ=UTC dh $@
 
-# Not intended for use by anyone except the author.
-announcedir:
-       @echo ${HOME}/src/ikiwiki/doc/news
+override_dh_auto_configure:
+       # keeps it out of /usr/local
+       dh_auto_configure -- PREFIX=/usr
+
+override_dh_compress:
+       # avoid compressing files in the doc wiki
+       dh_compress -Xhtml
+
+override_dh_auto_clean:
+       # distclean moans about MANIFEST, this is quieter
+       if [ -e Makefile ]; then $(MAKE) realclean; fi