-ikiwiki (1.5) UNRELEASED; urgency=low
+ikiwiki (1.6) unstable; urgency=low
+
+ * YA utf-8 patch from Recai, this time to fix previewing a page so that
+ the text in the input box is re-encoded back to utf-8.
+ * -CSD does not affect modules, so readfile() was not using the utf-8 input
+ layer, which led to lots of problems; make it force read files as utf-8.
+ Closes: #373203
+ * Note that as a consequence, this version of ikiwiki will actually try to
+ parse utf8 in source files for the first time, which may expose broken
+ utf8 in wiki sources that was hidden before. Most common will be
+ perl warnings like "utf8 "\xE9" does not map to Unicode"
+ * writefile() likewise needs to use the utf8 output layer.
+ * Remove the -CSD from ikiwiki's hashbang since it's useless to have it
+ there.
+ * Revert some of the decode_utf8 changes in CGI.pm that seem unnecessary
+ given the readfile fix.
+ * Add utf-8 testcases for readfile and htmlize.
+ * Put back the encode_utf8 in the input to markdown; it's really not utf-8
+ safe.
+ * More utf-8 fixes from Recai, partly to things I broke above:
+ - The serious problem is that writefile() saves the content in undecoded
+ format in CGI, hence all (non-ascii) chars are corrupted permanently.
+ - Comment field in edit page is not decoded and all the non-ascii chars in
+ this field are corrupted as the result. We should decode it as we do it
+ for the content.
+ - Add 'use encoding "utf8"' to CGI.pm to avoid warnings about wide
+ character in print.
+ * New SVG logo from Recai.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 18 Jun 2006 19:18:46 -0400
+
+ikiwiki (1.5) unstable; urgency=low
* Add --timeformat config option to allow changing how dates are displayed.
Note that as a side effect, dates will now be displayed using the local
timezone, not as GMT.
-
- -- Joey Hess <joeyh@debian.org> Mon, 29 May 2006 00:50:34 -0400
+ * More security review.
+ * Patch from Dr. Zini to add link() and backlink() to globlists. This allows
+ for some handy stuff like:
+ - Using links as a kind of tag; creating blog pages that list all pages
+ containing a given tag/link or not containing some other tag.
+ - Subscribing to mail notifications whenever a change is made to a page
+ that is a backlink of page foo. Ie, "Please notify me of changes in all
+ pages that link to my home page in the wiki"
+ - Locking any pages that are linked to from a particular page, so that
+ lists of locks can be exposed in the wiki.
+ * Reorganised the doc wiki's todo/* pages, using a link/tag to flag
+ when a todo item is done, instead of the previous moving it to a different
+ subdir.
+ * Allow pagetemplate plugins to override *anything* in the template.
+ * Add a meta plugin, which allows specifying various metadata about pages,
+ like license and author. It also allows for inserting html link and meta
+ tags into html, overriding the title, and adding hidden WikiLinks, which
+ can be useful when using link-based globbing for page categorisation.
+ * Remove preprocessor directives from inlined pages.
+ * Allow simple preprocessor directive values to be specified w/o quotes.
+ * Add support for using git instead of subversion as the RCS backend,
+ tremendous thanks to Recai Oktaş for this.
+ * Doc updates for git.
+ * Fix absolute url munging in rss generation to support https, ftp, etc urls
+ not just http urls.
+ * Patch from Recai Oktaş to improve utf-8 support, it should now use proper
+ utf-8 for edit and other fields, and for recentchanges. There may still
+ be utf-8 issues with the preferences page though.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 11 Jun 2006 19:56:54 -0400
ikiwiki (1.4) unstable; urgency=low