+ikiwiki (2.21) UNRELEASED; urgency=low
+
+ * Old versions of git-init don't support --git-dir or GIT_DIR with
+ --bare. Change ikiwiki-makerepo to use a method that should work with
+ those older versions too.
+ * aggregate: Don't let feeds set creation times for pages in the future.
+ * Add full parser for git diff-tree output (Brian Downing)
+
+ -- Joey Hess <joeyh@debian.org> Fri, 11 Jan 2008 15:09:37 -0500
+
+ikiwiki (2.20) unstable; urgency=low
+
+ * inline: Add copyright/license info on a per-post basis to atom
+ feeds if available. (rss doesn't allow such info on a per-post basis)
+ * Also include overall copyright/license and author info in atom feeds if
+ available.
+ * meta: Allow copyright/license metadata to contain arbitrary markup.
+ * Call preprocessor hooks in void context during the scan pass. This allows
+ the hook to determine if it's just scanning, and avoid expensive
+ operations.
+ * img: Detect scan mode and avoid generating and writing the image file
+ during it, for a 2x speedup.
+ * meta: Run in scan mode again (more intelligently) and re-add support for
+ meta link.
+ * Fix support for the case where metadata appears after an inline directive
+ that needs to use it. This was broken in version 2.16.
+ * template: Remove bogus htmlize pass added in 2.16.
+ * template: Htmlize template variables, but also provide a raw version
+ via `<TMPL_VAR raw_variable>`.
+ * When htmlizing text, if the input is a single line with no newline,
+ and the htmlizer (such as markdown and textile) generates a html
+ paragraph, remove it. This allows removing several hacks from other
+ plugins that htmlize fragements of pages.
+ * In preferences, allow the subscriptions and email fields to be cleared.
+ * teximg: Fix to support the same formula on multiple pages.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 10 Jan 2008 14:52:57 -0500
+
+ikiwiki (2.19) unstable; urgency=low
+
+ * Only try postsignin if no other action matched. Fixes a bug where the
+ user goes back from the signin screen and does something else.
+ * Improve behavior when trying to sign in with no cookies.
+ * Improved the canedit hook interface, allowing a callback function to be
+ returned (and not run in some cases) rather than the plugins directly
+ forcing a user to log in.
+ * opendiscussion: allow editing of the toplevel discussion page,
+ and, indirectly, allow creating new discussion pages.
+ * Add a prereq on Data::Dumper 2.11 or better, needed to dump q// objects.
+ * htmlscrubber: Further work around #365971 by adding tags for 'br/', 'hr/'
+ and 'p/'.
+ * aggregate: Include copyright statements from rss feed as meta copyright
+ directives.
+ * aggregate: Yet another state saving fix (sigh).
+ * aggregate: Add hack to support feeds with invalidly escaped html entities.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 08 Jan 2008 20:43:18 -0500
+
+ikiwiki (2.18) unstable; urgency=low
+
+ * Split error messages for failures to drop real uid and gid.
+ * Retry dropping uid and gid, possibly this will help with the "Resource
+ temporarily unavailable" failures I've experienced under xen.
+ * Stop testing Encode::is_utf8 in decode_form_utf8: That doesn't work.
+ * decode_form_utf8 only fixed the utf-8 encoding for fields that were
+ registered at the time it was called, which was before the
+ formbuilder_setup hook. Fields added by the hook didn't get decoded.
+ But it can't be put after the hook either, since plugins using the hook
+ need to be able to use form values. To fix this dilemma, it's been changed
+ to a decode_cgi_utf8, which is called on the cgi query object, before the
+ form is set up, and decodes *all* cgi parameters.
+ * aggregate: Only save state if it was already loaded. This didn't used to
+ matter, but after recent changes, state is not always loaded, and saving
+ would kill it.
+ * table: Fix dependency tracking for external data files. Closes: #458387
+
+ -- Joey Hess <joeyh@debian.org> Sat, 05 Jan 2008 02:15:18 -0500
+
+ikiwiki (2.17) unstable; urgency=low
+
+ * Improved parentlinks special case for index pages.
+ * redir: Support for specifying anchors.
+ * img: Avoid nesting images when linking to another image. Closes: #457780
+ * img: Allow the link parameter to point to an exterior url.
+ * conditional: Improve regexp testing for simple uses of pagespecs
+ that match only the page using the directive, adding 'included()'
+ and supporting negated pagespecs and added whitespace.
+ * map: Fix handling of common prefix to handle the case where it's
+ in a subdirectory. Patch by Larry Clapp.
+ * aggregate: Fix stupid mistake introduced when converting it to use
+ the needsbuild hook. This resulted in feeds not being removed when pages
+ were updated, and feeds sometimes being forgotten about.
+ * aggregate: Avoid uninitialised value warning when removing a feed that
+ has an expired guid.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 30 Dec 2007 14:57:44 -0500
+
+ikiwiki (2.16) unstable; urgency=low
+
+ * Major basewiki reorganisation. Most pages moved into ikiwiki/ subdirectory
+ to avoid polluting the main namespace, and some were further renamed.
+ * meta: Add redir support, based on a patch by Thomas Schwinge.
+ * Redirs added for moved basewiki pages. These will be removed in a future
+ release.
+ * Remove .otl file from sandbox to avoid build ugliness. Closes: #454181
+ * Finally implemented a simple per-page data storage mechanism for plugins,
+ via the %pagestate hash.
+ * Use pagestate in meta to detect potential redir loops.
+ * Added a version plugin that saves state about what's using it, to force
+ pages to rebuild when ikiwiki's version changes.
+ * The calendar plugin stores state about when it needs to be updated,
+ and forces rebuilds of the pages that contain calendars. So
+ running ikiwiki --refresh at midnight is now enough, no need for a full
+ wiki rebuild each midnight.
+ * calendar: Work around block html parsing bug in markdown 1.0.1 by
+ enclosing the calendar in an extra div.
+ * Fix file pruning code to work if ikiwiki is run with "." as the srcdir.
+ * Add an edittemplate plugin, allowing registering template pages, that
+ provide default content for new pages created using the web frontend.
+ * Change formbuilder hook to not be responsible for displaying a form,
+ so that more than one plugin can use this hook.
+ I believe this is a safe change, since only passwordauth uses this hook.
+ (If some other plugin already used it, it would have broken passwordauth!)
+ * Ensure that web edited pages always end in a newline.
+ * Avoid unnecessary stat calls to get mtime when rendering pages, use
+ cached value.
+ * Preserve input file modification times in output files.
+ * Allow dashes in preprocessor directive commands, and shortcuts.
+ * Htmlize parameters passed to the template preprocessor directive before
+ inserting them into the html template. This ensures that markdown
+ acts on them, even if the value is expanded inside a block-level html
+ element in the html template. Closes: #454058
+ * Use a div in the note template rather than a span.
+ * shortcut: Expand %S to the raw input text, not url-encoded.
+ * Don't increment feed numbers when an inline has no feeds. (Nis Martensen)
+ * Allow editing a page and deleting all content, while still disallowing
+ creating a new page that's entirely empty.
+ * meta: Drop support for "meta link", since supporting this for internal
+ links required meta to be run during scan, which complicated its data
+ storage, since it had to clear data stored during the scan pass to avoid
+ duplicating it during the normal preprocessing pass.
+ * If you used "meta link", you should switch to either "meta openid" (for
+ openid delegations), or tags (for internal, invisible links). I assume
+ that nobody really used "meta link" for external, non-openid links, since
+ the htmlscrubber ate those. (Tell me differently and I'll consider bringing
+ back that support.)
+ * meta: Improved data storage.
+ * meta: Drop the hackish filter hook that was used to clear
+ stored data before preprocessing, this hack was ugly, and broken (cf:
+ liw's disappearing openids).
+ * aggregate: Convert filter hook to a needsbuild hook.
+ * map: Don't inline images.
+ * brokenlinks: Don't list the same link multiple times. (%links might
+ contain multiple copies of the same link)
+ * git: Correct display of multiline commit messages in recentchanges.
+ * Re-organise dependencies and recommends now that recommends are installed
+ by default.
+ * Don't refuse to render files with ".." in their name. (Anchor the regexp.)
+ * Work around perl taint checking bug #411786, where perl sometimes randomly
+ sets the taint flag on untainted variables, by disabling taint checking
+ in the deb. This sucks.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 18 Dec 2007 16:37:22 -0500
+
+ikiwiki (2.15) unstable; urgency=low
+
+ * Add a new ikiwiki-makerepo program, that automates setting up a repo
+ and importing existing content for svn, git, and mercurial. This makes
+ the setup process much simpler.
+ * Reorganised git documentation.
+ * Actually install the ikiwiki-update-wikilist program.
+ * Improve workaround for perl bug #376329. Rather than double-encoding,
+ which has been reported to cause encoding problems (though I haven't
+ reproduced them), just catch a failure of markdown, and retry.
+ (The crazy perl bug magically disappears on the retry.)
+ Closes: #449379
+ * Add umask configuration option. Closes: #443329
+
+ -- Joey Hess <joeyh@debian.org> Sat, 01 Dec 2007 11:44:01 -0500
+
+ikiwiki (2.14) unstable; urgency=high
+
+ * Let CC be used to control what compiler is used to build wrappers.
+ * Use 'cc' instead of gcc as the default compiler.
+ * Security fix: Ensure that there are no symlinks anywhere in the path
+ to the top of the srcdir. In certian unusual configurations, an attacker
+ who could commit to one of the parent directories of the srcdir could
+ use a symlink attack to cause ikiwiki to publish files elsewhere in the
+ filesystem. More details at <http://ikiwiki.info/security/#index29h2>
+
+ -- Joey Hess <joeyh@debian.org> Mon, 26 Nov 2007 15:26:06 -0500
+
+ikiwiki (2.13) unstable; urgency=low
+
+ The ikiwiki zombie army release.
+
+ * Add liblwpx-paranoidagent-perl to recommends of Debian package,
+ this is needed to do OpenID really securely.
+ * ikiwiki.setup is licensed same as the basewiki, not GPLed.
+ * inline: Add timeformat parameter to control how the ctime of
+ inlined pages is displayed. Closes: #451019
+ * Add wrappergroup config option, which can be used to cause wrappers
+ to be created owned by some group other than the default. Useful
+ then there's a shared repository with access controlled by a group,
+ to let ikiwiki run setgid to that group.
+ * ikiwiki-mass-rebuild: Run build with the user in all their groups.
+ * Correct markdown in example index page in setup. Closes: #451469
+ * Better error message when a setup file has a syntax error.
+ Closes: #451666
+ * Fix mercurial historyurl in example setup file.
+ * More compact output for the brokenlinks plugin.
+ * Allow trailing slashes after page names in wikilinks.
+ * Don't consider links to anchors on the same page to be self links.
+ Patch by Daniel Burrows. Closes: #451729
+ * When usedirs is disabled, link direct to index.html files, not to
+ directories, to improve browsing of file:// urls.
+ Patch by Daniel Burrows. Closes: #451728
+ * Allow html5 video and audio tags and their attributes in the htmlscrubber.
+ * toc: Handle html elements embedded inside a header, rather than
+ stopping collecting the header text at the first element.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 24 Nov 2007 16:06:22 -0500
+
+ikiwiki (2.12) unstable; urgency=low
+
+ [ Joey Hess ]
+ * Fix some issues with toggles in preview mode.
+ * Fix an aggregate plugin expiry bug. Over time, it's possible for the same
+ page name to be expired and reused for several distinct guids. When this
+ happened, the expiry code counted each past guid that had used that page
+ name as a currently existing page, and thus expired too many pages.
+ * Avoid a race in the git rcs_commit function, by not assuming HEAD will
+ stay the same for the duration of the function.
+ * Avoid using commands like git-diff and instead use "git diff".
+ In some configurations, only the main git command is in the path.
+ * Improve the RecentChanges display for git merges, by passing -c instead
+ of -m to git-log, and by skipping display of commits that change no
+ pages.
+ * Don't truncate git commit messages to the first line in RecentChanges,
+ show the full message.
+ * map: Recent changes caused unnecessary ul's to be inserted for items
+ that were all at the same level, fix. Closes: #449285
+
+ [ Josh Triplett ]
+ * Fix table plugin to not generate an unbalanced tbody tag with header=no
+ * Add xmlns attribute on html element in templates; pages can now
+ validate.
+
+ [ Joey Hess ]
+ * In the example setup file, use mode 6755 for the git post-update hook.
+ It needs to be setgid if the master repo is a shared repository, so
+ that pushes into the working copy repository happen as the same group,
+ avoiding permissions problems.
+ * The first git commit legitimately has no parents. Avoid recentchanges
+ spewing uninitialised value warnings and debug messages about it.
+ Dummying up a parent of 0000000 allows gitweb to work too.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 12 Nov 2007 14:35:09 -0500
+
+ikiwiki (2.11) unstable; urgency=low
+
+ * Correct a pair of logic errors that triggered if svnpath was empty.
+ * If gitorigin_branch is set to the empty string, don't push or pull.
+ Useful for laptop clones of remote wikis.
+ * Add a calendar plugin, contributed by Manoj Srivastava.
+ * Reformat calendar plugin to ikiwiki conventions.
+ * The calendar plugin made *every* page depend on every other page,
+ which seemed a wee tiny little bit overkill. Fixed the dependency
+ calculations (I hope.)
+ * Removed manual ctime statting code, and just have the calendar plugin use
+ %pagectime.
+ * Ikiwiki has moved into a git repository.
+ * postsparkline: Avoid a confusing error message if no pages match
+ and instead show an empty graph.
+ * Add handling of feeds for nested inlines, as well as support for a
+ single page containing two different feeds.
+ * Also fixed some places in inline that failed to use destpage correctly.
+ * ikiwiki-mass-rebuild: Patch from HenrikBrixAndersen to fix order
+ of permissions dropping code to work on FreeBSD.
+ * ikiwiki-mass-rebuild: Don't clear PATH from the environment.
+ * Run git-commit -q (though it doesn't do much good due to its stderr
+ abuse).
+
+ -- Joey Hess <joeyh@debian.org> Fri, 26 Oct 2007 03:29:09 -0400
+
+ikiwiki (2.10) unstable; urgency=low
+
+ * Tidy ctime debug output for git.
+ * French translation update. Closes: #445923
+ * Fix --get-ctime with git, needed to remove srcdir from filename.
+ * In the cgi edit path, reload the index file before rendering. A bug
+ showed up where a web edit that added a page caused a near-concurrent
+ web edit to fail in will_render. While it would be hard to reproduce this,
+ my analysis is that the failing cgi started first, loaded the index file
+ (prior to locking) then the other cgi created the new page and rendered
+ it, and then the failing cgi choked on the new file when _it_ tried to
+ render it. Ensuring that the index file is loaded after taking the lock
+ will avoid this bug.
+ * Fix strange stderr-hiding code in the git module, allow error messages
+ to be passed on to stderr. Also fixes a potential bug, since git error
+ meesages were treated as if they came from git stdout.
+ * Add a "createlink" class attribute to the span for wikilinks pointing
+ to not-yet-existing pages. I don't have a useful style defined for that
+ though.
+ * Rewritten rst plugin by madduck is a python program that communicates with
+ ikiwiki via XML RPC. This should be much faster than the old plugin that
+ had to fork python for every rst page render. Note that if you use
+ the rst plugin, you now need to have the RPC::XML perl module installed.
+ * Danish translation from Jonas Smedegaard. Closes: #446952
+ * Support git authors of the form "joey <joey>", which is common when
+ importing from a svn repo.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 20 Oct 2007 19:42:46 -0400
+
+ikiwiki (2.9) unstable; urgency=low
+
+ * Fix copyright and licence styling.
+ * tag: Add taglink preprocessor directive, supporting visible tag links.
+ Closes: #443344
+ * map: Fully specify paths to links to avoid issues when the bestlink
+ didn't point to the correct page.
+ * map: Render pages on the way to subpages whose parent pages
+ are not included in the map. Include special styling for such pages.
+ * map: Remove common prefixes and don't over-indent.
+ * Add class option to htmllink().
+ * img: Allow link=somepage to cause the image to link to a given page.
+ Slight overriding of link, as link=no is still used to disable the linking
+ entirely. Unless you have a page named "no"..
+ * Save index after previewing page edit, since even previewing can create
+ files in some situations, and this is appropriate in some cases, such as
+ the teximg plugin's error log file.
+ Such files will be automatically cleaned up at an appopriate later time.
+ * Don't allow whitespace in link text in a wikilink. This was still
+ allowed by the regexp in one case though not documented to work, and
+ was ambiguous with preprocessor directives.
+ * camelcase: Tighten regexp to avoid false positives. WikiWords are only
+ linkified now if they are preceeded by whitespace.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 30 Sep 2007 15:07:24 -0400
+
+ikiwiki (2.8) unstable; urgency=low
+
+ * Redid the debian/copyright file, using the proposed new copyright file
+ format. Included many details not previously listed in the old file.
+ * inline: add feedonly option, set feedonly=yes to get only the feed button
+ but not inline the pages.
+ * meta: Support license and copyright information. The information will
+ be shown in the page footer. HTML will also be inserted that should
+ support the rel=license microformat as well as the HTML spec's
+ rel=copyright.
+ * table plugin: Actually specify the delimiter when parsing CSV.
+ * table plugin: The previous version broke WikiLinks inside quoted values.
+ Fix this by linkifying CSV data after parsing it, while DSV data is still
+ linkified before parsing.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 16 Sep 2007 20:02:25 -0400
+
+ikiwiki (2.7) unstable; urgency=low
+
+ [ Joey Hess ]
+ * Add an editcontent hook.
+ * Support for looking in multiple directories for underlay files.
+ * Plugins can add new directories to the search path with the add_underlay
+ function.
+ * Split out smiley underlay files into a separate underlay, so if the plugin
+ isn't used, the wiki isn't bloated with all those files.
+ * Allow -cgi -wrapper to be passed on the command line to generate a
+ wrapper.
+ * Fix some taint issues with generating wrappers using the command line.
+ * Don't allow newlines in link text in a wikilink.
+ * Tables containing links with a link text were misparsed, because the "|"
+ in the wikilink looked like a table field separator. Avoid this ambiguity
+ by linkifying the data before parsing it as a table.
+ * Turn on allow_loose_quotes in the table plugin's Text::CSV object,
+ so that links from wikilinks don't confuse the parser.
+ * mercurial: Pass --style default to hg log to ensure right format is used.
+ * mercurial: Fix rcs_getctime (thanks, bma)
+
+ [ Josh Triplett ]
+ * Use git-log rather than the shell, git-rev-list, and git-diff-tree.
+ Patch by Jamey Sharp <jamey@minilop.net>.
+ * Renames from git-diff-tree aren't handled, so don't ask for them.
+ Patch by Jamey Sharp
+ * Handle operating in sub-trees of a git repository.
+ When looking for git commits that affect the wiki, only include changes
+ that affect the ikiwiki source directory. If that is not the top-level
+ directory in this git repository, strip off the prefix as given by
+ `git-rev-parse --show-prefix` from all names reported by git-log.
+ Patch by Jamey Sharp
+
+ [ Joey Hess ]
+ * Correct generation of RFC 3339 format times for atom/rss feeds. Always use
+ gmtime for these since a time zone is not specified.
+ * Updated Spanish translation from Victor Moral.
+ * table: Text::CSV doesn't return decoded unicode (XS module); decode its
+ return values.
+ * Change git test suite to reflect change in log for initial repo creation
+ commit.
+ * Add the ikiwiki-update-wikilist command.
+ * Exclude external plugin from syntax check since it uses a module that is
+ not in the build depends. Closes: #441171
+
+ -- Joey Hess <joeyh@debian.org> Sat, 08 Sep 2007 21:54:11 -0400
+
+ikiwiki (2.6.1) unstable; urgency=low
+
+ * Ye olde brown paper bag.
+ * Fix minor bug when blogging by cgi, introduced in last version.
+ * Fix a bug in unlockwiki intorduced last version that made it crash ikiwiki
+ if it wasn't locked when called. This is known to break post-commit
+ emails.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 26 Aug 2007 13:38:23 -0400
+
+ikiwiki (2.6) unstable; urgency=low
+
+ * Various minor bug fixes for silly mistakes in the code, thanks to the
+ various reviewers.
+ * Fix problems with previewing in the graphviz plugin. Thanks,
+ HenrikBrixAndersen.
+ * Allow raw html in the rst plugin.
+ * Add --set-option command line switch.
+ * pagetemplate: don't display template name
+ * Add rel=tag attribute to tag links, supporting that microformat, as well
+ as allowing them to be styled specially. Thanks, NicolasLimare.
+ * Add sessioncgi hook.
+ * Move blog form code out of CGI.pm and into the inline plugin.
+ * Updated Spanish translation from Victor Moral.
+ * Updated French translation from Cyril Brulebois. Closes: #437181
+ * The toc directive doesn't work well or make sense inside an inlined page.
+ Disable it when the page with the toc is nested inside another page.
+ * Apply a patch from NicolasLimare adding modification date tags to rss and
+ atom feeds, and also changing the publication time for a feed to the
+ newest modiciation time (was newest creation time).
+ * The patch also adds dcterms:creator to rss items that have a known author.
+ * Support pagespec "functions" with no parameters, like included() in the
+ conditional plugin.
+ * Add time=mtime option to postsparkline.
+ * Fix --libdir to work at the command line.
+ * Plugins can now be written as standalone external programs, which can
+ be written in any language that can do XML RPC.
+ * Change yet again how unhandled and escaped preprocessor directives are
+ re-output onto the page. Hopefully I finally got it right..
+ * Fix bug in deletion/move during edit code introduced in 1.44. Need to take
+ the underlaydir into account.
+ * Fix bug when editing file from underlaydir, need to rcs_add it even though
+ a page creation isn't occuring.
+ * Various minor fixes and stylistic improvements suggested by Perl::Critic.
+ * Applied Jeremie Koenig's pluggable editpage buttons patch:
+ - add a title to the editpage form;
+ - pass a reference to the list of buttons to the formbuilder_setup
+ hooks, so we can add ours;
+ - relax asumption about the possible submit values (use "Save Page"
+ explicitly);
+ - de-hardcode the submit buttons from the editpage template
+ (This was needed for compatability with a bug in CGI::FormBuilder
+ 3.0401, but ikiwiki already needs a newer version.)
+ * Pass buttons to all other formbuilder_setup hooks too.
+ * Add color parameter to postsparkline. Closes: #438900
+ * Add proper Homepage field to Debian package (needs uber-new dpkg).
+ * Add monotone support, contributed by William Uther.
+ * Avoid ugly gettext messages if LANG is empty. Closes: #439035
+ * Added teximg plugin to generate images from latex code.
+ Contributed by Patrick Winnertz as a GSoC project.
+ * Call the formbuilder hook for the edit page.
+ * Call decode_form_utf8 before running formbuilder_setup hooks.
+ * Add editdiff plugin contributed by Jeremie Koenig.
+ * Fix it to not leak path info.
+ * Add embed plugin, which allows embedding content from google maps, video,
+ calendar, and youtube. Normally, the htmlsanitiser eats these since they
+ use unsafe tags, the embed plugin overrides it for trusted sites.
+ * The googlecalendar plugin is now deprecated, and will be removed
+ eventually. Please switch to using the embed plugin.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 24 Aug 2007 17:09:44 -0400
+
+ikiwiki (2.5) unstable; urgency=low
+
+ * Wrap the editpage template in the standard misctemplate, this allows the
+ pagetemplate hook to work for that page.
+ * Above change fixes the favicon plugin to work on edit pages.
+ * Correct some issues with escaped preprocessor directives.
+ * Make the map plugin notice when pages in the map are deleted and update
+ it.
+ * Add a htmlext config option, this can be used to make ikiwiki generate
+ html files with a different extension.
+ * Fix graphviz plugin to not try to read images as utf-8; they might
+ sometimes contain invalid utf-8 byte sequences. Thanks,
+ HenrikBrixAndersen.
+ * Fix re-rendering of pages when a linked to page goes away. This was broken
+ in version 1.50 with the addition of %destsources. Thanks, Ethan
+ Glasser-Camp.
+ * Add templatefile hook.
+ * Add pagetemplate plugin, which allows changing the template used for
+ a page. (Not to be confused with the hook of the same name..)
+ * Add a libdir config option to let ikiwiki load perl modules, including
+ plugins, from a user-configurable directory.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 26 Jul 2007 21:42:43 -0400
+
+ikiwiki (2.4) unstable; urgency=low
+
+ * Make the toc plugin use html-compatible anchors. This is necessary since
+ most web sites serve ikiwiki xhtml files as text/html and mozilla browsers
+ get confused. So it's best for ikiwiki to follow the compatability
+ recommendations in appendix C of the XHTML spec. Closes: #432045
+ * Support building on systems that lack asprintf.
+ * mercurial getctime is currently broken, apparently by some change in
+ mercurial version 0.9.4. Turn the failing test case into a TODO test case.
+ * Fix links to alternate stylesheets when usedirs is enabled. Closes: #432556
+ * Use type= not style= in html for alternate stylesheets, which is more
+ correct (but in my testing both epiphany and iceweasel work ok with
+ style=text/css).
+ * In img tag, allow link=no to disable link to full size image. Thanks,
+ Nis Martensen. Closes: #433188
+
+ -- Joey Hess <joeyh@debian.org> Sun, 15 Jul 2007 15:02:43 -0400
+
+ikiwiki (2.3) unstable; urgency=low
+
+ * Corrected a typo in an error handler in the image plugin.
+ * Allow svnpath config option to contain additional extra slashes anywhere
+ w/o confusing ikiwiki.
+ * Rcs modules are now imported, so other modules that need similar
+ normalisation of configs etc can do so.
+ * Patch fixing various additional problems with test suite. Closes: #425891
+ once more.
+ * French update from Jean-Luc Coulon. Closes: #430771
+ * Correct a longstanding bug that could cause the edit form to be empty.
+ This turns out to have occured if the cgi wrapper was created by an
+ ikiwiki invocation that included --rebuild. Thanks to Carl Worth for
+ tracking that down.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 29 Jun 2007 18:30:38 -0400
+
+ikiwiki (2.2) unstable; urgency=low
+
+ * Change the aggregate plugin's locking strategy. Now it defers loading state
+ until the wiki is building and already locked, unless it's aggregating.
+ When aggregating, it does not wait for the lock if it cannot get it, and
+ instead exits, to prevent aggregating processes from piling up.
+ * Updated Spanish translation from Victor Moral.
+ * Correct bug in the img plugin that caused dependencies on images to not
+ always be tracked correctly.
+ * Deal better with rebuilds that involve moving files; track and clean up the
+ old files.
+ * Change where the img plugin puts scaled images. It's better to make the
+ scaled images subpages of the page that embeds them, rather than putting
+ them alongside the original image, since if two pages scale the same image
+ the same way, this prevents complications in dealing with two pages
+ creating the same file. The move will be handled transparently, though you
+ might want to rebuild your wiki to make it occur in one step.
+ * Fix FTBFS in test suite introduced in last version. Closes: #425891
+ * Apply a patch from Carl Worth allowing a class attribute to be passed
+ through the img plugin. Also allow the id attribute to be passed through.
+ * More consistent encoding of titles in rss and atom feeds. Don't use
+ ESCAPE=HTML for titles in the templates for these feeds, and instead
+ escape the title going in to the template. Previously, the title was
+ sometimes double-escaped in a feed (if set via meta title), and sometimes
+ not (if set from the page filename).
+ * In the meta plugin, when a title is set, encode the html entities in it
+ numerically. This works better in the current landscape of a rss spec that
+ doesn't specify encoding, and variously broken feed consumers, according
+ to <http://www.rssboard.org/rss-profile#data-types-characterdata>.
+ * Correct some issues with display of unhandled preprocessor directives.
+ * Apply a patch from Carl Worth adding support for using globs in link()
+ in a PageSpec.
+ * Explode some of the more insane regexps.
+ * Add test suite for preprocessor directive parsing.
+ * Fix wrapper generator and untaint code's handling of strings contining
+ newlines.
+ * Make the url absolution code for feeds significantly more robust.
+ * Add typographyattributes configuration setting to typography plugin.
+
+ -- Joey Hess <joeyh@debian.org> Mon, 18 Jun 2007 21:21:56 +0100
+
+ikiwiki (2.1) unstable; urgency=low
+
+ [ Joey Hess ]
+ * Use div layout for the signin and preferences forms, so that they can be
+ styled using the stylesheet, rather than by creating signin and prefs
+ templates.
+ * Make the openid login form nicely styled.
+ * Fix a bug that prevented clearing email or subscriptions.
+ * Improve handling of edits of locked pages by users who are not yet signed
+ in.
+ * Make testpagespec more robust, including checking for missing/bad
+ parameters.
+ * Add all=no option to conditional, can be used to form conditionals that do
+ not need to examine every page in the wiki.
+ * Add the needsbuild hook. Plugins can use this to manipulate which files
+ ikiwiki builds when refreshing the wiki.
+
+ [ Josh Triplett ]
+ * Add an account-creation password as a simple anti-spam mechanism. If
+ set in the wiki setup, passwordauth will require the password in
+ order to create an account.
+
+ [ Joey Hess ]
+ * Updated Czech translation from Miroslav Kure.
+ * Apply patch from Paweł Tęcza to avoid using -L in Makefile as it's not
+ available in older finds.
+ * Make all templates have a footer div to ease themeing. Required template
+ and style sheet updates, and unless you're using customised versions,
+ you'll want to rebuild wikis on upgrade to this version to avoid
+ inconsistencies.
+ * Allow WIKINAME to to used in footers, as an example of something to put
+ there.
+ * Patch from hb to fix the pagestats plugin, which was broken by a past
+ change to the backlinks() function.
+ * Fix some bugs in password handling:
+ - If the password is empty in preferences, don't clear the existing
+ password.
+ - Actually check the confirm password field, even if it's left empty.
+ * Add a destpage parameter to the filter hook.
+ * Fix links to smilies generated by the smiley plugin for inlined pages. The
+ old links were often wrong, but often still worked by accident.
+ * Add a test ensuring that the basewiki is self-contained and has no broken
+ links.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 19 May 2007 20:37:38 -0400
+
+ikiwiki (2.00) unstable; urgency=low