+ikiwiki (3.20100424) UNRELEASED; urgency=low
+
+ [ Joey Hess ]
+ * tag: Automatic creation of tag pages can now be enabled using
+ the tag_autocreate setting. (David Riebenbauer)
+ * Customised templates can now be included in the source of wikis
+ (and also in underlays), and dependencies on them are tracked.
+ * TMPL_INCLUDE is no longer supported in any template.
+ * underlay: Removed the add_templates option.
+ * Add template_depends function to plugin API.
+ * bzr: Fix bzr log parsing to work with bzr 2.0. (liw)
+ * comments: Fix missing entity encoding in title.
+ * txt: Add a special case for robots.txt.
+
+ [ Simon McVittie ]
+ * Add support for link types, and make the the tagged() pagespec only
+ match tags, not regular links (a bugfix).
+ * Rebuild wikis on upgrade to this version to get tag link types recorded
+ correctly.
+ * Revamp sorting system; allow new sort methods to be added by plugins,
+ and add a "sortspec" syntax that can combine, reverse, etc sort methods.
+ * meta: Add `meta(author)`, `meta(title)` etc sortspecs to allow sorting
+ by metadata.
+ * meta: Add optional sortas parameter to author and title meta directives.
+ This can be used to get names sorted by last name without displaying
+ them last name first.
+ * sortnaturally: New plugin; the title_natural sort method has moved here.
+ * meta: store fields consistently unescaped, and escape on use.
+ (A wiki rebuild is also needed due to this change.)
+
+ [ Joey Hess ]
+ * Update dependency for git-core to git transition.
+ * po: Check that translated underlay directories exist before using them
+ for master language.
+ * po: Configuring the same language as master and slave confuses processing;
+ so filter out such a misconfiguration.
+ * calendar: Add archive_pagespec, which is used by ikiwiki-calendar to
+ specify which pages to include on the calendar archive pages.
+ (The pagespec can still also be specified on the ikiwiki-calendar command
+ line.)
+ * pagestats: Class parameter can be used to override default class for
+ custom styling.
+ * pagestats: Use style=list to get a list of tags, scaled by use like
+ in a tag cloud. This is useful to put in a sidebar.
+ * Rework example blog front page.
+ * CSS and templates for sidebar changed to use a class, not an id.
+ * sidebar: Now a sidebar directive can be used to override the sidebar
+ shown on a page.
+ * Enable calendar and sidebar in auto-blog.setup.
+ * sidebar: Add global_sidebars setting.
+ * conditional: Fix bug that forced "all" mode off by default.
+ * calendarmonth.tmpl: The month calendar is now put in a sidebar.
+ * calendar: Improved display of arrows.
+ * Rename --getctime to --gettime. (The old name still works for
+ backwards compatibility.)
+ * --gettime now also looks up last modification time.
+ * Automatically run --gettime the first time ikiwiki is run on
+ a given srcdir. (Use --no-gettime to disable.)
+ * Add rcs_getmtime to plugin API; currently only implemented
+ for git and svn.
+ * Optimise --gettime for git, so it's appropriately screamingly
+ fast. (This could be done for most other backends too.)
+ * However, --gettime for git no longer follows renames. That would
+ be slow, and whether a renamed wiki page is the same page is really
+ an iffy thing.
+ * Use above to fix up timestamps on docwiki, as well as ensure that
+ timestamps on basewiki files shipped in the deb are sane.
+ * autoindex: Switch to using %wikistate instead of abusing
+ $pagestate{index}.
+ * bzr: Support rcs_getmtime, and fix rcs_getctime implementation
+ (Jelmer Vernooij)
+ * Quite a lot of new optimisations, and one major fix to a recent
+ performance regression.
+ * Moved javascript files under the ikiwiki/ directory, to avoid cluttering
+ the top of the web root. This is another things that requires a wiki
+ rebuild on upgrade to this version.
+ * Fix removal of rendered files in rebuild mode.
+ * Add page() PageSpec, which is like glob() but matches only pages,
+ not other files.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 04 Apr 2010 12:17:11 -0400
+
+ikiwiki (3.20100403) unstable; urgency=low
+
+ * websetup: Add websetup_unsafe to allow marking other settings
+ as unsafe.
+ * Improve openid url munging; do not display anchors and cgi parameters,
+ as used by yahoo and google urls.
+ * Add complete German basewiki and directives translation done by
+ Sebastian Kuhnert.
+ * Add a include setting, which can be used to make ikiwiki process
+ wiki source files, such as .htaccess, that would normally be skipped
+ for security or other reasons. Closes: #447267
+ (Thanks to Aaron Wilson for the original patch.)
+ * Add support for setup files written in YAML.
+ * Add --set-yaml switch for setting more complex config file options.
+ * filecheck: Fix bugs that prevented the pagespecs from matching when
+ not called by attachment plugin.
+ * Fix incorrect influence info returned by a failing link() pagespec,
+ that could lead to bad dependency handling in certian situations.
+ * Add preprocessed 'use lib' line to ikiwiki-transition and ikiwiki-calendar
+ if necessary for unusual install.
+ * auto-blog.setup: Set tagbase by default, since most bloggers will want it.
+ * Allow wrappers to be built using tcc. (Workaround #452876)
+ * openid: Use Openid Simple Registration or OpenID Attribute Exchange
+ to get the user's email address and username. (Neither is yet
+ used, but they are available in the session object now.)
+ * page.tmpl: Add Cache-Control must-revalidate to ensure that users
+ (especially of Firefox) see fresh page content.
+ * htmlscrubber: Allow colons in urls after '?'
+ * template: Search for templates in the templatedir, if they are not
+ found as pages in the wiki.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 03 Apr 2010 14:17:28 -0400
+
+ikiwiki (3.20100312) unstable; urgency=HIGH
+
+ * Fix utf8 issues in calls to md5_hex.
+ * moderatedcomments: Added moderate_pagespec that can be used
+ to control which users or comment locations are moderated.
+ This can be used, just for example, to moderate "user(http://myopenid.com/*)"
+ if you're getting a lot of spammers from one particular openid
+ provider (who should perhaps answer your emails about them),
+ while not moderating other users.
+ * moderatedcomments: The moderate_users setting is deprecated. Instead,
+ set moderate_pagespec to "!admin()" or "user(*)".
+ * Fix missing span on recentchanges page template.
+ * search: Avoid '$' in the wikiname appearing unescaped on omega's
+ query template, where it might crash omega.
+ * htmlscrubber: Security fix: In data:image/* uris, only allow a few
+ whitelisted image types. No svg.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 09 Mar 2010 19:46:35 -0500
+
+ikiwiki (3.20100302) unstable; urgency=low
+
+ * comments: Display number of comments in comment action link.
+ * Rebuild wikis on upgrade to this version to get the comment counts
+ added to existing pages.
+ * Loosen regexp, to allow empty quoted parameters in directives.
+ * Add force_overwrite setting to make setup automator overwrite existing
+ files/directories.
+ * Fix admin openid detection in setup automator, and avoid prompting
+ for a password.
+ * Add new --clean option; this makes ikiwiki remove all built
+ files in the destdir, as well as wrappers and the .ikiwiki directory.
+
+ -- Joey Hess <joeyh@debian.org> Tue, 02 Mar 2010 22:17:30 -0500
+
+ikiwiki (3.20100212) unstable; urgency=low
+
+ * template: Preprocess parameters before htmlizing.
+ * img: Fix a bug that could taint @links with undef values.
+ * setup automator: Configure Term::Readline to use bold for prompt, rather
+ than default underline. Closes: #517656
+ * Allow jumping directly into account registration process by going to
+ ikiwiki.cgi?do=register
+ * Improve display of openid in preferences page.
+ * Add link to userpage (or creation link) to top of preferences page.
+ * opendiscussion: This plugin will also now allow posting comments
+ to otherwise locked-down sites.
+ * auto-blog.setup: Lock all pages, so only admin can post to the blog
+ by default, and enable opendiscussion so others can comment.
+ * Fix color and format plugins to appear in the websetup interface.
+ * amazon_s3: Fix to support the EU S3 datacenter, which is more picky
+ about attempts to create already existing buckets.
+ * httpauth: When cgiauthurl is configured, httpauth can now be used
+ alongside other authentication methods (like openid or anonok). Rather
+ than always redirect to the cgiauthurl for authentication, there is now
+ a button on the login form to use it.
+ * httpauth: Add httpauth_pagespec setting that can be used to limit
+ pages to only being edited via users authed with httpauth.
+ * Allow globs to be used in user() pagespecs.
+ * Group related plugins into sections in the setup file, and drop
+ unused rcs plugins from the setup file.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 12 Feb 2010 16:45:50 -0500
+
+ikiwiki (3.20100122) unstable; urgency=low
+
+ * inline: Avoid showing edit links if page editing is disabled.
+ (Sjoerd)
+ * signinedit: Auto-disable the plugin when all authentication methods
+ are disabled.
+ * comments: Fix permalinks for comments using new conflict-free filenames.
+ * img: Support alignment of images with captions. (Giuseppe Bilotta)
+ * websetup: Fix utf-8 problems.
+ * websetup: Fix bug in array change detection.
+ * linkmap: Simplify and improve browser compatibility by using an img,
+ not object tag.
+ * git: The new git-notes feature in git 1.6.6 changes git log output
+ in a way that broke ikiwiki's parser if notes are added to commits.
+ * po: Avoid crash when a page is empty.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 22 Jan 2010 16:02:36 -0500
+
+ikiwiki (3.20100102.3) unstable; urgency=low
+
+ Happy palindrome day!
+
+ * pagestats: Add show parameter. Closes: #562129 (David Paleino)
+ * toc: Add startlevel parameter. (kerravonsen)
+ * Remove example ikiwiki setup file from the Debian package. This
+ re-enables linking to /usr/share/ikiwiki/examples which has the
+ example sites also used by auto-blog.setup. The example setup file
+ can be generated at any time using ikiwiki --dumpsetup so I do
+ not see a reason to ship it. Closes: #562183
+ * Use env hack in python scripts.
+ * comments: Add a checksum to the name of comment pages, to
+ avoid merge conflicts when comments are posted to two branches of a
+ site.
+ * linkmap: Add option to omit disconnected pages from the map.
+ * inline: Fix bug that limited displayed pages when feedshow was
+ specified w/o show.
+ * Fix several places that did not properly handle capitalization of
+ the discussionpage setting. Specifically, fixes discussion actions
+ on discussion pages, and unbreaks the opendiscussion plugin.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 02 Jan 2010 21:46:16 -0500
+
+ikiwiki (3.20091218) unstable; urgency=low
+
+ * Add complete Spanish basewiki translation done by Fernando Gonzalez de
+ Requena.
+ * Improve javascript onload handling.
+ * monotone: Deal with format change in version 0.45.
+ (Thanks, Richard Levitte)
+ * cvs: Add missing bit to Automator.
+ * attachment: Fix reversion in attachment sorting by age.
+ * Fix utf-8 problems in rename, remove, attachment, 404, sourcepage, and
+ goto.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 18 Dec 2009 20:47:24 -0500
+
+ikiwiki (3.20091202) unstable; urgency=low
+
+ * meta: Generate meta description tags even when the html scrubber is
+ enabled.
+ * meta: Allow use of DESCRIPTION in templates to get at the meta description
+ value. (Thanks, NicolasLimare)
+ * inline: Use caching of inlined pages to speed up builds of inlines that
+ include feeds. Speedup of about 25% for small inlines; could be much
+ larger for inlines of many, or complex pages.
+ * Added (incomplete) Turkish po file. Closes: #556744
+ Thanks, Recai Oktaş
+ * date: New plugin that allows inserting date directives that expand to
+ pretty-printed dates, using the same formatting as used for page
+ modification date display, etc.
+ * htmllink: Allow a title attribute to be specified.
+ * calendar: Add title attributes for all links in the calendars.
+ * calendar: Fix month wraparound error that broke in December.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 02 Dec 2009 13:09:20 -0500
+
+ikiwiki (3.20091113) unstable; urgency=low
+
+ * underlay: Fix example values put in setup file to be array
+ references.
+ * underlay: Avoid crashing if lists of underlays (or template
+ directories) are not configured.
+ * Moved the postscan hook to run on the raw html of a page, before
+ the template is filled out. This improves the search plugin's indexing,
+ since it will not include navigational elements from the page template
+ or sidebar.
+ * localstyle: New plugin, allows overrding the toplevel local.css
+ with one that is closer to a page.
+ * httpauth: Add cgiauthurl setting that can be used to do http basic auth
+ only when ikiwiki needs authentication, rather than for any access to
+ the cgi/wiki.
+ * inline: Do not generate feeds for nested inlines.
+ * inline: Allow direct inclusion of non-page files in raw mode.
+ * inline: Fix display of all pages when archive=yes or show=0 are used.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 13 Nov 2009 20:51:57 -0500
+
+ikiwiki (3.20091031) unstable; urgency=low
+
+ * po: Fix breakage caused by changes to render code.
+ * mdwn: Avoid trying to use multimarkdown if it is not installed.
+ * moderatedcomments: New plugin to allow comment moderation w/o relying
+ on blogspam.net.
+ * When redirecting to a page, ie, after editing, ensure that the
+ url is uri-encoded. Most browsers other than MSIE don't care, but it's
+ the right thing to do.
+ * Add a spec file to allow building rpm from the source package.
+ * google: Pass the whole wiki url to google, not just the domain,
+ so that search works correctly for wikis that are located in
+ subdirectories of domains.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 31 Oct 2009 18:29:38 -0400
+
+ikiwiki (3.20091023) unstable; urgency=low
+
+ * inline: Fix raw mode. Closes: #552114
+
+ -- Joey Hess <joeyh@debian.org> Fri, 23 Oct 2009 12:38:50 -0400
+
+ikiwiki (3.20091022) unstable; urgency=low
+
+ * edittemplate: Allow template page name to be specified using anything
+ legal for a wikilink (including eg, leading slashes).
+ * edittemplate: Work around bug #551499 in CGI::FormBuilder.
+ * Fix a bug introduced in the last version that caused ikiwiki
+ to skip all files if a sourcedir of "./" was specified.
+ * Support CFLAGS when building wrapper.
+ * meta: Gather permalink info on scan pass so it is available
+ to inline when using a template that does not include page content.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 22 Oct 2009 20:25:15 -0400
+
+ikiwiki (3.20091017) unstable; urgency=low
+
+ * Added support framework for multiple types of dependencies, including
+ dependncies that are only affected by page precence or link changes.
+ * Rebuild wikis on upgrade to this version to get improved dependency
+ info.
+ * pagecount, calendar, postsparkline, progress: Use a presence dependency,
+ which makes these directives much less expensive to use, since page
+ edits will no longer trigger an unnecessary update.
+ * map: Use a presence dependency unless show= is specified.
+ This makes maps efficient enough that they can be used on sidebars!
+ * inline: Use a presence dependency in quick mode.
+ * brokenlinks: Use a link dependency.
+ This makes it much more efficient, only updating when really necessary.
+ * orphans, pagestats: Use a combination of presence and link dependencies.
+ This makes them more efficient. It also fixes a longstanding bug,
+ where if only a small set of pages were considered by orphans/pagestats,
+ changes to links on other pages failed to cause an update.
+ * linkmap: Use a combination of presence and link dependencies.
+ This makes the map be regenerated much less frequently in many cases,
+ so larger maps are more practical to use now.
+ * Plugins providing PageSpec `match_*` functions should pass additional
+ influence information when creating result objects. This allows correctly
+ handling many more complicated dependencies.
+ * API change: `pagespec_match_list` has completly changed its interface.
+ The old interface will be removed soon, and a warning will be printed
+ if any plugins try to use it.
+ * Transitive dependencies are now correctly supported.
+ * ikiwiki-calendar: New command automates creation of archive pages
+ using the calendar plugin.
+ * calendar: Fix midnight rebuild trigger of calendars with explicit
+ month/year.
+ * calendar: Fix bug in next/previous year/month links, which sometimes
+ linked to an archive page from the wrong year, or were missing.
+ * git: --getctime will now follow renames back to the original creation
+ of a file.
+ * calendar: Fix CSS for year calendar to match the plugin documentation.
+ * Added minimal default CSS for calendar plugin, just highlighting the
+ current day.
+ * inline: Optimize generation of archives, etc by not getting inlined page
+ content if the template does not use it.
+
+ -- Joey Hess <joeyh@debian.org> Sat, 17 Oct 2009 15:37:04 -0400
+