- - allows preprocessor directives to have parameters with no specified
- value
- - fixes preprocessor directive parameter parsing so that
- foo=bar baz now means "foo=bar" and a "baz" with no value
- - Add a tag plugin that allows more easily tagging pages.
- The meta plugin can also still be used for this.
-
- -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 17:03:09 -0400
+ - Adds a tag plugin that allows more easily tagging pages.
+ The meta plugin can also still be used for that, but the tag plugin
+ also lists a page's tags at the bottom of the page.
+ - Allows preprocessor directives to have parameters with no specified
+ value.
+ - Fixes preprocessor directive parameter parsing so that
+ foo=bar baz now means "foo=bar" and a "baz" with no value.
+ * Run pagetemplate hooks when inlining pages so that inlined pages also
+ list their tags.
+ * Make all plugins with pagetemplate hooks check that variables exist
+ on the template before setting them, for robustness.
+ * Switch pagetemplate hooks to using named parameters.
+ * Pass a destpage parameter to preprocessor and pagetemplate hooks.
+ This will be the page that a source page will be part of, which is
+ different than the source page for inlined pages.
+ * Audited all plugins to endure they pass (page, destpage) to htmllink
+ appropriatly. This means inlining of various plugins will not work
+ properly, with correct links generated.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 27 Jul 2006 20:51:23 -0400