+ikiwiki (1.27) UNRELEASED; urgency=low
+
+ * Add a googlecalendar plugin. A bit special-purpose, but it shows
+ one way to to deal with user-supplied content that could cause XSS
+ issues w/o the htmlscrubber, and won't survive the scrubber.
+ * Work on firming up the plugin interface:
+ - Plugins should not need to load IkiWiki::Render to get commonly
+ used functions, so moved some functions from there to IkiWiki.
+ - Picked out the set of functions and variables that most plugins
+ use, documented them, and made IkiWiki export them by default,
+ like a proper perl module should.
+ - Use the other functions at your own risk.
+ - This is not quite complete, I still have to decide whether to
+ export some other things.
+ * Changed all plugins included in ikiwiki to not use "IkiWiki::" when
+ referring to stuff now exported by the IkiWiki module.
+ * Add a module version number to IkiWiki, so you can "use IkiWiki '1.00'"
+ to declare which version of the interface your plugin needs.
+ * Anyone with a third-party ikiwiki plugin is strongly encouraged
+ to make like changes to it and avoid use of non-exported symboles from
+ "IkiWiki::".
+ * Link debian/changelog and debian/news to NEWS and CHANGELOG.
+ * Support hyperestradier version 1.4.2, which adds a new required phraseform
+ setting.
+ * If an inlined page has a permalink, link the page title to that.
+ * Patch from Recai to use utf8 when reading the setup file, so that
+ utf8 wikinames from there will be used properly.
+ * Patch from Recai to kill utf-8 on the wiki name when generating the
+ session cookie.
+ * Change ddate plugin to use the DateTime::Calendar::Discordian perl module.
+ * Fix a baseurl problem in hyperestradier search results.
+ * Add a stub local.css to avoid problems with 404's.
+ * Patch from Recai to fix a wide character warning from the search plugin
+ during setup if the wikiname contains utf8.
+ * Yet another fix for those poor case-insensative OSX users.
+ * pagetemplate hooks are now also called when generating cgi pages.
+ * Add a favicon plugin, which simply adds a link tag for an icon to each
+ page (and cgis).
+ * Patch from James Westby to deal with the case where you're editing a
+ new page, hit cancel, and need to be redirected to somewhere sane.
+ * Various documentation improvements by various wiki users.
+ * Support Text::Markdown from CPAN, which has a different interface from
+ the original markdown or the one in Debian.
+ * Version the libcgi-session-perl dependency, some features that need
+ the new version are used in some cases (sslcookie).
+
+ -- Joey Hess <joeyh@debian.org> Fri, 15 Sep 2006 22:28:31 -0400
+
+ikiwiki (1.26) unstable; urgency=low
+
+ * Add a missing -n to tla undo call.
+ * otl2hmtl can't be safely used with IPC::Open2 since it sometimes
+ writes before consuming its whole stdin. Avoid this deadlock.
+ * Fix alt tags for outline checkboxes.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 16:24:16 -0400
+
+ikiwiki (1.25) unstable; urgency=low
+
+ * Add proper waitpid calls for open2ed processes throughout to avoid
+ zombies; this hit htmltidy especially badly.
+ * Drop real uid/gid in the suid wrapper, thus allowing commits to remote
+ subversion repos and fixing some other issues.
+ * Add support for tla, contributed by Clint Adams. Closes: #385936
+ * Add support for mercurial, contributed by Emanuele Aina.
+ * Include <link rel> tag for RSS feeds, used by some aggregators and
+ firefox to find the feed.
+ * Add a linkmap plugin (requires graphviz).
+
+ -- Joey Hess <joeyh@debian.org> Fri, 8 Sep 2006 01:54:14 -0400
+
+ikiwiki (1.24) unstable; urgency=low
+
+ * Simplify the data structure returned by rcs_recentchanges to avoid
+ each rcs plugin needing to form complex strings on its own.
+ * Fix another destpage issue in the inline directive. Closes: #385512
+ again.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 15:46:45 -0400
+
+ikiwiki (1.23) unstable; urgency=low
+
+ * Allow inline directives to be nested inside eg, sidebars. Closes: #385512
+
+ -- Joey Hess <joeyh@debian.org> Sun, 3 Sep 2006 12:14:45 -0400
+
+ikiwiki (1.22) unstable; urgency=low
+
+ * Change how the stylesheet url is determined in the templates: Remove
+ STYLEURL and add BASEURL to all templates (some already had it). This
+ new more general variable can be used to link to other things (eg, images)
+ from the template, as well as stylesheets.
+ * Fix a bug introduced last version to do with nested inlines.
+ * Allow preprocessor directives to span multiple lines, both to make
+ long ones with lots of values easier to write, and to allow for ones with
+ multi-line quoted values.
+ * Allow preprocessor directives to contain python-like triple-quoted
+ text blocks, for easy nesting of quotes inside.
+ * Add a template plugin.
+ * Make pagespec merge code smarter about merging duplicate pagespecs.
+ * Patch from Jordà Polo to make Setup::Standard support hashes in config
+ files.
+ * Change order of linkify and preprocess; first preprocess and then linkify.
+ This allows passing a wikilink inside a parameter to a preprocessor
+ directive without it being expanded to html, and leaking out of the
+ parameter, which had required some non-obvious use of triple-quoting
+ to avoid. Note that any preprocessor plugins that output something
+ that looks like a wikilink will now have it treated as such; AFAIK
+ this doesn't change any behavior though except for the template plugin.
+ * Enable preprocessor directives when previewing an edit.
+ * Make all pages pull in a local.css style sheet, if present. This won't
+ be included in ikiwiki, but can be created to make local styling changes
+ w/o needing to merge in every new change to the distributed style.css.
+ * Use DESTDIR and not PREFIX to specify installation prefix for packaging.
+ * Support running "perl Makefile.PL PREFIX=foo" to build ikiwiki to run
+ from a different directory.
+ * Generalised preprocesser loop protection code.
+ * Patch from James Westby to allow a description to be set for rss feeds.
+ * Patch from James Westby to add a template for the search form.
+ * Added a ddate plugin.
+ * Patch from James Westby to add a --sslcookie switch, which forces
+ cookies to only be sent over ssl connections to avoid interception.
+ * Fix preferences page on anonok wikis; still need to sign in to get
+ to the preferences page.
+ * Add toc (table of contents) plugin.
+ * Change htmlize, format, and sanitize hooks to use named parameters.
+ * Patch from James Westby to add an actions option to inline; this
+ adds Edit and Discussion links at the end of blog entries.
+ * Due to some css changes, you'll want to rebuild your wiki on upgrade
+ to this version. Will be handled automatically by the deb.
+ * Add processed date to aggregate preprocessor directive status output.
+
+ -- Joey Hess <joeyh@debian.org> Fri, 1 Sep 2006 22:03:34 -0400
+
+ikiwiki (1.21) unstable; urgency=low
+
+ * Add a tail fin^W^Wsidebar plugin by Tuomo Valkonen.
+ * If a page links to itself, mark up the link text in a span with
+ class="selflink" so that it can be styled. I don't have a useful style
+ defined for that though.
+ * Call filter hooks on inlined page content.
+ * Support inlining pages raw, rather than creating a blog.
+ * Clean up yes/no parameter parsing in inline plugin.
+ * Implemented better cycle detection in the inline plugin; nested inlines
+ will now work.
+ * Add a map plugin contributed by Alessandro Dotti Contra.
+ * Add otl format plugin, which handles files as created by vimoutliner.
+ * Fix ikiwiki-mass-rebuild to work in the way the postinst uses it.
+ * Add first draft at a Restructured Text (rst) plugin, by Sergio
+ Talens-Oliag. Note that this has many known issues -- see the caveats on
+ the plugin's page.
+ * Credit everyone who wrote a plugin on the plugins' wiki pages.
+ * Fix utf-8 in blog post form.
+
+ -- Joey Hess <joeyh@debian.org> Sun, 20 Aug 2006 16:42:54 -0400
+
+ikiwiki (1.20) unstable; urgency=low
+
+ * Relicense the templates and basewiki under the 2-clause BSD license.
+ Since these can easily become part of other people's websites, they
+ should be under as permissive a license as possible.
+ * Add --syslog config option, to log to the syslog.
+ * Catch failing IPC::Open2 in tidy plugin and retry in case this is a
+ transient failure to fork (which I've seen happen in the wild).
+ * Fix a bug in the aggregator introduced last version that caused all
+ aggregator state to be lost during a non-aggregating build.
+
+ -- Joey Hess <joeyh@debian.org> Thu, 17 Aug 2006 19:05:56 -0400
+
+ikiwiki (1.19) unstable; urgency=low
+
+ * Fix several related bugs in page type determination during online editing.
+ * Add some locking to prevent 2 aggregators from running at once.
+ * Fix an infinite loop in the aggregator when finding a unique filename.
+
+ -- Joey Hess <joeyh@debian.org> Wed, 16 Aug 2006 13:46:25 -0400
+
+ikiwiki (1.18) unstable; urgency=low