]> git.vanrenterghem.biz Git - git.ikiwiki.info.git/blobdiff - debian/rules
git_revert test: reinstate ikiwiki.setup, and make it work uninstalled
[git.ikiwiki.info.git] / debian / rules
index bdbbf005002492bc5552bbe9135e8e6e5cd911a8..cf3087d1db711dc46539c908742b1983f2b70967 100755 (executable)
@@ -1,6 +1,6 @@
 #!/usr/bin/make -f
 %:
-       dh $@
+       LC_ALL=C.UTF-8 TZ=UTC dh $@
 
 override_dh_auto_configure:
        # keeps it out of /usr/local
@@ -12,8 +12,4 @@ override_dh_compress:
 
 override_dh_auto_clean:
        # distclean moans about MANIFEST, this is quieter
-       -$(MAKE) realclean
-
-# Not intended for use by anyone except the author.
-announcedir:
-       @echo ${HOME}/src/ikiwiki/doc/news
+       if [ -e Makefile ]; then $(MAKE) realclean; fi